ActiveReports 12 Server User Guide

ActiveReports Server provides a browser-based report designer for end users to serve up both end user reports and your more sophisticated developer reports. The Class Library contains documentation and code samples for the ActiveReports 12 Server API.

In This Documentation

Features and Benefits
Read about the most important ActiveReports 12 Server features and how they make an administrator's life easier.
What's New
Discover what has changed in this version of ActiveReports Server.
Breaking Changes
This section provides a list of breaking changes.
ActiveReports Limitations
Learn what limitations you will come across when working with ActiveReports in ActiveReports 12 Server.
Migration from Previous Versions
This section describes how to migrate all of your existing reports to the new version of ActiveReports Server.
License Types
Learn what features are included with each type of ActiveReports 12 Server license.
Installation
View the server and managed agent system requirements, installed files, and learn to log on.
Concepts
This section has a list of major features, and reviews general concepts to help you understand ActiveReports 12 Server.
Managing Models
This section has topics that show you how to work with models, including how create a new model and how to modify a model or its elements.
Report Categories
This section has topics that show you how to work with categories, including Managing System Categories topic.
Managing Reports
This topic describes your options with each type of reports that are supported.
Managing Schedules
This topic describes shared schedules that you can set up to allow specified user roles to schedule reports.
Managing Printers
This topic describes how to add printers in the server that are used to perform server printing.
Managing Data Sources
This topic describes how to work with data sources that are used to design reports in ActiveReports.
Managing Data Sets
This topic describes how to work with data sets that are used to design reports in ActiveReports.
Managing Style Sheets
This topic describes how to work with Style Sheets that are used to style reports in ActiveReports.
Managing Images
This topic describes how to work with Images that are used in reports.
Managing Templates
This topic describes how to work with Templates that are used while creating reports in HTML5 Web Designer.
Managing Themes and Styles
This section describes how to work with themes for entire reports, and styles for individual report items.
Managing Security
This section contains information about managing users, roles and permissions and about setting up SSL/HTTPS on the ActiveReports 12 Server Web site.
Managing Configuration
This section teaches you about the ActiveReports 12 Server Agents, Licenses, Security, SMTP settings, notification URL, Audit settings and server diagnostics for your site.
How To
Quickly learn how to perform specific tasks with ActiveReports 12 Server.
Samples and Walkthroughs
Learn to create and access Web services using the ActiveReports 12 Server.
Troubleshooting
Learn how to resolve some common issues with ActiveReports 12 Server.
Class Library
View the API documentation on the report list and designer controls.
Web Service Library
View the API documentation for the ActiveReports 12 Server ReportService.
Section 508 Compliance
Learn about Section 508 Compliance.

Licensing Agreement

Please see the ActiveReports 12 Server Licensing Agreement on our web site for full details about licensing for each edition.

Acknowledgements

Microsoft, Windows, Visual Studio, and Microsoft SQL Server are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.


Features and Benefits

Features and Benefits
ActiveReports 12 Server User Guide > Features and Benefits

Here are the most important ActiveReports Server features that make an administrator's life easier.

Feature | Benefit
A report designer designed especially for end users that don't use SQL. | End users can create and modify reports without depending on IT.
Completely browser-based designer. No installation required. | Fast and easy deployment in production. No updates to users’ desktops.
A logical data model from your database that users understand. | End users can query, sort, and filter data using familiar terms. No knowledge of database schema or SQL required.
Automatic generation of logical data models from your database. | IT can generate and then customize and extend the data models shown to end users.
Schedule & distribute reports to specific people at specific times. | Timely distribution of information to business users when they need it most.
Self-managed clustering & load-balancing. | Cost-effective and easy to manage scalability for a few or a hundred users.
Role-based security for reports and data models. | IT makes sure that only authorized users can create and view different reports.
Single sign-on security provider. | Allow users to sign in with their existing user name and password.
A set of ASP.NET controls for embedding reports and report designer. | Programmers can rapidly integrate reporting features into ASP.NET applications.
Flexible web service access to the reporting platform. | Programmers can exercise greater control integrating reporting into their applications.
Compatibility with ActiveReports. | ActiveReports Server supports all types of reports provided by ActiveReports. Publish existing ActiveReports report files for centralized storage, distribution, security, and scalability.
Install and configure in less than 10 minutes. | Install and configure a working server in your own environment to evaluate in minutes - not days.
Fully responsive HTML5 Report Portal and Admin Dashboard. | ActiveReports Server provides fully responsive HTML5 Mobile user interface which makes it possible to access the Report Portal and Admin Dashboard from any touch enabled device.
Server-side scheduled printing. | Add a printer to ActiveReports Server and set up a scheduled printing task.
Customizable UI. | ActiveReports Server provides the ability to customize the appearance of the Administrator Dashboard and the Report Portal.
ClickOnce End User Designer for ActiveReports Developer reports . | ActiveReports Server lets you design the ActiveReports Developer reports in Administrator Portal and Report Portal using the new ClickOnce End User Designer.
See Also
Concepts
Managing Models
Managing Reports
Managing Security
Managing Themes and Styles
Managing Configuration


What's New

What's New
ActiveReports 12 Server User Guide > What's New

We have made a number of changes since the last version of ActiveReports Server. Here are the major ones:

Administrator role for groups in Active Directory

With this feature, the Administrator role is automatically granted to the users who log-in to the ActiveReports Server with the Active Directory server groups that are listed in 'ARS Admin Groups' field.

For more information, see Using LDAP and Active Directory for Single Sign-On .

Templates Feature

The new templates feature has been introduced to allow users to use templates while creating reports in the Web Designer. Templates can be uploaded by an administrator on the Administration portal using the Upload template button (supported file formats are .rdl and .rdx) and can be viewed in the Templates list on the Templates page. An administrator can also convert a template into a report and a report into template.

For more information, see Templates.

JS Viewer (Beta)

JS Viewer is a new lightweight viewer now available with ActiveReports 12 Server. This viewer allows for faster report rendering with rich interactivity. Not only do the reports respond faster, but since the server is freed up sooner, your deployment can scale even better. The JS Viewer is currently in beta.

Monitoring Workers State

An administrator can now view the current tasks of each agent along with the details about status of the task as Idle or Busy, and the description and priority of tasks. The status of tasks is updated real-time in the new Workers section on the Agents page of the Administration site. For more information, see Managing Agents.

Send Report by Email in HTML5 Viewer

You can now send a report by email while previewing the report in HTML5 Viewer. Just enter the necessary details about sender, select the document format to be sent as link or as an attachment, and click send. For more information, see Send a Report by Email.

Schedule Retain Text and Copy Task

While modifying a scheduled task, you can benefit from a few improvements that have been introduced to the Report Portal. Now, when you change the schedule template settings, other settings of the schedule remain unchanged, provided the Delivery type option is same. Also, a new Copy task button is introduced that allows users to create a new schedule task with the settings of an existing schedule task. For more information, see Scheduling Reports.

Immediate Execution of Scheduled Tasks

Now you can run any saved scheduled task immediately by clicking the new Run once button. Once the task execution is complete, you can view the results under the History tab. For more information, see Scheduling Reports.

Create and Edit Shared Data Sets

The Administration dashboard adds new functionalities - create data set and edit data set - that allow creating and editing shared data sets directly on the browser, without any dependency on ActiveReports Developer.

Support for CSV Export

The CSV export is now available in HTML5 Report Viewer. You can now also choose to save the reports to CSV format while scheduling tasks.

Improved Performance with Large Reports

The report previewing experience with large reports (1000+ pages) has been significantly improved. The administrator can now control the page limit for the reports being rendered by end users on the viewers. Also, the users can choose to stop whole report from rendering and preview only a partial report. With these improvements, large reports are rendered in less time, which in turn saves server memory, and lowers CPU usage.

For more information, see Site Settings.

Enhancements in Web Designer

The HTML5 technology based ActiveReports Web Designer has received many enhancements including support for Page Reports, Sub-Reports, Templates, enhanced Themes and Styles support, and optimizations for reports based on Semantic Data Models. With these end users now have even more power and flexibility to design and publish reports on the fly from any browser. For more information, see Get Started with ActiveReports Web Designer.
Some more improvements are:

  • Text orientation for chart title and labels: With the new Text Orientation property, you can control the orientation chart titles and label text for chart axes points. The available options are Auto, Angle, Horizontal, Rotated90, Rotated270, and Stacked.
  • Appearance of series line in Column and Bar charts: The new Series Line Style properties allow you to apply settings - Style, Width, and Color - for series in Column and Bar charts (Stacked and PercentStacked). These properties are available on selecting a Chart's Plot area.
  • Support for more controls: The Web Designer now supports Barcode and Formatted Text controls.
  • New dataset query filter in semantic reports: The new dataset query filter in rdl reports adds more flexibility and performance to filtering data in a semantic dataset.
  • Double line style for Line control: The new 'Double' line style property is now available for Line control along with other line styles such as Solid, Dashed, Dotted, DashDot, and DashDotDot. The Double line style allows setting double lines with the specified gap in-between the lines.
  • Intelligent data models: We have improved the behavior of semantic data models in the Web Designer and now data model relations are determined intuitively when a semantic data model is created, meaning that the main entity of a data model is displayed automatically as the top of the data set.
  • Design visually appealing reports with ease: While designing reports, the default styles are now automatically applied to the controls that support style feature (Table, Tablix, Chart, Bullet, and Sparkline). So the users don't need to set the styles manually each time they add new control. The default styles can be later easily modified from the Style property.
  • Data set refresh: Now when a shared data set gets modified, you can refresh this data set in a report that uses it. When opening such a report in the Web Designer, a notification message will specify what data fields have been changed and ask you to save the report with a new data set version.
See Also
Breaking Changes
Migration from Previous Versions


Breaking Changes

Breaking Changes
ActiveReports 12 Server User Guide > Breaking Changes

Flash Report Portal and Mobile Portal in ActiveReports Server versions

When you upgrade reports from previous versions of ActiveReports Server, you should note that Flash based Report Portal and Mobile Portal are not available with ActiveReports 9 Server Service Pack 1 onwards. Both of these report portals have been replaced by the fully responsive HTML5 Report Portal.

Memory Usage

The MemoryLimit property is added to the controller service to prevent the Server or Agent process from consuming all machine memory. The ControllerService.MemoryLimit property is implemented for the target configuration files ActiveReports.Server.Host.exe.Config and ActiveReports.Server.Agent.exe.Config, the default value is 75 (%). The memory usage check is performed every minute, and if the service process has exceeded the value in the MemoryLimit property, the service is restarted. If the process has not exceeded the value in the MemoryLimit property, the agent continues running without restart. If the memory limit is exceeded between the agent checks, no agent restart is performed.

You can edit the MemoryLimit setting in the following files:

  • ActiveReports.Server.Host.exe.Config - the configuration file for the Server service. You can find this file in C:\ActiveReports 12 Server\Server.
  • ActiveReports.Server.Agent.exe.Config - the configuration file for the Agent service. You can find this file in C:\ActiveReports 12 Server\Agent.

In any of these files, you should find the line <add key="RunnerService.MemoryLimit" value="75" /> inside the <appSettings></appSettings> section and modify the value. You need to restart the service every time you change the setting value to apply the changes.


ActiveReports Limitations

ActiveReports Limitations
ActiveReports 12 Server User Guide > ActiveReports Limitations

Subreport Absolute Path

ActiveReports Server does not support using the absolute path for subreports because ActiveReports Server saves reports in the internal storage. In ActiveReports Server you have to specify the subreport name to locate the subreport.


Migration from Previous Versions

Migration from Previous Versions
ActiveReports 12 Server User Guide > Migration from Previous Versions

ActiveReports Server includes an easy path for migrating from previous versions.

Important: Before following the upgrade steps in a live environment, we suggest that you test the upgrade in a test environment.

The new version of ActiveReports 12 Server installs in the same folder over the previous version. The installer detects the previous version and suggests upgrading it, and then adapts any existing agents, models, roles, groups, users, schedules, permissions, themes, reports, styles, audit settings and SMTP settings to work with the new version.

Note: The minimum supported version for migration to ActiveReports 12 Server is ActiveReports 9 Server Service Pack 1.
  1. Run the ActiveReports 12 Server installation file.
  2. In the Upgrade dialog that appears, click Upgrade to upgrade the existing version of the product to the latest version.
  3. Once the installation finishes, a dialog notifies you. Click Finish to close the window and complete the installation process.

Once the installation process is complete, the Administrator site opens in your browser so that you can complete the configuration of ActiveReports 12 Server. Activate a new license, because the ActiveReports 10 Server product keys do not unlock ActiveReports 12 Server. For details, see Activate a License.

If you need a new product key for ActiveReports 12 Server, contact our sales team at activereports.sales@grapecity.com.

For information on the ActiveReports 12 Server installation process, see Installation.

Important Points
  • IIS configurations, custom security provider settings and any custom settings in the Web.config of the server web site may have to be reapplied after the upgrade process is complete.
  • Recompile the custom security providers with the latest version of the ActiveReports.Server.Extensibility assembly.
  • Clearing the cache is recommended on completing the upgrade.
  • Rebuild the code-based reports from any previous version using ActiveReports 12 and republish the reports to preview in ActiveReports 12 Server.
See Also
Configuring ActiveReports 12 Server on SSL and HTTPS Web Sites
Managing Configuration
Migration PowerShell Module Sample


License Types

License Types
ActiveReports 12 Server User Guide > License Types

There are three types of licenses for ActiveReports Server:

ActiveReports Server Trial Edition

This is a 30 day free trial version of the product that you can use to determine how ActiveReports Server can fulfill your needs. The Trial Edition includes all of the features in the Core Edition plus the Designer Add-On.

If the initial trial expires before you have had a chance to fully evaluate the product, you may contact activereports.sales@grapecity.com to request an extension of the trial period.

ActiveReports Server Core Edition

This license covers use of the server, the report portal, the HTML5 report viewer, and as many managed agents as you need. Once you purchase the Core Edition, there is no need to purchase additional licenses as you scale up to handle increased server loads.

With this license, you can schedule and distribute reports, take advantage of self-managed clustering and load-balancing, and provide role-based security for reports and data models. You can even allow users to sign in with their existing user name and password to access centrally stored ActiveReports report files.

ActiveReports Server Designer Add-On

In addition to serving up existing reports, if you want to offer your users the ability to create their own ad hoc reports right in the browser, you can purchase the optional Designer Add-On.

The Designer Add-On is a completely browser-based report designer for end users who do not use SQL. End users can create and modify reports and even query, sort, and filter data with no special knowledge of database schema or SQL.

See Also
Managing Licenses
Managing Agents
Activate a License
Managing Reports
Managing Models


Installation

Installation
ActiveReports 12 Server User Guide > Installation

ActiveReports Server allows you to provide a browser-based report designer for end users and to serve up both end user reports and your more sophisticated developer reports. This section helps you to get started.

Important: During installation, if you choose to create new users for the Web App Pool and Service, be sure to update the user properties to match your password policy, as the default setting is to use an expiring password.

In This Section

System Requirements
View the ActiveReports Server managed agent system and server requirements.
AppPool Permissions (SQL Server)
Learn how to set up ActiveReports Server so that you can use Windows authentication to create new data models with SQL Server.
Installed Files
Browse the files installed with ActiveReports Server and brief descriptions of how they are used.
Logging On to the Administrator Site
Find out how to access the first page of the Administrator site.
Backup and Recovery
Learn which files to back up when you set up ActiveReports Server and how to recover your data in the event of a problem.
Configuring ActiveReports 12 Server on SSL and HTTPS Web Sites
Find information on using ActiveReports Server with secure Web sites.

Important: If you use a virtual directory, you must copy the crossdomain.xml file (from C:\ActiveReports 12 Server\Site) to the full root of the parent application. If you have it only in the virtual directory, a Security sandbox violation occurs when you try to preview a report.

See Also
ActiveReports 12 Server User Guide
Concepts
Troubleshooting
Activate a License

Support

Support Options


System Requirements

System Requirements
ActiveReports 12 Server User Guide > Installation > System Requirements

To install and use ActiveReports Server, you must have compatible software installed on your server. If you have multiple servers set up for load balancing, the Managed Agent machines have fewer requirements than the Master Server machine. If you have a single-server deployment, the Site consists of a Master Server and a Managed Agent on the same machine.

Operating Systems

  • Server: Windows Server 2008 and above
  • Managed Agent: Windows Server 2008 and above; .NET Framework 4.5 and above
Note: Server machine should not be an ActiveDirectory Domain Controller. ActiveDirectory Domain Controller may cause issues with the user/group level security in ActiveReports Server.

Windows Server 2008, 2012

The following features must be turned on in Windows Server 2008, 2012 to run ActiveReports Server on your server machine. From Control Panel, Programs and Features, open Turn Windows features on or off to ensure that these features are turned on. All are on by default.

  • Internet Information Services / World Wide Web Services / Application Development Features / ASP.NET 4.5
  • .NET Framework 4.5 Advanced Services / WCF Services / HTTP Activation

Web Servers

  • IIS 7, IIS 7.5 with Windows Server 2008 (needs ASP.NET role service)
  • IIS 8 and IIS 8.5
  • IIS 10
  • IIS Management Console must be turned on.
  • .NET Framework: 4.5 or higher

Internet Information Service (IIS) Ports

TCP/IP

  • ActiveReports Server 4040, 2551, 2552, and 42011
  • ActiveReports Server Managed Agent 5050

UDP

  • ActiveReports Server 7923, 26637, or 57323
  • ActiveReports Server installer 7979, 37637, and 15377
Note: You can open and access the above mentioned port numbers on the server machine using the network or firewall configuration.

Database

  • Microsoft SQL Server 2005, 2008, 2008R2, 2012, 2014 and 2016
  • MySQL
  • Oracle 11g (32-bit and 64-bit)
  • PostgreSQL
  • C-TreeACE 10 and above

Note: For Oracle, the Oracle client must be installed on the server machine and on all agent machines.

Browsers

  • Internet Explorer 9 and above
  • Google Chrome 30 and above
  • Mozilla Firefox 20 and above
  • Mobile Safari iOS6 and above

Flash Player

  • Adobe Flash Player 11, 12, and 13

SDK (Designer and ReportList control)

  • Operating System: Windows ™ Vista, Windows 7, Windows 8 and 8.1, Windows Server 2008 and above
  • .NET Framework: 4.0 or higher
  • Microsoft Visual Studio: 2010 and above


AppPool Permissions (SQL Server)

AppPool Permissions (SQL Server)
ActiveReports 12 Server User Guide > Installation > AppPool Permissions (SQL Server)

In order to generate data models using Windows authentication with Microsoft SQL Server data, the AppPool used for ActiveReports Server needs proper credentials to access the database.

This is set during installation with the user that you assign for the Web Application Pool.

If the user you assign for the application pool does not have permission to access the database, when you try to create a new model using Windows Authentication, you get an error like:

"The connection test failed. Login failed for user 'YourUserName'."

You can avoid this error by setting the AppPool account with a user who has permissions to the data you want to use, or by opting to use Server Authentication when you create a data model. See Creating a New Model for more information.

See Also
Creating a New Model


Installed Files

Installed Files
ActiveReports 12 Server User Guide > Installation > Installed Files
Show All
Hide All

When you install ActiveReports Server and use all of the default settings, files are installed in the following folders:

C:\ActiveReports 12 Server

File (or Folder) Name | Description
Agent | Contains the files that you use to deploy your solution to separate machines that host your Managed Agents if you do a multi-server deployment for load balancing.
Data | Contains user information and reports and models. This is the folder that you need to back up to prevent loss of data. For more information, see Backup and Recovery.
DataProviders | Contains data provider assemblies.
SDK | Contains server report controls and a class library for the software developer kit.
SecurityProviders | Contains the ActiveDirectorySecurityProvider assembly used to create a security provider.
Server | Contains the files used to run the server.
Site | Contains the files used to run both the Report Portal and the Admin sites, as well as all associated help files.
ActiveReports 12 Server License Agreement.rtf | The license agreement that dictates the terms under which you may use this software.

C:\ActiveReports 12 Server\SDK

File Name | Description
HTML5 Viewer.Source | Includes Cascading Style Sheets and JavaScript files for HTML5.
ja | Includes resource files for the Japanese environment.
Samples | Contains sample Visual Studio projects that you can use to evaluate the software, or customize and extend to use in your own solutions. For more information on samples, see the SDK help.
zh-CN | Includes resource files for the Chinese environment.
ActiveReports.Server.ReportControls.dll | Assembly that supports the ReportDesigner and ReportList control for use in your ASP.NET solutions.

C:\ActiveReports 12 Server\Site

Folder Name | Description
Admin | Contains the files and folders used to run the Admin site, as well as the associated help file.
Bin | Contains ActiveReports and Data Dynamics Reports assemblies as well as SQLite and DotNetZip assemblies for use on the site.
i18n | Contains the files and folders having properties of different locales.
portal | Contains the files and folders used to run the Admin site, as well as the associated help file.
crossdomain.xml | Cross-domain policy file that make data available to WSF files in different domain.
Default.aspx | The default web file that shows the introductory text and links.
Default.aspx.cs | The default cs that shows the introductory text and links.
Designerservice.svc | The service host file for DesignerService.
Error.aspx | The file that contains error information for the Designer Web application.
Generic.master | The file that contains information regarding log-in page configuration.
Global.asax | The default class that sets global URL routing values for the Designer Web application.
index.html | The index file that contains html code for appearance and functioning of the main page.
ReportService.svc | The service host file for ReportService.
web.config | The main file that contains configuration information for the Designer Web application.

List of open source software used in ActiveReports Server

  • Report Portal
    Bootstrap v3.1.1
    Bootstrap Datetimepicker
    Bootstrap Multiselect
    jQuery Cookie Plugin v1.4.1
    jQuery JavaScript Library v2.1.0
    Sizzle.js
    knockout-handlebars.js v0.0.6
    Knockout JavaScript library v3.1.0
    Less - Leaner CSS v2.0.0
    Modernizr 2.7.1
    Placeholders.js
    parseUri 1.2.2
  • Administrator Dashboard
    jQuery.data.js
    jQuery UI Datepicker 1.8.10
    jQuery.deferred.js
    jQuery.editable-select
    jQuery customfileinput
    jQuery v1.4.4
    Sizzle.js
    jquery.meio.mask.js 1.1.3
    jQuery UI Tabs 1.8.10
    jQuery Tooltip plugin 1.3
    jquery.ui.i18n.datepicker.js
    jquery.ui.i18n.timepicker.js
    jQuery UI 1.8.10
    jQuery UI Slider 1.8.10
    jQuery timepicker add-on
    Watermark plugin for jQuery 3.1.4
    json2.js
    Knockout JavaScript library v3.1.0
    jQuery UI Spinner 1.20
  • Designer
    Adobe Flex framework
  • Others
    Microsoft.Owin
    Json.NET
    ESENT Managed
    Owin.Routing
    Owin.Hosting
    SQLite and SQLite LINQ
See Also
Installation
Backup and Recovery


Logging On to the Administrator Site

Logging On to the Administrator Site
ActiveReports 12 Server User Guide > Installation > Logging On to the Administrator Site
  1. From the Start menu, in All Programs, select GrapeCity, then ActiveReports 12 Server, Administration.
  2. In the Administration Login dialog that appears in your browser, enter your registered User Name and Password.
  3. Click Log In. The Administrator Dashboard appears.


Backup and Recovery

Backup and Recovery
ActiveReports 12 Server User Guide > Installation > Backup and Recovery

It is always a good idea to back up your data so that you have a safe copy of it while installing a new ActiveReports Server version or in the event of a disaster.
In order to backup and restore data, you can use corresponding import/export REST API. It allows import and export of all or particular set of resources.
You can also use Migration PowerShell Module sample shipped with ActiveReports Server (C:\ActiveReports 12 Server\SDK\Samples) to create backup and recover data.

To back up and recover your data using Migration PowerShell Module sample

  1. Run the sample. See Migration PowerShell Module Sample topic for the detailed steps.
  2. Export all the contents of the C:\ActiveReports 12 Server\Data folder to a zip folder by running the following PowerShell script:
    Export-ArsData -Path C:\...\Documents\backup.zip
    The backup is created.
  3. Install a fresh instance of ActiveReports Server.
  4. Import the contents in C:\ActiveReports 12 Server\Data folder of the new installed version by running the following PowerShell script:
    Import-ArsData -Path C:\...\Documents\backup.zip
    The data saved in backup.zip folder is recovered.
See Also
Installed Files


Configuring ActiveReports 12 Server on SSL and HTTPS Web Sites

Configuring ActiveReports 12 Server on SSL and HTTPS Web Sites
ActiveReports 12 Server User Guide > Installation > Configuring ActiveReports 12 Server on SSL and HTTPS Web Sites

To use SSL and HTTPS on the ActiveReports Server Web site, you need to make some configuration changes.

Note: If you want to use the HTTPS communication protocol, you need to specify the URL as "https://server:443/mobile/" or "https://server:443/m/".

To use the HTTPS protocol, you must create an SSL certificate. For help with this, see Microsoft's article How to: Configure an IIS-hosted WCF service with SSL.

To configure for HTTPS only

  1. Open Internet Information Services (IIS) Manager and expand the Sites node.

  2. Select the ActiveReports 12 Server site, and on the right, in the Edit Site section, click Bindings...

  3. In the Site Bindings dialog that appears, click Add..

  4. In the Add Site Binding dialog that appears, select https under Type and select an SSL certificate under SSL certificate, then click OK to close the dialog.

  5. In the Site Bindings dialog, select the default http binding, and then click Remove. This will remove the default http binding.

  6. Open the web.config file of the Site and add the following code to the <system.serviceModel> section, between the <service> and </service>tags, to change the server address and port.
    Paste in the web.config file BETWEEN the <service> and </service> tags
    Copy Code
    <endpoint address="https://servername:443/ReportService.svc/json" binding="webHttpBinding"
contract="ActiveReports.Server.ReportServices.Servicing.IReportService"
bindingConfiguration="ReportServiceJsonBindingSecured" behaviorConfiguration="JsonBehavior" />

  7. In the <system.serviceModel> section, between the <service> and </service> tags, remove the default code between the <endpoint> tags where the endpoint address="json".

  8. In the same <system.serviceModel> section, between the <service> and </service> tags, change the default code between the <endpoint> tags from "mexHttpBinding" to "mexHttpsBinding".

  9. In the same <system.serviceModel> section, under <behavior>, remove the default code httpGetEnabled="true from <serviceMetadata> tag and add the following code.
    Paste in the web.config file BETWEEN the <serviceMetadata> and </serviceMetadata> tags
    Copy Code
    httpsGetEnabled="true"

  10. In the <bindings> section, between the <webHttpBinding> tags, remove the default section <binding name="ReportServiceJsonBinding"> and add the following code.
    Paste in the web.config file BETWEEN the <webHttpBinding> and </webHttpBinding> tags
    Copy Code
    <binding name="ReportServiceJsonBindingSecured" maxReceivedMessageSize="0x3000000">
<readerQuotas maxStringContentLength="0x3000000" />
<security mode="Transport" />

</binding>

  11. In the <bindings> section, between the <wsHttpBinding> tags, change the default security mode code from <security mode="None /"> to <security mode="TransportWithMessageCredential" />.

  12. Restart the Internet Information Services (IIS) Manager.

To configure for HTTP/HTTPS

  1. Open Internet Information Services (IIS) Manager and expand the Sites node.

  2. Select the ActiveReports 12 Server site, and on the right, in the Edit Site section, click Bindings...

  3. In the Site Bindings dialog that appears, click Add..

  4. In the Add Site Binding that appears, select https under Type and select an SSL certificate under SSL certificate, then click OK.

  5. Open the web.config file and add the following code to the <system.serviceModel> section, between the <service> and </service>tags, changing the Server address and port.
    Paste in the web.config file BETWEEN the <service> and </service> tags
    Copy Code
    <endpoint address="https://servername:443/ReportService.svc/json" binding="webHttpBinding"
contract="ActiveReports.Server.ReportServices.Servicing.IReportService"
bindingConfiguration="ReportServiceJsonBindingSecured" behaviorConfiguration="JsonBehavior" />

  6. In the same <system.serviceModel> section, under <behavior>, between the <serviceMetadata> tags, add the following code.
    Paste in the web.config file BETWEEN the <serviceMetadata> and </serviceMetadata> tags
    Copy Code
    httpsGetEnabled="true"

  7. In the <bindings> section, between the <webHttpBinding> tags, remove the default section <binding name="ReportServiceJsonBinding" and add the following code.
    Paste in the web.config file BETWEEN the and </webHttpBinding> tags
    Copy Code
    <binding name="ReportServiceJsonBindingSecured" maxReceivedMessageSize="0x3000000">
<readerQuotas maxStringContentLength="0x3000000" />
<security mode="Transport" />
</binding>

  8. Restart the Internet Information Services (IIS) Manager.

Once you set up the certificate and start using https:// to access the Web site on which ActiveReports 12 Server is installed, it begins working in secure mode.

For more help with this, see Microsoft's article on Configuring SSL on a Web Server or Web Site (IIS 6.0) or How to Set Up SSL on IIS 7.

See Also
Installation
Managing Configuration


Concepts

Concepts
ActiveReports 12 Server User Guide > Concepts

This section reviews the most common concepts to help you understand ActiveReports Server and allow you to create and serve reports more efficiently.

Logical Data Models
In ActiveReports Server, data is organized in data models. This topic gives a general overview of a data model and its components.
Reports
End users can create and save reports in the ActiveReports Server Report Portal. Administrators can serve both developer reports and end user reports.
Report Loading
This topic explains some of the properties that you can use to load reports into the Web Designer control.
Styles and Themes
Review the elements that contribute to the visual presentation of a report.
Security: Users and Roles
Browse an overview of the ActiveReports Server role-based security.
Agents and Scalability
Find out how ActiveReports Server uses agents to handle more concurrent users and higher report execution loads.
Single Sign-On with LDAP or Active Directory
Find information on mapping LDAP or Active Directory users to ActiveReports Server.
Web Services
This topic explains the Web services that are installed with ActiveReports Server.
Configuration Section Handlers
This topic explains the Web services that are installed with ActiveReports Server.
URL Access to Reports and Designer
This topic explains some of the properties that you can use to load reports into the Web Designer control.
Templates
This topic explains the built-in templates that are available for use in HTML5 Web Designer.
See Also
ActiveReports 12 Server User Guide
Managing Models
Managing Reports
Managing Security


Logical Data Models

Logical Data Models
ActiveReports 12 Server User Guide > Concepts > Logical Data Models

A logical data model is an abstract model that organizes data into separate entities with defined relationships between entities. Each entity has its own set of attributes. A user selects a data model from a list of available data models, and then uses it as a basis for creating reports.

Entities

Entities represent business objects (e.g. Contact, Product, etc.) that are included in a data model. Entities are represented to the end user in a multi-level tree. Each entity has an associated set of attributes.

You can create Ad Hoc Entities by writing SQL queries and binding them to a logical table, but certain restrictions apply.

Attributes

Attributes are associated with an entity and represent values that are used for creating a report. A calculated field is a type of attribute which calculates a value based on other attributes.

Relations

A relation is an element of a data model that represents relationships between entities.

Relation Cardinality dictates how relations are created.

As administrator, you can create new models, delete models, and edit models to provide what your end users need in order to create meaningful reports. See the Managing Models section for information on how to perform these tasks.

See Also
Working with Models


Ad Hoc Entities

Ad Hoc Entities
ActiveReports 12 Server User Guide > Concepts > Logical Data Models > Ad Hoc Entities

An ad hoc entity is one that is bound to a dynamic SQL query, for example, a stored procedure or a view, rather than a query built by ActiveReports Server. You can use an ad hoc entity in the same ways as any other entity, except that you cannot add a logical column, a calculation, to the base table of an ad hoc entity. You can, however, add calculated attributes in the SQL query itself. You can also add attributes that bind to the existing columns, and you can add relations to other entities.

An example of a query that creates an ad hoc entity from the included ActiveTunes (Sample) model is as follows.

SQL Query
Copy Code

SELECT Address, City, State FROM Customer

Creating Ad Hoc Entities

Any limitations that apply to the underlying data also apply to your ad hoc entity.

  • In SQL subqueries, you can have up to 32 levels of nesting (or less depending on memory resources and the complexity of other expressions in the query).
  • Microsoft SQL Server does not allow the TOP function in nested queries.

If you try to create an entity using a query that exceeds your underlying data's limits, ActiveReports Server displays an appropriate error.

Tip: When editing queries for ad hoc entities, provide all attributes that are currently used by the entity. This way, if you want to exclude an attribute from the SQL query of the ad hoc entity at run time, you can delete it before the edit operation.

Take care when changing these queries, because you can change the actual data for attributes without changing the semantic model (except the entity edits). This could cause data in some reports to change dramatically.


Relation Cardinality

Relation Cardinality
ActiveReports 12 Server User Guide > Concepts > Logical Data Models > Relation Cardinality

Relation cardinality dictates how relations are generated when you create a logical model, and how they are used to generate underlying SQL JOIN queries when you run reports. Generally, the cardinality is set in the underlying database, but if it is not set up properly there, you can set the cardinality of a relation from the Administrator Dashboard in the Model Editor. For more information, see Modifying a Relation.

Relation Types

When you add relations between entities, ActiveReports Server uses rules to determine cardinality. There are four ways that entities can relate:

  • One: One-to-one
  • Many: Many-to-many
  • OptionalOne: One-to-zero or one
  • OptionalMany: Many-to-zero or more

If you add relations between entity A (from table A) and entity B (from table B) using the corresponding sets of tables in AC and BC, the rules for determining cardinality are as follows.

Adding relation AB to entity A

  • If there is a unique constraint on table B that is nullable and exactly matches the columns in BC: OptionalOne.
  • If there is a unique constraint on table B that is not nullable and exactly matches the columns in BC: One.
  • Otherwise: OptionalMany. (ActiveReports Server does not use Many in creating relations, but you can set it explicitly.)

Adding relation BA to entity B

  • If there is no unique constraint on table A that matches the columns in AC: OptionalMany.
  • If there is a unique constraint on table B that matches the columns in BC, and one of those columns is nullable: OptionalOne.
  • If there is a unique constraint on table B that matches the columns in BC, and none of those columns is nullable: One.

Example

We can add a relation between the Album and Artist tables using the ArtistID column. Assuming this relation does not exist in the database yet, if we add the relation from the Album entity, we get an Album-to-Artist relation with OptionalOne cardinality and an Artist-to-Album relation with OptionalMany cardinality.

SQL JOIN Types

ActiveReports Server does not take role cardinality into account in determining what JOIN type to use. The relation in the data source controls the behavior.

  • If the relation belongs to the table that the query joins to, then it uses a LEFT JOIN.
  • If there is at least one column in the relation that accepts a null value, then it uses a LEFT OUTER JOIN.
  • Otherwise, it uses an INNER JOIN.

Basically, if it accepts null values, it uses outer joins, otherwise it uses inner joins.

Examples

The Album table has a foreign key constraint linked with the Artist table, there is a relation created for it, and it belongs to the Album table. So long as Album.ArtistID does not accept null, then for queries joining the Album table to the Artist table, we use an INNER JOIN, but for queries joining the Artist table to the Album table, we use a LEFT JOIN. However, if Album.ArtistID is nullable, then even in the case of queries joining the Album table to the Artist table, we use a LEFT OUTER JOIN.

Consider relations based on foreign constraints between Playlist, Track and PlaylistTrack tables via PlaylistID and TrackID. The relations belong to the PlaylistTrack table as they refer to Playlist and Track. Assume for this purpose that CollapseInRelations is not set for PlaylistTrack.

If you drop Playlist.Name and Track.Name to create a table, then the query tree looks like this:
PlaylistTrack
> Playlists
> Tracks

In both cases, it uses an INNER JOIN, as both relations belong to the table (PlaylistTrack) from which the query pulls.

In the case of the Album and Artist tables, the relation connects an Album to an Artist by the ArtistID. So you can drop the Artist.Name attribute and a "Total Albums" aggregate to create a table. If you drop the Name attribute first, then the query looks like this:
Artist
> Album

In this case, it uses a LEFT OUTER JOIN because the relation belongs to the table (Album) from which the query pulls.

See Also
Model Editor Overview
Adding a New Logical Relation
Modifying a Relation


Reports

Reports
ActiveReports 12 Server User Guide > Concepts > Reports

End users can create reports in the ActiveReports Server Report Portal. When the end users save reports in the Report Portal, you can see them listed on the Reports page of the Administrator Dashboard, where you can modify, delete, download, or set permissions on them.
You can also design the ActiveReports Developer reports in Administrator Portal and Report Portal using the new ClickOnce End User Designer.
Reports that are hosted on ActiveReports Server can be previewed in ActiveReports. See Viewing Reports from ActiveReports Server, for more information.

End users can also serve more complex developer reports created with ActiveReports. See Managing Reports for information on adding developer reports.

Note:
  • ActiveReports Server Designer Add-On license is required to design a semantic report.
  • The ClickOnce End User Designer works only in Internet Explorer and Microsoft Edge browsers as both are based on the ClickOnce technology.

See Also
Managing Reports


Report Loading

Report Loading
ActiveReports 12 Server User Guide > Concepts > Report Loading

When you use the Designer Web control, you can load reports into it by specifying a value for one of two properties:

  • ReportName loads the first report with the specified name.
    IMPORTANT: Multiple reports can share the same name, so using the ReportName property does not guarantee that the same report is loaded every time.
  • ReportID loads the unique report with the specified ID. When this is specified, the ReportName property is ignored.

A third property, ReportAction, tells the designer how to open the report. ReportAction has two enumerated values:

  • Design is the default value for ReportAction, and tells the designer to open the report in Design view.
  • Preview tells the designer to open the report in the Preview tab.
Note: ActiveReports Server Designer Add-On license is required to design a report.
See Also

SDK Tutorials

Use the Designer Web Control


Styles and Themes

Styles and Themes
ActiveReports 12 Server User Guide > Concepts > Styles and Themes

Styles and themes allow your end users to control the visual presentation of the reports they create. You can control which styles and themes are available to your users.

Themes determine the overall look of a report, and change the appearance of all report items: tables, charts, etc. The end user accesses themes on the Report tab of the Report Portal.

Styles can be applied to individual report items. Some styles apply only to the Table report item, and the end user accesses them on the Table Design Tools tab. Others apply only to the Chart report item, and the end user accesses them on the Chart Design Tools tab.

Note: ActiveReports Server Designer Add-On license is required to apply Themes and Styles to a report.

You can upload, download, modify, and delete styles and themes, and control which are used by default. For more information, see Managing Themes and Styles.

See Also
Managing Themes and Styles
Managing Reports


Security: Users and Roles

Security: Users and Roles
ActiveReports 12 Server User Guide > Concepts > Security: Users and Roles

ActiveReports Server employs role-based security, which means that permissions are assigned to roles, rather than to individual users. To allow a user to access specific report options, you must include them in a role group that has the proper set of permissions. In the Security section of the dashboard, click Roles to administer roles.

As Administrator, you can create roles and users. You then add users to each role and control which roles are allowed to upload ActiveReports and which roles have Read access to each model. In the Security section of the dashboard, click Users to administer users. For more information, see Managing Security.

See Also
Managing Security
Server Diagnostics
Configuring Email
Managing Single Sign-On Security Providers
Single Sign-On with LDAP or Active Directory


Agents and Scalability

Agents and Scalability
ActiveReports 12 Server User Guide > Concepts > Agents and Scalability

Agents allow you to serve reports to more concurrent users, and respond to higher report execution loads.

Scale-Out Deployment

Using multiple report server instances that share a single report server database is called scale-out deployment. You can add Managed Agents to your deployment that the central controller server uses to automatically load-balance report execution tasks.

Licensing

When you purchase the ActiveReports Server Edition, you can use as many agents as you need.

Deployment Scenarios and Licensing Requirements

For optimal scalability, it is best practice to run agents on separate machines from the main host. But if your focus is on having less hardware to manage and keeping costs down, you can keep the agent on the same machine as the host.

See Also
Managing Agents
Managing Users


Single Sign-On with LDAP or Active Directory

Single Sign-On with LDAP or Active Directory
ActiveReports 12 Server User Guide > Concepts > Single Sign-On with LDAP or Active Directory

If your user information is already stored in a corporate directory that uses Lightweight Directory Access Protocol (LDAP) or Active Directory®, you can connect your ActiveReports Server users and roles to the directory by configuring it on the Security Provider page.

For information on how to set up your LDAP or Active Directory in ActiveReports Server, see the Managing Security Providers and Using LDAP and Active Directory topics.

Note: ActiveReports Server supports OpenLDAP v2.3 or later. Earlier versions are not supported because they do not have a MemberOf attribute.

Once you have the settings and mappings in place, when you edit a model, you can add a security filter to each model entity. (See the Modifying an Entity topic for more information.)

In the Filter Expression, the value on the right side gives you a list of the attributes that are mapped to your LDAP or Active Directory.

See Also
Managing Single Sign-On Security Providers
Using LDAP and Active Directory for Single Sign-On


Web Services

Web Services
ActiveReports 12 Server User Guide > Concepts > Web Services

When you install ActiveReports Server, it runs an ASP.NET Web site that gives you access to the Report Portal and the Administrator Dashboard. The root of that Web site is located in:

C:\ActiveReports 12 Server\Site\

In the Site folder, you will find the ReportService.svc file. This allows you to call and access the report service.

Important: If you use a virtual directory, you must copy the crossdomain.xml file (from C:\ActiveReports 12 Server\Site) to the full root of the parent application. If you have it only in the virtual directory, a Security sandbox violation occurs when you try to preview a report.

There is code in each of these Web service files that tells ASP.NET that when it encounters one of our file types, it can direct the call to ActiveReports Server for handling.

To use one of the ActiveReports Server Web services, you create a client of some sort, for example a console application, and add a Service Reference that points to the service address, by default:

http://localhost/ReportService.svc

Note: If you entered a different site port, enter that value after localhost. For example, http://localhost:8080/ReportService.svc

In the Add Service Reference dialog, once you enter the correct address and click Go, you can select the service and view the available operations in the pane to the right.

ASP.NET responds differently depending on how you access the Web service URL.

  • If you access it using a raw Web service client, it initiates an exchange of XML.
  • If you access it with a browser it displays a Web page with information about using and testing the service.

When you add a service reference, Visual Studio calls the URL and appends ?WSDL. For example,

http://localhost/ReportService.svc?wsdl

WSDL, or Web Service Description Language, is XML that describes the methods and arguments that are available on the Web service, which is how Visual Studio generates the classes that you can access from code.

To see the Web services in action, check out the included sample located in:

C:\ActiveReports 12 Server\SDK\Samples


Configuration Section Handlers

Configuration Section Handlers
ActiveReports 12 Server User Guide > Concepts > Configuration Section Handlers

You can use the ReportServiceProxy class to provide a handler for the ResolveRemoteEndPoint event using code in the web.config file.

Syntax

In web.config file, you can either provide a handler for the ResolveRemoteEndPoint or you can provide a remoteReportServicePath with a username and password. ASP.NET code for both the implementations are given below.

To provide a handler for the ResolveRemoteEndPoint event

ASP.NET code. Paste in the web.config file BETWEEN the <configSections> and </configSections> tags.
Copy Code
<sectionGroup name="activereports.server">
  <section name="reportServiceProxy" type="ActiveReports.Server.ReportControls.Configuration.ActiveReportsServerSection,
  ActiveReports.Server.ReportControls, Version=x.x.xxxx.x, Culture=neutral, PublicKeyToken=d557f2f30a260da2" allowDefinition="Everywhere" />
</sectionGroup>

To provide a remoteReportServicePath with a username and password

ASP.NET code. Paste in the web.config file BELOW the </configSections> tag.
Copy Code
<activereports.server>
  <reportServiceProxy remoteReportServicePath="http://localhost:8080/" username="Admin" password="1" />
</activereports.server>

Remarks

Default configuration:

  • You must specify a value for the RemoteReportServicePath to use the section handlers.
  • The username and password values are empty by default, and are optional.

Configurable Location

Use these handlers in the application-level web.config file.

Note: While other locations may work, we do not support them.


URL Access to Reports and Designer

URL Access to Reports and Designer
ActiveReports 12 Server User Guide > Concepts > URL Access to Reports and Designer

You can use a uniform resource locator (URL) request to preview or edit reports, or even design new ones from a specified model.

Important: The logged-in user must have permission to perform the specified action on the report.

Syntax

http://server/?param="string"&ReportAction=enum

Arguments

Argument | Description
server | Replace this with the name or IP address of the computer on which you run the report server.
? | The question mark indicates to ActiveReports Server that the rest of the URL contains parameters and an action to perform.
param | Replace this with the parameter that you want to use. Select from ModelName, or ReportID.
string | Replace this with the model name or ID, or report ID, depending on the parameter you use.
& | The ampersand indicates to ActiveReports Server that the parameter is complete and the action to perform follows.
ReportAction | This is the designer property that indicates to ActiveReports Server that an enumerated action value is to follow.
enum | Replace this with the enumerated action value that you want the designer to perform. Select from Create, Design, or Preview.

Examples

Create a New Report

To create a new report from a model that you specify without opening the Models page, replace the italicized portions of the following URL with your server name and model.

URL request syntax for creating a new report.
Copy Code
http://MyServer/?ModelName="MyModel"&ReportAction=Create

For the ModelName parameter, you can use the model name, the model ID, or the GUID. If you use the model name, and there is more than one model with the same name, ActiveReports Server uses the first model of that name that it encounters.

Edit a Report

To edit an existing report in the designer without opening the report list, replace the italicized portions of the following URL with your server name and report ID.

URL request syntax for editing a report.
Copy Code
http://MyServer/?ReportId="1"&ReportAction=Design

Preview a Report

To preview an existing report without opening the report list, replace the italicized portions of the following URL with your server name and report ID.

URL request syntax for previewing a report.
Copy Code
http://MyServer/?ReportID="1"&ReportAction=Preview
See Also

SDK Tutorials

Open the Designer without Selecting a Model


Templates

Templates
ActiveReports 12 Server User Guide > Concepts > Templates

With the introduction of Templates, users are provided with the ability to make use of these while creating a report in the HTML5 Web Designer. The end users can choose from the built-in templates uploaded by an administrator on the Administrator Dashboard. The supported file formats for the templates are .rdl and .rdlx.

The templates are displayed on the Templates page on the Administration portal.

Templates Page

Templates can be edited in any supported designer in the same way as the regular reports. See Managing Templates for more information on handling templates in ActiveReports 12 Sever.


Managing Models

Managing Models
ActiveReports 12 Server User Guide > Managing Models

This section contains information that helps Administrators with data management tasks.

Model List Overview
This section describes how to maintain the list of data models from which Report Portal users create their reports.
Model Editor Overview
Refer to this section to learn about the ways in which you can modify individual data models.
Note

  • You can create row-level security by creating custom security providers. See the Managing Single Sign-On Security Providers topic for more information.

  • ActiveReports Server Designer Add-On license is required to work with Models.
See Also
Logical Data Models
Managing Reports
Managing Security
Managing Themes and Styles


Model List Overview

Model List Overview
ActiveReports 12 Server User Guide > Managing Models > Model List Overview

You can view and modify all of the data models you have available for creating reports on the Administrator Dashboard Models page.

Note: ActiveReports Server Designer Add-On license is required to create new Model.

Creating a New Model
Learn to create a new data model with the wizard.
Cloning a Model
Learn to copy an existing data model.
Working with Model Versions
Learn to use versioning to track changes to your data model. This allows you to revert to previous versions.
Deleting a Model
Learn to delete data models.
Uploading and Downloading Models
Learn to upload and download data models for backing up or transferring them.

Model Commands

You can perform actions on models using the commands to the right of each model in the list.

Command Descriptions

Command | Description
Create report | Opens the report designer with the data model already selected.
Edit | Opens the Model Editor so that you can modify the model's properties. For more information, see Model Editor Overview.
Rename | Allows you to change the model's name.
Permissions | Opens the Change Permissions dialog where you can select which roles have access to the model.
History | Displays a list of modifications by date. If you do not supply comments when you modify it, a description of the modification is automatically generated.
Download | Downloads and saves a model to the local file system.
Clone | Creates a copy of the latest version of the model, without any of the reports.
Delete | Deletes the model. This command is not available for the sample model, ensuring that there is always at least one model available.
See Also
Model Editor Overview


Creating a New Model

Creating a New Model
ActiveReports 12 Server User Guide > Managing Models > Model List Overview > Creating a New Model

Create a new data model using the model generation wizard.

To create a new model

  1. From the Administrator Dashboard, select Models.
  2. On the Models page, click New Model.

  3. In the new model wizard that appears, enter a Name for this new data source and the database server information in the provided fields.

    To enter the connection string directly in the Connection String Editor dialog

    1. In the new model wizard, next to Main settings, click the Advanced button.

      Sample connection string for SQL server
      Copy Code

      Provider=SQLCLIENT;Data Source=HQ;Initial Catalog=PUBS;User Id=myUsername;Password=myPassword;
      Sample connection string for Oracle
      Copy Code

      Provider=ORACLE;Data Source=MyServiceName;User Id=myUsername;Password=myPassword;
    2. Click Test connection to test the connection string for the new model.
    Tip: You can use any UserContext attribute in the connection string by putting the attribute name between percent signs. For example,

Provider=SQLOLEDB.1;Data Source=HQ;Initial Catalog=%TenantDatabase%;
User Id=myUsername;Password=myPassword;
  4. Click Next to proceed to the Select Tables and Views page of the wizard.
  5. Click check boxes to select items from the list of available tables and views.
    Tip: You can use the Find additional relations check box to determine whether to create relations between like-named columns (selected by default) or not. If this checkbox is not selected, a model is generated with predefined relations from the data source, which helps to avoid the generation of extra relations.

    You can also select all visible items at once by selecting the Select/Deselect All Visible Items check box.

    Notes: If you have a lot of items, you can filter what is shown by entering a value in the Filter Items By Name box.

    If you do not select any items in this step, you can generate an empty model without any data, and later add data to the model manually. See Adding a New Entity, Adding a New Logical Column (Attribute) and Adding a New Logical Relation for details.

  6. Click Next to finish the model generation wizard. A new model is generated and appears in the Models list, available to users for creating reports in the Report Portal.
See Also
Cloning a Model
Uploading and Downloading Models
AppPool Permissions (SQL Server)


Cloning a Model

Cloning a Model
ActiveReports 12 Server User Guide > Managing Models > Model List Overview > Cloning a Model

Another way to create a new model is by cloning. In this case, we choose a model from the list of current models and create its precise copy as an independent model that we can edit.

To clone a model

  1. From the Administrator Dashboard, select Models.
  2. In the Models list, select the model that you want to copy and then click Clone model button. A new model is created and displayed in the Models list.

  3. To rename the newly created model, click the clone model properties button to display the model properties.
  4. In the Name box, enter the name to update.
Note: When you clone a model, the reports remain bound to the initial model. A newly cloned model is created without any bound reports.
See Also
Creating a New Model
Uploading and Downloading Models


Working with Model Versions

Working with Model Versions
ActiveReports 12 Server User Guide > Managing Models > Model List Overview > Working with Model Versions

Model versioning allows you to keep and manage various versions of a model, so that you can track modifications and easily revert to any version of the model at any time. ActiveReports Server always uses the latest version of the model to create reports in the Report Portal.

To save a model version

When you upload an existing model, ActiveReports Server saves it in the version history the same as when you modify it in the model editor.

  1. After you finish Saving a Modified Model, click the Save & Publish button. This creates a new version of the model. The old version, as well as all other previous model versions, is kept in the History section of the model.
  2. All reports associated with the model automatically bind to the latest model version. Model changes, especially deletions, may break some reports, so compatibility is checked automatically.
    Note: See Managing Model Breaking Changes for more information on how broken reports are handled.

To view the model history

  1. In the Administration section of the Administrator Dashboard, click Models.
  2. In the Models list, next to the model whose history you want to view, click History.
  3. The History section of the model drops down to display a numbered list of model versions, the dates the changes were saved, and any comments.

  4. To hide the expanded History section, click History again.

To revert to an historic model version

  1. Click History to expand the History section of the model you want to revert.
  2. In the list of model versions, next to the version that you want, click Revert to.
  3. A copy of the selected version of the model becomes the latest version, and a compatibility check runs for all associated reports.
    Note: If a report is not compatible with the selected model version, the compatibility check continues until a compatible model version is found.

See Also
Saving a Modified Model
Managing Model Breaking Changes
Managing Models
Entering Modification Comments


Deleting a Model

Deleting a Model
ActiveReports 12 Server User Guide > Managing Models > Model List Overview > Deleting a Model

You can delete any model that does not have any associated reports.

To delete a model

  1. Delete any reports associated with the model to enable the delete function. (See Managing Reports for more information.)
  2. In the Models list, next to the model that you want to delete, click the Delete button.

See Also
Deleting an Item
Working with Model Versions
Saving a Modified Model


Uploading and Downloading Models

Uploading and Downloading Models
ActiveReports 12 Server User Guide > Managing Models > Model List Overview > Uploading and Downloading Models

The upload and download model operations offer an additional means of backing up or transferring models between servers without requiring access to the server console. To streamline upload and download times, models are saved as specially formatted and compressed xml with a file extension of .datamodel.

To download a model

  1. In the Models list, next to the model that you want to save, click Download model button.
  2. The compressed xml model file is copied onto your machine in .datamodel format.
    Tip: If your browser does not automatically offer you a choice of where to save the file, you can right-click Download and select Save As.

To upload a model

  1. On the Models page, click the Upload model button next to Upload Existing Model, click Browse and navigate to the location of a locally saved compressed xml model file.
  2. In the Upload an existing model dialog that appears, you can either drop a model file or click inside the dotted box to browse to a model file.
    Tip: Supported file extensions are .datamodel, .xml, and .smdl, so long as the file uses valid semantic model data.

    Note: ActiveReports 12 Server does not support the SSRS data model.

  3. In the Open dialog that appears, navigate to the model file that you want to upload and click Open. The dialog closes and the file name appears in the dotted box.
  4. Click Upload to add the model to the server.
See Also
Working with Model Versions
Model Editor Overview


Model Editor Overview

Model Editor Overview
ActiveReports 12 Server User Guide > Managing Models > Model Editor Overview

To access the Model Editor, next to a model in the Models list, click Edit.

The Model Editor allows you to modify a model's entities, attributes and relations. An asterisk (*) by the model name in edit mode indicates that the model has been modified. Select an entity from the Entities list on the left to edit it.

Note: ActiveReports Server Designer Add-On license is required to edit Models.

Changing the Connection String
Learn to modify the Connection String of an existing model.
Modifying an Entity
Learn which properties you can modify on each entity.
Adding a New Logical Table (Entity)
Learn to add new logical tables and to base new tables on existing entities.
Modifying an Attribute
Learn which properties you can modify on an entity's attributes.
Adding a New Logical Column (Attribute)
Learn to add new logical columns and to base new columns on existing attributes.
Modifying a Relation
Learn which properties you can modify on an entity's relations.
Adding a New Logical Relation
Learn to add new logical relations and to base new relations on existing ones.
Deleting an Item
Learn to delete any entity, attribute, or relation.
Saving a Modified Model
Learn to save a working draft of a model and to publish model changes.
Entering Modification Comments
Learn to add comments that help you to identify versions in the model history.
Managing Model Breaking Changes
Learn about changes that may break reports, and how ActiveReports Server handles them.

Model Editor Toolbar Buttons

  • Save & Publish validates and, if no errors are found, saves modifications as a new version of the model.
  • Save Draft saves modifications as a local draft copy available only to the user making the modifications.
    (Use this button to save a draft of a model that does not pass validation.)
  • Validate checks modified elements for errors.
  • Properties displays model properties such as the model name and connection string information.
See Also
Model List Overview
Logical Data Models


Changing the Connection String

Changing the Connection String
ActiveReports 12 Server User Guide > Managing Models > Model Editor Overview > Changing the Connection String

You can modify the connection string of an existing model. This is useful if you want to substitute a UserContext attribute for a value in the connection string when you use LDAP and ActiveDirectory or a custom security provider.

You can also modify the name and command timeout value of the model.

To change the connection string

  1. In the Models list, select the model that you want to edit and then click Edit model button. The model editor appears.
  2. In the Model Editor toolbar, click the Properties button.
  3. In the workspace, change properties as necessary. The table below details the properties that you can change.

    Model Properties

    Property | Description
    Model Name | Changes the name of the model that appears in the Models list. Note that if you change this name, you must update it in any reports based on the model.
    Command Timeout | Specifies the wait time before terminating an attempt to execute a command and generating an error. Leave this value blank to use the provider's default timeout.
    Connection String | Specifies the connection string used to access data for the model. This value is disabled for the sample model, but with an actual model, you can edit the connection string here. You can put a UserContext attribute name between percent signs in place of any value in the connection string.
See Also
Managing Model Breaking Changes
Saving a Modified Model
Using LDAP and Active Directory for Single Sign-On


Modifying an Entity

Modifying an Entity
ActiveReports 12 Server User Guide > Managing Models > Model Editor Overview > Modifying an Entity

You can modify the properties of an existing entity within a model.

Caution: Modifying a model may break reports attached to it. See Managing Model Breaking Changes for more information.

To modify an entity

  1. In the Models list, select the model that you want to edit and then click Edit model button. The model editor appears.
  2. In the model editor that appears, in the Entities list on the left, select the entity that you want to modify. The properties appear in the workspace and the Attributes and Relations lists populate with any associated attributes and relations.
  3. In the workspace, change properties as necessary. The table below details the properties.

    Entity Properties

    Property Name | Type | Description
    (Id) | ID | A unique identifier for the entity. Used internally by the system.
    Name | String | The name of the entity.
    Binding | ID | The database object that the entity represents.
    CollectionName | String | The name to be used for a collection of instances of the entity. Use this property to ensure that plural nouns are spelled correctly.
    Description | String | A description of the entity that appears as tooltip text in the Report Portal when a user hovers the pointer over the entity.
    Hidden | Boolean | Indicates whether the entity is hidden from end users.
    CollapseInRelations | Boolean | Indicates whether to collapse the entity when it is displayed within a relation.
    Security Filter | Expression | Allows you to use custom security providers to filter the data displayed for the entity. See Managing Single Sign-On Security Providers for more information.
    DefaultAggregateAttributes | Object | Determines the attributes to display by default when the entity appears in an aggregate.
    DefaultDetailAttributes | Object | Determines the attributes to display by default. For example, when you drag the entity onto the designer surface and create a table or chart, these attributes display by default.
    IdentifyingAttributes | Object | The set of attributes to use to identify a unique instance of the entity. This is used instead of DefaultDetailAttributes to build a table or chart if that collection is empty, since this one is never empty. This is also used to create the grouping label when you group an entity.
See Also
Modifying an Attribute
Modifying a Relation
Cloning a Model


Adding a New Logical Table (Entity)

Adding a New Logical Table (Entity)
ActiveReports 12 Server User Guide > Managing Models > Model Editor Overview > Adding a New Logical Table (Entity)

Show All
Hide All

You can create and add a new logical table to a model, or base a new one on an existing entity from the list.

To create a new logical table (entity)

Follow these steps to create a new entity using a SQL query.

Create a new entity from a query

  1. In the Models list, select the model that you want to edit and then click Edit model button. The model editor appears.

  2. In the model editor that appears, in the Entities list on the left, click Add. The New Entity dialog appears.

  3. In the New Entity dialog, enter a Name for the new entity. This value appears in the list of entities for the model.
  4. In the Description box, enter a description that provides users with additional information about the entity, such as when it is appropriate to use it.
  5. In the Query box, define the entity with a SQL query that pulls the data that you want.
  6. Check your query using the commands above the preview box.
    • Validate verifies the query and displays any errors it finds in red at the top of the dialog.
    • Preview Schema populates a table with information pulled by the query (column name, size, data type, and is nullable).
    • Preview Data populates a table with a sampling of the data pulled by the query.

  7. Click OK to add the new logical table to the model as a new entity.
    Note: In the Entities pane, when you select an entity that you created, an Edit command appears next to the Add command at the top of the pane. Click Edit to re-open the New Entity dialog and make changes to the name, description, or query.
  8. In the Model Editor toolbar, click the Save & Publish button to save the changes. The new logical table is added to the model and displayed in the Entities list.

Base a new entity on an existing logical table

Follow these steps to select an existing logical table to use as a new entity.

Base a new entity on an existing logical table

  1. In the Entities pane to add an existing entity, click Add. The New Entity dialog appears.

  2. To the right of the Query box, click the ellipsis button.

  3. In the Select an Existing Table dialog that appears, select the table that you want and click OK. The Query box in the New Entity dialog is populated with the table name, for example _Expenses, and the Name box is populated with the user friendly table name, for example Expenses.
  4. You can check your results using the commands above the preview box.
    • Validate verifies the query and displays any errors it finds in red at the top of the dialog.
    • Preview Schema populates a table with information pulled by the query (column name, size, data type, and is nullable).
    • Preview Data populates a table with a sampling of the data pulled by the query.
  5. In the Description box, enter a description that provides users with additional information about the entity, such as when it is appropriate to use it.
  6. Click OK to add the new logical table to the model as a new entity.
  7. In the Model Editor toolbar, click the Save & Publish button to save the changes. The new logical table is added to the model and displayed in the Entities list.
See Also
Adding a New Logical Column (Attribute)
Adding a New Logical Relation
Modifying an Entity


Modifying an Attribute

Modifying an Attribute
ActiveReports 12 Server User Guide > Managing Models > Model Editor Overview > Modifying an Attribute

You can modify the properties of an existing attribute within a model.

Caution: Modifying a model may break reports attached to it. See Managing Model Breaking Changes for more information.

To modify an attribute

  1. In the Models list, select the model that you want to edit and then click Edit model button.

  2. In the model editor that appears, in the Entities list on the left, select the entity whose attribute you want to modify. The properties appear in the workspace and the Attributes and Relations lists populate with any associated attributes and relations.
  3. In the Attributes list on the right, select the attribute whose properties you want to modify. The properties appear in the workspace.
  4. In the workspace, change properties as necessary. The table below details the properties that you can change.

    Attribute properties

    Property Name | Type | Description
    (Id) ID A unique identifier for the attribute. Used internally by the system.

    Name | String | The name for the attribute.
    Binding | ID | The database object that the attribute represents.
    DataType Enum

    The data type for the attribute.
    DiscourageGrouping | Boolean | Indicates whether data is grouped by entity instead of by attribute.
    Format | String | The default format for the attribute.
    Hidden | Boolean | Indicates whether the attribute is hidden from end users.
    IsAggregate | Boolean | Indicates whether the attribute is an aggregate.
    Nullable | Boolean | Indicates whether the attribute can have a null value and is used in filter and parameter editors to provide special values.
    ValueSelection Enum

    Determines what control is used to display attribute values in the filter and parameters editors.

    • Dropdown shows lookup values in a dropdown control.
    • List shows more values at once than Dropdown.
    • None disables the entire lookup process.

    By default, ActiveReports Server selects this value based on the UAVC (unique attribute values count):

    • Less than 200 - Dropdown
    • Between 200 and 1,000 - List
    • Otherwise - None
    Supports Null Values | Boolean | Indicates whether the attribute supports null values.
    Supports Blank Values | Boolean | Indicates whether the attribute supports blank values.
  5. If the attribute that you are modifying has a list of variations under it such as date parts (e.g. Expense Day, Expense Month) or aggregations (e.g. Total Amount, Avg Amount), that you have modified with format changes or deletions, you can click the Regenerate command at the top right of the Attributes list to generate all of the available variations. Note that the attribute for which you want to regenerate variations must have focus for the Regenerate command to appear.

See Also
Adding a New Logical Column (Attribute)
Modifying an Entity
Model Editor Overview


Adding a New Logical Column (Attribute)

Adding a New Logical Column (Attribute)
ActiveReports 12 Server User Guide > Managing Models > Model Editor Overview > Adding a New Logical Column (Attribute)
Show All
Hide All

You can create and add a new logical column to an entity, or base a new attribute on an existing logical column from the list.

To base a new attribute on a related entity

Follow these steps to select an existing attribute on a related entity.

Base a new attribute on an existing logical column

  1. In the Models list, select the model that you want to edit and then click Edit model button.
  2. In the model editor that appears, in the Entities list on the left, select the entity to which you want to add an attribute.
  3. In the Attributes list on the right, click Add. The Add Attribute wizard appears.

  4. In the Add Attribute wizard, click the Related Entity selection.
  5. In the list of existing attributes that appears, a white triangle indicates that you can expand the node to reveal related attributes. (A black triangle indicates that a node is expanded.)

  6. Select the one that you want to use and click Next.
  7. In the Name and Description boxes that appear, enter the name and description for the new attribute.
  8. Click Finish. The new attribute appears in the Attributes list.
  9. In the Model Editor toolbar, click the Save & Publish button to save the changes. The new logical column is available to report creators.

To base a new attribute on a database field

Follow these steps to select a database field to use as an attribute.

Base a new attribute on a database field

  1. In the Models list, select the model that you want to edit and then click Edit model button.
  2. In the model editor that appears, in the Entities list on the left, select the entity to which you want to add an attribute.
  3. In the Attributes list on the right, click Add. The Add Attribute wizard appears.

  4. In the Add Attribute wizard, click the Database Field selection.
  5. In the list of existing columns that appears, select the one that you want to use and click Next.
  6. In the Name and Description boxes that appear, enter the name and description for the new attribute.
  7. Click Finish. The new attribute appears in the Attributes list.
  8. In the Model Editor toolbar, click the Save & Publish button to save the changes. The new logical column is available to report creators.

To create a new logical column (attribute)

Follow these steps to create a new attribute using a SQL expression definition.

Creating a new attribute from an expression

  1. In the Models list, select the model that you want to edit and then click Edit model button.
  2. In the model editor that appears, in the Entities list on the left, select the entity to which you want to add an attribute.
  3. In the Attributes list on the right, click Add. The Add Attribute wizard appears.
  4. In the Add Attribute wizard, click the SQL Expression selection.
  5. In the Name box that appears, enter the name for the new attribute. This value appears in the list of entities for the model.
  6. In the Description box, enter a description that provides users with additional information about the attribute, such as when it is appropriate to use it.
  7. In the Expression Definition box, define the expression for the logical column with a SQL expression that pulls the data that you want.
    Note: The syntax to use for expressions is T-SQL for SQL data sources or PL-SQL for Oracle data sources.
  8. Check your query using the commands above the preview box.
    • Validate verifies the expression and displays any errors it finds in red at the top of the dialog.
    • Preview Schema populates a table with information pulled by the expression (column name, size, data type, and is nullable).
    • Preview Data populates a table with a sampling of the data pulled by the expression.

  9. Click Finish. The new attribute appears in the Attributes list.
  10. In the Model Editor toolbar, click the Save & Publish button to save the changes. The new logical column is available to report creators.
See Also
Modifying an Attribute
Adding a New Logical Table (Entity)
Adding a New Logical Relation
Model Editor Overview


Modifying a Relation

Modifying a Relation
ActiveReports 12 Server User Guide > Managing Models > Model Editor Overview > Modifying a Relation

A relation item in a model describes the relationships between entities. You can modify the properties of an existing relation within a model.

Caution: Modifying a model may break reports attached to it. See Managing Model Breaking Changes for more information.

To modify a relation

  1. In the Models list, select the model that you want to edit and then click Edit model button.

  2. In the model editor that appears, in the Entities list on the left, select the entity whose relation you want to modify. The properties appear in the workspace and the Attributes and Relations lists populate with any associated attributes and relations.
  3. In the Relations list on the lower right, select the relation whose properties you want to modify. The properties appear in the workspace.
  4. In the workspace, change properties as necessary. The table below gives details about the properties.

    Relation properties

    Property Name | Type | Description
    (Id) | ID | A unique identifier for the relation. Used internally by the system.
    Name String

    The name for the relation.
    Binding | ID | The database object that the relation represents.
    Cardinality Enum

    Defines the rules and restrictions for the relation's behavior in the entity tree and in semantic query building. Possible values are One, Many, OptionalOne, or OptionalMany.

    This property determines whether the Recursive property has an effect on the relation.
    Description | String | A description of the relation that appears as tooltip text in the Report Portal when a user hovers the pointer over the relation.
    Hidden | Boolean | Indicates whether the entity reached by the relation is hidden from end users.
    Recursive | Boolean | Indicates whether the relation can be added more than once to the same path. This applies only to relations with a Cardinality of One or OptionalOne. For relations with a Cardinality of Many or OptionalMany, this property is ignored.
    Include self | Boolean | Indicates whether to allow the relation to be accessible to itself in the same recurring path. This applies only in the second level of an entity.
    HiddenFields | Object | Defines the set of entity fields that is hidden from end users when they reach the entity through the relation.
    RelatedRelation | Object | Indicates the backward relation (the relation for the related entity) of the relation. You cannot edit this value, but you can use the navigate link to go to the related relation.
    RelatedEntity | Object | The entity to which the relation is bound. You cannot edit this value, but you can use the navigate link to go to the related entity.
See Also
Adding a New Logical Relation
Modifying an Attribute
Modifying an Entity
Model Editor Overview


Adding a New Logical Relation

Adding a New Logical Relation
ActiveReports 12 Server User Guide > Managing Models > Model Editor Overview > Adding a New Logical Relation
Show All
Hide All

You can create and add a new logical relation to an entity, or base a new relation on an existing logical relation from the list.

To create a new relation

Follow these steps to create a new logical relation by specifying a target entity, and source and target attributes.

Creating a new logical relation

  1. In the Models list, select the model that you want to edit and then click Edit model button.
  2. In the model editor that appears, in the Entities list on the left, select the entity to which you want to add a relation.
  3. In the Relations list on the lower right, click Add. The New Relation dialog appears.
  4. In the New Relation dialog, in the Name box, enter the name for the new relation. This value appears in the list of relations for the model.

  5. In the Description box, enter a description that provides users with additional information about the attribute, such as when it is appropriate to use it.
  6. In the Relation section, the Source Entity is already set (based on the entity you selected to which to add a relation). Drop down the Target Entity list and select a target for the relation. This enables the Target Columns drop-down list below.
  7. Drop down the Source Columns list and select a source attribute for the relation. This adds a new pair of drop-down lists for additional sources and targets below.
  8. Drop down the Target Columns list and select a target attribute for the relation.
  9. Click OK. The new relation appears in the Relations list.
  10. In the Model Editor toolbar, click the Save & Publish button to save the changes. The new logical relation is available to report creators.

To base a new logical relation on an existing relation

Follow these steps to select a relation to use as a new logical relation.

Base a new attribute on an existing logical column

  1. In the Models list, select the model that you want to edit and then click Edit model button.
  2. In the model editor that appears, in the Entities list on the left, select the entity to which you want to add a relation.
  3. In the Relations list on the lower right, click Add. The New Relation dialog appears.
  4. In the New Relation dialog, in the Relation name box, enter the name for the new relation. This value appears in the list of relations for the model.
  5. In the Description box, enter a description that provides users with additional information about the attribute, such as when it is appropriate to use it.
  6. Next to the Relation section, click the ellipsis button.

  7. In the Select an Existing Relation dialog that appears, select the one that you want to use and click OK.
  8. In the New Relation dialog, click OK. The new relation appears in the Relations list.
  9. In the Model Editor toolbar, click the Save & Publish button to save the changes. The new logical relation is available to report creators.

See Also
Modifying a Relation
Adding a New Logical Column (Attribute)
Adding a New Logical Table (Entity)
Model Editor Overview


Deleting an Item

Deleting an Item
ActiveReports 12 Server User Guide > Managing Models > Model Editor Overview > Deleting an Item

Show All
Hide All

You can delete any model item, whether entity, attribute or relation, by clicking the X button to the right each item in the Model Editor.

Caution: Modifying a model may break reports attached to it. See Managing Model Breaking Changes for more information.

To delete an entity

Follow these steps to delete an entity from a model.

Delete an entity

  1. In the Models list, select the model that you want to edit and then click Edit model button.
  2. In the model editor that appears, in the Entities list on the left, to the right of the entity that you want to delete, click the X button.
  3. In the Model Editor toolbar, click the Save & Publish button to save the changes. The deleted entity is no longer available to report creators. See Managing Model Breaking Changes for more information.

Note: It is recommended that you hide an entity or an attribute of the model instead of deleting it. This way, the entity or attribute is not available for use in new reports, but existing reports are not broken.

To delete an attribute or relation

Follow these steps to delete an attribute or relation from an entity.

Delete an attribute or relation

  1. In the Models list, select the model that you want to edit and then click Edit model button.
  2. In the model editor that appears, in the Entities list on the left, select the entity that contains the attribute or relation that you want to delete. The Attributes and Relations lists populate with any associated attributes and relations.
  3. In the Attributes list on the right, or the Relations list on the lower right, to the right of the attribute or relation that you want to delete, click the X button.
  4. In the Model Editor toolbar, click the Save & Publish button to save the changes. The deleted attribute or relation is no longer available to report creators. See Managing Model Breaking Changes for more information.
See Also
Model Editor Overview
Managing Model Breaking Changes
Entering Modification Comments


Saving a Modified Model

Saving a Modified Model
ActiveReports 12 Server User Guide > Managing Models > Model Editor Overview > Saving a Modified Model

Show All
Hide All

When you modify a model in the Model Editor, you can save the modifications and make them available to users right away, or if you have many changes to make, or a specific roll-out date, you can save a draft until you are ready to make your changes public.

Caution: Modifying a model may break reports attached to it. See Managing Model Breaking Changes for more information.

To save changes and make them public

Follow these steps to publish your changes so that report creators can use the updated model.

Publishing changes

  1. In the Models list, select the model that you want to edit and then click Edit model button.
  2. Modify, add, or delete any entities, attributes, or relations that you need to modify. (See Model Editor Overview for topics relating to these actions.)

  3. In the Model Editor toolbar, click the Save & Publish button to save the changes. This creates a new version of the model. The old version, as well as all other previous model versions, is kept in the History section of the model. (See Working with Model Versions for more information.)

  4. All reports associated with the model automatically bind to the latest model version. Model changes, especially deletions, may break some reports, so compatibility is checked automatically. (See Managing Model Breaking Changes for more information.)

To save a draft of your changes

Follow these steps to save a working draft that you can return to later, without releasing the changes to report creators. ActiveReports Server automatically saves a draft while you are working, but you can save the draft any time.

Saving a working draft

  1. In the Models list, select the model that you want to edit and then click Edit model button.
  2. Modify, add, or delete any entities, attributes, or relations that you need to modify. (See Model Editor Overview for topics relating to these actions.)
  3. In the Model Editor toolbar, click the Save Draft button to save a draft copy of the model with the changes you have made. This does not create a new version of the model. The old version is still what report creators use.
  4. The draft copy is available only to the user who made the modifications, and is marked in the Models list with (Draft Saved).

To discard a draft

ActiveReports 12 Server automatically saves a draft while you are working, and you can save it as you make changes, but if you do not want to keep the changes, you can discard them.

Discarding a draft

  1. In the Model list, select the model for which you have saved the draft and then click Edit model button.
  2. Before the model loads into the model editor, the Continue Draft message box appears.
  3. Click No. The draft changes are discarded and the unchanged version of the model loads into the model editor.

To apply the modifications of the draft copy to the model

Follow these steps to keep changes saved to a working draft, and publish the changes for report creators.

Publishing a draft

  1. In the Model list, select the model for which you have saved the draft and then click Edit model button.
  2. Before the model loads into the model editor, the Continue Draft message box appears.
  3. Click Yes. The changed draft version of the model loads into the model editor.

  4. In the Model Editor toolbar, click the Save & Publish button to save the changes. This creates a new version of the model. The old version, as well as all other previous model versions, is kept in the History section of the model. (See Working with Model Versions for more information.)

  5. All reports associated with the model automatically bind to the latest model version. Model changes, especially deletions, may break some reports, so compatibility is checked automatically. (See Managing Model Breaking Changes for more information.)

See Also
Model Modification Comments
Managing Model Breaking Changes
Model Editor Overview


Entering Modification Comments

Entering Modification Comments
ActiveReports 12 Server User Guide > Managing Models > Model Editor Overview > Entering Modification Comments

ActiveReports Server automatically adds a comment with the name of the administrator who published a change, or you can enter your own comments after you modify and save a model. These comments appear in the history of model versions so that you can easily find the version you want. See Working with Model Versions for more information.

To enter modification comments

  1. In the Models list, select the model that you want to edit and then click Edit model button.
  2. Modify, add, or delete any entities, attributes, or relations that you need to modify. (See Model Editor Overview for topics relating to these actions.)

  3. In the Model Editor toolbar, click the Save & Publish button to save the changes.

  4. In the Save & Publish dialog that appears, the automatically generated comments are highlighted.

  5. Enter your comments and click Save & Publish. This creates a new version of the model. The old version, as well as all other previous model versions, is kept in the History section of the model.

    Note: If you do not wish to enter your own comments, click Save & Publish anyway to save the automatically generated comments.

  6. The comments are displayed in the model history. (See Working with Model Versions for more information.)
See Also
Saving a Modified Model
Model Editor Overview


Managing Model Breaking Changes

Managing Model Breaking Changes
ActiveReports 12 Server User Guide > Managing Models > Model Editor Overview > Managing Model Breaking Changes

When you modify a model, certain changes may break reports that are associated with the model. Such model changes are:

  1. Deleting an entity, attribute or relation.
  2. Modifying the Cardinality property of a model's relation.

Note: It is recommended that you hide an entity or an attribute of the model instead of deleting it. This way, the entity or attribute is not available for use in new reports, but existing reports are not broken.

When you save a change that breaks a report, a warning appears below the work area for each broken report.

The "ReportName" report was broken by your changes, therefore it is still bound to the old version of this model so that users can view this report without errors. For more information about this warning, see the "Model Breaking Changes" topic in the help.

See Also
Model Editor Overview
Model List Overview


Report Categories

Report Categories
ActiveReports 12 Server User Guide > Report Categories

ActiveReports Server provides the ability to create categories and sub-categories to help manage your reports better. The purpose of this feature is to allow users to organize their reports into categories to make report navigation easier.

You can create, edit, rename, move or delete a category or create sub-categories within your category.

Categories

There are two types of categories available in ActiveReports Server.

System Categories

The Administrator creates and manages System Categories from the Administrator Dashboard. Both the Administrator and end users can view these categories but only the administrator can create, rename, edit, move or delete a system category.

The System Categories are visible to the End Users in the Categories tab of the Report Portal but the end users can only assign these System Categories if the Administrator gives them permission to do so. The System category names are highlighted in bold in the Categories panel of the Report Portal. See Managing Reports, for further information. The Administrator can assign multiple System Categories to a report, and can also move multiple reports to a single category at the same time.

Role Root Category

Role Root Category is a system category that is set as the top level category for each user role. All the sub-categories under this level are available to the users in that particular user role. If more than one role is assigned to any user, then the user can view the category hierarchy for both the roles on the Report Portal. The Administrator can set a role root category for each role using the Role Properties option. Each user is assigned a root category based on their role.

For example, an administrator wants to create two system categories, namely Sales and Marketing, that are only visible to the users in their respective roles. To do this, set the Sales system category as the role root category for the Sales role, and the Marketing system category as the role root category for the Marketing role. For further details, see Managing System Categories.

Note: By default, the Root category is assigned for a role if no role root category specified. This allows the role to access all categories.

Personal Categories

End users create and manage Personal Categories from the Report Portal. These categories are unique to each end user and are not visible on the Administrator Dashboard. End users can create, rename, edit, move or delete these Personal Categories and can assign one or multiple Personal Categories to a report. or even move multiple reports to a single category at the same time. See Personal Categories for further information.

See Also
Managing System Categories


Managing System Categories

Managing System Categories
ActiveReports 12 Server User Guide > Report Categories > Managing System Categories

The Administrator can add, delete, edit, move and modify existing System Categories from the Administrator Dashboard. These System Categories are available to the Administrator and End Users. See Report Categories for further details on System Categories.

Categories Section

  • Add a New System Category
  • Edit an Existing System Category
  • Delete a System Category
  • Assign Multiple System Categories to a Report
  • Assign a Single System Category to Multiple Reports
  • Change the System Category of a Report
  • Set a Role Root Category
  • Hide Empty System Categories

Add a New System Category

  1. In the Administration section of the Administrator Dashboard, click Categories.
  2. In the list of categories that appear, click the Add Category button to open the Add category dialog.

  3. In the Add category dialog, enter the Category Name and select a Location where you want to create a System category.
    Note: System category location can either be root (Parent node) or you can create a sub-category under any existing category.
  4. Click Create to add the new System category to the list of categories.

Edit an Existing System Category

  1. In the Administration section of the Administrator Dashboard, click Categories.
  2. On the Categories page, select a category from the list, and then click the category properties button to display the category properties.
  3. From the Category properties pane, modify the Category Name or Location of the System category.

Delete a System Category

  1. In the Administration section of the Administrator Dashboard, click Categories.
  2. On the Categories page, click the Delete tag button next to the category.
  3. In the Delete dialog, click OK to delete the System category from the list of categories.

Assign Multiple System Categories to a Report

  1. In the Administration section of the Administrator Dashboard, click Reports.
  2. In the report list that appears, select the check-box to the left of the report.
  3. Click the Categories button to open the Assign categories dialog.
  4. In the Assign categories dialog, select check boxes to assign your report to multiple System Categories.
  5. Click Assign to assign multiple System Categories to your report.

Assign a Single System Category to Multiple Reports

  1. In the Administration section of the Administrator Dashboard, click Reports.
  2. In the report list that appears, select the check-boxes to the left of the reports that you want to select.
  3. Click the Categories button to open the Assign categories dialog.
  4. In the Assign categories dialog, check any check-box to select the System category to which you want to add all the selected reports.
  5. Click Assign to assign a System category to multiple reports.

Change the System Category of a Report

  1. In the Administration section of the Administrator Dashboard, click Reports.
  2. In the report list that appears, select the check-box to the left of the report to select the report.
  3. Click Categories button to open the Assign categories dialog.
  4. In the Assign categories dialog, clear the check box for the assigned System category.
  5. Select the check box for the new System category that you want to assign to your report. Click Assign to change the System category of the selected report.

Set a Role Root Category

  1. In the Security section of the Administrator Dashboard, click Roles.
  2. On the Roles page of the Administrator Dashboard, select a role from the list, and then click the role properties button to display the role properties.
    Set Role Root Category

    Set Role Root Category

  3. In the Root category section, select any role root category from the drop-down list box. The role root category is set for the selected role.
Note: Setting up a root category does not impact the report permissions. Reports that are not visible under the System Category hierarchy for the role, but for which the role has the required permissions, appear under the No category section of the report Portal.

Hide Empty System Categories

  1. In the Configuration section of the Administrator Dashboard, click Site Settings.
  2. On the Site Settings page of the Administrator Dashboard, check the Hide Empty Categories in Report Portal option. This will hide the empty system categories from the Report Portal.
See Also

Designer12Onwards

Report Categories


Managing Reports

Managing Reports
ActiveReports 12 Server User Guide > Managing Reports

Reports saved in the Report Portal are displayed on the Administrator Dashboard in the Reports list. Administrators can convert a report into a template, assign categories, rename, set permissions, download, preview, delete, or upload them. Reports can also be opened and saved directly from ActiveReports Designer or Visual Studio Designer to ActiveReports Server. For further information, see Server Reports.

Note:

  • Reports created by different users can have same names, but the reports created by the same user should have unique names.
  • A report name can not be same as an existing template name.

Report Commands

You can perform actions on reports using the commands to the right of each report in the list.

Report Commands

Command Descriptions

Command | Description
Upload Uploads a report from your local files. First, drop a file or click the special area to locate a valid report file in one of the supported formats: .rdl, .rdlx, .rpx, .dll or .exe. (Reports in other formats are not uploaded.) Select a report, click Open, and then click the Upload command. The report is added to the Reports list.

Notes: An uploaded report is automatically bound to a compatible model. If there is no compatible version of the model that the report is bound to on the server, the report is not uploaded.

The user who uploads the report is the Owner of the report, with full, irrevocable permission.
Click to show report properties | Allows you to show the report properties in the pane that opens to the right of the Reports list. In the Report properties pane, you can edit the report's name and description in the corresponding fields, and modify the report's permissions. Under the Categories tab, you can assign categories to the selected report.
Convert a report into a template

A user can convert a report into a template using the Set as Template button that is available on the information panel for a selected report on the Reports page.

Note: The Set as Template button is not available for code-based and section reports. Once a report is set as a template by clicking this button, it is no longer available in the Reports list and can only be viewed in the templates list that appears on the Templates page in the admin portal.

Also, only two permissions are available for templates - None and Read. If a report with permissions Read/Read&Modify/full is converted into a template, then these permissions are changed to Read.
Preview report | Runs the report and displays it in the Designer Preview window.
Design report Displays the selected report in the Designer - ActiveReports Server Designer for Semantic reports and ClickOnce End User Designer for ActiveReports Developer reports.
Note:
  • ActiveReports Server Designer Add-On license is required to design a report.
  • The ClickOnce End User Designer works only in Internet Explorer and Microsoft Edge browsers as both are based on the ClickOnce technology.
Download report | Downloads and saves the report to the local file system in .rdlx format.
Delete report | Deletes the report and removes it from the report list.
Permissions | Opens the Change Permissions dialog where you can select which roles have access to the model. See Managing Permissions to Reports and Models for more information.
Categories | Allows you to assign categories to the existing reports. Click the Categories button to open the Assign categories dialog. See Managing System Categories for more information.

Special Reports

Some types of reports require special consideration. These include drill-through reports, and reports created with the developer version of ActiveReports or Data Dynamics Reports. Find out how to handle these reports in the following topics.

  • Using Code Based Section Reports from ActiveReports Developer
  • Using RPX Reports from ActiveReports Developer
  • Using Data Dynamics Reports
  • Uploading Drill-Through Reports
See Also
Reports
Security: Users and Roles
Managing Permissions
Managing Models
Managing Security
Managing Themes and Styles


Using Code Based Section Reports

Using Code Based Section Reports
ActiveReports 12 Server User Guide > Managing Reports > Using Code Based Section Reports

If your developers use ActiveReports, you can upload your existing ActiveReports code-based files that are compiled into a .NET assembly to take advantage of the ActiveReports Server scheduling, security, and scalability features. Note that if you also use the Designer Add-On, these developer reports cannot be edited by end users.

.NET Assembly Requirements

In order to upload your code-based section reports to ActiveReports Server, first compile them into a .NET assembly. Your compiled report assembly must meet all of the following requirements in order to avoid errors.

  • It must be a valid .NET assembly with a strong name signature.
  • It must have the target platform set to Any CPU.
  • It must be compiled for .NET Framework 3.5.
  • All its dependencies must be resolvable on the Server side.
  • The version of ActiveReports 12 assemblies that you reference in the compiled report assembly cannot be newer than the version of ActiveReports 12 assemblies installed on the Server.
  • It must contain at least one code-based section report.
  • All its reports must have a parameter-less constructor.

To upload developer ActiveReports code-based files

Developer ActiveReports appear in the list of available reports in the Report Portal as well as in the Reports list in the Administrator Dashboard. In the Report Portal, they have only Preview and Delete buttons, with the Design button omitted.

  1. In the Administration section of the Administrator dashboard, click Reports.
  2. On the Reports page, click the Upload report button.
  3. In the Upload an existing report dialog that appears, click the special area to navigate to the .NET assembly file (dll or exe) with the code-based section report that you want to distribute via ActiveReports Server, select it and click Upload.

  4. Select reports in the list by selecting the corresponding check boxes.
  5. Click OK to add the report to the Reports list in both the Administrator Dashboard and the Report Portal. If a report with same name already exists, you can select the Overwrite checkbox to replace the report.

Note:
  • The code-based ActiveReports Developer reports cannot be created in ActiveReports Server. To create or modify such reports, please use ActiveReports in Visual Studio IDE.
  • The code-based reports built with an older version of ActiveReports cannot be previewed in ActiveReports 12 Server. Users should always rebuild all code-based reports using ActiveReports 12 and republish them on the server.

To schedule developer ActiveReports

As with any report, you can schedule code-based section reports to run at certain times, and have them automatically sent to stakeholders.

See Also
Managing Reports
Using RPX Reports from ActiveReports
Using Data Dynamics Reports
Managing Schedules


Using RPX Reports from ActiveReports

Using RPX Reports from ActiveReports
ActiveReports 12 Server User Guide > Managing Reports > Using RPX Reports from ActiveReports

You can upload your existing ActiveReports RPX files to take advantage of the ActiveReports Server scheduling, security, and scalability features. Of necessity, there are some limits to what is supported. Here are some tips to make your RPX files compliant with ActiveReports Server.

Only self-contained RPX files are supported

  • Convert any Visual Basic or C# code used in the original ActiveReport into script in the RPX file.
  • Convert any references to external classes, Web services, or application code to a self-contained script inside the RPX file.
  • Remove any function that requires access to the local file system, or the .NET security policies used to ensure server stability will cause errors.
  • Connect reports to databases such as SQL Server or Oracle normally, using only a connection string.
  • Connect to XML data sources on a remote host using the FileURL property to enable unbound data source scenarios.

To upload developer ActiveReports RPX files

Developer ActiveReports appear in the list of available reports in the Report Portal as well as in the Reports list in the Administrator Dashboard. In the Report Portal, they have only Preview and Delete buttons, with the Design button omitted.

  1. In the Administration section of the Administrator dashboard, click Reports.
  2. On the Reports page, click the Upload report button.
  3. In the Upload an existing report dialog, you can either drop a RPX file or click inside the dotted box to browse a RPX file.
  4. In the Open dialog that appears, navigate to the RPX file that you want to upload and click Open. The dialog closes and the file name appears in the dotted box.
  5. Click Upload to add the report to the Reports list.

Note: Developer ActiveReports cannot be edited in the ActiveReports Server designer. To edit such reports, please use ActiveReports in Visual Studio or in an End User Designer application created with the Pro Edition of ActiveReports.

To schedule developer ActiveReports

As with any report, you can schedule RPX reports to run at certain times, and have them automatically sent to stakeholders.

See Also
Using Data Dynamics Reports
Managing Reports
Using Code Based Section Reports
Managing Schedules


Using Data Dynamics Reports

Using Data Dynamics Reports
ActiveReports 12 Server User Guide > Managing Reports > Using Data Dynamics Reports

You can upload your existing Data Dynamics Reports RDLX files to take advantage of the ActiveReports Server scheduling, security, and scalability features.

Caution: In order to run RDLX reports in ActiveReports Server, the server must have access to the data source. Shared data sources are not supported for Data Dynamics Reports in ActiveReports Server.

To upload Data Dynamics Reports RDLX files

Data Dynamics Reports appear in the list of available reports in the Report Portal as well as in the Reports list in the Administrator Dashboard. In the Report Portal, they have only Preview and Delete buttons, with the Design button omitted.

  1. From the Administrator Dashboard, select the Reports page.
  2. Above the list of reports, click the Upload report button.
  3. In the Upload an existing report dialog that appears, click the special area and navigate to the RDLX file that you want to distribute via ActiveReports Server, select it, and click Open.
  4. In the Upload an existing report dialog, click Upload to add the report to the Reports list in both the Administrator Dashboard and the Report Portal.

Note: Data Dynamics Reports cannot be edited in the ActiveReports Server designer. To edit such reports, please use Data Dynamics Reports in Visual Studio or in an End User Designer application created with Data Dynamics Reports.

To schedule Data Dynamics Reports

As with any report, you can schedule RDLX reports to run at certain times, and have them automatically sent to stakeholders.

See Also
Using RPX Reports from ActiveReports
Managing Reports
Using Code Based Section Reports
Managing Schedules


Uploading Drill-Through Reports

Uploading Drill-Through Reports
ActiveReports 12 Server User Guide > Managing Reports > Uploading Drill-Through Reports

You can download and upload drill-through reports like any other report created with ActiveReports Server, but to keep the drill-through functionality intact, you must keep two things in mind.

  • The linked report must always be kept with the main report.
  • If you change the linked report's name, you must also change it in the main report.

When you upload a report with drill-through links, if the linked reports do not exist on the server, an error message appears.

See Also
Managing Reports


Managing Schedules

Managing Schedules
ActiveReports 12 Server User Guide > Managing Schedules
Show All
Hide All

Shared schedules allow you to specify a recurring interval at which to run a report. Each schedule has a name, an optional description, and a list of roles that defines which users have permission to assign reports to it.

Once you add a shared schedule, all users in each role that is granted permission to the schedule can assign reports to run on it.

Note: If the Don't process empty reports setting is selected on the Site Settings page under Configuration, the schedule task result will not be delivered.

Recurrence

You can set up recurrence options on shared schedules.

Recurrence options

Option | Description
Starting On | Set the date and time for the task to start.
Ending On | Set the date and time for the task to end. By default, this setting doesn't have an end date. To set it, you can select the ending date and time from the Calendar control.
Repeat Task Every | Enter a number and select Minutes, Hours, Days, Weeks, or Months to set the frequency of the report execution.
On days | Select check boxes to specify which day or days of the week the task runs.
On hours | Enter hours within a day separated by a comma to specify which hour or hours of the day the task runs. When left blank, then "All" hours in the day are used for processing the schedule.
On minutes | Enter minutes within an hour separated by a comma to specify which minute or minutes of the hour the task runs. When left blank, then "All" minutes in the hour are used for processing the schedule.
Result Expires After | Enter a number and select Minutes, Hours, or Days to specify how long to keep the report in the History. When the specified time period expires, you can no longer open the report from the History tab by clicking Open.

Note: The Repeat Task Every and On days settings work in conjunction to define the dates for a scheduled task to run.

For example, if you set the Repeat Task Every setting to 2 Days and the On days setting to Fri, the scheduled task runs every second day that falls on a Friday.

Another example: if you set the Starting On setting to Thursday, the Repeat Task Every setting to 2 Weeks, and the On days setting to Thu, the scheduled task runs every second Thursday. However, if a day other than Thursday is selected in the On days setting, the scheduled task will NOT run, as the days for the schedule to run include the starting date.

Note: If the Repeat Task Every is set to 1 minutes and On minutes is set to 5,10,15, then the task is executed on 5, 10, 15 minutes only.

Delivery

You can optionally set delivery options for your users, or you can leave them as set by default and allow the users to choose the settings.

Option | Description
Format | Select the format to which you want to deliver the report. Formats: Allow User to Choose, Excel file (xls), MHT document (archived Web page), Image file, PDF document, Word document, XML file (xml), or CSV file (csv).
Delivery Type | Select Allow User to Choose, Email, Windows File Share, or Print. Below are more options that appear with these delivery types.
Note: The Format option is unavailable if the Delivery Type is set to 'Print'. Also note that you must have permissions to the specified printer.

Delivery Type options

Email Delivery Type Options

Option | Description
Email report to | Enter one or more e-mail addresses where the report is to be sent. Separate multiple e-mail addresses with commas.
Subject

Enter the text to use for the e-mail's subject line. You can use the following syntax in the subject:

  • ?ParameterName: To specify parameter values for the report in the subject. Replace ParameterName with the actual name of the parameter.
  • &ReportName: To specify the report name.
  • &ExecutionTime: To specify the execution date and time of the report.
Body Enter text to use in the body of the e-mail. You can use the following syntax in the e-mail body:
  • ?ParameterName: To specify parameter values for the report in the e-mail body. Replace ParameterName with the actual name of the parameter.
  • &ReportName: To specify the report name.
  • &ExecutionTime: To specify the execution date and time of the report.

    Caution: When using a syntax such as, &ReportName, add a whitespace character after the syntax to replace the placeholder correctly.

    For example:

    • Correct: This is &ReportName template.
    • Incorrect: This is &ReportNametemplate.

    You can also enclose the syntax with curly braces to replace the placeholder correctly.

    For example:

    • &{ReportName}
Delivery method | Select Allow User to Choose, or As Link to insert a hyperlink to the report in the body of the message, or As Attachment to attach the report to the message in the format specified above. If you select As Link, please see Site Settings Notification URL.
Attachment template Enter the resource name template. You can use the following syntax in the attachment template:
  • ?ParameterName: To specify parameter values for the report in the attachment template. Replace ParameterName with the actual name of the parameter.
  • &ReportName: To specify the report name. This is default template.
  • &ExecutionTime: To specify the execution date and time of the report.
Note: ExecutionTime token is specified as &{ExecutionTime:<TokenFormat>}. Different DateTime format strings for .NET framework such as "d", "F", "T" etc. can be specified for the TokenFormat. For example, &{ExecutionTime:d} will be displayed as 06/10/2014.
Caution: When "g" DateTime format is specified using special characters in the "&ExecutionTime" token, the generated attachment that is received through scheduled e-mail is downloaded in an unsupported format.

Windows File Share Delivery Type Options

Option | Description
File name Enter the name of the report file. You can use the following syntax in the file name:
  • ?ParameterName: To specify parameter values for the report in the file name. Replace ParameterName with the actual name of the parameter.
  • &ReportName: To specify the report name. This is default template.
  • &ExecutionTime: To specify the execution date and time of the report.
Add file extension | Select to add the file extension for the report's format to the file name.
Path | Enter the fully qualified UNC path of the location at which to share the report.
User name | Enter the user name to connect to the UNC path.
Password | Enter the password of the user for the UNC path.
Overwrite | Select Allow User to Choose, Overwrite the existing file if it exists , or Increment filename as newer versions are added to control how stored versions of the report are handled.

Print Delivery Type Options

Option | Description
Printer | Select a printer from the list of available printers on the server, or select Allow User to Choose option.
Printer Options The following options are available:
  • Color: Choose to print in Color, Gray scale, or select Allow user to choose option.
  • Two sided: Specify printing as One-sided, Two-sided(Long edge), Two-sided(Short edge), or select Allow user to choose.
  • Number of copies: Enter the number of copies to be printed or select Allow user to choose.
  • Paper size: Select the page size from several available options such as Letter, Legal, Statement, A5, and so on, or select Allow user to choose.
  • Paper source: Select paper source as Auto, Multi-purpose Tray, Drawer 1, Drawer 2, Paper Type Priority, or select Allow user to choose.

Setting Allow user to choose for any of the above options allows the user to set that option in the Report Portal later.
See Also
Managing Roles
Site Settings Notification URL


Managing Printers

Managing Printers
ActiveReports 12 Server User Guide > Managing Printers

You can add printers on ActiveReports Server and manage the properties of available printers from the Printers page. After a printer is added to the server, you can create scheduled printing tasks. You can also assign permissions to the roles that can schedule tasks on the printer.

To add a printer

  1. In the Administration section of the Administrator Dashboard, click Printers.
  2. On the Printers page, click the Add a printer button. The Add Printer dialog appears.
  3. Fill in the options in the Add Printer dialog as follows:
    Options | Description
    Printer Name | Specify the printer name. The printer name should be the same as the name of a printer installed on the server machine. This is a required field.
    Model Name | Specify the model name.
    Hosts | Select the host to use for server printing. You can select multiple hosts or select 'All' to select all the available hosts. This is a required field.
    Description | Add a description of the printer.
    Assign permissions | Select the role(s) that can schedule server printing.
  4. Click the Test connection button to test the connection between the printer and the server.
  5. On successful testing, click Create to add the printer to the server.
Note: Virtual printers such as Microsoft XPS Document Writer and Universal Document Converter are not supported in ActiveReports server. If a user performs server printing with a virtual printer, the status of the task will always appear as executing and the agent machine will hang. In this case, the user will not be able to preview a report or perform other tasks. To resolve this, the user needs to remove this schedule from the report and restart the agent service manually.

To edit the printer settings

  1. In the Administration section of the Administrator Dashboard, click Printers.
  2. On the Printers page, select a printer from the list, and then click the printer properties button.
  3. Modify the printer properties, change permissions, or host settings. You cannot modify the Printer Name.
  4. Click Save to save the modified printer properties.

On re-installing or upgrading the product, 'Unable to resolve all agents' error message is displayed under the Host name of the printer(s) on the Printers page. To resolve this error, you need to set the agents again as follows:

  1. Go to the Printers page.
  2. Select the printer from the list and click printer properties button.
  3. Check the Checkbox to select the agent from the list of Hosts.
See Also
Managing Roles
Managing Schedules


Managing Data Sources

Managing Data Sources
ActiveReports 12 Server User Guide > Managing Data Sources

ActiveReports Server provides you with the ability to create, upload, download, or delete data sources from the Administrator dashboard. Data sources are files in RDSX format that contain data connection information. You can not only access the data sources in the Report Portal, but also access these in ActiveReports. See Server Shared Data Sources, for more information.

Data Sources

Create

  1. In the Administration section of the Administrator Dashboard, click Data Sources.
  2. Click Create data source.
  3. From Add data source window, enter Name of the data source, provide its description, and select the type of Provider from the drop-down. You can select form the following data providers:
    • Microsoft SQL Client Provider
    • Csv Provider
    • DataSet Provider
    • JSON Provider
    • Microsoft ODBC Provider
    • Microsoft OleDb Provider
    • Oracle Client Provider
    • XML Provider
  4. Fill-in the required fields such as connection string, server name, etc. corresponding to the selected provider. For more information on data sources, see Report Data Source Dialog topic.
  5. Click Test connection to test the connection to the data provider.
  6. Click Save.

Download

  1. In the Administration section of the Administrator Dashboard, click Data Sources.
  2. On the Data Sources page, click the Download data source button next to the data source.
  3. The data source file is downloaded on your system in .rdsx format.

Upload

  1. In the Administration section of the Administrator Dashboard, click Data Sources.
  2. On the Data Sources page, click the Upload data source button.
  3. In the Upload an existing data source dialog that appears, you can either drop a data source file or click inside the dotted box to browse to a data source file.

  4. In the Open dialog that appears, navigate to the *.rdsx file that you want to upload and click Open. The dialog closes and the file name appears in the dotted box.
  5. Click Upload to add the data source to the server.

Delete

  1. In the Administration section of the Administrator Dashboard, click Data Sources.
  2. On the Data Sources page, click the Delete data source button next to the data source. The data source is removed from the list.

Rename

  1. In the Administration section of the Administrator Dashboard, click Data Sources.
  2. On the Data Sources page, select a data source from the list, and then click the Data source properties button to display the data source properties.
  3. In the Name box, enter the name to update.

Manage Permissions

  1. On the Data Sources page of the Administrator Dashboard, select a data source from the list, and then click the data source properties button to display the data source properties.
  2. In the Change permissions section, next to each role, drop down the box to select whether to allow its users Execute or Execute and Create Datasets.
Note: Users must have the Execute and Create Datasets permission to access the Server Shared Data Sources in ActiveReports.

See Also
Managing Data Sets
Managing Reports


Managing Data Sets

Managing Data Sets
ActiveReports 12 Server User Guide > Managing Data Sets

ActiveReports Server provides you with the ability to create, edit, upload, download or delete data sets from the Administrator dashboard. The server administrator sets up permissions to control who can access data sets uploaded on ActiveReports Server. You can use these server shared data sets to design reports in ActiveReports. See Server Shared Data Sets, for more information.

Data sets

Create

  1. In the Administration section of the Administrator Dashboard, click Data Sets.
  2. Click Create data set.
  3. In the Add data set dialog window, enter the Name of the data set and select the Data Source from the drop-down list. The drop-down list contains the data sources available on the ActiveReports Server.
  4. Enter the query and select a Command Type from the drop-down list - Text (default value) or StoredProcedure.
    Note: When you add a data set (stored procedure) with a parameter, and the Command type is set to StoredProcedure, the parameter is created automatically at the query validation.
  5. Click Validate to validate the query.
  6. In the Fields section, you can Add or Delete a bound field and/or a calculated field according to your requirements in your data set. Bound fields are populated automatically at the data set query validation.
  7. Click Next to pass to the second page Settings and Options.
  8. In the Settings section, you can add or delete a parameter according to your requirements to the data set. The parameter options are available on the Edit Parameter page that you can open by clicking the Edit button. For more information, see Server Shared Data Sets topic.

  9. In the Settings section, you can also add a filter to your data set. The filter options are available on the Edit Filter page. For more information, see Server Shared Data Sets topic.
  10. In the Options section, select from the following options:
    • Case Sensitivity. Set this value to Auto, True, or False to indicate whether to make distinctions between upper and lower case letters. Auto (by default) causes the report server to get the value from the data provider. If the data provider does not set the value, the report runs without case sensitivity.
    • Collation. Choose from Default or a country from the list to indicate which collation sequence to use to sort data. The Default value causes the report server to get the value from the data provider. If the data provider does not set the value, the report uses the server locale. This is important with international data, as the sort order for different languages can be different from the machine sort.
    • Kanatype Sensitivity. Set this value to Auto, True, or False with Japanese data to indicate whether distinctions are made between Hiragana and Katakana kana types. Auto (by default) causes the report server to get the value from the data provider. If the data provider does not set the value, the report runs without kana type sensitivity.
    • Width Sensitivity. Set this value to Auto, True, or False with Japanese data to indicate whether distinctions are made between single-byte (half-width) characters and double-byte (full-width) characters. Auto (by default) causes the report server to get the value from the data provider. If the data provider does not set the value, the report runs without width sensitivity.
    • Accent Sensitivity. Set this value to Auto, True, or False to indicate whether distinctions are made between accented and unaccented letters. Auto (by default) causes the report server to get the value from the data provider. If the data provider does not set the value, the report runs without accent sensitivity.
  11. Click Finish.

Download

  1. On the Data Sets page of the Administrator Dashboard, click the Download data set button next to the data set.
  2. The data set file is downloaded on your system in .rdsx format.

Upload

  1. On the Data Sets page of the Administrator Dashboard, click the Upload data set button.
  2. In the Upload an existing data set dialog that appears, you can either drop a data set file or click inside the dotted box to browse to a data set file.
    Upload an existing data sets

    Upload an existing data sets

  3. In the Open dialog that appears, navigate to the *.rsdx file that you want to upload and click Open. The dialog closes and the file name appears in the dotted box.
  4. Click Upload to add the data set to the server.

Delete

  1. On the Data Sets page of the Administrator Dashboard, click the Delete data set button next to the data set. The data set is removed from the list.

Rename

  1. On the Data Sets page of the Administrator Dashboard, select a data set from the list, and then click the data set properties button to display the data set properties.
  2. In the Name box, enter the name to update.

Manage permissions

  1. On the Data Sets page of the Administrator Dashboard, select a data set from the list, and then click the data set properties button to display the data set properties.
  2. In the Change permissions section, next to each role, drop down the box to select whether to allow its users Read or None to hide the data set from users in that role.
    Note: Users should at least have Read permission to access the Server Shared Data Sets in ActiveReports.
See Also
Managing Data Sources
Managing Reports


Managing Style Sheets

Managing Style Sheets
ActiveReports 12 Server User Guide > Managing Style Sheets

ActiveReports Server provides you with the ability to upload, download or delete style sheets from the Administrator dashboard. Style sheets are a collection of style objects. You can provide access to style sheets uploaded on ActiveReports Server to all of your developers who design reports in ActiveReports. See Working with Styles in ActiveReports help, for more information.

Stylesheets

You can perform the following operations from the Stylesheets page on the Administrator dashboard.

Download

  1. In the Administration section of the Administrator Dashboard, click Stylesheets.
  2. On the Stylesheets page, click the Download stylesheet button next to the stylesheet.
  3. The style sheet file is downloaded on your system in *.rdlx-styles format.

Upload

  1. In the Administration section of the Administrator Dashboard, click Stylesheets.
  2. On the Stylesheets page, click the Upload stylesheet button.
  3. In the Upload an existing stylesheet dialog that appears, you can either drop a style sheet file or click inside the dotted box to browse to a style sheet file.
  4. In the Open dialog that appears, navigate to the *.rdlx-styles file that you want to upload and click Open. The dialog closes and the file name appears in the dotted box.
  5. Click Upload to add the style sheet to the server.

Delete

  1. On the Stylesheets page, click the Delete stylesheet button next to the style sheet. The style sheet is removed from the list.

Rename

  1. On the Stylesheets page, select a style sheet from the list, and then click the stylesheet properties button to display the style sheet properties.
  2. In the Name box, enter the name to update.

Manage Permission

  1. On the Stylesheets page of the Administrator Dashboard, select a style sheet from the list, and then click the stylesheet properties button to display the style sheet properties.
  2. In the Change permissions section, next to each role, drop down the box to select whether to allow its users Read, Read & Modify or None to hide the style sheet from users in that role.
    Note: Users require Read permission to access the shared style sheets in ActiveReports.


Managing Images

Managing Images
ActiveReports 12 Server User Guide > Managing Images

ActiveReports Server provides you with the ability to upload, download or delete images from the Administrator dashboard. You can provide access to images uploaded on ActiveReports Server to all of your developers who design reports in ActiveReports. For more information, see Working with Images in the ActiveReports help.

Managing Images

You can perform the following operations from the Images page on the Administrator dashboard.

Download

  1. In the Administration section of the Administrator Dashboard, click Images.
  2. On the Images page, click the Download image button.
    The image file is downloaded on your system.

Upload

  1. In the Administration section of the Administrator Dashboard, click Images.
  2. On the Images page, click the Upload image button.
  3. In the Upload an existing image dialog that appears, you can either drop an image file or click inside the dotted box to browse to an image file.
  4. In the Open dialog that appears, navigate to the image file that you want to upload and click Open. The dialog closes and the file name appears in the dotted box.
  5. Click Upload to add the image to the server.

Delete

  1. On the Images page, click the Delete image button next to the image. The image is removed from the list.

Rename

  1. On the Images page, select an image from the list, and then click the image properties button to display the image properties.
  2. In the Name box, enter the name to update.

Manage Permissions

  1. On the Images page of the Administrator Dashboard, select an image from the list, and then click the image properties button to display the properties.
  2. In the Change permissions section, next to each role, drop down the box to select whether to allow its users Read, Read & Modify or None to hide the image from users in that role.
    Note: Users require Read permission to access the images in ActiveReports.


Managing Templates

Managing Templates
ActiveReports 12 Server User Guide > Managing Templates

Administrators can upload templates from their local computer to the Administration portal. The uploaded templates are displayed on the Templates page in the Administrator Dashboard. One can sort the templates list using the Sort list icon next to the Sorted By button on the top left corner to display results on the basis of Template name, Model name, Created, Created by, Modified, and Modified by. Also, administrators can view template properties and preview, design, download, delete the uploaded template as and when they want.

You can perform the following operations from the Templates page on the Administrator dashboard.

Upload

  1. In the Administration section of the Administrator Dashboard, click Templates.
  2. On the Templates page of the Administrator Dashboard, click the Upload template button at the top right corner.

  3. In the Upload an existing template dialog that appears, you can either drop a file with .rdl or .rdx extension, or simply click inside the box and browse to the template on your computer.

  4. In the Open dialog that appears, navigate to the .rdl or .rdx file that you want to upload and click Open. The dialog closes and the file name appears in the dotted box.
  5. Click Upload to add the template to the server.
    Note: A template name can not be same as an existing report name.

In addition to template uploading, an administrator can also set any Page/RDL report as a template and vice versa.

Set as template

Manage Uploaded Templates

After you upload the templates, you can work with them as described in the table shown below:

Command | Icon | Description
Click to show template properties | Properties icon | Displays the template properties in the pane that opens to the right of the Templates list. In the Template properties pane, you can edit the template name and description in the corresponding fields, view the template information and modify the template permissions. Also, you can click the Set as report button to convert the selected template into a report.
Preview template | Preview icon | Displays the template in the Designer Preview window that opens as a separate window on your browser.
Design template | Designer icon | Displays the selected template in the ActiveReports Server Designer application.
Download template | Download icon | Downloads and saves the template to the local file system in .rdl or .rdx file format.
Delete template | Delete icon | Deletes the template and removes it from the Templates list displayed on the Templates page.

See Also
Templates


Managing Themes and Styles

Managing Themes and Styles
ActiveReports 12 Server User Guide > Managing Themes and Styles

Themes and styles allow you to control the appearance of reports. Themes determine the overall look of reports and all of their tables and charts, whereas styles are applied to individual report items.

Working with Themes
Learn to delete themes and styles from the server, rename them, and set your default theme.
Working with Styles
Learn to download themes and styles to your local machine and upload them to the server.
See Also
Styles and Themes
Managing Models
Managing Reports
Managing Security


Working with Themes

Working with Themes
ActiveReports 12 Server User Guide > Managing Themes and Styles > Working with Themes
Show All
Hide All

ActiveReports Server provides you with the ability to upload, download or delete themes from the Administrator dashboard. The themes are applied to modify the overall appearance of the report. They are specially formatted xml files with a file extension of .rdlx-theme.

To download a theme

Save a working copy of a theme to your local machine

  1. From the Administrator Dashboard, select Themes.
  2. On the Themes page, next to the theme that you want to save, click Download theme button.
  3. The xml theme file is copied onto your machine in .rdlx-theme format.

To upload a theme

Save a file from your local machine onto the server

  1. From the Administrator Dashboard, select Themes.
  2. On the Themes page, click the Upload theme button.
  3. In the Upload an existing theme dialog that appears, you can either drop a .rdlx-theme file or click inside the dotted box to browse to a data source file.
  4. In the Open dialog that appears, navigate to the file with the extension .rdlx-theme to upload and click Open. The dialog closes and the file name appears in the box.
  5. Click Upload to add the theme from your computer to the server.

To delete a theme

You can delete any themes that you do not want your users to access when they design reports.

Remove a theme from the list

  1. From the Administrator Dashboard, select Themes.
  2. On the Themes page, next to the theme that you want to delete, click the Delete theme button. The theme is removed from the list.

To rename a theme

You can name themes after departments to let them know which one to use, or use any name that suits your business needs.

Make a theme name relevant for your users

  1. From the Administrator Dashboard, select Themes.
  2. On the Themes page, select a theme from the list, and then click the theme properties button to display the properties.
  3. In the Name box, enter the name to update.

To change your default theme

You can select which theme is used by default when your users create new reports. Users can still select any other theme that you have in the themes list.

Designate the most commonly used theme for your company

  1. From the Administrator Dashboard, select Themes.
  2. On the Themes page, select a theme from the list, and then click the theme properties button to display the properties.
  3. Select the Set as default checkbox to set the theme as your default. The Set as default command is removed from the selected theme, and added back to the theme that was previously the default theme.
See Also
Styles and Themes
Managing Themes and Styles
Working with Styles


Working with Styles

Working with Styles
ActiveReports 12 Server User Guide > Managing Themes and Styles > Working with Styles
Show All
Hide All

ActiveReports Server provides you with the ability to upload, download or delete styles from the Administrator dashboard. The styles change the look and feel of individual report controls. They are specially formatted xml files with a file extension of .style.

To download a style

Save a working copy of a style to your local machine

  1. From the Administrator Dashboard, select Styles.
  2. On the Styles page, next to the stylee that you want to save, click Download style button.
  3. The xml style file is copied onto your machine in .style format.

To upload a style

Save a file from your local machine onto the server

  1. From the Administrator Dashboard, select Styles.
  2. On the Styles page, click the Upload style button.
  3. In the Upload an existing report style dialog that appears, you can either drop a .style file or click inside the dotted box to browse to a data source file.
  4. In the Open dialog that appears, navigate to the file with the extension .style to upload and click Open. The dialog closes and the file name appears in the box.
  5. Click Upload to add the style from your computer to the server.

To delete a style

You can delete any styles that you do not want your users to access when they design reports.

Remove a style from the list

  1. From the Administrator Dashboard, select Styles.
  2. On the Styles page, next to the style that you want to delete, click the Delete style button. The style is removed from the list.

To rename a style

You can name styles to reflect where and how they are used in your company to keep your users consistent.

Make a style name relevant for your users

  1. From the Administrator Dashboard, select Styles.
  2. On the Styles page, select a style from the list, and then click the style properties button to display the properties.
  3. In the Name box, enter the name to update.
See Also
Styles and Themes
Working with Themes


Managing Security

Managing Security
ActiveReports 12 Server User Guide > Managing Security

This section contains information that helps administrators manage users, roles, and permissions.

Managing Users
Learn to add and delete users, and to modify user credentials, password, and roles.
Managing Roles
Learn to add and delete roles, and to modify permissions for roles.
Managing Permissions
Learn what permissions you can set on reports and models.
Using LDAP and Active Directory for Single Sign-On
Learn about how you can integrate your LDAP and Active Directory users into ActiveReports Server security.

Note: You can also create row-level security by creating custom security providers. the Managing Single Sign-On Security Providers topic for more information.

See Also
Security: Users and Roles
Managing Models
Managing Reports
Managing Themes and Styles
Server Diagnostics


Managing Users

Managing Users
ActiveReports 12 Server User Guide > Managing Security > Managing Users
Show All
Hide All

An administrator can add and delete users, and modify existing users' credentials, passwords, and roles. All of these functions are in the Users list, which you can access from the Administrator Dashboard by clicking Users in the Security section.

To add a user

Each user needs an email address, password, and user name.

  1. In the Security section of the Administrator Dashboard, click Users. The Users list appears.

  2. Click the New user button. The Create new user dialog appears.

  3. In the dialog, fill in the User Name, Password, Confirm password, Email, and Description fields.

  4. Click Next and then select the check box under any roles to which to assign the user.
  5. Click Finish. The new user is added to the Users list and any selected roles, and the user can log in to the Report Portal with the user name and password specified.
    Note: By default Everyone role is assigned to each new user. For more information, see Managing Roles.

To add multiple users at once

You can add many users at once by providing user data in a CSV (comma separated values) file. Drop down the following section for details on the format to use for user data in a CSV file.

Format for CSV user data

For successful user registration, you need to provide user data in a specific format in the CSV file. The following table lists the user data format that you can add in the CSV file.

Data fields | Example | Remarks
User name | Richard | This is a required field.
Password | ****** | This is a required field.
Email address | user1@gmail.com | This is a required field.
Description | Store Keeper | This is an optional field.
Role | Administrator | You can add multiple roles by delimiting data fields with comma or semi-colon.

Use a comma or semi-colon to delimit data fields. The format for each user data field in the CSV file is like this:

User name,Password,Email,Description,Role,Other Role

Examples of valid user data:

username1,password1,user1@gmail.com
username2;password2;user2@gmail.com,description2,roleA
username3,password3,user3@gmail.com,description3,roleA,roleB

User registration fails in the following scenarios:

  • A required user data field (User name, Password, or Email) is not specified.
  • A data field includes an invalid character.
  • The email data field is not in a valid email format.
  • The user is already registered with the same name or email address.
  • The CSV file contains a header row.

To add multiple users at once

  1. In the Security section of the Administrator Dashboard, click Users. The Users list appears.

  2. Click the Bulk create button. The Upload a CSV file dialog appears.

  3. In the Upload a CSV file dialog, drop a CSV file or click inside the blue rectangle area to browse to your CSV file.

  4. Click the Upload button to add the new users from the CSV file to the Users list. After the CSV file is uploaded, the Bulk upload result dialog displays the registration results.

    This dialog notifies you of how many user registrations succeeded, how many already existed, and how many failed.

    Note: You can also refer to the log file created in C:\ActiveReports 12 Server\Logs for messages, warnings, and errors related to bulk registration.

To delete users

You can remove users from ActiveReports Server so that they no longer have access.

  1. In the Security section of the Administrator Dashboard, click Users. The Users list appears.

  2. Select the user you want to remove, and then click Delete user. To delete multiple users, select the users from the check boxes, or click select all to select all users, and then click Delete. The user(s) are removed from the list.

    Note: The currently signed-in user Admin cannot be deleted, so there is no Delete command for this user.

To modify the credentials of an existing user

In addition to changing a user's email address or description, you can lock or unlock user accounts.

  1. In the Security section of the Administrator Dashboard, click Users. The Users list appears.
  2. On the Users page, select a user from the list, and then click the user properties button to display the properties.
  3. Modify the information in the activated fields of the Users table to update.

    The Description allows you to enter a description of the user.
    The Email address of the user.
    The Enabled check box is cleared automatically if the user has made several unsuccessful log-in attempts.

To change a user's password

You can change a user's password when they forget it, or if their password security is in doubt.

  1. In the Security section of the Administrator Dashboard, click Users. The Users list appears.
  2. Select the user whose password you want to change, and then click Reset password. The Specify a New Password dialog appears.
  3. In the Specify a New Password dialog, enter the new password and then once again to confirm it.

  4. Click the Change password button to confirm the password change.

To manage a user's roles

In addition to editing the user’s credentials, you can add or remove the user from roles.

  1. In the Security section of the Administrator Dashboard, click Users. The Users list appears.
  2. On the Users page, select a user from the list, and then click the user properties button to display the properties.
  3. In the User roles section, select or clear the roles to assign to the user.
    Note: ActiveReports Server has role-based security, which means that permissions are assigned to roles, not users.
See Also
Managing Roles
Managing Permissions
Security: Users and Roles


Managing Roles

Managing Roles
ActiveReports 12 Server User Guide > Managing Security > Managing Roles
Show All
Hide All

All permissions are granted to a Role. To grant permission to users, add the user to one or more roles. By default, four roles are configured. These roles cannot be deleted, but you can add new roles to the list.

  • Administrators contains users with the permission to enter the Administration area.
  • Anonymous contains no users, but it allows users to work with the Report Portal without credentials.
  • Everyone By default, the Everyone role is assigned to each new user. The Administrator can also enable or disable the Everyone role from the Site Settings page of the Administrator dashboard. Once you disable the Everyone role, a user who created a report while belonging only to that role loses the ability to assign or revoke permissions of that report even if their new role has Full permissions for the report. Also, if this role is disabled, it is not visible to users on the report Information tab (Permissions section) located to the right of a selected report on the Report portal.
  • Owner contains the user who originally created or uploaded the report. By default, this is the only role with full permissions on a newly created or uploaded report.

To create a new role

You can add as many roles as you need to the list. Then if you decide to grant permission for a report or model to an entire department, you can make the change once instead of for each individual.

  1. In the Security section of the Administrator Dashboard, click Roles.The Roles list appears.

  2. From the Roles page, click Create role button. The Create new role dialog appears.

  3. In the Role Name box, enter a name for the new role.
  4. Select the Root category that you want to assign to the role.
  5. If you want to allow the role to upload reports, select the Allow role to upload reports check box.
  6. If you want to allow the role to schedule reports, select the Allow role to schedule reports check box.
  7. If you want to allow the role to assign system categories, select the Allow role to Assign System Categories check box.
  8. Click Create role. The new role is added to the list, with an extra command that allows you to delete it. To begin using the role, add users to it. To add more permissions, see Managing Permissions.

To add a user to a role

When you create a new role, it has no users.

  1. In the Security section of the Administrator Dashboard, click Roles.
  2. In the Roles list that appears, to the right of the role to which you want to add a user, click the Manage users command. The Manage users dialog appears.
  3. In the Manage users dialog, select check boxes next to users to assign them to the role.
    Note: To remove a user from the role, clear the corresponding check box. You cannot add or remove users from the Owner role, which has a user for each report based on the Created By value for that report.
  4. Click the Update button to save the changes.

To grant permission to upload reports

By default, only the Administrator role has permission to upload reports.

  1. In the Security section of the Administrator Dashboard, click Roles.
  2. On the Roles page, select a role from the list, and then click the role properties button to display the Role properties.
  3. In the Role permission section, select the Upload Reports checkbox. All users assigned to the role are able to upload reports.

To grant permission to schedule reports

By default, only the Administrator role has permission to schedule reports.

  1. In the Security section of the Administrator Dashboard, click Roles.
  2. On the Roles page, select a role from the list, and then click the role properties button to display the Role properties.
  3. In the Role permission section, select the Schedule Reports checkbox. All users assigned to the role are able to schedule reports.

To grant permission to assign system categories

By default, only the Administrator role has permission to assign system categories.

  1. In the Security section of the Administrator Dashboard, click Roles.
  2. On the Roles page, select a role from the list, and then click the role properties button to display the Role properties.
  3. In the Role permission section, select the Assign System Categories checkbox. All users assigned to the role are able to assign system categories.

To delete a role

  1. In the Security section of the Administrator Dashboard, click Roles.
  2. In the Roles list that appears, to the right of the role that you want to delete, click the Delete role button.
  3. If the role does not contain any users, it is removed from the list immediately. If the role does contain users, you are asked to confirm.
  4. Click OK to delete the role.

You can grant other permissions to reports and models by selecting roles to allow for each individual report and each model. See Managing Permissions for more information.

See Also
Managing Users
Managing Security
Managing Permissions
Configuring ActiveReports 12 Server on SSL and HTTPS Web Sites


Managing Permissions

Managing Permissions
ActiveReports 12 Server User Guide > Managing Security > Managing Permissions
Show All
Hide All

Administrators can modify permissions to data models, reports, and shared schedules by assigning rights to a role. Once a role has permission to use a model, report, or shared schedule, all users added to that role have the same permission.

Table defining what permissions are granted for each combination of settings for reports and models

Permission Setting | Model: Read | Model: Create Report | Model: None
Report: None | No operations | No operations | No operations
Report: Read | Preview only | Create a copy of report and modify the copy | Preview only
Report: Read & Modify | Preview, delete, and modify report | Preview, delete, and modify report | Preview and delete report
Report: Full | Preview, delete, and modify report Change access | Preview, delete, and modify report Change access | Preview and delete report Change access

To manage permissions to a model

You can grant read or read and create permission to different roles for each model.

Allow or deny read permission to a model

  1. From the Administrator Dashboard, select Models.
  2. On the Models page, select a model from the list, and then click the model properties button to display the properties.
  3. In the Change Permissions section, next to each role, drop down the box to select whether to grant Read permission, Create Report, or None to hide the model from users in that role.

  4. The selected roles have permission to read or read and create reports on the model.

To manage permissions to a report

You can grant different roles permission to read, modify, or change permissions on each report. The Owner of the report (the user who created or uploaded it) has full permission which cannot be modified.

Allow or deny read, modify, or change permissions

  1. From the Administrator Dashboard, select Reports.
  2. On the Reports page, select a report from the list, and then click Permissions button.
  3. In the Change permissions dialog that appears, next to each role, drop down the box to select whether to allow its users Read, Read & Modify, or Full permissions on the report, or None to hide the report from users in that role.
    • Read allows users in the role to see the report in the Report Portal Open page and preview the rendered report, but does not allow them to modify it in the Report Portal.
    • Read & Modify allows users in the role to modify the report in the Report Portal in addition to Read permissions.
    • Full allows users in the role to modify permissions on the report in addition to Read & Modify permissions.
  4. Click the Update button to save the changes. All users in the selected roles are granted the specified access.

To change ownership of a report

By default, the user who created or uploaded the report has full permission to it. The Owner role always has full permission to the report, so the only way to change that is to change ownership by deleting the report and having a new owner upload it to the server.

Change ownership

  1. From the Administrator Dashboard, select Reports.
  2. On the Reports page, next to the report for which you want to change ownership, click Download report button. The RDLX file of the report is copied to your local machine.
  3. Next to the same report, click Delete. In the message box that appears, click Yes to confirm that you want to delete the report. The report is removed from the server.
  4. Log in with a new user.
  5. On the Reports page, click the Upload report button.
  6. In the Upload an existing report dialog, you can either drop a report file or click inside the dotted box to browse to a report file.
  7. In the Open dialog that appears, navigate to the report and click Open. The dialog closes and the file name appears in the dotted box.
  8. Click Upload. The report appears in the list with the new owner listed under the Created By column.

To manage permissions to a data source

  1. From the Administrator Dashboard, select Data Sources.
  2. On the Data Sources page, select the data source for which you want to manage permissions, and then click the data source properties button to display the properties.
  3. In the Change permissions section that appears, next to each role, drop down the box to select whether to allow its users Execute or Execute and Create Datasets permissions on the report.
    • Execute allows a user to view reports based on this data source.
    • Execute and Create Datasets allows a user to view reports based on this data source AND create embedded datasets in his/her new or modified reports.
      Note: Users must have the Execute and Create Datasets permission to access the Server Shared Data Sources in ActiveReports.

To manage permissions to a shared schedule

You can grant different roles the permission to use shared schedules to schedule reports to run. You can also set options in the Delivery section to allow or prevent users from changing the settings. For more information, see Managing Schedules.

Allow or deny read, modify, or change permissions

  1. From the Administrator Dashboard, select Schedules.
  2. On the Schedules page, select the schedule on which you want to set permissions, and then click the schedule properties button to display the properties.
  3. In the Change permission section, next to each role, select the checkbox for each role whose users you want to allow to schedule reports. By default, Everyone is allowed to schedule reports, so clear that checkbox to limit permissions to your selected roles.
  4. Click Save.

To manage permissions to printers

You can grant different roles the permission to use a printer to schedule report printing. For more information, see Managing Schedules and Managing Printers.

Allow or deny read, modify, or change permissions

  1. From the Administrator Dashboard, select Printers.
  2. On the Printers page, select the printer on which you want to set permissions, and then click the print permissions button to display the properties.
  3. In the Change permissions section that appears, next to each role, select the checkbox for each role whose users you want to allow to schedule report printing jobs.
  4. Click Save.
Note: A role that has permission to run a schedule also has permission to schedule printing. However, the role also needs permission to use the printer for the schedule. For example, if a role can run a scheduled task but does not have permission to use the printer specified in the schedule, the report will not print.
See Also
Managing Roles
Managing Users
Managing Reports
Managing Models
Managing Schedules
Managing Data Sources


Using LDAP and Active Directory for Single Sign-On

Using LDAP and Active Directory for Single Sign-On
ActiveReports 12 Server User Guide > Managing Security > Using LDAP and Active Directory for Single Sign-On
Show All
Hide All

You can use your existing LDAP or Active Directory® with ActiveReports Server so that your users can log in with their existing user names and passwords, and so that you can use existing groups to provide access to specific data.

Note: ActiveReports Server supports OpenLDAP v2.3 or later. Earlier versions are not supported because they do not have a MemberOf attribute.

To map your user directory to ActiveReports Server, you specify LDAP (Active Directory) as your custom security provider, and set properties to give ActiveReports Server access to it. These properties are described in the table below.

Security provider properties table

Property | Description
LDAP Server URL (required) The URL to the directory where you can find users. The syntax is: ldap://host:port/domain
  • ldap:// is an optional prefix
  • host is the LDAP server name or IP address
  • port is the optional LDAP server port number (default is 389)
  • domain is the optional distinguished name of the domain in which to search for users
Example: ldap://example.org:888/DC=grapecity,DC=net
In this example, example.org is the name of the server answering LDAP queries, 888 is a non-standard port used on the LDAP server, and grapecity.net is the ActiveDirectory domain.
LDAP Admin User (required) The name or DN (distinguished name) of the user under which the LDAP connection is established. This user is also used to implement the ISecurityProvider.GetAdminContext method when you add a custom entity.
Note: Most non-Active Directory LDAP servers require a DN (distinguished name) for this, so a DN in the administrator account would be the directory manager.
Example: cn=Directory Manager,cn=Root DNs,cn=config
LDAP Admin Password (required) The password associated with the administrative user on the LDAP server.

Example: *****
ARS Admin Groups

Contains the list of Active Directory groups (Group1, Group2…). If user from one of these groups is logging on ActiveReports Server, then the server grants him Administrator role. The default value of the new field is 'Administrator' for the backward compatibility.

Note: If 'ARS Admin Groups' field does not have 'Administrator' group listed, then AD users from 'Administrator' group should not have 'Administrator' role on ActiveReports Server.
User Name Attribute (optional) By default, this value is samaccountname and specifies the LDAP attribute to use in resolving the user name passed in the ISecurityProvider.GetUserToken method.

Example: uid
User Display Name Attribute (optional) By default, this value is displayName and specifies the LDAP attribute to use in resolving the user-friendly name with the ISecurityProvider.GetUserDescription method.

Example: sn
User Email Attribute (optional) By default, this value is mail and specifies the LDAP attribute to use in resolving the user e-mail with the ISecurityProvider.GetUserDescription method.

Example: mail
Define Mappings | Description
User Context Attribute Name | LDAP User Attribute Name

To configure ActiveReports 12 Server to use your LDAP or Active Directory

  1. In the Configuration section of the Administrator Dashboard, click Security Provider. The Custom security provider drop-down list appears.
  2. From the drop down list box, select Active Directory.
  3. In the Security Provider Settings that appear, enter a value for each of the properties.
  4. Below the Security Provider Settings, in the Define mappings section, click on Add row button..
  5. In the boxes that appear, enter a valid User Context Attribute Name, and a LDAP User Attribute Name that you will be able to select when you create security filters in the model editor. (See the To create a new security filter section below.)

To test your custom security provider

You can place percent signs around a UserContext attribute to use it in a connection string when you create a model. This is useful when each tenant in a multi-tenant application has a separate database, and you need to supply a dynamic value for the database.

Provider=SQLOLEDB.1;Data Source=HQ;Initial Catalog=%TenantDatabase%;
User Id=myUsername;Password=myPassword;

When you create a security filter, you can re-use it for other entities that contain the attribute on which the filter expression is based.

To create a new security filter for row-level security

From the Administrator Dashboard, in the Administration section on the left, click Models. The Models list appears.

  1. Select the model to which you want to add a filter, and then click Edit model button. The model editor appears.
  2. Select the entity that you want to filter. The editable properties appear in the center workspace.
  3. Next to Security Filter, click the Add command. The Edit Security Filter dialog appears.
  4. In the box next to Filter Name, enter a name for your filter.
  5. With Filter Expression selected, click the ellipsis button to open the Select Attribute dialog where you can select an attribute of the entity on which to filter data, and click OK.
  6. Drop down the list next to the attribute to select whether to display data that equals or does not equal the following value.
  7. Drop down the list to the right, and select a User Context Attribute Name mapping against which to filter the selected attribute.
  8. Click the Apply button to create the filter, or to discard the changes, click Cancel.

To use UserContext attributes from LDAP or ActiveDirectory in a connection string

You can place percent signs around a UserContext attribute to use it in a connection string when you create a model. This is useful when each tenant in a multi-tenant application has a separate database, and you need to supply a dynamic value for the database.

Provider=SQLOLEDB.1;Data Source=HQ;Initial Catalog=%TenantDatabase%;
User Id=myUsername;Password=myPassword;
See Also
Managing Single Sign-On Security Providers
Single Sign-On with LDAP or Active Directory


Managing Configuration

Managing Configuration
ActiveReports 12 Server User Guide > Managing Configuration

This section contains information that helps administrators manage SMTP settings and diagnose problems.

Managing Agents
This section describes how ActiveReports Server uses agents to handle scale-out deployment so that you can serve up more reports to more users as needed.
Managing Licenses
Learn about different licenses for ActiveReports Server and how to manage them.
Managing Single Sign-On Security Providers
Learn about using custom security providers as well as LDAP or Active Directory® security providers.
Configuring Email
Learn to configure SMTP settings for your site to enable the error reporting and password reminder functions.
Site Settings
Learn how to set a base URL for links sent in notifications for lost passwords and scheduled reports.
UI Settings
Learn how to customize the appearance of ActiveReports Server.
Managing Audit Settings
This section describes how to set up auditing on your site, and reports and data are automatically set up.
Server Diagnostics
Learn about monitoring your server with the ActiveReports Server Diagnostics page.
See Also
Managing Security
Managing Models
Managing Reports


Managing Agents

Managing Agents
ActiveReports 12 Server User Guide > Managing Configuration > Managing Agents

You can use agents to manage your report execution load and concurrent users in ActiveReports Server. The agents list displays information about each agent to help you manage them. For more information, see Agents and Scalability.

Image Title

Agent Information and Command

You can obtain information on agents and activate or deactivate them using the command to the right of each agent in the list.

The Workers section displays the current tasks of each agent along with the details of its status (Idle or Busy), description and priority.

Column Descriptions

Column | Description
Agent ID | Displays a unique internal identification code for the agent.
Host | Displays the name of the hosting machine.
Version | Displays the ActiveReports Server version number.
License Status | Displays licenses and serial numbers for licensed agents, or lets you know when no license is available. If the agent is disabled or cannot connect, the license goes back into circulation, and the license status is N/A.
Connection Status | Displays the state of the connection: Connected or Cannot Connect.
Deactivate (or Activate) | Takes the agent out of action, but allows you to enable it later. It remains connected, but no tasks are assigned to it, and its license is freed up for use by another agent. You can deactivate an agent and re-activate it to force it to check for an available license. When a new agent is installed, it is deactivated until an Administrator activates it.
Workers
Worker ID | Describes a unique ID for the worker.
Priority | Describes the priority of the worker: 1 indicates the highest priority .
Status | Describes the status of worker: Idle or Busy.
Task | Displays the current task in execution by a worker of the agent, for example, Render report, Export report, Test connection, etc.

Installing agent in a same environment as server

  1. On the Maintenance page of the installer, select the Install an agent service on this computer option.
  2. In the Service User dialog that appears, enter the account information and click Install to start the installation.
    Note: The ActiveReports 12 Server internally uses its own Windows service, and it is necessary to register the service on the system. In this dialog, the account is set to register or execute the service. You can set an already registered account or you can create a new account.

    Caution:

    • If there are not enough rights in the account, then the agent does not work. If you are not sure about the settings, please select New user and create a new account.
    • Depending on the policy settings of the server, the created account may have a password deadline. Please check the password deadline of the created account and change it to remove the deadline.

Installing agent in a different environment from the server

  1. On the Installation Type page of the installer, select Report Runner Agent and click Next.

    Note:

    • Both server and agent virtual machines should exist on same Virtual Network.
    • If you run agent specific installer downloaded from 'Dashboard' page of Administrator site, then these steps gets skipped.

  2. Specify the folder to install the agent. By default, agents are installed in C:\ActiveReports 12 Server directory. Confirm the installation directory and click Next.

  3. Select the main server in which you want to add the agent and click Next. A server that can add agents gets displayed in the drop-down menu.
    Note: When installing Server and Report Runner agent of ActiveReports Server in separate virtual machines on Microsoft Azure, the main server does not appear in the list. In that case, please directly enter the name of Azure's virtual machine and port ": 4040" where you installed the main server. For example, if the name of the virtual machine is "activereports - server - vm", input "activereports - server - vm:4040. This method is enabled only when the Azure virtual machine deploy model is Resource Manager. In case of 'Classic' deploy model, you can not install server and agent even if you enter the name of the virtual machine directly.

  4. In the Service User dialog that appears, enter the account information and click Install to start the installation.
    Note: The ActiveReports 12 Server internally uses its own Windows service, and it is necessary to register the service on the system. In this dialog, the account is set to register or execute the service. You can set an already registered account or you can create a new account.

    Caution:

    • If there are not enough rights in the account, then the agent does not work. If you are not sure about the settings, please select New user and create a new account.
    • Depending on the policy settings of the server, the created account may have a password deadline. Please check the password deadline of the created account and change it to remove the deadline.


Managing Licenses

Managing Licenses
ActiveReports 12 Server User Guide > Managing Configuration > Managing Licenses

When you purchase an initial license, you receive a product key to unlock them. You can manage these licenses on the Administrator Dashboard Licenses page. For more information, see Agents and Scalability.

License Information and Commands

You can obtain information on licenses and remove them using the command to the right of each license in the list. You can add a new license using the command below the list.

Column Descriptions

Column | Description
Product name | Displays the type of license you purchased, which may be a Trial, Core, and Designer Add-On Edition.
Product Key | Displays the product key that you received when purchasing the license.
License Status | Displays the status of the license, which may be Activated, or may show the number of days left on a trial license.
Delete license | Click Delete license button to remove a license from the list. This allows you to clean up any expired evaluation licenses.
Activate New License | Click this button to add a new license. It opens a dialog where you can enter your product key and activate the license online. See Activate a License for more information.
See Also
Activate a License
Agents and Scalability
Managing Agents


Managing Single Sign-On Security Providers

Managing Single Sign-On Security Providers
ActiveReports 12 Server User Guide > Managing Configuration > Managing Single Sign-On Security Providers

Show All
Hide All

You can provide row-level security with security filters. While editing a model, you can add and delete security filters from entities, and modify existing ones, as well as configure and use an LDAP security provider. All of these functions are in the Model Editor, which you can access from the Administrator Dashboard.

Note: In order to use single sign-on security filters, you must first create a custom security provider. For information on creating custom security providers, please refer Create a Custom Security Provider.

To use an Active Directory® or LDAP security provider

When using a Lightweight Directory Access Protocol (LDAP) security provider, you can create User Context attributes that map to LDAP user attributes, and use them in security filter expressions to enable single sign-on for your users.

Use an LDAP security provider

  1. In the Configuration section of the Administrator Dashboard, click Security Provider. The Custom security provider drop-down list appears.
  2. From the drop down list box, select Active Directory.
  3. In the Security Provider Settings that appear, enter a value for each of the properties.
  4. Below the Security Provider Settings, in the Define mappings section, click on Add row button..
  5. In the boxes that appear, enter a valid User Context Attribute Name, and a LDAP User Attribute Name that you will be able to select when you create security filters in the model editor. (See the To create a new security filter section below.)

To add your new security provider to the server

Once you have compiled your custom security provider into a DLL, you can begin using it to filter entities in your models.

Add a new security provider

  1. In Windows Explorer, create a SecurityProviders folder on the same level as your site, for example, if you have C:\ActiveReports 12 Server, create the folder C:\ActiveReports 12 Server\SecurityProviders.
  2. Copy your custom security provider DLL file into the new folder.
  3. In the Configuration section of the Administrator Dashboard, click Security Provider. The Custom security provider drop-down list appears.
  4. Drop down the list and select your new security provider.
  5. Depending on your security provider, there may be settings that you can select.
  6. When you have the settings the way that you want them, click the Apply changes button. The security filter becomes available to your model entities.

To delete a security provider

You can stop the server site and remove security providers from ActiveReports Server.

Delete a security provider

  1. Open Internet Information Services (IIS) Manager, and expand the Sites node.
  2. Select the ActiveReports 12 Server site, and on the right, in the Manage Web Site section, click Stop.
  3. In Windows Explorer, locate your SecurityProviders folder.
  4. Delete the DLL containing the security provider that you long longer wish to use. The provider is removed from the list.
  5. Back in IIS, with the ActiveReports 12 Server site selected, in the Manage Web Site section, click Start.

To create a new security filter

When you create a security filter, you can re-use it for other entities that contain the attribute on which the filter expression is based, providing row-level security for your data.

Create a new filter

  1. Select the model to which you want to add a filter, and then click Edit model button. The model editor appears.
  2. Select the entity that you want to filter. The editable properties appear in the center workspace.
  3. Next to Security Filter, click the Add command. The Edit Security Filter dialog appears.
  4. In the box next to Filter Name, enter a name for your filter.
  5. With Filter Expression selected, click the ellipsis button to open the Select Attribute dialog where you can select an attribute of the entity on which to filter data, and click OK.
  6. Drop down the list next to the attribute to select whether to display data that equals or does not equal the following value.
  7. Drop down the list to the right, and select a User Context Attribute Name mapping against which to filter the selected attribute.
  8. Click the Apply button to create the filter, or to discard the changes, click Cancel.

To use an existing filter

You can re-use security filters with other entities that use the same attributes.

Use an existing filter

  1. In the Administration section of the Administrator Dashboard, click Models. The Models list appears.
  2. Select the model to which you want to add a filter, and then click Edit model button. The model editor appears.
  3. Select the entity that you want to filter. The editable properties appear in the center workspace.
  4. Next to Security Filter, click the Add command. The Edit Security Filter dialog appears.
  5. In the box next to Filter Name, enter a name for your filter.
  6. With Use existing filter selected, click the ellipsis button to open the Select Existing Filter dialog where you can select a previously created filter (if it is based on an attribute shared by this entity), and click OK.
  7. Click the Apply button.


Configuring Email

Configuring Email
ActiveReports 12 Server User Guide > Managing Configuration > Configuring Email

To ensure that error reporting and password reminders function properly for your site, you can configure the SMTP settings. The report server also uses these settings to connect with the e-mail server to deliver scheduled reports. You can configure e-mail SMTP settings from the Administrator Dashboard.

To configure e-mail from the Administrator Dashboard

  1. From the Administrator Dashboard, at the bottom left under Configuration, click SMTP Settings.
  2. In the SMTP Settings dialog that appears, enter values for your SMTP server.

    • SMTP host Enter the host address for your server, usually with syntax like "smtp.yourdomainname.com."
    • SMTP port Enter the port number for your server, for example, 587.
    • Use SMTP authentication Select this check box to add a user name and password.
    • Sender e-mail Enter the e-mail address to use as the return address for error reporting, password reminders, and scheduled report delivery.
    • Sender name Enter the name to use for the sender.
    • Use SSL Select this check box to enable the Secure Sockets Layer protocol.
  3. When you have finished entering the values for your server, click Apply changes.

Troubleshooting

The table below explains the possible reasons for e-mail failure messages that you may get in the diagnostic report.

Cause | Error description
Incorrect host | System.Net.Mail.SmtpException: Failure sending mail. ----> System.Net.WebException: Unable to connect to the remote server ----> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
Incorrect port | System.Net.Mail.SmtpException: Failure sending mail. ----> System.Net.WebException: Unable to connect to the remote server ----> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond .
Incorrect login | System.Net.Mail.SmtpException: The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.7.1 Authentication required.
Incorrect password | System.Net.Mail.SmtpException: The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.7.1 Authentication required.
Incorrect sender e-mail | System.Net.Mail.SmtpFailedRecipientException: Mailbox name not allowed. The server response was: 5.7.1 <INCORRECT_EMAIL>: Sender address rejected: not owned by user CORRECT_EMAIL.
SSL is enabled but not required | System.Net.Mail.SmtpException: Error in processing. The server response was: 4.3.0 Error: queue file write error. OR System.Net.Mail.SmtpException: Failure sending mail. ----> System.IO.IOException: Unable to read data from the transport connection: net_io_connectionclosed.
SSL is disabled but required | System.Net.Mail.SmtpException: Failure sending mail. ----> System.IO.IOException: Unable to read data from the transport connection: net_io_connectionclosed.
SMTP authentication is enabled but not required | System.Net.Mail.SmtpException: The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.7.1 Authentication required.
SMTP authentication is disabled but required | System.Net.Mail.SmtpException: The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.7.1 Authentication required.
See Also
Server Diagnostics
Managing Security


Site Settings

Site Settings
ActiveReports 12 Server User Guide > Managing Configuration > Site Settings

ActiveReports Server lets you manage a number of site settings. The following settings are available to the administrator.

Notification Link URL

The Notification Link URL field allows you to enter the URL address of the server that hosts ActiveReports Server. The URL specified in the Notification Link URL field is included in the notification link that goes out to the users via email. When you schedule reports and choose Email as the delivery type, and As Link as your delivery method, the email that goes out to your users contains a link to the report location.

For example, if you enter 'http://localhost:3000'; in the Notification Link URL field, the following link is in the email notification.

http://localhost:3000/?view=changePassword&key=VAtHJJrldNySQdknuC15KcfQL6M

Disable the Everyone role

Check this option to disable the Everyone role that contains all users by default.

If the Everyone role is disabled, it is not visible to users on the report Information tab (Permissions section) located to the right of a selected report on the Report portal.

Hide Empty Categories in Report Portal

Check this option to hide any system categories that do not have any reports.

Disable the built-in ClickOnce Report Designer

Check this option to disable designing the Developer reports - RDL, Page, and Section - using the built-in ClickOnce Report Designer.

Disable HTML5 Web Designer

Check this option if you want to use the legacy Flash based Designer for Semantic Reports. We recommend to keep this unchecked to use the new designer for RDL and Semantic Reports.

Compatibility with Web Designer

  • The Table data region in an existing report, when opened in the Web Designer, is converted into Tablix.
  • When an existing semantic report is opened in the Web Designer, it gets converted to an rdl based semantic report.
  • The reports created in Web Designer can not be opened in Flash Designer.

Report preview type

ActiveReports Server provides you with an option to view your reports in the HTML5 Viewer or Flash Viewer. Select HTML5 or Flash from the Report preview type dropdown and click the Save button to apply the selected changes.

Preview pages limit

On ActiveReports Server, you can control the number of pages to be rendered on HTML5Viewer while previewing RDL or Page reports. In this setting, specify the maximum number of report pages that you want your users to view. Users can still view full report using 'Partial Data. Run Full Report' option, or view partial report using 'Cancel Report' option.

Sharing (Links/History)

ActiveReports Server allows you to provide different settings for scheduling links and history. Scheduling links and history are visible to the user depending upon the settings the administrator selects here. You can select from the following settings.

Public Access - Everyone can share links and history when scheduling.
Role Access - Select which roles can share links and history when scheduling.
Private Sharing - Select a particular user who can share links and history when scheduling.

Hidden Administrator dashboard pages

ActiveReports Server provides you with an option to hide pages from the Administrator dashboard. To hide a page in the dashboard, click beside the page name you want to hide and click the Save button. You can select multiple pages to hide in the Administrator dashboard.

Scheduled reports processing

On ActiveReports Server, you can control schedule execution for an empty report, which is a report without data. There are several conditions to define an empty report.

  • A report with no report items.
  • A report with report items with static data.
  • A report with report items except the data region controls - Table, Matrix, Chart, List, Tablix, Bandedlist that are set to expressions containing the dataset fields and/or parameters.
  • A report with Table, Matrix, Chart, List, Tablix, Bandedlist report items where
    • a Table/Tablix/List/BandedList/Map is bound to a dataset that returns no data.
    • a Chart has an empty plot area.
    • a List or a BandedList is bound to a dataset that returns non-empty data but without report items.
    • a Map is bound to a dataset that returns non-empty data but no layer is bound to a dataset.

You can select from the following settings.

Don’t process empty reports - the schedule result for an empty report will not be delivered.

Process all reports - the default setting where the schedule result is delivered to all reports.

Note: The new settings are not applied to section reports.

See Also
Managing Schedules


UI Settings

UI Settings
ActiveReports 12 Server User Guide > Managing Configuration > UI Settings

ActiveReports Server lets you change the appearance of the Administrator Dashboard and the Report Portal. You can customize the following UI elements of ActiveReports Server:

  • Page title - Set up the title to display in the browser tab.
  • Theme, header color, and sidebar color - Select from predefined themes to change the whole look and feel, and modify the individual text and background colors for the header and sidebar.
  • Help and Feedback - Toggle Help and Feedback buttons off or on, and change the link to your own help page.
  • Logo and Favicon - Change the ActiveReports Server logo and favicon (the icon that shows in the browser tab) to your company's logo.

The following settings are available to the administrator.

To customize UI elements

  1. In the Administrator Dashboard sidebar menu, expand the Configuration section and click UI Settings.
  2. Select the Turn on UI Customization check box to enable customization. The Common, Report Portal, and Admin Portal tabs appear.
Note: The following steps assume that you have already enabled UI customization using the above steps.

To customize the page title

  • Report Portal
  • Admin Portal
  • Click the Report Portal or Admin Portal tab for which you want to customize the Page title.
  • Enter the title under Report Portal Title or Admin Portal Title.
  • Click Save. This changes the title displayed in the browser tab for all pages of the Report Portal (including login page) or Admin Portal.
  1. Select the Report Portal tab.
  2. Enter the page title under Report Portal Title.
  3. Click Save. This changes the title displayed in the browser tab for all pages of the Report Portal, including the login page.

    Login page of Report Portal

    Default page of Report Portal

  • Click the Report Portal or Admin Portal tab for which you want to customize the Page title.
  • Enter the title under Report Portal Title or Admin Portal Title.
  • Click Save. This changes the title displayed in the browser tab for all pages of the Report Portal (including login page) or Admin Portal.
  1. Select the Admin Portal tab.
  2. Enter the title under Admin Portal Title.
  3. Click Save. This changes the title displayed in the browser tab for all pages of the Admin Portal, including the login page.

    Login page of Admin Portal

    Default page of Admin Portal

To apply and customize a predefined theme

ActiveReports server provides multiple predefined themes. You can choose from default, aurora, cloudy, contrast, light, superhero, and winter themes. You can further customize the themes by overriding the colors of the header and sidebar areas to match your requirement.

  • Report Portal
  • Admin Portal
  • Click the Report Portal or Admin Portal tab for which you want to customize the theme.
  • Select a theme from the dropdown menu - aurora, cloudy, contrast, light, superhero, and winter.
  • Click Save. It changes the background color and font color of Report Portal or Admin Portal.
  1. Select the Report Portal tab.
  2. Select a theme from the dropdown menu.
  3. Click Save. This changes the theme of the Report Portal.
  • Click the Report Portal or Admin Portal tab for which you want to customize the theme.
  • Select a theme from the dropdown menu - aurora, cloudy, contrast, light, superhero, and winter.
  • Click Save. It changes the background color and font color of Report Portal or Admin Portal.
  1. Select the Admin Portal tab.
  2. Select a theme from the dropdown menu.
  3. Click Save. This changes the theme of the Admin Portal.

Header color

You can customize the color of the background, text, highlighted background, and hover background in the header area.

  • Report Portal
  • Admin Portal
  1. Select the Report Portal tab.
  2. In the Customize header colors section, select a color from the palette to change any of the following header colors. You can preview the selected colors at the bottom of the UI Settings page, and click the reset button next to the color picker to revert to the default color.
    Background color
    Text color
    Highlighted background color
    Hover background color
  1. Select the Admin Portal tab.
  2. In the Customize header colors section, select a color from the palette to change any of the following header colors. You can preview the selected colors at the bottom of the UI Settings page, and click the reset button next to the color picker to revert to the default color.
    Background color
    Text color
    Highlighted background color
    Hover background color

Sidebar color

You can customize the color of the background, text, active item background, and active item text in the sidebar area.

  • Report Portal
  • Admin Portal
  1. Select the Report Portal tab.
  2. In the Customize sidebar colors section, select a color from the palette to change any of the following sidebar colors. You can preview the selected colors at the bottom of the UI Settings page, and click the reset button next to the color picker to revert to the default color.
    Background color
    Text color
    Active item background color
    Active item text color
  1. Select the Admin Portal tab.
  2. In the Customize sidebar colors section, select a color from the palette to change any of the following sidebar colors. You can preview the selected colors at the bottom of the UI Settings page, and click the reset button next to the color picker to revert to the default color.
    Background color
    Text color
    Active item background color
    Active item text color

To toggle the Help and Feedback buttons

  1. Select the Common tab. By default, Enable Feedback and Enable Help check boxes are selected.
  2. Clear the Enable Feedback check box to hide the Feedback button, and clear the Enable Help check box to hide the Help button.
  3. Click Save.
  • Report Portal
  • Admin Portal
Help and Send Feedback menu
Help and Send Feedback menu

To customize the help page URL

  1. Select the Common tab.
  2. Under Custom URL, enter the URL to which you want the Help button to navigate.
  3. Click Save.

To customize the logo

  1. Select the Common tab. By default, the Display logo check box is selected.
  2. Keep the Display logo check box selected to customize the logos in ActiveReports Server - Login, Header, Mobile, and Favicon. Or clear the Display logo check box to hide all the logos.
  3. Click the Upload button to open the Upload a Logo dialog. Drag an image file or click to upload an existing image file.
  4. In the Upload a Logo dialog, click the Upload button.
  5. Click Save.

    Login logo

    The Login Logo appears on the welcome screen. The supported image types are PNG, JPG, BMP, EMF, WMF, or GIF. The recommended size is 420 x 68 pixels.

    Header logo

    The Header Logo appears on the top left corner of the Report Portal and Admin Dashboard. The supported image types are PNG, JPG, BMP, EMF, WMF, or GIF. The recommended size is 370 x 80 pixels.

    Mobile logo

    The Mobile logo appears in the top left corner of the Report portal and Admin dashboard in mobile devices. The supported image types are PNG, JPG, BMP, EMF, WMF, or GIF. The recommended size is 60 x 60 pixels.

    Favicon

    The Favicon appears in the browser tab. The supported image type is ICO and the recommended size is 16 x 16 pixels.


Managing Audit Settings

Managing Audit Settings
ActiveReports 12 Server User Guide > Managing Configuration > Managing Audit Settings
Show All
Hide All

Whether you need to be HIPAA compliant and able to track who accessed personally identifiable data, or you just want to know which reports your clients actually use and which ones they do not use, auditing allows you to track which reports are accessed and what is done with them.

When you turn on auditing, in addition to setting the number of days to store audit data, you also specify a database in which to store the data.

Depending on the Provider you select, a different set of fields appears, allowing you to provide the information needed to connect to the database. Once you provide all of the information, click Connect to save it and begin auditing report usage statistics. ActiveReports Server asks you whether to create its own tables, and when you OK the action, it takes care of everything else, including adding an Audit Model and two Audit Reports.

Connection String Editor

If you just want to enter a connection string, you can click the Advanced button to open the Connection String Editor, where you can also specify a connection timeout period.

Tip: You can use any UserContext attribute in the connection string by putting the attribute name between percent signs. For example:
Provider=SQLOLEDB.1;Data Source=HQ;Initial Catalog=%TenantDatabase%;
User Id=myUsername;Password=myPassword;

Provider

Here are descriptions of the fields that you need to fill in for each type of provider.

MS SQL Server

Field | Description
Server Name | Enter the name of the server on which to store auditing data, for example, HQ.
Database Name | Enter the name of the database in which to store auditing data, for example, REPORTAUDITS.
Authentication | Select whether to use Windows authentication or server authentication to provide access to the database.
User Name | Enter the user name under which to log in to the database.
Password | Enter the password to use for logging in to the database.

MySQL Server

Field | Description
Server Name | Enter the name of the server on which to store auditing data, for example, localhost.
Database Name | Enter the name of the schema object in your SQL Editor Object Browser in which to store auditing data, for example, ARServerAudit.
User Name | Enter the user name under which to log in to the database.
Password | Enter the password to use for logging in to the database.

Oracle

Field | Description
Service Name | Enter the name of the service on which to store auditing data.
User Name | Enter the user name under which to log in to the database.
Password | Enter the password to use for logging in to the database.

Postgre SQL

Field | Description
Host | Enter the name of the host machine on which to store auditing data, for example, localhost.
Port | Enter the port number to use on the host machine, for example, 8080.
Database Name | Enter the name of the database in which to store auditing data, for example, REPORTAUDITS.
User Name | Enter the user name under which to log in to the database.
Password | Enter the password to use for logging in to the database.
See Also
Audit Model
Audit Reports


Audit Model

Audit Model
ActiveReports 12 Server User Guide > Managing Configuration > Managing Audit Settings > Audit Model

Once you turn on auditing, provide the information needed to connect to a database, and click Save to apply changes, ActiveReports Server asks you whether to create its own tables. When you OK that action, it immediately begins auditing report usage statistics, saving the data in the specified database, and automatically creates a data model called Audit.

In the Models list, the Audit model has two reports by default, and differs from other models in that you cannot edit or clone it. This is to satisfy requirements for secure audit data.

Like other models, you can create new reports using its data, rename it, set permissions on it to allow other users to access it, view its history, and download it.

See Also
Audit Reports
Managing Audit Settings


Audit Reports

Audit Reports
ActiveReports 12 Server User Guide > Managing Configuration > Managing Audit Settings > Audit Reports

Once you turn on auditing, provide the information needed to connect to a database, and click Save to save it, ActiveReports Server asks you whether to create its own tables. When you OK that action, it immediately begins auditing report usage statistics, saving the data in the specified database, and automatically creates two auditing reports.

Reports contain data for the number of days that you specify when you set up auditing.

In the auditing reports, the following items are stored in the 'Operation Info' table:

  • The string "Print" under 'Rendering Format'.
  • Server name, printer name that performed printing, and printer options under 'Details'. For example, Server: ServerTEST, Printer: Canon XXXXX, Color: Gray scale, Number of copies: 1000, Orientation: Landscape, Paper Size: A4, Two sided: OFF, Paper source: Tray 1.

The following items will be stored in the 'Request Infos' table:

  • User
  • E-mail.

Auditing Access Summary

The Auditing Access Summary report logs all of the following types of access for the most recent seven day period:

  • Recently accessed reports, including date, report name, user, and client IP address.
  • Recently accessed models, including date, model name, action type, user, and client IP address.
  • User logon and logoff attempts, including date, user, client IP address, and success or fail.

Auditing Activity Summary

The Auditing Activity Summary report logs all of the following action types for every report for the most recent 30 day period:

  • Download
  • Logon
  • ModelGeneration
  • ParametersResolving
  • Rendering
  • Upload

You can also create custom reports on your auditing data, as you would on any other data model.

See Also
Managing Audit Settings
Audit Model


Server Diagnostics

Server Diagnostics
ActiveReports 12 Server User Guide > Managing Configuration > Server Diagnostics

The Diagnostics page allows you to perform run-time monitoring of the server that hosts ActiveReports Server. This page provides information on the application system environment, its installed files, assemblies and services.

To open the Diagnostics page

  1. In the Configuration section of the Administrator Dashboard, click Diagnostics.
  2. In the item description list that appears, click the Toggle visibility [image] icon next to an item to display details.
  3. If you want to send a diagnostic report in for support, you can click the command at the bottom of the page to Download the complete diagnostic report as a zip file.

If you encounter an error, you are presented with the Error Reporting dialog. The information we collect from this dialog is protected by our privacy policies. For more information, see Privacy.

See Also
Configuring Email
Configuring ActiveReports 12 Server on SSL and HTTPS Web Sites


Privacy

Privacy
ActiveReports 12 Server User Guide > Managing Configuration > Server Diagnostics > Privacy

Privacy Statement for the ActiveReports 12 Server Error Reporting Service

Last updated: 19/01/2016

GrapeCity is committed to helping protect your privacy. This statement explains how the ActiveReports 12 Server Error Reporting Service collects information and how collected information can be used. This statement does not apply to other online or offline GrapeCity Web sites, software, or services.

Why does GrapeCity collect information about errors and problems?

The information helps GrapeCity and ActiveReports 12 Server diagnose problems in the software you use and provide solutions. Not all problems have solutions but when solutions are available, they are offered as steps for solving a problem you've reported or as updates to install. To help prevent problems and make software more reliable, some solutions are also included in service packs and future versions of the software.

How is information collected?

GrapeCity ActiveReports 12 Server includes its own error reporting service. If a problem occurs in this software, you are asked if you want to report it. You can view the details of the report before sending it, although some files might not be in a readable format.

Some software also allows you to report problems automatically instead of requesting your consent each time a problem occurs. If you use automatic reporting, you are not prompted to review the information in a report before it is sent. However, no information is collected unless you (or your system or network administrator) choose to report problems. You can choose to stop reporting problems at any time.

What types of information can be collected?

The reporting service can collect information about problems that interrupt you while you work and about errors that occur behind the scenes. It is important to diagnose errors that occur behind the scenes because these problems, if left unsolved, may cause additional problems such as performance or program failures.

Reports contain information that is most useful for diagnosing and solving the problem that has occurred, such as:

  • Where the problem happened in the software or hardware. Occasionally, empty files might be included as an initial indication of a problem.
  • Type or severity of the problem, if known.
  • Files that help describe the problem (typically system or report-generated files about software behavior before or after the problem occurred).
  • Basic software and hardware information (such as operating system version and language, device models and manufacturers, or memory and hard disk size).

Your Internet Protocol (IP) address is also collected because you are connecting to an online service (web service) to send error reports. However, your IP address is used only to generate aggregate statistics. It is not used to identify you or contact you.

Reports might unintentionally contain personal information, but this information is not used to identify you or contact you. For example, a report that contains a snapshot of memory might include your name, part of a document you were working on, or data that you recently submitted to a Web site. If you are concerned that a report might contain personal or confidential information, you should not send the report.

Who can use the information and how can it be used?

GrapeCity uses information about errors and problems to improve ActiveReports 12 Server. GrapeCity employees and contractors may be provided access to information collected by the reporting service. However, they may use the information only to repair or improve the products that they publish or manufacture.
For example, if an error report indicates that a third-party product is involved, GrapeCity may send that information to the vendor of the product. The vendor may provide the information to sub-vendors and partners. If a third-party product is involved, and information is transferred to the vendor of that product, that vendor will be subject to its own policies. GrapeCity cannot monitor such vendor's compliance with its policies.

About surveys and report tracking

After you report a problem, you might be asked to complete a survey about the error experience. If you choose to provide a phone number or e-mail address in response to the survey, your error report will no longer be anonymous. GrapeCity may contact you to request additional information to help solve the problem you reported.

You might also be provided with the opportunity to track some error reports so you can check to see if a solution has been found. If you choose to track an error report, the report is associated with your e-mail address and is no longer anonymous.

Information storage, processing, and release

Information that is collected by or sent to GrapeCity may be stored and processed in the United States or any other country in which GrapeCity or its affiliates, subsidiaries, or agents maintain facilities. GrapeCity may disclose this information if required to do so by law or in the good faith belief that such action is necessary to: (a) conform to the edicts of the law or comply with legal process served on GrapeCity or the site; (b) protect or defend the rights or property of GrapeCity and its affiliates, or (c) act in urgent circumstances to protect the personal safety of GrapeCity employees, users of GrapeCity software or services, or members of the public.

GrapeCity occasionally hires other companies to provide limited services on its behalf, such as providing customer support, processing transactions, or performing statistical analysis of reports. GrapeCity will provide these companies only the information they need to deliver the service. They are required to maintain the confidentiality of the information and are prohibited from using it for any other purpose.

Security practices

GrapeCity is committed to helping protect the security of the information we collect. The Error Reporting Service uses multiple security technologies and procedures to help protect information from unauthorized access, use, or disclosure. For example, reports are sent to GrapeCity from your computer using encryption technology. The information is then stored on computer servers with controlled access.

Changes to this statement

GrapeCity may update this privacy statement. If we do, we will revise the "Last updated" information at the top of the statement. To stay informed about how we are helping protect the information collected by the Error Reporting Service, we encourage you to periodically review the privacy statement.

For more information

GrapeCity welcomes your comments regarding this privacy statement. If you believe that GrapeCity has not adhered to this statement, please contact us. We will use commercially reasonable efforts to promptly determine and remedy the problem.

GrapeCity Contact Information

8025 Creedmoor Rd., Raleigh NC 27613
TEL: +1 (866) 459-5567 | +1 (984) 242-0700

To find contact details for the GrapeCity subsidiary or affiliate in your country or region, see the GrapeCity corporate Web site at http://activereports.grapecity.com/.


How To

How To
ActiveReports 12 Server User Guide > How To

This section provides quick answers to your questions about how to perform specific tasks with ActiveReports Server.

Activate a License
This topic explains how to license ActiveReports Server with your product key.
Add Row-Level Security
This topic explains how to license ActiveReports Server with your product key.
Use the Designer Web Control
This topic explains how to use the Designer control on a Web Form.
Hide Log In and Log Out Buttons
This topic explains how to hide authentication UI elements when you use the Designer in your own web applications.
Open the Designer without Selecting a Model
This topic explains how to open the Designer without first visiting the list of models.
Create a Custom Security Provider
This topic explains how to create a custom security provider and use it with a model.
Debug a Custom Security Provider
This topic explains how to debug a custom security provider.
Work with the HTML5 Viewer Using Javascript
This topic explains how to work with the HTML5 Viewer using the Javascript.
Get a Security Token
This topic explains how to get a security token.
Customize and Publish the ClickOnce End User Designer
This topic explains how to customize and publish the ClickOnce End User Designer.
See Also
Concepts
Troubleshooting


Create Users and Roles

Create Users and Roles
ActiveReports 12 Server User Guide > How To > Create Users and Roles

Show All
Hide All

To control which users have access to data models and reports, you can set up users and group them by roles. You can assign roles access to each report and data model, and you can designate which roles are able to upload reports.

To set up a user

  1. In the Security section of the Administrator Dashboard, click Users. The Users list appears.

  2. Click the New user button. The Create new user dialog appears.

  3. In the dialog, fill in the User Name, Password, Confirm password, E-mail, and Description fields.

  4. Click Next and then select the check box under any roles to which to assign the user.
  5. Click Finish. The new user is added to the Users list and any selected roles, and the user can log in to the Report Portal with the user name and password specified.

To set up a role

  1. In the Security section of the Administrator Dashboard, click Roles. The Roles list appears.

  2. Click the Create role button. The Create Role dialog appears.

  3. In the Role Name box, enter a name for the new role.
  4. If you want to allow the role to upload reports, select the Allow Upload Report check box.
  5. Click Create role. The new role is added to the list, with an extra command that allows you to delete it. To begin using the role, add users to it.

To add a user to a role

  1. In the Security section of the Administrator Dashboard, click Roles.
  2. In the Roles list that appears, to the right of the role to which you want to add a user, click the Manage users button. The Manage users dialog appears.
  3. In the Manage users dialog, select check boxes next to users to assign them to the role.
    Note: To remove a user from the role, clear the corresponding check box.
  4. Click the Update button to save the changes.

To give a role permissions on a report

  1. From the Administrator Dashboard, select Reports.
  2. On the Reports page, select a report from the list, and then click Permissions button.
  3. In the Change permissions dialog that appears, next to each role, drop down the box to select whether to allow its users Read, Read & Modify, or Full permissions on the report, or None to hide the report from users in that role.

    • Read allows users in the role to see the report in the Report Portal Open page and preview the rendered report, but does not allow them to modify it in the Report Portal.
    • Modify allows users in the role to modify the report in the Report Portal.
    • Change Permissions allows users in the role to modify permissions on the report.
  4. Click the Apply button to save the changes. All users in the selected roles are granted the specified access.

To give a role permissions on a model

  1. From the Administrator Dashboard, select Models.
  2. On the Models page, select a model from the list, and then click the model properties button to display the properties.
  3. In the Change permissions section, next to each role, drop down the box to select whether to grant Read permission, Create Report, or None to hide the model from users in that role

  4. The selected roles have permission to create reports on the model.
See Also
Managing Roles
Managing Users
Managing Permissions
Managing Reports
Managing Models


Activate a License

Activate a License
ActiveReports 12 Server User Guide > How To > Activate a License
Show All
Hide All

If you have not yet licensed ActiveReports Server, you will see an evaluation message in the top bar of both the Administrator Dashboard and the Report Portal. To remove the evaluation message, license the server using the product key you received via e-mail when you purchased the product.

To license your server

  1. In the configuration section of the Administrator dashboard, click Licenses. The Licenses list appears.
  2. Click Activate new license. The Enter Product Key dialog appears.
  3. In the Activate new license dialog, fill in the Product Key that you received when you purchased ActiveReports Server.
  4. Select the check box to indicate your acceptance of the licensing agreement terms, and click Next. The Authentication Number fills in automatically.
  5. Click the link that appears in Step 2 to open the activation site in a new browser tab. Your Product Key and Authentication Number fill in automatically.
  6. Click Send Request. Your License Key appears, along with your activation date. Select the License Key number and copy it.
  7. Return to the browser tab with the Administrator Dashboard, paste the License Key into Step 3 of the dialog and click Finish. The evaluation message is removed, and the product key is listed in the Licenses list with a License Status of Activated.
See Also
Managing Agents


Add Row-Level Security

Add Row-Level Security
ActiveReports 12 Server User Guide > How To > Add Row-Level Security
Show All
Hide All

To control access to row-level data based on user permissions, you must create security filters and apply them to the model entities that you want to secure. Security filters can be based on LDAP or Active Directory, or you can create a custom security provider.

For information on creating custom security providers, please see Create a Custom Security Provider topic, or the sample in C:\ActiveReports 12 Server\SDK\Samples\ActiveTunes.SecurityProvider.

If you use LDAP or Active Directory, please see Using LDAP and Active Directory for Single Sign-On. If you have created a custom security provider, follow the steps below.

To configure ActiveReports Server to use your custom security provider

  1. In the configuration section of the Administrator dashboard, click Security Provider. The Custom security provider drop-down list appears.
  2. Drop down the list and select your custom security provider.
  3. In the Security Provider Settings that appear, enter a value for any properties that appear.
  4. When you have entered all of the information, click the Apply changes button. Your custom security provider becomes available for use in security filters.

To create a new security filter for row-level security

  1. In the Administration section of the Administrator dashboard, click Models. The Models list appears.
  2. Select the model to which you want to add a filter, and then click Edit model button. The model editor appears.
  3. Select the entity that you want to filter. The editable properties appear in the center workspace.
  4. Next to Security Filter, click the Add command. The Edit Security Filter dialog appears.

  5. In the box next to Filter Name, enter a name for your filter.
  6. With Filter Expression selected, click the ellipsis button to open the Select Attribute dialog where you can select an attribute of the entity on which to filter data, and click OK.
  7. Drop down the list next to the attribute to select whether to display data that equals or does not equal the following value.
  8. Drop down the list to the right, and select a User Context Attribute Name mapping against which to filter the selected attribute.
  9. Click the Apply button to create the filter, or to discard the changes, click Cancel.
See Also
Using LDAP and Active Directory for Single Sign-On
Managing Single Sign-On Security Providers
Managing Permissions


Use the Designer Web Control

Use the Designer Web Control
ActiveReports 12 Server User Guide > How To > Use the Designer Web Control
Show All
Hide All

The Web controls need to be directed to the server used for ActiveReports 12 Server in order to function. In your production application, specify the user name and password based on the current user and store information in the current session to persist these values.

To add the Designer control to a Web Form

  1. In Visual Studio, create a new C# ASP.NET Web Site.

    If you need to add the control to your toolbox, drop down these steps.

    1. Right-click in the General tab and select Choose items.
    2. In the Choose Toolbox Items dialog that appears, the .NET Framework Components tab is selected by default. Click the Namespace column header to sort by namespace.
    3. The ActiveReports.Server.ReportControls namespace is at or near the top of the list. Select the checkbox next to Designer and click OK.
    4. The Designer control appears in your Visual Studio toolbox.
  2. Open the Design view of your Web Form and from the toolbox, drag and drop the Designer control onto the body section of the Web Form.
  3. On the message box that appears, click Yes to automatically add .svc files to your Web site to give the designer access to proxy services.

  4. You can resize the designer using the Properties grid by changing the Width property.
  5. So that the link at the top of the Designer will work for your Admin users, change the AdminPath property to the URL of your Admin site, for example, http://localhost:8080/Admin/.

To direct the Designer to the server used for ActiveReports Server

You can specify the security token and ActiveReports 12 Server host using code in a Global Application Class.

  1. From the Visual Studio Website menu, select Add New Item.
  2. In the Add New Item dialog that appears, select Global Application Class and click Add.
  3. In the Global.asax file that appears, provide a handler for the ResolveRemoteEndPoint event using code like the following in the Application Start event:

    To provide a handler for the event

    C# code. Paste INSIDE the Application_Start event.
    Copy Code
    ReportServiceProxy.ResolveRemoteEndpoint += ResolveRemoteEndpoint;
  4. Below the Application Language tag at the top of the file, import the Servicing namespace so that you can use the ReportServiceProxy using a directive like the following:

    To import the Servicing namespace

    ASP.NET code. Paste in the Global.asax file on the line BELOW the Application Language line.
    Copy Code
    <%@ Import Namespace="ActiveReports.Server.ReportControls.Servicing" %>
  5. Below the Application Start event, create the ResolveRemoteEndpoint event using code like the following, but with your address, user name, and password:

    To create the ResolveRemoteEndpoint event

    C# code. Paste in the Global.asax file AFTER the Application_Start event.
    Copy Code
        static void ResolveRemoteEndpoint(RemoteEndpoint remoteEndpoint)
    {
        remoteEndpoint.Address = "http://localhost:8080";
        remoteEndpoint.SecurityToken = "MySecurityToken";
    }

You can also specify the user name, password, and ActiveReports 12 Server host in your web application's web.config file.

  1. In the web.config file, provide a handler for the ResolveRemoteEndPoint event using code like the following.

    To provide a handler for the event

    C# code. Paste BETWEEN the <configSections> and </configSections> tags.
    Copy Code
        <sectionGroup name="activereports.server">
      <section name="reportServiceProxy" type="ActiveReports.Server.ReportControls.Configuration.ActiveReportsServerSection,
      ActiveReports.Server.ReportControls, Version=x.x.xxxx.x, Culture=neutral, PublicKeyToken=d557f2f30a260da2" allowDefinition="Everywhere" />
    </sectionGroup>
  2. Below the Application Start event, create the ResolveRemoteEndpoint event using code like the following, but with your address, user name, and password

    To import the Servicing namespace

    ASP.NET code. Paste in the web.config file BELOW the </configSections> tag.
    Copy Code
      <activereports.server>
    <reportServiceProxy remoteReportServicePath="http://localhost:8080/" username="Admin" password="1" />
  </activereports.server>

See Also
Using the ReportList Web Control

Reference

Report Loading


Hide Log In and Log Out Buttons

Hide Log In and Log Out Buttons
ActiveReports 12 Server User Guide > How To > Hide Log In and Log Out Buttons

When you add the Designer control to your custom web application and use a custom security provider, you probably do not want to show our built-in Log In and Log Out buttons on the designer.

To hide the authentication buttons

  1. On the Design view of your web form, select the Designer control.
  2. In the Properties window, locate the SecurityToken property.
  3. Enter a string value representing a valid security token.

You can obtain a security token from the IReportService Login Method.

See Also
Create a Custom Security Provider
Use the Designer Web Control
SecurityToken Property

Web Service Library

Login Method


Open the Designer without Selecting a Model

Open the Designer without Selecting a Model
ActiveReports 12 Server User Guide > How To > Open the Designer without Selecting a Model

If you want to make report designing even faster for your business users, you can allow them to skip the steps involved in selecting a data model. Use the new DataModel property so they can just click a button to open the designer on a blank report with a pre-selected data model, or copy the Create report link from the models list.

This topic assumes that you are already familiar with how to Use the Designer Web Control.

To code a button click event to open a blank report with data

  1. From the Visual Studio Standard toolbox, drag a Button control and drop it onto your Web form.
  2. Double-click the button to create a Click event handling method in the code view.
  3. Paste code like the following into the event to open a blank report in the designer with a pre-selected data model.
    C# code. Paste INSIDE the Button Click event.
    Copy Code
    this.Designer1.ModelName = "ActiveTunes (Sample)";
this.Designer1.ReportAction = ActiveReports.Server.ReportControls.ReportAction.Create;

To copy the Create report link

  1. In the Administration section of the Administrator dashboard, click Models.
  2. In the list of models, find the model that you want to use and, to the right of the model, click the Create report command.
  3. In the browser's address bar, select the URL and copy it.
  4. You can use this link as a hyperlink or in a response.redirect command.
See Also
Use the Designer Web Control

Reference

URL Access to Reports and Designer


Create a Custom Security Provider

Create a Custom Security Provider
ActiveReports 12 Server User Guide > How To > Create a Custom Security Provider
Show All
Hide All

You must create custom security providers in order to provide security filters for model entities. This allows you to add single sign-on functionality using LDAP and Active Directory, and to control access to data with row-level security.

Once you implement interfaces from the Extensibility assembly and configure the resulting assembly in the Administrator Dashboard by selecting it in the Security Provider list, you and your administrators can add security filters to entities when you edit a model. For more information, see Managing Single Sign-On Security Providers and Modifying an Entity topics.

You can use your UserContext attributes in the connection string of your data models by encasing them in percent signs. For more information, see Changing the Connection String topic.

To implement Extensibility interfaces in a .NET 3.5 Class Library

  1. In Visual Studio, create a new C# .NET Framework 3.5 Class Library project.
  2. From your ActiveReports 12 Server\Server installation folder, copy the ActiveReports.Server.Extensibility.dll file into your project's bin folder.
  3. In the Visual Studio Solution Explorer, right-click References and select Add Reference.
  4. In the Add Reference dialog that appears, on the Browse tab, look in the bin folder, select the ActiveReports.Server.Extensibility.dll and click OK.
  5. Add a class to your project that implements the ISecurityProvider interface, and another that implements the ISecurityProviderFactory interface.
    Note: For details on how to do this, please see the ActiveTunes.SecurityProvider sample in the C:\ActiveReports 12 Server\SDK\Samples directory.
    Important methods in the ISecurityProvider interface include:
    • CreateToken creates the security token that the server holds to identify the current logged in session with username and password parameters, as well as a custom parameter for any other credentials data used by the provider.
    • FilterRoles gets the collection of roles associated with the specified security token.
    • GetUserContext returns the UserContext object for the specified security token.
    • GetUserDescription returns two useful objects:
      • UserDescription.Email automatically fills the email field in the error log submission dialog.
      • UserDescription.FriendlyUserName automatically fills the CreatedBy and ModifiedBy fields for reports.
  6. Once all of the necessary classes are in place with your custom data, from the Build menu, select Build ClassLibrary1. A DLL is created in your project's bin folder.

To configure the provider

  1. In Windows Explorer, create a SecurityProviders folder on the same level as your site, for example, if you have C:\ActiveReports 12 Server, create the folder C:\ActiveReports 12 Server\SecurityProviders.
  2. Copy your custom security provider DLL file into the new folder.
  3. On the Administrator Dashboard, in the Configuration section, click Security Provider.
  4. From the Custom security provider drop-down that appears, select your new provider.
  5. Select values for any properties that may be available, depending on your provider.
  6. Click the Apply changes button.

To add a row-level security filter

  1. On the Administrator Dashboard, in the Administration section, click Models.
  2. In the list of models that appears, next to the model containing the entity that you want to filter, click the Edit command.
  3. In the model editor that appears, from the Entities list to the left, click the entity that you want to filter.
  4. In the workspace at the center, next to the Security Filter property, click the Add command.
  5. In the Edit Security Filter dialog that appears, select Filter Expression, and click the ellipsis button next to the box under that label.
  6. In the Select Attribute dialog that appears, expand nodes as necessary to select the attribute to which you want to apply a filter condition, and click OK.
  7. In the center, you can choose whether the attribute equals or does not equal the value to the right.
  8. In the drop-down box to the right, select the value from your security provider to compare to the attribute on the left.
  9. Click Apply to add the filter to the entity.
See Also
ISecurityProvider Interface
ISecurityProviderFactory Interface


Debug a Custom Security Provider

Debug a Custom Security Provider
ActiveReports 12 Server User Guide > How To > Debug a Custom Security Provider
Show All
Hide All

Once you have created a custom security provider, you may need to debug it. The following steps walk you through how to do this using the sample custom security provider project installed with ActiveReports Server. By default, this sample is in the following folder.

C:\ActiveReports 12 Server\SDK\Samples\ActiveTunes.SecurityProvider

To deploy the custom security provider for debugging

  1. If you have not done so already, open the project in Visual Studio and from the Build menu, select Build Solution.
  2. If you have not done so already, in the C:\ActiveReports 12 Server directory, create a new folder named SecurityProviders.
  3. From your project bin\Debug\ folder, copy the following files, and paste them into C:\ActiveReports 12 Server\SecurityProviders\ to make the security provider and debugging file available to ActiveReports 12 Server.
    • ActiveTunes.SecurityProvider.dll
    • ActiveTunes.SecurityProvider.pdb
    • System.Data.SQLite.dll
  4. Open the ActiveReports Administrator Dashboard in your browser, and under Configuration, select Security Provider.
  5. Next to Custom security provider, drop down the list and select ActiveTunesSecurityProviderFactory. The page refreshes to allow you specify security provider settings and to test the configured provider.
    Important: If you need to update the DLL at any point, you must first change this value back to Default (builtin). You can change it back after you finish updating the DLL.
  6. Under Security Provider Settings, for the ConnectionString property, enter the following connection string and click Apply changes.
    Connection string
    Copy Code
    Data Source=C:\ActiveReports 12 Server\SDK\Samples\ActiveTunes.SecurityProvider\ActiveTunes.sqlite

To debug the custom security provider

In order to perform the following steps, you must run Visual Studio as Administrator.

  1. From the Visual Studio Tools menu, select Attach to Process.
  2. In the Attach to Process dialog that appears, select the Show processes in all sessions checkbox, or navigate to the remote machine where the server web site resides.
  3. Scroll down and select the w3wp.exe process for server's web site and click Attach. The project goes into Debugging mode.
    Caution: There may be multiple w3wp.exe processes, so be sure to attach the one on the server machine running the ActiveReports services.
  4. In the ActiveTunesSecurityProvider.cs file, locate the ActiveTunesSecurityProvider.CreateToken method and click in the margin to the left to set a breakpoint on it.
  5. In your browser, on the Administrator Dashboard Security Provider page in the Login to test and Password to test boxes, enter test values from the table below.
    Login | Password
    andrew@chinookcorp.com | 1
    nancy@chinookcorp.com | 2
    jane@chinookcorp.com | 3
    margaret@chinookcorp.com | 4
    steve@chinookcorp.com | 5
    michael@chinookcorp.com | 6
    robert@chinookcorp.com | 7
    laura@chinookcorp.com | 8
  6. Click the Test provider link. The Visual Studio window takes focus and shows the breakpoint, allowing you to debug the code.

To debug your custom security provider with Visual Studio on the server

Here is another way to debug your security provider if you have Visual Studio installed on the server and have direct access to the server machine.

Caution: Ensure that you remove this code before you go live with your deployment.

  1. Open your SecurityProvider implementation, and in one of its methods, for example, ISecurityProviderFactory.Create, add the following code.
    C# code. Paste inside the method to debug.
    Copy Code
    System.Diagnostics.Debugger.Break();
  2. From the Build menu, select Rebuild Solution.
  3. Copy the resulting DLL and PDB files and paste them into C:\ActiveReports 12 Server\SecurityProviders\.
  4. Open the ActiveReports Administrator Dashboard in your browser, and under Configuration, select Security Provider.
  5. Next to Custom security provider, drop down the list and select your security provider. The page refreshes to allow you specify any security provider settings specified in your provider.
    Important: If you need to update the DLL at any point, you must first change this value back to Default (builtin). You can change it back after you finish updating the DLL.
  6. When you run a test or try to log in as a user, The Visual Studio Just-In-Time Debugger prompt appears asking whether you want to debug w3wp.exe.
  7. Click Yes to open Visual Studio and begin debugging.
See Also
Create a Custom Security Provider
Custom Security Provider Sample
Using LDAP and Active Directory for Single Sign-On


View Reports Using the HTML5 Viewer

View Reports Using the HTML5 Viewer
ActiveReports 12 Server User Guide > How To > View Reports Using the HTML5 Viewer
Show All
Hide All

This topic walks you through how to initialize the HTML5 Viewer in JavaScript. It also provides details on all public initialization options, plus all of the public API methods and properties that you can use with the viewer after you initialize it.

Initializing the HTML5 Viewer

  1. Copy the following files from the ...\ActiveReports 12 Server\SDK\HTML5 Viewer.Source folder to a folder accessible from the target HTML page:
    • GrapeCity.ActiveReports.Viewer.Html.js
    • GrapeCity.ActiveReports.Viewer.Html.min.js
    • GrapeCity.ActiveReports.Viewer.Html.cs
  2. In the target HTML page, add the references to the GrapeCity.ActiveReports.Viewer.Html.css, GrapeCity.ActiveReports.Viewer.Html.js and its dependencies:
    • jQuery 1.9.0 or higher
    • Bootstrap 3.0
    • Knockout.js 2.3.0 or higher
    Note: You can access the dependencies like jQuery in a Content Delivery Network (CDN) or copy them locally.
    HTML
    Copy Code
    <link rel="stylesheet" href="GrapeCity.ActiveReports.Viewer.Html.css" >
<script src="//ajax.googleapis.com/ajax/libs/jquery/1.9.0/jquery.min.js"></script>
<script src="//netdna.bootstrapcdn.com/bootstrap/3.0.3/js/bootstrap.min.js"></script>
<script src="http://cdnjs.cloudflare.com/ajax/libs/knockout/2.3.0/knockout-min.js" type="text/javascript"></script>
<script src="Scripts/GrapeCity.ActiveReports.Viewer.Html.js" type="text/javascript"></script>
<script type="text/javascript">
</script>
  3. In the target HTML page, add the DIV element that will contain the HTML5 Viewer.
    HTML
    Copy Code
    <div id="viewer" style="width:600px;height:480px;"></div>
  4. Add the following code to initialize the HTML5 Viewer. The code might vary depending on the technology that you use to develop the HTML5 Viewer component. To learn how to get a security token for the reportService, see Get a Security Token.
    Javascript
    Copy Code
    $(function ()
{
   var viewer = GrapeCity.ActiveReports.Viewer(
   {
      element: '#viewer',
      report: {
         id: "myreport"

      },

      reportService: {
          url: 'http://myAR12server.com/ReportService.svc/json/',
          securityToken: securityToken,
          resourceHandler : 'http://myAR12server.com/cache/'
      },
      uiType: 'desktop',
      documentLoaded: function reportLoaded()
      {
         console.log(viewer.pageCount);
      },
      reportLoaded: function (reportInfo)
      {
         console.log(reportInfo.parameters);
      },

      error: function (error)
      {
         console.log("error");
      }

   });
});

    Alternatively, you can use the REST API endpoint URL for the HTML5 Viewer initialization.

    Javascript
    Copy Code
    $(function ()
{
   var viewer = GrapeCity.ActiveReports.Viewer(
   {
      element: '#viewer',
      report: {
         id: "myreport"

      },

      reportService: {
          url: 'http://myAR12server.com/api/',
          securityToken: securityToken,
          resourceHandler : 'http://myAR12server.com/cache/'
      },
      uiType: 'desktop',
      documentLoaded: function reportLoaded()
      {
         console.log(viewer.pageCount);
      },
      reportLoaded: function (reportInfo)
      {
         console.log(reportInfo.parameters);
      },

      error: function (error)
      {
         console.log("error");
      }

   });
});
  5. Add the following code to the system.webServer section of the web.config file of your ActiveReports 12 Server web site.
    XML
    Copy Code
    <system.webServer>

        <httpProtocol>

                <customHeaders>

                        <add name="Access-Control-Allow-Origin" value="*" />

                        <add name="Access-Control-Allow-Headers" value="AuthToken, Authorization, Origin, Content-Type, Accept, X-Requested-With" />

                </customHeaders>

        </httpProtocol>

...

</system.webServer>

Initialization Options

The following options can be set during initialization or at runtime while working with the HTML5 Viewer.

uiType

Description: Sets the UI mode of the HTML5 Viewer.

Type: String

Accepted Value: 'Custom', 'Mobile' or 'Desktop'

Example:
viewer.option('uiType', 'Mobile');

element

Description: JQuery selector that specifies the element that hosts the HTML5 Viewer control.

Note: This option is used during initialization only.

Type: String

Example:
var viewer = GrapeCity.ActiveReports.Viewer(
{
   element: '#viewerContainer2',
   reportService: {
      url: '/ActiveReports.ReportService.asmx'
   },
});

reportService

Description: The report service that can use ActiveReports Server or ActiveReports Web Report Service.

Type: Object that has the URL and optional securityToken properties

Example:
reportService: {
   url: 'http://remote-ar-server.com',
   securityToken: '42A9CD80A4F3445A9BB60A221D042FCC',
   resourceHandler: 'http://remote-ar-server.com/resourceHandler.aspx'
};

reportService.url

Description: The URL of ActiveReports 12 Server instance of the ActiveReports Web service that provides the reportInfo and output.

Type: String

Example:
reportService: {
   url: 'http://remote-ar-server.com'
};

reportService.securityToken

Description: The security key needed to log in to ActiveReports Server.

Type: String

Example:
reportService: {
   securityToken: '42A9CD80A4F3445A9BB60A221D042FCC'
};

reportService.resourceHandler

Description: The URL of the ActiveReports Server resource handler.

Type: String

Example:
reportService: {
   resourceHandler: 'http://remote-ar-server.com/resourceHandler.aspx'
};

report

Description: The report that is displayed in ActiveReports Server or ActiveReports Web Report Service.

Type: An object that has id and parameters properties.

Example:
report: {
   id: 'CustomersList',
   parameters: [
   {
      name: 'CustomerID',
      value: 'ALFKI'
   }]
};

reportID

Description: The id of the report to be shown by the HTML5 Viewer.

Type: String

Example:

Example:
report: {
   id: 'CustomersList',
   parameters: [
   {
      name: 'CustomerID',
      value: 'ALFKI'
   }]
};

reportParameters

Description: The array of the {name, value} pairs that describe the parameters values used to run the report.

Type: Array

Example:
report: {
   id: 'CustomersList',
   parameters: [
   {
      name: 'CustomerID',
      value: 'ALFKI'
   }]
};

reportLoaded

Description: The callback that is invoked when the HTML5 Viewer obtains the information about the requested report. The reportInfo object is passed in the callback including the TOC info, Parameters info and the link to the rendered report result.

Type: function(reportInfo)

Example:
var reportLoaded = function reportLoaded(reportInfo)
   {
      console.log(reportInfo.parameters);
   }
viewer.option('reportLoaded', reportLoaded);

action

Description: The callback that is invoked before the HTML5 Viewer opens the hyperlink, bookmark link, drill down report or toggles the report control visibility.

Type: function(actionType, actionParams)

Example:
function onAction(actionType, actionParams)
{
   if (actionType === 0)
   {
      window.open(params.url, "Linked from report", "height=200,width=200");
   }
}
viewer.option('action', onAction);

availableExports

Description: The array of export types available via Export functionality of HTML5 Viewer. By default, PDF, Word, Image, Mht, Excel, and CSV exports are available.

Type: Array

Example:
viewer.option("availableExports", ['Pdf']);

maxSearchResults

Description: The number of search results received for a single search invoke.

Type: Number

Example:
maxSearchResults: 10

error

Description: The callback that is invoked when an error occurs in the process of displaying the report. The error message can be customized.

Type: function(error)

Example:
var options = {
  error: function(error){
    error.message = "My error message";
  },
  // other properties
};
var viewer = GrapeCity.ActiveReports.Viewer(options);

documentLoaded

Description: The callback that is invoked when a document is loaded entirely on the server.

Type: function()

Example:
var documentLoaded = function documentLoaded()
   {
      setPaginator();
   }
viewer.option('documentLoaded', documentLoaded);

localeUri

Description: The URL of the file containing the localization strings.

Note: This option is used during initialization only.

Type: String

Example:
var viewer = GrapeCity.ActiveReports.Viewer(
{
   localeUri: 'Scripts/i18n/ru.txt'
});

Public API Methods and Properties

After initializing the HTML5 Viewer, the following API methods and properties can be used.

Methods

option

Description: Gets or sets the option value by name if the value parameter is specified.

Syntax: option(name,[value])Object

Parameters:

  • name: The option name to get or set.
  • value: (optional) The option value to set. If this argument is omitted than the method returns the current option value.
Example:
viewer.option('uiType', 'mobile');
viewer.option('report', {
   id: 'my report'
});

Return Value: The current option value.

refresh

Description: Refreshes the report preview.

Syntax: option(name,[value])Object

Example:
viewer.refresh()

Return Value: Void

print

Description: Prints the currently displayed report if any.

Syntax: print()Void

Example:
viewer.print()

Return Value: Void

goToPage

Description: Makes the viewer to display the specific page, scroll to the specific offset (optional) and invokes the callback once it's done.

Syntax: goToPage(number, offset, callback)Void

Parameters:

  • number: The number of pages to go to.
  • offset object: The object such as {left:12.2, top:15}.
  • callback: The function to call after perform action.
Example:
viewer.goToPage(1, {
   2, 3
}, function onPageOpened()
{});

Return Value: Void

backToParent

Description: Makes the viewer to display the parent report of the drill-down report.

Syntax: backToParent()Void

Example:
viewer.backToParent()

Return Value: Void

destroy

Description: Removes the viewer content from the element.

Syntax: destroy()Void

Example:
viewer.destroy()

Return Value: Void

export

Description: Exports the currently displayed report.

Syntax: export(exportType,callback,saveAsDialog,settings)Void

Parameters:

  • exportType: Specifies export format.
  • callback: Function that is invoked once the export result is available (its URL is passed in the callback).
  • saveAsDialog: Indicates whether the save as dialog should be shown immediately once the export result is ready.
  • settings: The export settings, vary for each export type.
Example:
viewer.export('Word', function ()
{
   console.log('export callback');
}, true, {
   FileName: 'Document.doc'
})

Return Value: Void

search

Description: Performs the search of a specific term with specific search options (match case, whole word) and invokes the specific callback with the search result passed.

Syntax: search(searchTerm, searchOptions, callback)Void

Parameters:

  • searchTerm: String to find.
  • searchOptions: The object optionally defines the search options:
    • matchCase: Whether the search should respect the case.
    • wholePhrase: Whether the search should look for a whole phrase.
  • callback: The function to call after performing search.
Example:
viewer.search('a', {
   matchCase: true,
   wholePhrase: false
}, function (results)
{
   console.log(results);
});

Return Value: Void

getToc

Description: Obtains the part of the report TOC specified by parent(node), startChild(index), count parameters and invokes callback function passing the result as parameter.

Syntax: getToc(callback) Void

Parameters:

  • callback: The callback to handle TOC tree.
Example:
viewer.getToc(function (toc)
{
   console.log(toc);
})

Return Value: Void

Properties

pageCount

Description: Gets the page count of the currently displayed report.

Syntax: viewer.pageCount

Example:
console.log(viewer.pageCount)

Return Value: An integer representing page count.

currentPage

Description: Gets the currently displayed page number.

Syntax: viewer.currentPage

Example:
console.log(viewer.currentPage)

Return Value: An integer representing currently displayed page number.

Toolbar

Description: Returns the HTML element that displays the toolbar in desktop UI mode. The developer may use it to add the custom elements or remove the existing ones using jQuery/Html/Css capabilities.

Syntax: viewer.Toolbar

Example:
// Toolbar, MobileToolbarTop, MobileToolbarBottom
$(viewer.toolbar).hide();
$(viewer.toolbarTop).hide();
$(viewer.toolbarBottom).hide();

ToolbarTop

Description: Returns the HTML element that displays the top toolbar in mobile UI mode. The developer may use it to add the custom elements or remove the existing ones using jQuery/Html/Css capabilities.

Syntax: viewer.ToolbarTop

Example:
// Toolbar, MobileToolbarTop, MobileToolbarBottom
$(viewer.toolbar).hide();
$(viewer.toolbarTop).hide();
$(viewer.toolbarBottom).hide();

ToolbarBottom

Description: Returns the HTML element that displays the bottom toolbar in mobile UI mode. The developer may use it to add the custom elements or remove the existing ones using jQuery/Html/Css capabilities.

Syntax: viewer.ToolbarBottom

Example:
// Toolbar, MobileToolbarTop, MobileToolbarBottom
$(viewer.toolbar).hide();
$(viewer.toolbarTop).hide();
$(viewer.toolbarBottom).hide();


Get a Security Token

Get a Security Token
ActiveReports 12 Server User Guide > How To > Get a Security Token

When you use the HTML5 Viewer to access the ActiveReports Server web site, you need to provide the Report Service with a security token to use.

Below are the steps to retrieve a security token.

To get a security token by the Javascript function

  1. In the target HTML page, add the following code to get a security token. The code might vary depending on the technology that you use to develop the HTML5 Viewer component. For more information, see the HTML5 Viewer Sample. By default, this sample is in the following folder.

    C:\ActiveReports 12 Server\SDK\Samples\HTML5 Viewer.

    Note: You need to change these settings in the code below.

    • url parameter represents the location (reportservice.svc/json/login) which stays constant where as the arsEndpoint represents the URL used to access the Report Portal Website. Example: http://<ActiveReports12ServerName>:<portnumber>.
    • username is your username to log into the ActiveReports Server web site.
    • password is your password to log into the ActiveReports Server web site.
    Javascript
    Copy Code
    function getSecurityToken() {
    if (_securityToken) return _securityToken;
    _securityToken = "error";

    try {
        $.ajax({
             async: false,
             type: "POST",
             url: arsEndpoint + "ReportService.svc/json/Login",
             data: JSON.stringify({
                   username: "username",
                   password: "password"
             }),
             contentType: "application/json",
             dataType: "json"
        }).done(function(res) {
              _securityToken = res.d;
        }).fail(function() {
              _securityToken = "error";
        });
    } catch(e) {
          return "error";
    }

    return _securityToken;
}

    If you are using the REST API, add the following code to get a security token.

    Javascript
    Copy Code
    function getSecurityToken() {
    if (_securityToken) return _securityToken;
    _securityToken = "error";

    try {
        $.ajax({
             async: false,
             type: "POST",
             url: arsEndpoint + "api/accounts/login",
             data: JSON.stringify({
                   user: "username",
                   password: "password"
             }),
             contentType: "application/json",
             dataType: "json"
        }).done(function(res) {
              _securityToken = res.Token;
        }).fail(function() {
              _securityToken = "error";
        });
    } catch(e) {
          return "error";
    }

    return _securityToken;
}
See Also
View Reports Using the HTML5 Viewer


Customize and Publish the ClickOnce End User Designer

Customize and Publish the ClickOnce End User Designer
ActiveReports 12 Server User Guide > How To > Customize and Publish the ClickOnce End User Designer

With the ActiveReports Professional Edition, you can use the ClickOnce Designer sample to create your own ClickOnce End User Designer and publish it to ActiveReports Server. The ClickOnce Designer sample is provided with the ActiveReports Server installation.

To compile the ClickOnce Designer sample, first install ActiveReports with the Professional license.
  1. Open the ClickOnce Designer sample in Visual Studio. By default, the ClickOnce Designer sample is located at C:\ActiveReports 12 Server\SDK\Samples\Click Once Designer.
  2. In Solution Explorer, select the EndUserDesigner.cs sample file.
  3. Right-click the file and select View code.
  4. Modify the sample files based on your requirements. For example, in the Code view, find the following code line:
    private void CreateReport(DesignerReportType type)
      {
       reportDesigner.NewReport(type);
       EnableTabs();
       _reportName = "Untitled";
      }
    and replace "Untitled" with "NewReport1".

    This replaces the default name of the report before you save it to the file system.

    Note: You cannot modify the Program.cs file as it contains the ActiveReports Server initialization parameters and other important code.
  5. In the Build menu, click Build ClickOnce Designer.
  6. In the Build menu, click Publish ClickOnce Designer and follow the Publish Wizard. Be sure to enter the path to the ActiveReports Server folder to replace the default ClickOnce End User Designer with the customized one.

    Note: When the ClickOnce Designer application is republished after modifications, the existing certificate is revoked from the application. You need to sign the certificate again to create a trusted application.

See Also
ActiveReports Editions
ClickOnce End User Designer


Samples and Walkthroughs

Samples and Walkthroughs
ActiveReports 12 Server User Guide > Samples and Walkthroughs

These topics describe the Server Core samples and provide step-by-step walkthroughs detailing ActiveReports Server project creation.

Samples
These topics explain how to access the sample files installed with ActiveReports Server.
Walkthroughs
Learn to work with ActiveReports 12 Server controls in Visual Studio.


Samples

Samples
ActiveReports 12 Server User Guide > Samples and Walkthroughs > Samples

The ActiveReports Server installation includes several sample projects in Visual Studio 2012, 2013, and 2015 solutions. You can find the solution in C:\ActiveReports 12 Server\SDK\Samples.

To open the solution, double-click the ActiveReports 12 Server SamplesVSxxxx.sln file.

Sample Project | Description
ActiveTunes.SecurityProvider | Shows how to use security providers with ActiveReports Server to control authentication.
Angular REST API Sample | Shows how to call the most frequently used REST API methods in your angular based application linked to ActiveReports Server.
ASP.NET Integration | Shows how to embed the Report Designer control in your own applications, and how to customize the Report List control. It also demonstrates how to use the Web service features using JavaScript.
ASP.NET REST API Sample | Shows how to call the most frequently used REST API methods in your ActiveReports Server application.
Click Once Designer | Shows how to create your own ClickOnce End User Designer and publish it to ActiveReports Server.
HTML5 Viewer | Shows how to use the HTML5 Viewer to preview reports hosted in web applications.
Migration PowerShell Module | Shows how to migrate users, reports, or roles from one server to another.
REST API HTML5 Sample | Shows how to call some of the most frequently used REST API methods in your custom ActiveReports Server application.
WinForms REST API Sample | Shows how to call the most frequently used REST API methods in your Windows Forms application linked to ActiveReports Server.

Also included is a separate Security Provider Sample. See Custom Security Provider Sample for details.

See Also
Samples and Walkthroughs
Debug a Custom Security Provider
View Reports Using the HTML5 Viewer
Customize and Publish the ClickOnce End User Designer
WinForms REST API Sample
REST API HTML5 Sample
ASP.NET REST API Sample
Migration PowerShell Module Sample
Custom Security Provider Sample
Create a Custom Security Provider
Angular REST API Sample


Custom Security Provider Sample

Custom Security Provider Sample
ActiveReports 12 Server User Guide > Samples and Walkthroughs > Samples > Custom Security Provider Sample
Show All
Hide All

The ActiveReports Server installation includes a security provider sample that you can find in:

C:\ActiveReports 12 Server\SDK\Samples\ActiveTunes.SecurityProvider

To open the solution, double-click the ActiveTunes.SecurityProvider.sln file.

This sample comes with an SQLite database (ActiveTunes.sqlite), which has Customer and Employee tables. The sample demonstrates how you can log in to ActiveReports Server with the user information saved in those tables and use row-level security.

Note: By default, users from the Customer table have the ActiveTunesCustomer role and users from the Employee table have the ActiveTunesEmployee role. To enable the setting, you should create the ActiveTunesCustomer and ActiveTunesEmployee roles on the Administrator Dashboard in advance.

To compile and use the Security Provider sample

  1. With the sample open in Visual Studio, from the Build menu, select Build Solution.

    If Nuget Package Manager extension version 2.7 or above is installed, the SQLite assembly is restored on building. If Nuget version is older than 2.7, you need to select 'Restore NuGet Packages' from the solution's context menu.

  2. In Windows Explorer, open the following folder, and copy the ActiveTunes.SecurityProvider.dll assembly.
    C:\ActiveReports 12 Server\SDK\Samples\ActiveTunes.SecurityProvider\ActiveTunes.SecurityProvider\bin\Debug
  3. Paste the assembly into the following folder in your ActiveReports 12 Server installation folder.
    C:\ActiveReports 12 Server\SecurityProviders
  4. On the Administrator Dashboard, in the Configuration section, click Security Provider.
  5. From the Custom security provider drop-down that appears, select ActiveTunesSecurityProviderFactory.
  6. In the ConnectionString property that appears, enter the connection string:
    ConnectionString
    Copy Code
    Data Source=C:\ActiveReports 12 Server\SDK\Samples\ActiveTunes.SecurityProvider\ActiveTunes.sqlite
  7. To test the custom security provider, in the Login to test and Password to test boxes, enter test values from the table below.
    Login | Password
    andrew@chinookcorp.com | 1
    nancy@chinookcorp.com | 2
    jane@chinookcorp.com | 3
    margaret@chinookcorp.com | 4
    steve@chinookcorp.com | 5
    michael@chinookcorp.com | 6
    robert@chinookcorp.com | 7
    laura@chinookcorp.com | 8
  8. Click the Test provider link to connect to the sample database and verify that the authentication is successful. You will see the following screen.

  9. Click the Apply changes button.
  10. Open the Report Portal and enter Login and Password values from the table above, e.g. nancy@chinookcorp.com and 2 as password.

  11. You are logged into the Report Portal as a user Nancy Edwards from the ActiveTunes security provider.

Now, when you edit the ActiveTunes sample model, you can apply either the EmployeeID or CustomerID filter to any entity.

To add row-level security to the ActiveTunes sample model

  1. On the Administrator Dashboard, in the Administration section, click Models.
  2. In the list of models that appears, next to the ActiveTunes (Sample) model, click the Edit command.
  3. In the model editor that appears, from the Entities list to the left, click the entity that you want to filter.
  4. In the workspace at the center, next to the Security Filter property, click the Add command.
  5. In the Edit Security Filter dialog that appears, in the box next to Filter Name, enter a name for your filter.
  6. Select Filter Expression, and click the ellipsis button next to the box under that label.
  7. In the Select Attribute dialog that appears, select the attribute to which you want to apply the filter condition, and click OK.
  8. To the right of the equals option, click the drop-down arrow and select UserContext.CustomerID or UserContext.EmployeeID.
  9. Click Apply to add the filter to the entity.
See Also
Create a Custom Security Provider


WinForms REST API Sample

WinForms REST API Sample
ActiveReports 12 Server User Guide > Samples and Walkthroughs > Samples > WinForms REST API Sample

The ActiveReports Server installation includes a REST API sample for WinForms that you can find in:

C:\ActiveReports 12 Server\SDK\Samples\RestApi Sample WinForms

This sample is also part of the ActiveReports Server Samples project that you can find in:

C:\ActiveReports 12 Server\SDK\Samples

The REST API sample demonstrates how to call the most frequently used REST API methods in your application linked to ActiveReports Server. To open the solution, double-click the WinForms REST API Sample.csproj file.

To run the sample

  1. When you run the sample, following login screen appears:

  2. Enter the login information. Following RestfulAPI sample window appears:

    Image Title

  3. Double-click a report from the list of reports to preview it in the right pane.

Note:

  • The sample doesn't support parameterized reports.
  • Before building the REST API WinForms sample with NuGet version lower than 2.7, you need to manually restore the PDFiumViewer package. NuGet 2.7 and later versions are automatically restored in Visual Studio.

When a report is open for preview, you can choose one of the following operations to perform on the report.

Save as

You can choose from the following available formats to save your report. When you click the Run button, the report is saved in the selected format.

  • PDF. The rendering is performed with the following options.
    • Application: ActiveReports Server
    • Author: ActiveReports Server
    • OptimizeStatic: True
  • Word. The rendering is performed with the following options.
    • Author: ActiveReports Server
    • FileFormat: OOXML
  • Image. The rendering is performed with the following options.
    • Compression: Lzw
    • ImageType: TIFF
  • HTML. The rendering is performed with the following options.
    • MhtOutput: True
  • Excel. The rendering is performed with the following options.
    • MultiSheet: False

Print

When you click the Run button with the selected Print option, the following window appears. Select the Server printing options and click Print.

For the ActiveReports Server REST API documentation, please see http://arhelp.grapecity.com/webhelp/AR12Server/WebAPI/index.html.

See Also
REST API HTML5 Sample


REST API HTML5 Sample

REST API HTML5 Sample
ActiveReports 12 Server User Guide > Samples and Walkthroughs > Samples > REST API HTML5 Sample

The ActiveReports Server installation includes a REST API sample for HTML5 Viewer that you can find in:

C:\ActiveReports 12 Server\SDK\Samples\REST API HTML5 Sample

This sample is also part of the ActiveReports Server Samples sample project that you can find in:

C:\ActiveReports 12 Server\SDK\Samples

The REST API HTML5 sample demonstrates how to call the most frequently used REST API methods in your custom ActiveReports Server application. To open the solution, double-click the REST API HTML5 Sample.csproj file.

Note: To have the sample work properly, you need to update the ActiveReports Server web-site to accept cross-domain requests.
Go to C:\ActiveReports 12 Server\Site path and add the following lines in the <system.webServer> section of the web.config file:

<httpProtocol>
<customHeaders>
<add name="Access-Control-Allow-Origin" value="*" />
<add name="Access-Control-Allow-Headers" value="AuthToken, Authorization, Origin, Content-Type, Accept, X-Requested-With" />
<add name="Access-Control-Expose-Headers" value="X-ARS-DocumentId" />
</customHeaders>
</httpProtocol>

The sample application requires Internet Explorer 9 or higher.

To run the sample:

  1. When you run the sample, following login screen appears:

  2. Enter the login information. Following RestfulAPI sample window appears:

    Image Title

  3. Click a report from the list of reports to preview it in the right pane.

When a report is open for preview, you can choose one of the following operations to perform on the report.

Save file in this format

You can choose from the following available formats to save your report. When you click the Run button, the report is saved in the selected format.

  • PDF Document. The rendering is performed with the following options.
    • Application: ActiveReports Server
    • Author: ActiveReports Server
    • OptimizeStatic: True
  • Word Document. The rendering is performed with the following options.
    • Author: ActiveReports Server
    • FileFormat: OOXML
  • Image File. The rendering is performed with the following options.
    • Compression: Lzw
    • ImageType: TIFF
  • MHTML Web Archives. The rendering is performed with the following options.
    • MhtOutput: True
  • Excel Workbook. The rendering is performed with the following options.
    • MultiSheet: False

Print using a printer on Server

When you click the Run button with this option selected, the following window appears. Select the Server printing options and click Print.

Print using a printer on Client

When you click the Run button with this option selected, the report opens. Select the client printing options and click Print.

For the ActiveReports Server REST API documentation, please see http://arhelp.grapecity.com/webhelp/AR12Server/WebAPI/index.html.

See Also
WinForms REST API Sample
View Reports Using the HTML5 Viewer
ASP.NET REST API Sample


ASP.NET REST API Sample

ASP.NET REST API Sample
ActiveReports 12 Server User Guide > Samples and Walkthroughs > Samples > ASP.NET REST API Sample

The ActiveReports Server installation includes an ASP.NET REST API sample that you can find in:

C:\ActiveReports 12 Server\SDK\Samples\ASP.NET REST API Sample

This sample is also part of the ActiveReports Server Samples project that you can find in:

C:\ActiveReports 12 Server\SDK\Samples

The REST API sample demonstrates how to call the most frequently used REST API methods in your application hosted on ActiveReports Server. To open the solution, double-click the ASP.NET REST API Sample.csproj file.

To run the sample:

  1. When you run the sample, following login screen appears:

  2. Enter the login information. Following RestfulAPI sample window appears:

    Image Title

  3. Click a report from the list of reports to preview it in the right pane.

NOTE: The sample doesn't support parameterized reports.

When a report is open for preview, you can choose one of the following operations to perform on the report.

Save as

You can choose from the following available formats to save your report. When you click the Run button, the report is saved in the selected format.

  • PDF. The rendering is performed with the following options.
    • Application: ActiveReports Server
    • Author: ActiveReports Server
    • OptimizeStatic: True
  • Word. The rendering is performed with the following options.
    • Author: ActiveReports Server
    • FileFormat: OOXML
  • Image. The rendering is performed with the following options.
    • Compression: Lzw
    • ImageType: TIFF
  • HTML. The rendering is performed with the following options.
    • MhtOutput: True
  • Excel. The rendering is performed with the following options.
    • MultiSheet: False

Server print

When you click the Server print button, the following window appears. Select the Server printing options and click Print.

Client print

When you click the Client print button, the print preview window opens. Select the client printing options and click Print.

Project Details

The Scripts folder contains the following javascript files and its dependencies required to build this application:

  • PrintingService.js
  • validation.js

The Styles folder contains the StyleSheet.css file that stores styles for the sample.

The Constants.cs file contains string values that are required for the REST API methods in the sample.

The Domain.cs file contains enumerations and classes used in the sample.

The ExportReportHandler.cs file contains code that allows the sample reports to process.

The LoginPage.aspx file is the Web page of the sample that shows the login screen.

The Main.aspx file is the main Web page with the options that demonstrate the sample features.

The RestClient.cs file contains code for the CustomWebClient API and the RestClient API.

The SampleResources.resx file contains the string values for the captions, labels and error messages that are used in the sample.

The ServerPrint.aspx.cs file contains code that sets up server-side printing and print properties.

The Utils.cs file contains code that sets export settings for each export type.

The Web.config file is the configuration file that allows ActiveReports Server to process the sample.

For the ActiveReports Server REST API documentation, please see http://arhelp.grapecity.com/webhelp/AR12Server/WebAPI/index.html.

See Also
WinForms REST API Sample
REST API HTML5 Sample


Angular REST API Sample

Angular REST API Sample
ActiveReports 12 Server User Guide > Samples and Walkthroughs > Samples > Angular REST API Sample

The ActiveReports Server installation includes a REST API sample for Angular 4 that you can find in:

C:\ActiveReports 12 Server\SDK\Samples\Angular REST API Sample

This sample is also part of the ActiveReports Server Samples project that you can find in:

C:\ActiveReports 12 Server\SDK\Samples

The REST API sample demonstrates how to call the most frequently used REST API methods in your application linked to ActiveReports Server.

Note: Before you run the Angular REST API sample, you need to follow certain set of instructions that are given in the Prerequisites section in the README.md file. The location of this file is : C:\ActiveReports 12 Server\SDK\Samples\Angular REST API Sample

To run the sample

  1. Open the command prompt window, type the following and press enter :
    cd C:\ActiveReports 12 Server\SDK\Samples\Angular REST API Sample

  2. Execute the below command to start installing the package and link dependencies:
    yarn install

  3. After the installation is finished, run the following command to compile the package and start the server.
    yarn start

  4. After the compilation is successful, open http://localhost:54512/ in browser.

To work with the sample

  1. When you open the browser, following login screen appears:

  2. Enter the login information. Following RestfulAPI sample window appears:

  3. Click a report from the list of reports to preview it in the right pane.

Note:
  • This sample does not support parameterized reports.
  • Internet Explorer 9 and 10 browsers are not supported by this sample.

When a report is opened for preview, you can choose one of the following operations to perform on the report.

Save as

You can choose from the following available formats to save your report. When you click the Run button, the report is saved in the selected format.

  • PDF Document - The rendering is performed with the following options.
    • Application: ActiveReports Server
    • Author: ActiveReports Server
    • OptimizeStatic: False
  • Word Document - The rendering is performed with the following options.
    • Author: ActiveReports Server
    • FileFormat: OOXML
  • Image File- The rendering is performed with the following options.
    • Compression: Lzw
    • ImageType: TIFF
  • MHTML Web archives - The rendering is performed with the following options.
    • MhtOutput: True
  • Excel Workbook - The rendering is performed with the following options.
    • MultiSheet: False

Print using a printer on server

When you click the Run button with the selected Print option, the following window appears. Select the Server printing options and click Print.

Print using a printer on client

When you click the Run button with the selected Print option, the following window appears. Select the Server printing options and click Print.

For the ActiveReports Server REST API documentation, please see http://arhelp.grapecity.com/webhelp/AR12Server/WebAPI/index.html.


Migration PowerShell Module Sample

Migration PowerShell Module Sample
ActiveReports 12 Server User Guide > Samples and Walkthroughs > Samples > Migration PowerShell Module Sample
Show All
Hide All

ActiveReports Server provides a Migration PowerShell Module sample to migrate resources (reports, models, roles, or other resources) from one server to another. This sample provides a list of commands to enable users to choose the resources to migrate. You can find the Migration PowerShell Module sample at the following location.

C:\ActiveReports 12 Server\SDK\Samples\Migration PowerShell Module

To run the sample

  1. Open the Windows PowerShell console.

  2. Enter the following command:
    cd "%\Samples\Migration PowerShell Module"

  3. In the PowerShell console, execute the following commands to start using the module:

    PS C:\> Set-ExecutionPolicy Unrestricted -Scope CurrentUser
    PS C:\> Import-Module .\ArsMigration.psd1

    Note: A warning message appears on executing the above command: "The names of some imported commands from the module 'ArsMigration' include unapproved verbs that might make them less discoverable. To find the commands with unapproved verbs, run the Import-Module command again with the Verbose parameter. For a list of approved verbs, type Get-Verb." To disable the warning message, execute the following command:

    PS C:\> Import-Module .\ArsMigration.psd1 -disablenamechecking

To get a list of available commands

PS C:\> Get-Command -Module ArsMigration

Available commands

Export-ArsData

Exports the data from ActiveReports Server.

Syntax | Export-ArsData [[-Types] <String[]>] [-Path] <String> [[-Session] <PSObject>] [<CommonParameters>]
Parameters

-Types <String[]>: The types of resources to export. If not specified all supported resources are exported.

Note: To export all the roles, the roles Types parameter should be specified as '$roles'.

-Path <String>: The output file in which to store the exported archive.

-Session <PSObject>: The session object for the target server.

<CommonParameters>: This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see About CommonParameters.
Required Parameter | Path
Examples
  • Export-ArsData -Types reports,models,themes -Path data.zip
  • Export-ArsData -Path data.zip
  • Export-ArsData -Types reports,models,themes -Path data.zip -Session @{uri='http://another-ars-instance'; token='123...'}
  • Export-ArsData -Types '$roles' -Path data_roles.zip

Get-ArsList

Retrieves the list of resources of the specified type from ActiveReports Server.

Syntax | Get-ArsList [-Type] <String> [[-Session] <PSObject>] [<CommonParameters>]
Parameters

-Type <String>: The type of resources to list.

-Session <PSObject>: The session object for the target server.

<CommonParameters>: This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see About CommonParameters.
Required Parameter | Type
Examples
  • Get-ArsList -Type Report
  • Get-ArsList -Type Report -Session @{uri='http://another-ars-instance'; token='123...'}

Get-ArsResource

Retrieves the content of the specified resource.

Syntax Get-ArsResource [-Id] <String> [-Type] <String> [[-Path] <String>] [-Description] [[-Session] <PSObject>] [<CommonParameters>]
Parameters

-Id <String>: The ID of the resource.

-Type <String>: The type of resource.

-Path <String>: The path to the output file.

-Description [<SwitchParameter>]:

-Session <PSObject>: The session object for the target server.

<CommonParameters>: This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see About CommonParameters.
Required Parameter

Id

Type
Examples
  • Get-ArsResource -id 224234d34234 -Type report
  • Get-ArsResource -id 224234d34234 -Type report -Path data.rdlx
  • Get-ArsResource -id 224234d34234 -Type report -Path data.rdlx -Description:$true

Import-ArsData

Imports the previously exported data from the specified file to the target ActiveReports Server.

Syntax | Import-ArsData [-Path] <String> [[-Session] <PSObject>] [<CommonParameters>]
Parameters -Path <String>: The path to the exported archive.

-Session <PSObject>: The session object for the target server.

<CommonParameters>: This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see About CommonParameters.
Required Parameter | Path
Examples
  • Import-ArsData -Path data.zip
  • Import-ArsData -Path data.zip -Session @{uri='http://another-ars-instance'; token='123...'}

Migrate-ArsResource

Migrates a single resource from one server to another.

Syntax Migrate-ArsResource [-Type] <String> [-Id] <String> [[-From] <PSObject>] [[-To] <PSObject>] [-SkipValidation] [<CommonParameters>]
Parameters

-Type <String>: The resource type to migrate.

-Id <String>: The resource ID of the resource being migrated.

-From <PSObject>: The session object specifying the server to migrate data from.

-To <PSObject>: The session object specifying the server to migrate data to.

-SkipValidation [<SwitchParameter>]

<CommonParameters>: This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see About CommonParameters.
Required Parameter

Id

Type
Examples
  • Migrate-ARsResource -type report -id 582069eb5302
  • $prodServer=New-ArsSession -User admin -Password 2 -Uri http://another-ars-instance/ Migrate-ArsResource -Type report -Id 5809a9249497eb1298b4486b -To $prodServer
  • Migrate-ARsResource -type report -id 582069eb53020c3da8930f0a -To (new-arssession -user admin -password admin -uri http://another-ars-instance)
  • Migrate-ARsResource -type report -id 582069eb53020c3da8930f0a -from (new-arssession -user admin -password admin -uri http://another-ars-instance) -TO (new-arssession -user admin -password admin -uri http://another-ars-instance)

Migrate-ArsResources

Migrates all resources of the specified type.

Syntax | Migrate-ArsResources [[-Type] <String[]>] [[-From] <PSObject>] [[-To] <PSObject>] [<CommonParameters>]
Parameters

-Type <String[]>: The resource type to migrate.

Note: To migrate all the roles, the roles Types parameter should be specified as '$roles'.

-From <PSObject>: The session object specifying the server to migrate data from.

-To <PSObject>: The session object specifying the server to migrate data to.

<CommonParameters>: This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see About CommonParameters.
Required Parameter | Null
Examples
  • $from = New-ArsSession -User admin -Password 1 -Urihttp://localhost:8080/
    $to = New-ArsSession -User admin -Password 2 -Uri http://another-ars-instance/
    Migrate-ArsResources -Type reports,models -From $from -To $to
  • Migrate-ArsResources -Type users,'$roles' -To (New-ArsSession -User admin -Password 2 -Uri http://another-ars-instance/)
  • Migrate-ArsResources
  • Migrate-ArsResources -To (New-ArsSession -User admin -Password 2 -Uri http://another-ars-instance/)

New-ArsResource

Uploads the resource to the ActiveReports Server.

Syntax
  • New-ArsResource [-Name <String>] -Type <String> -Path <String[]> [-Overwrite] [-SkipValidation] [-Session<PSObject>] [<CommonParameters>]
  • New-ArsResource [-Name <String>] -Type <String> -Content <Array> [-Overwrite] [-SkipValidation] [-Session<PSObject>] [<CommonParameters>]
Parameters

-Name <String>: The name of the new resource.

-Type <String>: The type of the new resource.

-Path <String[]>: The path to the file to upload.

-Content <Array>: The contents of the resource as an array.

-Overwrite [<SwitchParameter>]: Specifies whether to overwrite any existing resource with the same name.

-SkipValidation [<SwitchParameter>]

-Session <PSObject>: The session object for target server.

<CommonParameters>: This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see About CommonParameters.
Required Parameter

Type

Path

Content
Examples
  • New-ArsResource -Type report -Name Invoice -Path invoice.rdlx
  • New-ArsResource -Type report -Name Invoice -Path invoice.rdlx - Overwrite:$true
  • New-ArsResource -Type report -Name Invoice -Path invoice.rdlx - Overwrite:$true -Session @{uri='http://another-ars-instance'; token='123...'}
  • New-arsresource -name mymigrationreport -type report -content "<Content>"

New-ArsSession

Creates a session using the specified user credentials and ActiveReports Server URI.

Syntax New-ArsSession [-User] <String> [-Password] <String> [[-Uri] <String>] [-Default] [<CommonParameters>]
Parameters

-User <String>: The user name for the session.

-Password <String>: The password of the specified user.

-Uri <String>: The server URI.

-Default [<SwitchParameter>]: Specifies whether to set the result as the default session for other cmdlets.

<CommonParameters>: This cmdlet supports these common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see About CommonParameters.
Required Parameter

User

Password
Examples
  • New-ArsSession -user admin -password admin
  • New-ArsSession -user admin -password admin -uri http://another-ars-instance
  • New-ArsSession -user admin -password admin -uri http://another-ars-instance/ -default:$true

To get help about a specific command

PS C:> Get-Help <Command> -Full

To install the module for a current user and enable the module autoload

Place the module files into the following directory:

$Home\Documents\WindowsPowerShell\Modules\ArsMigration

See Also

Administration

Migration from Previous Versions


Walkthroughs

Walkthroughs
ActiveReports 12 Server User Guide > Samples and Walkthroughs > Walkthroughs

Learn to use ActiveReports Server controls and API in Visual Studio.

Using the ReportList Web Control
This topic explains how to use the ReportList control on a Web Form.
Uploading a Code-Based Section Report
This topic explains how to upload a code-based section report by the UploadResource method.
Rendering a Code-Based Section Report
This topic explains how to render a code-based section report by the RenderReport method.
Downloading a Code-Based Section Report
This topic explains how to download a code-based section report by the Download method.
UserContext for Multi-Tenancy
The topic explains how to provide specific report data to the user logged onto the Server by setting the UserContext attribute in ActiveReports report.
See Also
Samples


Using the ReportList Web Control

Using the ReportList Web Control
ActiveReports 12 Server User Guide > Samples and Walkthroughs > Walkthroughs > Using the ReportList Web Control
Show All
Hide All

You can use the ReportList control to retrieve a list of available reports from ActiveReports Server. You can also use it to let your users export reports to PDF, Word, or Excel format. Here is how to retrieve reports from the server by entering credentials in the log-in screen or through the Web.config file.

To create a log-in page

Note: The following steps are not required if you are adding credentials in the Web.config file.
  1. In Visual Studio, create a new C# ASP.NET Web Site.
  2. Open the Design view of your default Web Form and from the Standard section of the Toolbox, drag the following controls and drop them onto the body section of the Web Form, setting their properties as in the table below.

    Controls for the Log In page

    Control | Text Property
    Label | User Name:
    TextBox ?
    Label | Password:
    TextBox ?
    Button | Log In
  3. Select Add New Item from the Website menu of Visual Studio.
  4. In the Add New Item dialog that appears, select Class, enter SessionStorage.vb/SessionStorage.cs in the name field and click Add.
  5. Replace the SessionStorage.vb/SessionStorage.cs code with the following code:

    Visual Basic

    Visual Basic (Paste INSIDE SessionStorage.vb)
    Copy Code
    Imports System
Imports System.Web

Namespace App_Code
    Public Class SessionStorage

        Private Const SecurityTokenKey As String = "{DEBDB016-040A-48f4-B568-897E6D410919}"

        Public Shared Property SecurityToken() As String
            Get
                Return TryCast(HttpContext.Current.Session(SecurityTokenKey), String)
            End Get
            Set(value As String)
                HttpContext.Current.Session(SecurityTokenKey) = value
            End Set
        End Property
    End Class
End Namespace

    C#

    C# (Paste INSIDE SessionStorage.cs)
    Copy Code
    using System;
using System.Web;

namespace App_Code
{
    public static class SessionStorage
    {
        private const string SecurityTokenKey = "{DEBDB016-040A-48f4-B568-897E6D410919}";

        public static string SecurityToken
        {
            get { return HttpContext.Current.Session[SecurityTokenKey] as string; }
            set { HttpContext.Current.Session[SecurityTokenKey] = value; }
        }
    }
}
  6. At the top of Default.aspx.vb/Default.aspx.cs, with the other Imports/using directives, paste the following code to use the Servicing namespace and App_Code namespace.

    Visual Basic

    Visual Basic (Paste at the top of file)
    Copy Code
    Imports ActiveReports.Server.ReportControls.Servicing
Imports App_Code

    C#

    C# (Paste at the top of file)
    Copy Code
    using ActiveReports.Server.ReportControls.Servicing;
using App_Code;

    Note: An error occurs on the following line until you add the ActiveReports.Server.ReportControls.dll reference using the steps mentioned in To add the ReportList control to a Web Form.

    using ActiveReports.Server.ReportControls.Servicing;

  7. Double-click the button to create a button click event. The *.cs file for the page appears with the cursor inside the button click event.
  8. In the button click event, paste the following code to get the security token from the user's credentials entered in the log-in screen.

    Visual Basic

    Visual Basic (Paste INSIDE the button click event)
    Copy Code
    Dim username = TextBox1.Text
Dim password = TextBox2.Text

Dim reportService = New ReportServiceProxy()
SessionStorage.SecurityToken = Nothing

Dim securityToken = reportService.Login(username, password, Nothing, False)

SessionStorage.SecurityToken = securityToken
Server.Transfer("Default2.aspx")

    C#

    C# (Paste INSIDE the button click event)
    Copy Code
    var username = TextBox1.Text;
var password = TextBox2.Text;

var reportService = new ReportServiceProxy();
SessionStorage.SecurityToken = null;

var securityToken = reportService.Login(username, password, null, false);

SessionStorage.SecurityToken = securityToken;
Server.Transfer("Default2.aspx");

    Note: An error occurs on the following line until you add the ActiveReports.Server.ReportControls.dll reference using the steps mentioned in To add the ReportList control to a Web Form.

    Dim reportService = New ReportServiceProxy()
    OR
    var reportService = new ReportServiceProxy();

  9. In the Web.config file, add the following code to enable the compatibility mode.

    To enable the ASP.NET compatibility mode

    ASP.NET code. Paste BETWEEN the <configSections> tab and </configSections>
    Copy Code
    <system.serviceModel>
        <serviceHostingEnvironment aspNetCompatibilityEnabled="true" />
    </system.serviceModel>

To create an .svc file for the WCF service

Note: These steps are required when using an ASP.NET website. You do not need to create the .svc file manually in an ASP.NET Web application, as it automatically adds a service file when you drop a ReportList control on the web form.

  1. Select Add New Item from the Website menu of Visual Studio.
  2. In the Add New Item dialog that appears, select WCF, enter ReportService.svc in the name field and click Add.
  3. Replace the ReportService.svc code with the following code:

    To create .svc file for WCF service

    ASP.NET code
    Copy Code
    <%@ ServiceHost
Service="ActiveReports.Server.ReportControls.Servicing.ReportServiceProxy"
Factory="ActiveReports.Server.ReportControls.Servicing.ReportServiceHostFactory" %>
  4. In the App_Code file, the following files are added by default. You need to delete these files as they are not required.
    • IReprotService.cs
    • ReprotService.cs

To add the ReportList control to a Web Form

  1. Add a second Web Form to your project, Default2.aspx. (Use the default Web form if you did not create a Log-in page.)
  2. Open the Design view of your Web Form and from the toolbox, drag and drop the ReportList control onto the body section of the Web Form.

    If you need to add the control to your toolbox, drop down these steps.

    1. Right-click in the General tab and select Choose items.
    2. In the Choose Toolbox Items dialog that appears, the .NET Framework Components tab is selected by default. Click the Namespace column header to sort by namespace.
    3. The ActiveReports.Server.ReportControls namespace is at or near the top of the list. Select the checkbox next to ReportList and click OK.
    4. The ReportList control appears in your Visual Studio toolbox.
  3. In the message box that appears, click Yes to automatically add the .svc file to your Web site to give the report list access to proxy services.

    Note: The .svc file is not added automatically in an ASP.NET Website. You need to manually add the ReportService.svc file using the steps in To create an .svc file for the WCF service.

  4. In the Properties window, set the ServerEndpointRootPath property to the URL that you want to use as the basis for all of the other URLs in your site, which can then be set as relative URLs. (Replace localhost:8080 with the site port where you installed ActiveReports Server)

    Note: The ReportServicePath property is not automatically set in an ASP.NET website. You need to manually set the file path of ReportService.svc.

  5. You can resize the control by changing the Width property in the Properties grid.

To display the report list on the ReportList control

You can specify the security token and ActiveReports 12 Server host using code in a Global Application Class.

  1. From the Visual Studio Website menu, select Add New Item.
  2. In the Add New Item dialog that appears, select Global Application Class and click Add.
  3. Below the Application Language tag at the top of Global.asax, import the Servicing namespace so that you can use the ReportServiceProxy with a directive like the following:

    To import the Servicing namespace

    ASP.NET code. (Paste on the line BELOW the Application Language line)
    Copy Code
    <%@ Import Namespace="ActiveReports.Server.ReportControls.Servicing" %>

    <%@ Import Namespace="App_Code" %>
    Note: You need to add directives to the Global.asax.vb or Global.asax.cs file when using an ASP.NET Web application.
    Visual Basic (Paste at the top of Global.asax.vb file)
    Copy Code
    Imports ActiveReports.Server.ReportControls.Servicing
Imports App_Code
    C# (Paste at the top of Global.asax.cs file)
    Copy Code
    using ActiveReports.Server.ReportControls.Servicing;
using App_Code;
  4. Below the Application Start event, create the ResolveRemoteEndpoint event using code like the following, but with your address and security token:

    Visual Basic

    Visual Basic (Paste in the Global.asax file AFTER the Application_Start event)
    Copy Code
    Private Shared Sub ResolveRemoteEndpoint(remoteEndpoint As RemoteEndpoint)
    remoteEndpoint.Address = "http://localhost:8080"
    remoteEndpoint.SecurityToken = SessionStorage.SecurityToken
End Sub

    C#

    C# (Paste in the Global.asax file AFTER the Application_Start event)
    Copy Code
    static void ResolveRemoteEndpoint(RemoteEndpoint remoteEndpoint)
{
    remoteEndpoint.Address = "http://localhost:8080";
    remoteEndpoint.SecurityToken = SessionStorage.SecurityToken;
}
  5. Provide a handler for the ResolveRemoteEndPoint event using code like the following in the Application Start event:

    To provide a handler for the event

    C# code. Paste INSIDE the Application_Start event.
    Copy Code
    ReportServiceProxy.ResolveRemoteEndpoint += ResolveRemoteEndpoint;

You can also specify the user name, password, and ActiveReports 12 Server host in your web application's web.config file.

Note: Use the following steps to add credentials to the Web.config file without creating a log-in page.

In the web.config file, add credentials using code like the following.

ASP.NET code. Paste in the web.config file AFTER the </configSections> tag.
Copy Code
<configSections>
    <sectionGroup name="activereports.server">
      <section name="reportServiceProxy" type="ActiveReports.Server.ReportControls.Configuration.ActiveReportsServerSection,
      ActiveReports.Server.ReportControls, Version=12.x.xxxx.0, Culture=neutral, PublicKeyToken=d557f2f30a260da2" allowDefinition="Everywhere" />
    </sectionGroup>
</configSections>

<activereports.server>
    <reportServiceProxy remoteReportServicePath="http://localhost:8080/" username="MyUserName" password="MyPassword" />
</activereports.server>
Note: Replace "Version=12.x.xxxx.0" with the version number of the installed ActiveReports 12 Server.

At run time, the ReportList control retrieves all of the reports from ActiveReports 12 Server, and provides buttons to export each to PDF, Word, and Excel.

See Also
Use the Designer Web Control


Uploading a Code-Based Section Report

Uploading a Code-Based Section Report
ActiveReports 12 Server User Guide > Samples and Walkthroughs > Walkthroughs > Uploading a Code-Based Section Report

You can upload all types of developer-created ActiveReports to the server using the UploadResource method. This topic explains how to upload a code-based section report.

  1. From the Visual Studio File menu, select New Project.
  2. In the New Project dialog that appears, select Visual C# or Visual Basic from the template list, click Windows and select Console Application.
  3. Rename the project to UploadReport and click OK.
    Note: The target framework of the project must be set to .NET Framework 4.5 or above.
  4. From the Visual Studio Project menu, select Add Service Reference.
  5. In the Add Service Reference dialog that appears, enter the following address in the Address field.
    Paste in the Address box, replacing 8080 with the site port where you installed ActiveReports 12 Server.
    Copy Code
    http://localhost:8080/ReportService.svc
  6. Click Go, and when the ReportService appears in the Services pane, you can expand it and select the service interface to reveal its available operations in the pane to the right.
  7. Rename the Namespace that you want to use to ReportService and click OK. The reference appears in the Solution Explorer.
  8. Open the app.config file and in the address attribute of the endpoint element, check whether the service address set in step 5 is correct. Replace the address if it is not correct.
    Confirm the value of address attribute in the endpoint element of the app.config file
    Copy Code
    <client>
        <endpoint address="http://localhost:8080/ReportService.svc"
            binding="wsHttpBinding" bindingConfiguration="WSHttpBinding_IReportService"
            contract="ReportService.IReportService" name="WSHttpBinding_IReportService" />
    </client>
    Note: The service address may not get updated automatically by the server configuration of the installed ActiveReports Server.
  9. In Program.cs or Module1.vb, add the following statements to the using/Imports statements at the top of the code.

    Visual Basic

    Visual Basic code (Add to the list of Imports statements at the top of the code.)
    Copy Code
    Imports System.IO
Imports UploadReport.ReportService

    C#

    C# code(Add to the list of using statements at the top of the code.)
    Copy Code
    using System.IO;
using UploadReport.ReportService;
  10. In Program.cs or Module1.vb, add the following code into the Main method.

    Visual Basic

    Visual Basic code (Paste the following code into the Main method of the Module1 module declaration)
    Copy Code
    Dim filepath As String = "C:\section_report.rpx"
Dim serverUserName = "USER"
Dim serverUserPwd = "PASS"
Dim uploadOptions = New UploadOptions() With { _
    .Overwrite = True _
}
Dim reportService = New ReportServiceClient("WSHttpBinding_IReportService")
Dim securityToken = reportService.Login(serverUserName, serverUserPwd, Nothing, True)

' Name: Report name to display after the upload.
' ReportType: Type of the report to upload.
' ClassName: Class name. Specify while uploading code-based section report.
' AssemblyResourceId: Assembly Resource ID. Specify while uploading code-based section report.
Dim reportDescription As New ReportDescription()
With reportDescription
    .Name = "Test Report"
    .ReportType = ReportType.SectionReport
    .ClassName = Nothing
    .AssemblyResourceId = Nothing
End With
reportService.UploadResource(securityToken, ReportDescription, Convert.ToBase64String(File.ReadAllBytes(filepath)), UploadOptions)

    C#

    C# code (Paste the following code into the Main method of the Program class declaration)
    Copy Code
    string filepath = @"C:\section_report.rpx";
var serverUserName = "USER";
var serverUserPwd = "PASS";
var uploadOptions = new UploadOptions { Overwrite = true };
var reportService = new ReportServiceClient("WSHttpBinding_IReportService");
var securityToken = reportService.Login(serverUserName, serverUserPwd, null, true);

// Name: Report name to display after the upload.
// ReportType: Type of the report to upload.
// ClassName: Class name. Specify while uploading code-based section report.
// AssemblyResourceId: Assembly Resource ID. Specify while uploading code-based section report.
var reportDescription = new ReportDescription()
{
    Name = "Test Report",
    ReportType = ReportType.SectionReport,
    ClassName = null,
    AssemblyResourceId = null
};
reportService.UploadResource(securityToken, reportDescription, Convert.ToBase64String(File.ReadAllBytes(filepath)), uploadOptions);
  11. Run the project.
See Also
Rendering a Code-Based Section Report
Downloading a Code-Based Section Report


UserContext in Multi-Tenant Reports

UserContext in Multi-Tenant Reports
ActiveReports 12 Server User Guide > Samples and Walkthroughs > Walkthroughs > UserContext in Multi-Tenant Reports
Show All
Hide All

The topic demonstrates different ways how to provide specific report data to a current user by setting the UserContext attribute in a report.

In the developer version of ActiveReports, you can set the UserContext attribute in Page, RDL, and Section report, then upload the report to ActiveReports Server. On the Server, the UserContext attribute filters report data to display only data specific to the current user. The UserContext attribute is particularly helpful when you have multiple tenants, logging into the same portal and you want to restrict the data available to each tenant.

Note: The topic uses the Chinook database as a custom security provider. For information about the Chinook database, see https://github.com/lerocha/chinook-database.

To set the UserContext attribute as a parameter in a static query

To create a report for multiple tenants using the Chinook database

  1. In the ActiveReports Designer, under File, click New.
  2. In the Create New Report wizard, select Page Report and click OK.
  3. To connect to a data source, in the Report Explorer, right-click the Data Sources node and select the Add Data Source option.

  4. In the Report Data Source dialog, create a connection to the Chinook database. For information, see Connect to a Data Source.
  5. To add a dataset, in the Report Explorer, right-click the Data Sources node and select the Add Data Set option.
    • In the DataSet dialog, on the General page, enter Invoice as the name of the dataset.
    • On the Query page of this dialog, in the Query field enter the following SQL query.
      SQL Query
      Copy Code
      Select * from Invoice where CustomerID=@Invoice
    • On the Parameters page of this dialog, click the Add button.
    • In the Name field, enter Invoice and set its value to =[@Customer].
    • Click OK to close the dialog.
  6. From the Toolbox, drag the Table control onto the Design surface.

  7. Select the Table control and in the Properties window, set the DataSetName property to Invoice.

  8. In the Table's detail row, click the adorner in each cell to show a list of available fields from the data set and add the following fields to the cells.

    Cell | Field
    Left Cell | InvoiceID
    Middle Cell | InvoiceDate
    Right Cell | Total

To set the UserContext attribute

The UserContext attribute is set in the report parameter that will retrieve specific information for the user that is logged into the server. See Add Parameters for detailed information about parameters in a page report.

  1. In the Report Explorer, right-click the Parameters node and select Add Parameter. The Report Parameters dialog appears.
  2. On the General tab, set the Name to Customer, set the Data type to Integer and select the Hidden box.
  3. On the Available Values tab, select Non-queried and in the Value field, enter = Code.UserContext.GetValue("CustomerID").
  4. Click OK.

To format the table (optional)

There are many ways you can format the table that you have added to the report in ActiveReports Designer. See Table in the ActiveReports User Guide for more information on the formatting possibilities.

  1. Select the Table control and go to the Properties window to set the following properties.
    FixedSize | 6.5in, 7in
    Location | 0in, 0.5in
    RepeatHeaderOnNewPage | True
    Size | 6.4in, 0.7in
  2. Select the Table's detail row and in the Properties window set the TextAlign property to Left and the BorderStyle property to Solid.

  3. Select the middle cell (InvoiceDate) of the details row and in the Properties window set the Format property to d.
  4. Select the right cell of the Table Footer and go to the Properties window to set the following properties.
    Format | c
    Value | =Sum(Fields!Total.Value)

To upload the report to ActiveReports Server

  1. Connect to ActiveReports Server as described in Connecting to ActiveReports Server.
  2. Select the directory in the folders tree to choose the location in which to save the report on the server.
  3. Enter the report name in the Report name field as Invoices and click Save.

To set up the custom security provider

This topic uses the sample custom security provider project installed with ActiveReports Server. By default, this sample is in the following folder.

C:\ActiveReports 12 Server\SDK\ActiveTunes.SecurityProvider

For detailed steps on how to set up the custom security provider, see Deploy the Custom Security Provider for Debugging.

To set permissions for the report on ActiveReports Server

On ActiveReports Server, the report permissions have to be modified so that its multiple users can read it.

See To Manage Permissions to a Report on how to grant the Read permissions on the report.

To preview the report on ActiveReports Server

  1. Open the ActiveReports 12 Server Report Portal.
  2. On the Login screen that appears, in the User Name field, enter a customer ID, for example, luisg@embraer.com.br.
  3. In the Password field, enter 1 (for the luisg@embraer.com.br customer ID).
  4. Click Login.
  5. In the ActiveReports Server Report Portal that appears, click the Preview report button for the Invoices report to see all invoices for the logged-in user.

To set the UserContext attribute in a dynamic query

To add a user to the Administrator role

You must add a user from the ActiveTunes security provider to the Administrator role to enable this user modify the report's Server Shared Data Source dialog and filter the report's data with the UserContext attribute.

This topic uses the sample custom security provider project installed with ActiveReports Server. By default, this sample is in the following folder.

C:\ActiveReports 12 Server\SDK\Samples\ActiveTunes.SecurityProvider

  1. In Visual Studio, open the ActiveTunes.SecurityProvider project.
  2. In the Constants.cs file, change the following string
    public readonly string Employees = "ActiveTunes.Employee";
    to
    public readonly string Employees = "Administrator";
  3. From the Build menu, select Build Solution.
  4. From your project bin\Debug\ folder, copy the ActiveTunes.SecurityProvider.dll file and paste it into C:\ActiveReports 12 Server\SecurityProviders\ to make the security provider and debugging file available to ActiveReports 12 Server.

To set up the custom security provider

This topic uses the sample custom security provider project installed with ActiveReports Server. By default, this sample is in the following folder.

C:\ActiveReports 12 Server\SDK\Samples\ActiveTunes.SecurityProvider

For detailed steps on how to set up the custom security provider, see Deploy the Custom Security Provider for Debugging.

To create a report for multiple tenants using the Chinook database

  1. In the ActiveReports Designer, under File, click New.
  2. In the Create New Report wizard, select Page Report and click OK.
  3. To connect to a data source, in the Server menu, select Edit Shared Data Sources. You will be asked to connect to ActiveReports Server.
  4. Enter the user credentials from the ActiveTunes security provider to connect. In the User name field, enter steve@chinookcorp.com and in the Password field enter 5.
  5. Сlick Connect and then, in the Edit Shared Data Sources dialog, click Add.
  6. In the Report Data Source dialog, create a connection to the Chinook database. For information, see Connect to a Data Source.
  7. To add a dataset, in the Server menu, select Edit Shared Data Sets and click Add.
    1. In the DataSet dialog, on the General page, enter Invoice as the name of the dataset.
    2. On the Query page of this dialog, in the Query field enter the following SQL query.
      Note: You can use the Visual Query Designer to build your dynamic query. See Visual Query Designer in the ActiveReports 12 documentation for details.
      SQL Query
      Copy Code
      ="select * from Invoice where CustomerID = " + Code.UserContext.GetValue("CustomerID")
  8. Click the Validate button to validate the query.
  9. Click Save to add the shared data set to the server.
  10. In the Report Explorer, right-click Server Data Sets and select Add Data Set.
  11. In the Add Server Data Set dialog, select Invoice and click OK.
  12. From the Toolbox, drag the Table control onto the Design surface.

  13. Select the Table control and in the Properties window, set the DataSetName property to Invoice.

  14. In the Table's detail row, click the adorner in each cell to show a list of available fields from the data set and add the following fields to the cells.

    Cell | Field
    Left Cell | InvoiceID
    Middle Cell | InvoiceDate
    Right Cell | Total

To format the table (optional)

There are many ways you can format the table that you have added to the report in ActiveReports Designer. See Table in the ActiveReports User Guide for more information on the formatting possibilities.

  1. Select the Table control and go to the Properties window to set the following properties.
    FixedSize | 6.5in, 7in
    Location | 0in, 0.5in
    RepeatHeaderOnNewPage | True
    Size | 6.4in, 0.7in
  2. Select the Table's detail row and in the Properties window set the TextAlign property to Left and the BorderStyle property to Solid.

  3. Select the middle cell (InvoiceDate) of the details row and in the Properties window set the Format property to d.
  4. Select the right cell of the Table Footer and go to the Properties window to set the following properties.
    Format | c
    Value | =Sum(Fields!Total.Value)

To upload the report to ActiveReports Server

  1. Connect to ActiveReports Server as described in Connecting to ActiveReports Server .
  2. Select the directory in the folders tree to choose the location in which to save the report on the server.
  3. Enter the report name in the Report name field as Invoices and click Save.

To preview the report on ActiveReports Server

  1. Open the ActiveReports 12 Server Report Portal.
  2. On the Login screen that appears, in the User Name field, enter a customer ID, for example, luisg@embraer.com.br.
  3. In the Password field, enter 5 (for the steve@chinookcorp.com customer ID).
  4. Click Login.
  5. In the ActiveReports Server Report Portal that appears, click the Preview report button for the Invoices report to see all invoices for the logged-in user.

See Also
Custom Security Provider Sample
Create a Custom Security Provider
Managing Permissions
Debug a Custom Security Provider


Rendering a Code-Based Section Report

Rendering a Code-Based Section Report
ActiveReports 12 Server User Guide > Samples and Walkthroughs > Walkthroughs > Rendering a Code-Based Section Report

You can render reports hosted on ActiveReports Server to PDF or Excel format using the RenderReport method. This topic explains how to render an XML-based section report to PDF format.

Note: You can also render a code-based section report or a page report to PDF format using the same steps.
  1. From the Visual Studio File menu, select New Project.
  2. In the New Project dialog that appears, select Visual C# or Visual Basic from the template list, click Windows and select Console Application.
  3. Rename the project to RenderReport and сlick OK.
    Note: The target framework of the project must be set to .NET Framework 4.5 or above.
  4. From the Visual Studio Project menu, select Add Service Reference.
  5. In the Add Service Reference dialog that appears, enter the following address in the Address field.
    Paste in the Address box, replacing 8080 with the site port where you installed ActiveReports 12 Server.
    Copy Code
    http://localhost:8080/ReportService.svc
  6. Click Go, and when the ReportService appears in the Services pane, you can expand it and select the service interface to reveal its available operations in the pane to the right.
  7. Rename the Namespace that you want to use to ReportService and click OK. The reference appears in the Solution Explorer.
  8. Open the app.config file and in the address attribute of the endpoint element, check whether the service address set in step 5 is correct. Replace the address if it is not correct.
    Confirm the value of the address attribute in the endpoint element of the app.config file
    Copy Code
    <client>
        <endpoint address="http://localhost:8080/ReportService.svc"
            binding="wsHttpBinding" bindingConfiguration="WSHttpBinding_IReportService"
            contract="ReportService.IReportService" name="WSHttpBinding_IReportService" />
    </client>
    Note: The service address may not get updated automatically by the server configuration of the installed ActiveReports Server.
  9. In Program.cs or Module1.vb, add the following statements to the using/Imports statements at the top of the code.

    Visual Basic

    Visual Basic code (Add to the list of Imports statements at the top of the code.)
    Copy Code
    Imports System.IO
Imports System.Net
Imports RenderReport.ReportService

    C#

    C# code(Add to the list of using statements at the top of the code.)
    Copy Code
    using System.IO;
using System.Net;
using RenderReport.ReportService;
  10. In Program.cs or Module1.vb, add the following code into the Main method.

    Visual Basic

    Visual Basic code (Paste the following code into the Main method of the Module1 module declaration)
    Copy Code
    Dim serverUserName = "USER"
    Dim serverUserPwd = "PASS"
    Dim reportService = New ReportServiceClient("WSHttpBinding_IReportService")
    Dim securityToken = reportService.Login(serverUserName, serverUserPwd, Nothing, True)
    ' Get the report list from internal storage.
    Dim description = reportService.[Select](securityToken, New Query())

    ' Get the report description of output target.
    Dim TargetRepDescription As New ReportDescription()
    For Each des As ReportDescription In description
        If des.Name = "Payment Slip" Then
            TargetRepDescription = des
            Exit For
        End If
    Next

    ' Output into PDF
    Dim result = reportService.RenderReport(securityToken, TargetRepDescription, New RenderOptions() With {.Extension = "PDF"})
    Dim info As RequestInfo
    Do
        info = reportService.GetRequestStatus(securityToken, Result.Info.RequestId).Info
    Loop While info.State = RequestState.Pending OrElse info.State = RequestState.Running

    If info.State = RequestState.Accomplished Then
        Using client = New WebClient()
            client.DownloadFile(http://localhost:8080/cache/ + info.PrimaryUrl, "C:\work\test.pdf")
        End Using
    End If

    C#

    C# code (Paste the following code into the Main method of the Program class declaration)
    Copy Code
    var serverUserName = "USER";
    var serverUserPwd = "PASS";
    var reportService = new ReportServiceClient("WSHttpBinding_IReportService");
    var securityToken = reportService.Login(serverUserName, serverUserPwd, null, true);
    // Get the report list from internal storage.
    var description = reportService.Select(securityToken, new Query());

    // Get the report description of output target.
    ReportDescription TargetRepDescription = new ReportDescription();
    foreach (var des in description)
    {
        if (des.Name == "Payment Slip")
        {
            TargetRepDescription = des;
            break;
        }
    }

    // Output into PDF
    var result = reportService.RenderReport(securityToken, TargetRepDescription, new RenderOptions { Extension = "PDF" });
    RequestInfo info;
    do
    {
        info = reportService.GetRequestStatus(securityToken, result.Info.RequestId).Info;
    } while (info.State == RequestState.Pending || info.State == RequestState.Running);

    if (info.State == RequestState.Accomplished)
    {
        using (var client = new WebClient())
        {
            client.DownloadFile("http://localhost:8080/cache/" + info.PrimaryUrl, @"C:\work\test.pdf");
        }
    }
  11. Run the project.
See Also
Uploading a Code-Based Section Report
Downloading a Code-Based Section Report


Downloading a Code-Based Section Report

Downloading a Code-Based Section Report
ActiveReports 12 Server User Guide > Samples and Walkthroughs > Walkthroughs > Downloading a Code-Based Section Report

You can download the reports uploaded in the ActiveReports Server using the Download method and can save it into report definition format. This topic explains how to download an XML-based section report to PDF format.

Note: You can also download a page report or an RDL report using the same steps.
  1. From the Visual Studio File menu, select New Project.
  2. In the New Project dialog that appears, select Visual C# or Visual Basic from the template list, click Windows and select Console Application.
  3. Rename the project to RenderReport and сlick OK.
    Note: The target framework of the project must be set to .NET Framework 4.5 or above.
  4. From the Visual Studio Project menu, select Add Service Reference.
  5. In the Add Service Reference dialog that appears, enter the following address in the Address field.
    Paste in the Address box, replacing 8080 with the site port where you installed ActiveReports Server.
    Copy Code
    http://localhost:8080/ReportService.svc
  6. Click Go, and when the ReportService appears in the Services pane, you can expand it and select the service interface to reveal its available operations in the pane to the right.
  7. Rename the Namespace that you want to use to ReportService and click OK. The reference appears in the Solution Explorer.
  8. Open the app.config file and in the address attribute of the endpoint element, check whether the service address set in step 5 is correct. Replace the address if it is not correct.
    Confirm the value of the address attribute in the endpoint element of the app.config file
    Copy Code
    <client>
        <endpoint address="http://localhost:8080/ReportService.svc"
            binding="wsHttpBinding" bindingConfiguration="WSHttpBinding_IReportService"
            contract="ReportService.IReportService" name="WSHttpBinding_IReportService" />
    </client>
    Note: The service address may not get updated automatically to the server configuration of the installed ActiveReports Server.
  9. In the app.config file, add a maxReceivedMessageSize attribute inside the binding element and set an appropriate value. If you want to send or receive large amount of data in a WCF service, you need to customize this value. In the following example, the value is set to 10 MB.
    Add INSIDE the binding element of the app.config file
    Copy Code
    <bindings>
    <wsHttpBinding>
        <binding name="WSHttpBinding_IReportService" maxReceivedMessageSize="10000000">
            <security mode="None" />
                </binding>
        </wsHttpBinding>
</bindings>
  10. In Program.cs or Module1.vb, add the following statements to the using/Imports statements at the top of the code.

    Visual Basic

    Visual Basic code (Add to the list of Imports statements at the top of the code.)
    Copy Code
    Imports System.IO
    Imports DownloadReport.ReportService

    C#

    C# code(Add to the list of using statements at the top of the code.)
    Copy Code
    using System.IO;
    using DownloadReport.ReportService;
  11. In Program.cs or Module1.vb, add the following code into the Main method.

    Visual Basic

    Visual Basic code (Paste the following code into the Main method of the Module1 module declaration)
    Copy Code
    Dim serverUserName As String = "USER"
    Dim serverUserPwd As String = "PASS"
    Dim reportService As New ReportServiceClient("WSHttpBinding_IReportService")
    ' Get the security token using Login method
    Dim securityToken As String = reportService.Login(serverUserName, serverUserPwd, Nothing, True)
    ' Get the list information of the uploaded form
    Dim query As New ReportService.Query()
    Dim description As ReportDescription() = reportService.[Select](securityToken, query)

    ' Get the report description of the output target
    Dim TargetRepDescription As New ReportDescription

    For Each des As ReportDescription In description
        If des.Name = "Payment Slip" Then
            TargetRepDescription = des
            Exit For
        End If
    Next

    ' Get the encoded form data
    Dim result As DataResult = reportService.Download(securityToken, TargetRepDescription.Id)
    ' Return to byte array
    Dim s As String = result.Data
    Dim bs As Byte() = System.Convert.FromBase64String(s)

    ' Specify the target folder
Dim outFileName As String = "C:\work\PaymentSlip.rpx"
Dim outFile As New System.IO.FileStream(outFileName, System.IO.FileMode.Create, System.IO.FileAccess.Write)
    outFile.Write(bs, 0, bs.Length)
    outFile.Close()

    C#

    C# code (Paste the following code into the Main method of the Program class declaration)
    Copy Code
    var serverUserName = "USER";
    var serverUserPwd = "PASS";
    var reportService = new ReportServiceClient("WSHttpBinding_IReportService");
    var securityToken = reportService.Login(serverUserName, serverUserPwd, null, true);
    // Get the report list from internal storage
    var description = reportService.Select(securityToken, new Query());

    // Get the report description of the output target
    ReportDescription TargetRepDescription = new ReportDescription();
    foreach (var des in description)
    {
        if (des.Name == "Payment Slip")
        {
            TargetRepDescription = des;
            break;
        }
    }

    // Get the encoded form data
    var result = reportService.Download(securityToken, TargetRepDescription.Id);
    // Return to byte array
    string s = result.Data;
    byte[] bs = System.Convert.FromBase64String(s);

    // Specify the target folder
    string outFileName = @"C:\work\PaymentSlip.rpx";

    System.IO.FileStream outFile = new System.IO.FileStream(outFileName,
    System.IO.FileMode.Create, System.IO.FileAccess.Write);
    outFile.Write(bs, 0, bs.Length);
    outFile.Close();
  12. Run the project.
See Also
Uploading a Code-Based Section Report
Rendering a Code-Based Section Report


Troubleshooting

Troubleshooting
ActiveReports 12 Server User Guide > Troubleshooting
Show All
Hide All

Here you can find solutions to issues that you may encounter while working with ActiveReports Server. Click a description below to view the symptoms, cause, and solution.

When trying to open the Report Portal page, you get the Server Error "Could not connect to endpoint DesignerService.svc on the server."

Symptoms: The Report Portal page will not open. Instead, you get a Server Error that reads: "Could not connect to endpoint DesignerService.svc on the server. Please verify connectivity to the server and check the server configuration. HTTP request error"

Causes: The IIS Management Console is turned off by default, or WCF is not configured on your machine.

Solution 1: Turn on the IIS Management Console.

  1. Open Control Panel and select Programs and Features.
  2. On the left, select Turn Windows features on or off.
  3. In the Windows Features window that appears, expand the Internet Information Services node, then the Web Management Tools node.
  4. Ensure that the check box next to the IIS Management Console is selected and click OK.

Solution 2: Configure WCF on your machine.

  1. From the Start menu, open a command prompt (cmd.exe).
  2. In the command window, enter cd %SystemRoot%\Microsoft.Net\Framework\v3.0\Windows Communication Foundation\ to change to the directory where the ServiceModel Registration Tool is installed.
  3. For Framework 4 or 4.5, enter the command: ServiceModelReg.exe -ia to run the tool to install all WCF and WF components. (For Framework 3 or 3.5, the command is: ServiceModelReg.exe -ir.)

Solution 3: Add features to WCF Services on the server.

  1. From the Start menu, select Server Manager.
  2. On the Manage menu, select Add Roles and Features.
  3. In the Add Roles and Features window, select the Features tab.
  4. Under Features, expand the .NET Framework 4.5 (Installed) node, then the WCF Services (Installed) node.
  5. Under WCF Services (Installed), select the following three features:
    • HTTP Activation
    • Named Pipe Activation
    • TCP Activation
  6. Click the Install button.

When trying to open the Administrator Dashboard or Report Portal page, you get HTTP Error 503 Service Unavailable.

Symptoms: The Administrator Dashboard and Report Portal pages will not open. Instead, you get HTTP Error 503.

Cause: The application pool for the service is stopped.

Solution: Restart the application pool.

  1. Open IIS and expand your localhost node.
  2. Select Application Pools.
  3. In the Application Pools page that appears, find ASP.NET v4.0 AR_AppPool and check its Status.
  4. If the Status is Stopped, right-click ASP.NET v4.0 AR_AppPool and select Start.

When trying to reinstall, you get the error: "Service 'ActiveReports Server' failed to start. Verify that you have sufficient privileges to start system services."

Symptoms: The service will not start when you try to reinstall. Instead, you get "Service 'ActiveReports 12 Server' failed to start."

Cause: The previous version did not uninstall completely.

Solution: Uninstall the remnants of the previous version before reinstalling.

  1. In Windows Explorer, delete the directory C:\ActiveReports 12 Server.
  2. Open IIS, expand the localhost, then the Sites node, and delete the ActiveReports 12 Server site.
  3. Right-click the installer and select Run as administrator and follow the installation instructions.

The reports list is not displayed on the sample web page

Symptoms: The report list is not displayed on the sample web page.

Cause: When deploying samples, two access options in the Internet Information Services (IIS) settings are selected: "Enable anonymous access" and "Integrated Windows authentication."

Solution: Change the IIS settings to use only a single authentication scheme, "Enable anonymous access."

  1. In the Control Panel, open Administrative Tools, then Internet Information Services Manager.
  2. In the Internet Information Services window that appears, expand the tree view in the left pane until you see the Web sites/sample node.
  3. Right-click Web Sites/sample to open the Web Sites Properties dialog.
  4. On the Directory Security tab, in the Authentication and access control section, click Edit.

  5. In the Authentication Methods dialog that appears, ensure that only one authentication scheme is selected in the corresponding checkbox.

  6. Click OK to apply the changes, and OK again to close the dialog.
  7. Back in Visual Studio, run the sample again.

When trying to install a remote agent on Azure, the error "Service 'ActiveReports 12 Agent' (ActiveReports.Agent) failed to start" is displayed

Symptoms: The service does not start when you try to install the agent. Instead, you get the "Service 'ActiveReports 12 Agent' failed to start" error.

Cause: You are using an IP address to connect a remote agent to a controller.

Solution: You must enter a server name "(server-name):4040" into the server list box.

  1. Locate the agent installer ActiveReport 12 Server Agent in C:\ActiveReports 12 Server\Site\Admin.
  2. Run the installer on Azure VM and follow the installation instructions.
  3. On the Report Runner Agent Installation page, enter the server URL as "<server-name>:4040".
  4. Complete the installation.

How to preview ActiveReports reports with custom tile provider

Symptoms: An ActiveReports report with a custom tile provider does not open in ActiveReports Server.

Cause: The ActiveReports Server does not consider a custom tile provider as a full trust assembly.

Solution: You must configure a custom tile provider to have full trust permission.

  1. Create or use an existing custom tile provider, for example, MyCustomProvider.
  2. Run Visual Studio and open the MyCustomProvider project.
  3. Go to Project > MyCustomProvider Properties.
  4. Go to Signing and sign the assembly with the public key.
  5. Rebuild the project.
  6. Copy the MyCustomProvider.dll from the project folder to the ActiveReports Server Agent folder located at C:\ActiveReports 12 Server\Agent.
  7. Add the custom tile provider to GrapeCity.ActiveReports.configuration file located at C:\Program Files (x86)\Common Files\GrapeCity\ActiveReports 12 and copy it to C:\ActiveReports 12 Server\Agent.
  8. Open the Visual Studio command prompt and navigate to C:\ActiveReports 12 Server\Agent.
  9. Type sn -Tp MyCustomProvider.dll.
  10. Copy the code you get.
  11. Open the ActiveReports.Server.Agent.exe configuration file.
  12. In the configuration file, add the following code to the <appSettings> section. Replace X with the code you get in the step 10.
    Add this code to the <appSettings> section
    Copy Code
    <add key="RunnerService.FullTrustAssemblies" value="MyCustomProvider, 1.0.0.0, X"/>
  13. Save and close the ActiveReports.Server.Agent.exe configuration file.
  14. Restart the ActiveReports agent.
See Also

Support

Support Options


Support Options

Support Options
ActiveReports 12 Server User Guide > Troubleshooting > Support Options

We provide a number of technical support options to help you succeed with our products.

Free Community Support

Our community web site is available free of charge. Community members and ActiveReports Server team members provide answers to your most common questions.

In addition, we offer the following support options:

Annual Maintenance Package

Customers who purchase annual maintenance can benefit from the full suite of technical support services for one year. These benefits include:

  1. All major releases.
  2. All service releases and minor upgrades.
  3. Email support

    For e-mail support, please submit your request on this page of the ActiveReports Server web site.
    Please include the build number, the environment you are using, and a detailed description of the problem.
    This will help speed up the support process.

  4. Phone support

    Support telephone number: (425) 952-6362
    Support hours: Monday through Friday, 9:00 am-5:00 pm US Pacific Standard Time (PST)
    When contacting support, please be prepared to provide your serial number, a complete description of the problem, as well as hardware and operating environment specifications.

See Also

Administration

Troubleshooting


Class Library

Class Library
ActiveReports 12 Server User Guide > Class Library

The Class Library contains documentation and code samples of the ActiveReports Server API.

In This API Documentation

ActiveReports.Server.ReportControls
View the API documentation on the report list and designer controls.
ActiveReports.Server.ReportControls.Servicing
View the API documentation on the service proxies.
ActiveReports.Server.ReportServices.Contracts
View the API documentation on the report service contracts.
ActiveReports.Server.ReportServices.Contracts.Descriptions
View the API documentation on report service descriptions.
ActiveReports.Server.ReportServices.Contracts.Errors
View the API documentation on report service errors.
ActiveReports.Server.ReportServices.Contracts.Feedback
View the API documentation on the service feedback.
ActiveReports.Server.ReportServices.Contracts.Policy
View the API documentation on report service policy.
ActiveReports.Server.ReportServices.Servicing
View the API documentation on servicing.
ActiveReports.Server.Scheduling
View the API documentation on report service scheduling.
ActiveReports.Server.Security
View the API documentation on the security interfaces.
See Also
Samples and Walkthroughs
Web Service Library


ActiveReports.Server.ReportControls Namespace

ActiveReports.Server.ReportControls Namespace
Inheritance Hierarchy
ActiveReports.Server.ReportControls Assembly : ActiveReports.Server.ReportControls Namespace
Classes
 | Class | Description
Class | Designer | Wraps the Flash designer control into ASP.NET control.
Class | LocalizedDescriptionAttribute | Description attribute with localization support
Class | ReportList | Represents a list of report available on the server.
Enumerations
 | Enumeration | Description
Enumeration | DesignerElements | Defines designer control elements.
Enumeration | ReportAction | Specifies the action designer should undertake on load.
Enumeration | ReportList.Theme | Specifies one of the built in report list themes.
Enumeration | WindowMode | Possible values of WindowMode property of the SWF file for transparency, layering, positioning, and rendering in the browser. The default value is "window".
See Also

Reference

ActiveReports.Server.ReportControls Assembly


Designer Class

Designer Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace : Designer Class
Wraps the Flash designer control into ASP.NET control.
Object Model
Designer Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Designer
   Inherits System.Web.UI.Control
public sealed class Designer : System.Web.UI.Control
Inheritance Hierarchy

System.Object
System.Web.UI.Control
ActiveReports.Server.ReportControls.Designer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Members
ActiveReports.Server.ReportControls Namespace

Product Support Forum | Print this page


Designer Class Members

Designer Class Members
Properties Methods Events

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace : Designer Class

The following tables list the members exposed by Designer.

Public Constructors
 | Name | Description
Public Constructor | Designer Constructor |
Top
Public Properties
 | Name | Description
Public Property | AdminPath | Gets or sets the URL of the administrator site.
Public Property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the System.Web.UI.Page or System.Web.UI.UserControl object that contains this control. (Inherited from System.Web.UI.Control)
Public Property | ClientID | Gets the control ID for HTML markup that is generated by ASP.NET. (Inherited from System.Web.UI.Control)
Public Property | ClientIDMode | Gets or sets the algorithm that is used to generate the value of the System.Web.UI.Control.ClientID property. (Inherited from System.Web.UI.Control)
Public Property | Controls | Gets a System.Web.UI.ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from System.Web.UI.Control)
Public Property | DesignerHelpPath | Gets or sets the URL of the diagnostic page.
Public Property | DesignerServicePath | Gets or sets the URL of the designer service for designer to communicate with.
Public Property | DiagnosticPagePath | Gets or sets the URL of the diagnostic page.
Public Property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from System.Web.UI.Control)
Public Property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from System.Web.UI.Control)
Public Property | FlashNotInstalledTemplate | Gets or sets the template to show an alternative content when a proper flash player version is required.
Public Property | Height | Gets or sets the height of the Web server control.
Public Property | HiddenElements | Gets or sets the enumeration of UI elements which should be hidden.
Public Property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from System.Web.UI.Control)
Public Property | ModelName | Gets or sets the model name/id for report portal to undertake a specific action on.
Public Property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same System.Web.UI.Control.ID property value. (Inherited from System.Web.UI.Control)
Public Property | Page | Gets a reference to the System.Web.UI.Page instance that contains the server control. (Inherited from System.Web.UI.Control)
Public Property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from System.Web.UI.Control)
Public Property | RenderingCompatibility | Gets a value that specifies the ASP.NET version that rendered HTML will be compatible with. (Inherited from System.Web.UI.Control)
Public Property | ReportAction | Gets or sets the report action for report portal to undertake on a specific report.
Public Property | ReportId | Gets or sets the report id for report portal to undertake a specific action on.
Public Property | ReportName | Gets or sets the name of the report for report portal to undertake a specific action on.
Public Property | RequestStatusCheckInterval | Gets or sets the time interval in seconds to check status of render request.
Public Property | ResourcePath | Gets or sets the URL of the designer help.
Public Property | SecurityToken | Gets or sets security token.
Public Property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from System.Web.UI.Control)
Public Property | SiteRootPath | Gets or sets the URL of the ARS site root to redirect to.
Public Property | SkinID | Gets or sets the skin to apply to the control. (Inherited from System.Web.UI.Control)
Public Property | SnapshotId | Gets or sets the snapshot id for report rendering.
Public Property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | Gets the virtual directory of the System.Web.UI.Page or System.Web.UI.UserControl that contains the current server control. (Inherited from System.Web.UI.Control)
Public Property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from System.Web.UI.Control)
Public Property | ValidateRequestMode | Gets or sets a value that indicates whether the control checks client input from the browser for potentially dangerous values. (Inherited from System.Web.UI.Control)
Public Property | ViewStateMode | Gets or sets the view-state mode of this control. (Inherited from System.Web.UI.Control)
Public Property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from System.Web.UI.Control)
Public Property | Width | Gets or sets the width of the Web server control.
Public Property | WindowMode | Gets or sets possible values for transparency, layering, and positioning in the browser.
Top
Protected Properties
 | Name | Description
Protected Property | Adapter | Gets the browser-specific adapter for the control. (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | Gets a character value representing the separator character used in the System.Web.UI.Control.ClientID property. (Inherited from System.Web.UI.Control)
Protected Property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from System.Web.UI.Control)
Protected Property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from System.Web.UI.Control)
Protected Property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from System.Web.UI.Control)
Protected Property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by System.Web.UI.Control.ID instead of index. (Inherited from System.Web.UI.Control)
Protected Property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | Gets a value that indicates whether the System.Web.UI.StateBag object is case-insensitive. (Inherited from System.Web.UI.Control)
Top
Public Methods
 | Name | Description
Public Method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from System.Web.UI.Control)
Public Method | DataBind | Overloaded. Binds a data source to the invoked server control and all its child controls. (Inherited from System.Web.UI.Control)
Public Method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from System.Web.UI.Control)
Public Method | FindControl | Overloaded. Searches the current naming container for a server control with the specified id parameter. (Inherited from System.Web.UI.Control)
Public Method | Focus | Sets input focus to a control. (Inherited from System.Web.UI.Control)
Public Method | GetRouteUrl | Overloaded. Gets the URL that corresponds to a set of route parameters. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | Returns the prefixed portion of the System.Web.UI.Control.UniqueID property of the specified control. (Inherited from System.Web.UI.Control)
Public Method | HasControls | Determines if the server control contains any child controls. (Inherited from System.Web.UI.Control)
Public Method | RenderControl | Overloaded. Outputs server control content to a provided System.Web.UI.HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from System.Web.UI.Control)
Public Method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from System.Web.UI.Control)
Top
Protected Methods
 | Name | Description
Protected Method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's System.Web.UI.ControlCollection object. (Inherited from System.Web.UI.Control)
Protected Method | BuildProfileTree | Gathers information about the server control and delivers it to the System.Web.UI.Page.Trace property to be displayed when tracing is enabled for the page. (Inherited from System.Web.UI.Control)
Protected Method | ClearCachedClientID | Sets the cached System.Web.UI.Control.ClientID value to a null reference (Nothing in Visual Basic). (Inherited from System.Web.UI.Control)
Protected Method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | ClearEffectiveClientIDMode | Sets the System.Web.UI.Control.ClientIDMode property of the current control instance and of any child controls to System.Web.UI.ClientIDMode.Inherit. (Inherited from System.Web.UI.Control)
Protected Method | CreateControlCollection | Creates a new System.Web.UI.ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from System.Web.UI.Control)
Protected Method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from System.Web.UI.Control)
Protected Method | GetDesignModeState | Gets design-time data for a control. (Inherited from System.Web.UI.Control)
Protected Method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from System.Web.UI.Control)
Protected Method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from System.Web.UI.Control)
Protected Method | LoadViewState | Restores view-state information from a previous page request that was saved by the System.Web.UI.Control.SaveViewState method. (Inherited from System.Web.UI.Control)
Protected Method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from System.Web.UI.Control)
Protected Method | OnDataBinding | Raises the System.Web.UI.Control.DataBinding event. (Inherited from System.Web.UI.Control)
Protected Method | OnInit | Overridden. Raises the System.Web.UI.Control.Init event.
Protected Method | OnLoad | Overridden. This method notifies the server control that it should perform actions common to each HTTP request for the page it is associated with.
Protected Method | OnPreRender | Overridden. Raises the System.Web.UI.Control.PreRender event.
Protected Method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from System.Web.UI.Control)
Protected Method | Render | Overridden. Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Protected Method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from System.Web.UI.Control)
Protected Method | SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from System.Web.UI.Control)
Protected Method | SetDesignModeState | Sets design-time data for a control. (Inherited from System.Web.UI.Control)
Protected Method | TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's System.Web.UI.StateBag object. This object is accessible through the System.Web.UI.Control.ViewState property. (Inherited from System.Web.UI.Control)
Top
Public Events
 | Name | Description
Public Event | DataBinding | Occurs when the server control binds to a data source. (Inherited from System.Web.UI.Control)
Public Event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from System.Web.UI.Control)
Public Event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from System.Web.UI.Control)
Public Event | Load | Occurs when the server control is loaded into the System.Web.UI.Page object. (Inherited from System.Web.UI.Control)
Public Event | PreRender | Occurs after the System.Web.UI.Control object is loaded but prior to rendering. (Inherited from System.Web.UI.Control)
Public Event | Unload | Occurs when the server control is unloaded from memory. (Inherited from System.Web.UI.Control)
Top
See Also

Reference

Designer Class
ActiveReports.Server.ReportControls Namespace


Designer Constructor

Designer Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > Designer Class : Designer Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Designer()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Designer Class Methods

Designer Class Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace : Designer Class

For a list of all members of this type, see Designer members.

Public Methods
 | Name | Description
Public Method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from System.Web.UI.Control)
Public Method | DataBind | Overloaded. Binds a data source to the invoked server control and all its child controls. (Inherited from System.Web.UI.Control)
Public Method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from System.Web.UI.Control)
Public Method | FindControl | Overloaded. Searches the current naming container for a server control with the specified id parameter. (Inherited from System.Web.UI.Control)
Public Method | Focus | Sets input focus to a control. (Inherited from System.Web.UI.Control)
Public Method | GetRouteUrl | Overloaded. Gets the URL that corresponds to a set of route parameters. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | Returns the prefixed portion of the System.Web.UI.Control.UniqueID property of the specified control. (Inherited from System.Web.UI.Control)
Public Method | HasControls | Determines if the server control contains any child controls. (Inherited from System.Web.UI.Control)
Public Method | RenderControl | Overloaded. Outputs server control content to a provided System.Web.UI.HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from System.Web.UI.Control)
Public Method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from System.Web.UI.Control)
Top
Protected Methods
 | Name | Description
Protected Method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's System.Web.UI.ControlCollection object. (Inherited from System.Web.UI.Control)
Protected Method | BuildProfileTree | Gathers information about the server control and delivers it to the System.Web.UI.Page.Trace property to be displayed when tracing is enabled for the page. (Inherited from System.Web.UI.Control)
Protected Method | ClearCachedClientID | Sets the cached System.Web.UI.Control.ClientID value to a null reference (Nothing in Visual Basic). (Inherited from System.Web.UI.Control)
Protected Method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | ClearEffectiveClientIDMode | Sets the System.Web.UI.Control.ClientIDMode property of the current control instance and of any child controls to System.Web.UI.ClientIDMode.Inherit. (Inherited from System.Web.UI.Control)
Protected Method | CreateControlCollection | Creates a new System.Web.UI.ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from System.Web.UI.Control)
Protected Method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from System.Web.UI.Control)
Protected Method | GetDesignModeState | Gets design-time data for a control. (Inherited from System.Web.UI.Control)
Protected Method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from System.Web.UI.Control)
Protected Method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from System.Web.UI.Control)
Protected Method | LoadViewState | Restores view-state information from a previous page request that was saved by the System.Web.UI.Control.SaveViewState method. (Inherited from System.Web.UI.Control)
Protected Method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from System.Web.UI.Control)
Protected Method | OnDataBinding | Raises the System.Web.UI.Control.DataBinding event. (Inherited from System.Web.UI.Control)
Protected Method | OnInit | Overridden. Raises the System.Web.UI.Control.Init event.
Protected Method | OnLoad | Overridden. This method notifies the server control that it should perform actions common to each HTTP request for the page it is associated with.
Protected Method | OnPreRender | Overridden. Raises the System.Web.UI.Control.PreRender event.
Protected Method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from System.Web.UI.Control)
Protected Method | Render | Overridden. Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Protected Method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from System.Web.UI.Control)
Protected Method | SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from System.Web.UI.Control)
Protected Method | SetDesignModeState | Sets design-time data for a control. (Inherited from System.Web.UI.Control)
Protected Method | TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's System.Web.UI.StateBag object. This object is accessible through the System.Web.UI.Control.ViewState property. (Inherited from System.Web.UI.Control)
Top
See Also

Reference

Designer Class
ActiveReports.Server.ReportControls Namespace


OnInit Method (Designer)

OnInit Method (Designer)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > Designer Class : OnInit Method
An System.EventArgs object that contains the event data.
Raises the System.Web.UI.Control.Init event.
Syntax
  • Visual Basic
  • C#
'Declaration

Protected Overrides NotOverridable Sub OnInit( _
   ByVal args As EventArgs _
)
protected override void OnInit(
   EventArgs args
)

Parameters

args
An System.EventArgs object that contains the event data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Base Implementation in OnInit


OnLoad Method

OnLoad Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > Designer Class : OnLoad Method
The EventArgs object that contains the event data.
This method notifies the server control that it should perform actions common to each HTTP request for the page it is associated with.
Syntax
  • Visual Basic
  • C#
'Declaration

Protected Overrides NotOverridable Sub OnLoad( _
   ByVal e As EventArgs _
)
protected override void OnLoad(
   EventArgs e
)

Parameters

e
The EventArgs object that contains the event data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Base Implementation in OnLoad


OnPreRender Method

OnPreRender Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > Designer Class : OnPreRender Method
An System.EventArgs object that contains the event data.
Raises the System.Web.UI.Control.PreRender event.
Syntax
  • Visual Basic
  • C#
'Declaration

Protected Overrides NotOverridable Sub OnPreRender( _
   ByVal e As EventArgs _
)
protected override void OnPreRender(
   EventArgs e
)

Parameters

e
An System.EventArgs object that contains the event data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Base Implementation in OnPreRender


Render Method

Render Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > Designer Class : Render Method
The HtmlTextWriter object that receives the server control content.
Sends server control content to a provided HtmlTextWriter object, which writes the content to be rendered on the client.
Syntax
  • Visual Basic
  • C#
'Declaration

Protected Overrides NotOverridable Sub Render( _
   ByVal writer As HtmlTextWriter _
)
protected override void Render(
   HtmlTextWriter writer
)

Parameters

writer
The HtmlTextWriter object that receives the server control content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members
Base Implementation in Render


Designer Class Properties

Designer Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace : Designer Class

For a list of all members of this type, see Designer members.

Public Properties
 | Name | Description
Public Property | AdminPath | Gets or sets the URL of the administrator site.
Public Property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the System.Web.UI.Page or System.Web.UI.UserControl object that contains this control. (Inherited from System.Web.UI.Control)
Public Property | ClientID | Gets the control ID for HTML markup that is generated by ASP.NET. (Inherited from System.Web.UI.Control)
Public Property | ClientIDMode | Gets or sets the algorithm that is used to generate the value of the System.Web.UI.Control.ClientID property. (Inherited from System.Web.UI.Control)
Public Property | Controls | Gets a System.Web.UI.ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from System.Web.UI.Control)
Public Property | DesignerHelpPath | Gets or sets the URL of the diagnostic page.
Public Property | DesignerServicePath | Gets or sets the URL of the designer service for designer to communicate with.
Public Property | DiagnosticPagePath | Gets or sets the URL of the diagnostic page.
Public Property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from System.Web.UI.Control)
Public Property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from System.Web.UI.Control)
Public Property | FlashNotInstalledTemplate | Gets or sets the template to show an alternative content when a proper flash player version is required.
Public Property | Height | Gets or sets the height of the Web server control.
Public Property | HiddenElements | Gets or sets the enumeration of UI elements which should be hidden.
Public Property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from System.Web.UI.Control)
Public Property | ModelName | Gets or sets the model name/id for report portal to undertake a specific action on.
Public Property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same System.Web.UI.Control.ID property value. (Inherited from System.Web.UI.Control)
Public Property | Page | Gets a reference to the System.Web.UI.Page instance that contains the server control. (Inherited from System.Web.UI.Control)
Public Property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from System.Web.UI.Control)
Public Property | RenderingCompatibility | Gets a value that specifies the ASP.NET version that rendered HTML will be compatible with. (Inherited from System.Web.UI.Control)
Public Property | ReportAction | Gets or sets the report action for report portal to undertake on a specific report.
Public Property | ReportId | Gets or sets the report id for report portal to undertake a specific action on.
Public Property | ReportName | Gets or sets the name of the report for report portal to undertake a specific action on.
Public Property | RequestStatusCheckInterval | Gets or sets the time interval in seconds to check status of render request.
Public Property | ResourcePath | Gets or sets the URL of the designer help.
Public Property | SecurityToken | Gets or sets security token.
Public Property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from System.Web.UI.Control)
Public Property | SiteRootPath | Gets or sets the URL of the ARS site root to redirect to.
Public Property | SkinID | Gets or sets the skin to apply to the control. (Inherited from System.Web.UI.Control)
Public Property | SnapshotId | Gets or sets the snapshot id for report rendering.
Public Property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | Gets the virtual directory of the System.Web.UI.Page or System.Web.UI.UserControl that contains the current server control. (Inherited from System.Web.UI.Control)
Public Property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from System.Web.UI.Control)
Public Property | ValidateRequestMode | Gets or sets a value that indicates whether the control checks client input from the browser for potentially dangerous values. (Inherited from System.Web.UI.Control)
Public Property | ViewStateMode | Gets or sets the view-state mode of this control. (Inherited from System.Web.UI.Control)
Public Property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from System.Web.UI.Control)
Public Property | Width | Gets or sets the width of the Web server control.
Public Property | WindowMode | Gets or sets possible values for transparency, layering, and positioning in the browser.
Top
Protected Properties
 | Name | Description
Protected Property | Adapter | Gets the browser-specific adapter for the control. (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | Gets a character value representing the separator character used in the System.Web.UI.Control.ClientID property. (Inherited from System.Web.UI.Control)
Protected Property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from System.Web.UI.Control)
Protected Property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from System.Web.UI.Control)
Protected Property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from System.Web.UI.Control)
Protected Property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by System.Web.UI.Control.ID instead of index. (Inherited from System.Web.UI.Control)
Protected Property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | Gets a value that indicates whether the System.Web.UI.StateBag object is case-insensitive. (Inherited from System.Web.UI.Control)
Top
See Also

Reference

Designer Class
ActiveReports.Server.ReportControls Namespace


AdminPath Property

AdminPath Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > Designer Class : AdminPath Property
Gets or sets the URL of the administrator site.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AdminPath As String
public string AdminPath {get; set;}
Remarks
Should be an relative to the page where the control is located.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


DesignerHelpPath Property

DesignerHelpPath Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > Designer Class : DesignerHelpPath Property
Gets or sets the URL of the diagnostic page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DesignerHelpPath As String
public string DesignerHelpPath {get; set;}
Remarks
Should be an relative to the page where the control is located.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


DesignerServicePath Property

DesignerServicePath Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > Designer Class : DesignerServicePath Property
Gets or sets the URL of the designer service for designer to communicate with.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DesignerServicePath As String
public string DesignerServicePath {get; set;}

Property Value

The report service path.
Remarks
Should be an relative to the page where the control is located.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


DiagnosticPagePath Property

DiagnosticPagePath Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > Designer Class : DiagnosticPagePath Property
Gets or sets the URL of the diagnostic page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DiagnosticPagePath As String
public string DiagnosticPagePath {get; set;}
Remarks
Should be an relative to the page where the control is located.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


FlashNotInstalledTemplate Property

FlashNotInstalledTemplate Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > Designer Class : FlashNotInstalledTemplate Property
Gets or sets the template to show an alternative content when a proper flash player version is required.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FlashNotInstalledTemplate As ITemplate
public ITemplate FlashNotInstalledTemplate {get; set;}

Property Value

The alternative content template.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Height Property (Designer)

Height Property (Designer)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > Designer Class : Height Property
Gets or sets the height of the Web server control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Height As Unit
public Unit Height {get; set;}

Property Value

A System.Web.UI.WebControls.Unit that represents the height of the control.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


HiddenElements Property

HiddenElements Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > Designer Class : HiddenElements Property
Gets or sets the enumeration of UI elements which should be hidden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HiddenElements As DesignerElements
public DesignerElements HiddenElements {get; set;}

Property Value

The enumeration of UI elements which should be hidden.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ModelName Property (Designer)

ModelName Property (Designer)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > Designer Class : ModelName Property
Gets or sets the model name/id for report portal to undertake a specific action on.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ModelName As String
public string ModelName {get; set;}

Property Value

The mode name/id.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ReportAction Property

ReportAction Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > Designer Class : ReportAction Property
Gets or sets the report action for report portal to undertake on a specific report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReportAction As ReportAction
public ReportAction ReportAction {get; set;}

Property Value

The report action.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ReportId Property (Designer)

ReportId Property (Designer)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > Designer Class : ReportId Property
Gets or sets the report id for report portal to undertake a specific action on.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReportId As String
public string ReportId {get; set;}

Property Value

The report id.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ReportName Property

ReportName Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > Designer Class : ReportName Property
Gets or sets the name of the report for report portal to undertake a specific action on.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReportName As String
public string ReportName {get; set;}

Property Value

The report name.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


RequestStatusCheckInterval Property

RequestStatusCheckInterval Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > Designer Class : RequestStatusCheckInterval Property
Gets or sets the time interval in seconds to check status of render request.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RequestStatusCheckInterval As Integer
public int RequestStatusCheckInterval {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


ResourcePath Property

ResourcePath Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > Designer Class : ResourcePath Property
Gets or sets the URL of the designer help.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ResourcePath As String
public string ResourcePath {get; set;}
Remarks
Should be an relative to the page where the control is located.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


SecurityToken Property (Designer)

SecurityToken Property (Designer)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > Designer Class : SecurityToken Property
Gets or sets security token.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SecurityToken As String
public string SecurityToken {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


SiteRootPath Property

SiteRootPath Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > Designer Class : SiteRootPath Property
Gets or sets the URL of the ARS site root to redirect to.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SiteRootPath As String
public string SiteRootPath {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


SnapshotId Property

SnapshotId Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > Designer Class : SnapshotId Property
Gets or sets the snapshot id for report rendering.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SnapshotId As String
public string SnapshotId {get; set;}

Property Value

The report action.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


Width Property (Designer)

Width Property (Designer)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > Designer Class : Width Property
Gets or sets the width of the Web server control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Width As Unit
public Unit Width {get; set;}

Property Value

A System.Web.UI.WebControls.Unit that represents the width of the control.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


WindowMode Property

WindowMode Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > Designer Class : WindowMode Property
Gets or sets possible values for transparency, layering, and positioning in the browser.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WindowMode As WindowMode
public WindowMode WindowMode {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Designer Class
Designer Members


LocalizedDescriptionAttribute Class

LocalizedDescriptionAttribute Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace : LocalizedDescriptionAttribute Class
Description attribute with localization support
Object Model
LocalizedDescriptionAttribute Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class LocalizedDescriptionAttribute
   Inherits System.ComponentModel.DescriptionAttribute
public class LocalizedDescriptionAttribute : System.ComponentModel.DescriptionAttribute
Inheritance Hierarchy

System.Object
System.Attribute
System.ComponentModel.DescriptionAttribute
ActiveReports.Server.ReportControls.LocalizedDescriptionAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocalizedDescriptionAttribute Members
ActiveReports.Server.ReportControls Namespace


LocalizedDescriptionAttribute Class Members

LocalizedDescriptionAttribute Class Members
Properties Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace : LocalizedDescriptionAttribute Class

The following tables list the members exposed by LocalizedDescriptionAttribute.

Public Constructors
 | Name | Description
Public Constructor | LocalizedDescriptionAttribute Constructor | Initializes LocalizedDisplayNameAttribute
Top
Public Properties
 | Name | Description
Public Property | Description | (Inherited from System.ComponentModel.DescriptionAttribute)
Public Property | TypeId | When implemented in a derived class, gets a unique identifier for this System.Attribute. (Inherited from System.Attribute)
Top
Protected Properties
 | Name | Description
Protected Property | DescriptionValue | (Inherited from System.ComponentModel.DescriptionAttribute)
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.ComponentModel.DescriptionAttribute)
Public Method | GetHashCode | (Inherited from System.ComponentModel.DescriptionAttribute)
Public Method | IsDefaultAttribute | (Inherited from System.ComponentModel.DescriptionAttribute)
Public Method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from System.Attribute)
Top
See Also

Reference

LocalizedDescriptionAttribute Class
ActiveReports.Server.ReportControls Namespace


LocalizedDescriptionAttribute Constructor

LocalizedDescriptionAttribute Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > LocalizedDescriptionAttribute Class : LocalizedDescriptionAttribute Constructor
The id of resource to get message
Initializes LocalizedDisplayNameAttribute
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal resourceId As String _
)
public LocalizedDescriptionAttribute(
   string resourceId
)

Parameters

resourceId
The id of resource to get message
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LocalizedDescriptionAttribute Class
LocalizedDescriptionAttribute Members


ReportList Class

ReportList Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace : ReportList Class
Represents a list of report available on the server.
Object Model
ReportList Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ReportList
   Inherits System.Web.UI.ScriptControl
public class ReportList : System.Web.UI.ScriptControl
Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
System.Web.UI.ScriptControl
ActiveReports.Server.ReportControls.ReportList

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Members
ActiveReports.Server.ReportControls Namespace


ReportList Class Members

ReportList Class Members
Properties Methods Events

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace : ReportList Class

The following tables list the members exposed by ReportList.

Public Constructors
 | Name | Description
Public Constructor | ReportList Constructor | Creates new list of report available on the server.
Top
Public Properties
 | Name | Description
Public Property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ActionTemplate | Gets or sets the layout template for report list item action.
Public Property | AlternateItemTemplate | Gets or sets the item template.
Public Property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the System.Web.UI.Page or System.Web.UI.UserControl object that contains this control. (Inherited from System.Web.UI.Control)
Public Property | ARRenderExtensions | Gets or sets the collection of rendering extensions for AR reports.
Public Property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | Gets or sets the background color of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | Gets or sets the border color of the Web control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BuiltInTheme | Gets or sets the value indicating whether to use one of the built in themes or not.
Public Property | ClientDataBound | Gets or sets the client data bound event.
Public Property | ClientError | Gets or sets the client error event.
Public Property | ClientID | Gets the control ID for HTML markup that is generated by ASP.NET. (Inherited from System.Web.UI.Control)
Public Property | ClientIDMode | Gets or sets the algorithm that is used to generate the value of the System.Web.UI.Control.ClientID property. (Inherited from System.Web.UI.Control)
Public Property | ClientRender | Gets or sets the client render event.
Public Property | ClientRenderComplete | Gets or sets the client render complete event.
Public Property | CompleteTemplate | Gets or sets the complete template.
Public Property | Controls | Gets a System.Web.UI.ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | Gets a value indicating whether a System.Web.UI.WebControls.Style object has been created for the System.Web.UI.WebControls.WebControl.ControlStyle property. This property is primarily used by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | DateTimeFormat | Gets or sets the format string to apply to the date time values within the control.
Public Property | DDRRenderExtensions | Gets or sets the collection of rendering extensions for DDR reports.
Public Property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from System.Web.UI.Control)
Public Property | ErrorTemplate | Gets or sets the error template.
Public Property | Filter | Gets or sets the filter to use to retrieve the list of reports from the service.
Public Property | FirstItemTemplate | Gets or sets the first item template.
Public Property | Font | Gets the font properties associated with the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | FooterTemplate | Gets or sets the template for report list footer.
Public Property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HeaderTemplate | Gets or sets the template for report list header.
Public Property | Height | Overridden. Gets or sets the height of the Web server control.
Public Property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from System.Web.UI.Control)
Public Property | ItemTemplate | Gets or sets the item template.
Public Property | LastItemTemplate | Gets or sets the last item template.
Public Property | ListTemplate | Gets or sets the template defining layout for this report list.
Public Property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same System.Web.UI.Control.ID property value. (Inherited from System.Web.UI.Control)
Public Property | NoReportsTemplate | Gets or sets the template that will be shown in case there are no reports.
Public Property | Page | Gets a reference to the System.Web.UI.Page instance that contains the server control. (Inherited from System.Web.UI.Control)
Public Property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from System.Web.UI.Control)
Public Property | ProgressTemplate | Gets or sets the progress template.
Public Property | RenderingCompatibility | Gets a value that specifies the ASP.NET version that rendered HTML will be compatible with. (Inherited from System.Web.UI.Control)
Public Property | ReportServicePath | Gets or sets the report service path.
Public Property | ResourceHandler | Gets or sets the resource handler url.
Public Property | SeparatorTemplate | Gets or sets the item separator template.
Public Property | ServerEndpointRootPath | Gets or sets the server endpoint root path.
Public Property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from System.Web.UI.Control)
Public Property | SkinID | Gets or sets the skin to apply to the control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Sorting | Gets or sets the sorting to use to retrieve the list of reports from the service.
Public Property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SupportsDisabledAttribute | Gets a value that indicates whether the control should set the disabled attribute of the rendered HTML element to "disabled" when the control's System.Web.UI.WebControls.WebControl.IsEnabled property is false. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | Gets the virtual directory of the System.Web.UI.Page or System.Web.UI.UserControl that contains the current server control. (Inherited from System.Web.UI.Control)
Public Property | Timeout | Gets or sets the timeout in milliseconds for the associated report service.
Public Property | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from System.Web.UI.Control)
Public Property | ValidateRequestMode | Gets or sets a value that indicates whether the control checks client input from the browser for potentially dangerous values. (Inherited from System.Web.UI.Control)
Public Property | ViewStateMode | Gets or sets the view-state mode of this control. (Inherited from System.Web.UI.Control)
Public Property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from System.Web.UI.Control)
Public Property | Width | Overridden. Gets or sets the width of the Web server control.
Top
Protected Properties
 | Name | Description
Protected Property | Adapter | Gets the browser-specific adapter for the control. (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | Gets a character value representing the separator character used in the System.Web.UI.Control.ClientID property. (Inherited from System.Web.UI.Control)
Protected Property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from System.Web.UI.Control)
Protected Property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from System.Web.UI.Control)
Protected Property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from System.Web.UI.Control)
Protected Property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by System.Web.UI.Control.ID instead of index. (Inherited from System.Web.UI.Control)
Protected Property | TagKey | Overridden. Gets the System.Web.UI.HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers.
Protected Property | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | Gets a value that indicates whether the System.Web.UI.StateBag object is case-insensitive. (Inherited from System.Web.UI.Control)
Top
Public Methods
 | Name | Description
Public Method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | Copies the properties not encapsulated by the System.Web.UI.WebControls.WebControl.Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | Overloaded. Binds a data source to the invoked server control and all its child controls. (Inherited from System.Web.UI.Control)
Public Method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from System.Web.UI.Control)
Public Method | FindControl | Overloaded. Searches the current naming container for a server control with the specified id parameter. (Inherited from System.Web.UI.Control)
Public Method | Focus | Sets input focus to a control. (Inherited from System.Web.UI.Control)
Public Method | GetRouteUrl | Overloaded. Gets the URL that corresponds to a set of route parameters. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | Returns the prefixed portion of the System.Web.UI.Control.UniqueID property of the specified control. (Inherited from System.Web.UI.Control)
Public Method | HasControls | Determines if the server control contains any child controls. (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | Overloaded. Outputs server control content to a provided System.Web.UI.HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from System.Web.UI.Control)
Top
Protected Methods
 | Name | Description
Protected Method | AddAttributesToRender | Overridden. Adds HTML attributes and styles that need to be rendered to the specified System.Web.UI.HtmlTextWriterTag. This method is used primarily by control developers.
Protected Method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's System.Web.UI.ControlCollection object. (Inherited from System.Web.UI.Control)
Protected Method | BuildProfileTree | Gathers information about the server control and delivers it to the System.Web.UI.Page.Trace property to be displayed when tracing is enabled for the page. (Inherited from System.Web.UI.Control)
Protected Method | ClearCachedClientID | Sets the cached System.Web.UI.Control.ClientID value to a null reference (Nothing in Visual Basic). (Inherited from System.Web.UI.Control)
Protected Method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | ClearEffectiveClientIDMode | Sets the System.Web.UI.Control.ClientIDMode property of the current control instance and of any child controls to System.Web.UI.ClientIDMode.Inherit. (Inherited from System.Web.UI.Control)
Protected Method | CreateChildControls | Overridden. Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering.
Protected Method | CreateControlCollection | Creates a new System.Web.UI.ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from System.Web.UI.Control)
Protected Method | CreateControlStyle | Creates the style object that is used internally by the System.Web.UI.WebControls.WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from System.Web.UI.Control)
Protected Method | GetDesignModeState | Gets design-time data for a control. (Inherited from System.Web.UI.Control)
Protected Method | GetScriptDescriptors | Overridden. When overridden in a derived class, returns the System.Web.UI.ScriptDescriptor objects for the control.
Protected Method | GetScriptReferences | Overridden. When overridden in a derived class, returns the script files for the control.
Protected Method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from System.Web.UI.Control)
Protected Method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from System.Web.UI.Control)
Protected Method | LoadViewState | Restores view-state information from a previous request that was saved with the System.Web.UI.WebControls.WebControl.SaveViewState method. (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from System.Web.UI.Control)
Protected Method | OnDataBinding | Raises the System.Web.UI.Control.DataBinding event. (Inherited from System.Web.UI.Control)
Protected Method | OnInit | Overridden. Raises the System.Web.UI.Control.Init event.
Protected Method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from System.Web.UI.Control)
Protected Method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from System.Web.UI.Control)
Protected Method | SaveViewState | Saves any state that was modified after the System.Web.UI.WebControls.Style.TrackViewState method was invoked. (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | SetDesignModeState | Sets design-time data for a control. (Inherited from System.Web.UI.Control)
Protected Method | TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's System.Web.UI.Control.ViewState property. (Inherited from System.Web.UI.WebControls.WebControl)
Top
Public Events
 | Name | Description
Public Event | DataBinding | Occurs when the server control binds to a data source. (Inherited from System.Web.UI.Control)
Public Event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from System.Web.UI.Control)
Public Event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from System.Web.UI.Control)
Public Event | Load | Occurs when the server control is loaded into the System.Web.UI.Page object. (Inherited from System.Web.UI.Control)
Public Event | PreRender | Occurs after the System.Web.UI.Control object is loaded but prior to rendering. (Inherited from System.Web.UI.Control)
Public Event | Unload | Occurs when the server control is unloaded from memory. (Inherited from System.Web.UI.Control)
Top
See Also

Reference

ReportList Class
ActiveReports.Server.ReportControls Namespace


ReportList Constructor

ReportList Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : ReportList Constructor
Creates new list of report available on the server.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ReportList()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members


ReportList Class Methods

ReportList Class Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace : ReportList Class

For a list of all members of this type, see ReportList members.

Public Methods
 | Name | Description
Public Method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | Copies the properties not encapsulated by the System.Web.UI.WebControls.WebControl.Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | Overloaded. Binds a data source to the invoked server control and all its child controls. (Inherited from System.Web.UI.Control)
Public Method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from System.Web.UI.Control)
Public Method | FindControl | Overloaded. Searches the current naming container for a server control with the specified id parameter. (Inherited from System.Web.UI.Control)
Public Method | Focus | Sets input focus to a control. (Inherited from System.Web.UI.Control)
Public Method | GetRouteUrl | Overloaded. Gets the URL that corresponds to a set of route parameters. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | Returns the prefixed portion of the System.Web.UI.Control.UniqueID property of the specified control. (Inherited from System.Web.UI.Control)
Public Method | HasControls | Determines if the server control contains any child controls. (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | Overloaded. Outputs server control content to a provided System.Web.UI.HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from System.Web.UI.Control)
Top
Protected Methods
 | Name | Description
Protected Method | AddAttributesToRender | Overridden. Adds HTML attributes and styles that need to be rendered to the specified System.Web.UI.HtmlTextWriterTag. This method is used primarily by control developers.
Protected Method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's System.Web.UI.ControlCollection object. (Inherited from System.Web.UI.Control)
Protected Method | BuildProfileTree | Gathers information about the server control and delivers it to the System.Web.UI.Page.Trace property to be displayed when tracing is enabled for the page. (Inherited from System.Web.UI.Control)
Protected Method | ClearCachedClientID | Sets the cached System.Web.UI.Control.ClientID value to a null reference (Nothing in Visual Basic). (Inherited from System.Web.UI.Control)
Protected Method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | ClearEffectiveClientIDMode | Sets the System.Web.UI.Control.ClientIDMode property of the current control instance and of any child controls to System.Web.UI.ClientIDMode.Inherit. (Inherited from System.Web.UI.Control)
Protected Method | CreateChildControls | Overridden. Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering.
Protected Method | CreateControlCollection | Creates a new System.Web.UI.ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from System.Web.UI.Control)
Protected Method | CreateControlStyle | Creates the style object that is used internally by the System.Web.UI.WebControls.WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from System.Web.UI.Control)
Protected Method | GetDesignModeState | Gets design-time data for a control. (Inherited from System.Web.UI.Control)
Protected Method | GetScriptDescriptors | Overridden. When overridden in a derived class, returns the System.Web.UI.ScriptDescriptor objects for the control.
Protected Method | GetScriptReferences | Overridden. When overridden in a derived class, returns the script files for the control.
Protected Method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from System.Web.UI.Control)
Protected Method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from System.Web.UI.Control)
Protected Method | LoadViewState | Restores view-state information from a previous request that was saved with the System.Web.UI.WebControls.WebControl.SaveViewState method. (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from System.Web.UI.Control)
Protected Method | OnDataBinding | Raises the System.Web.UI.Control.DataBinding event. (Inherited from System.Web.UI.Control)
Protected Method | OnInit | Overridden. Raises the System.Web.UI.Control.Init event.
Protected Method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from System.Web.UI.Control)
Protected Method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from System.Web.UI.Control)
Protected Method | SaveViewState | Saves any state that was modified after the System.Web.UI.WebControls.Style.TrackViewState method was invoked. (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | SetDesignModeState | Sets design-time data for a control. (Inherited from System.Web.UI.Control)
Protected Method | TrackViewState | Causes the control to track changes to its view state so they can be stored in the object's System.Web.UI.Control.ViewState property. (Inherited from System.Web.UI.WebControls.WebControl)
Top
See Also

Reference

ReportList Class
ActiveReports.Server.ReportControls Namespace


AddAttributesToRender Method

AddAttributesToRender Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : AddAttributesToRender Method
A System.Web.UI.HtmlTextWriter that represents the output stream to render HTML content on the client.
Adds HTML attributes and styles that need to be rendered to the specified System.Web.UI.HtmlTextWriterTag. This method is used primarily by control developers.
Syntax
  • Visual Basic
  • C#
'Declaration

Protected Overrides Sub AddAttributesToRender( _
   ByVal writer As HtmlTextWriter _
)
protected override void AddAttributesToRender(
   HtmlTextWriter writer
)

Parameters

writer
A System.Web.UI.HtmlTextWriter that represents the output stream to render HTML content on the client.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members
Base Implementation in AddAttributesToRender


CreateChildControls Method

CreateChildControls Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : CreateChildControls Method
Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering.
Syntax
  • Visual Basic
  • C#
'Declaration

Protected Overrides Sub CreateChildControls()
protected override void CreateChildControls()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members
Base Implementation in CreateChildControls


GetScriptDescriptors Method

GetScriptDescriptors Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : GetScriptDescriptors Method
When overridden in a derived class, returns the System.Web.UI.ScriptDescriptor objects for the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Protected Overrides Function GetScriptDescriptors() As IEnumerable(Of ScriptDescriptor)
protected override IEnumerable<ScriptDescriptor> GetScriptDescriptors()

Return Value

An System.Collections.IEnumerable collection of System.Web.UI.ScriptDescriptor objects.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members
Base Implementation in GetScriptDescriptors


GetScriptReferences Method

GetScriptReferences Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : GetScriptReferences Method
When overridden in a derived class, returns the script files for the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Protected Overrides Function GetScriptReferences() As IEnumerable(Of ScriptReference)
protected override IEnumerable<ScriptReference> GetScriptReferences()

Return Value

An System.Collections.IEnumerable collection that contains ECMAScript (JavaScript) files that have been registered as embedded resources.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members
Base Implementation in GetScriptReferences


OnInit Method (ReportList)

OnInit Method (ReportList)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : OnInit Method
An System.EventArgs object that contains the event data.
Raises the System.Web.UI.Control.Init event.
Syntax
  • Visual Basic
  • C#
'Declaration

Protected Overrides Sub OnInit( _
   ByVal e As EventArgs _
)
protected override void OnInit(
   EventArgs e
)

Parameters

e
An System.EventArgs object that contains the event data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members
Base Implementation in OnInit


ReportList Class Properties

ReportList Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace : ReportList Class

For a list of all members of this type, see ReportList members.

Public Properties
 | Name | Description
Public Property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ActionTemplate | Gets or sets the layout template for report list item action.
Public Property | AlternateItemTemplate | Gets or sets the item template.
Public Property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the System.Web.UI.Page or System.Web.UI.UserControl object that contains this control. (Inherited from System.Web.UI.Control)
Public Property | ARRenderExtensions | Gets or sets the collection of rendering extensions for AR reports.
Public Property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | Gets or sets the background color of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | Gets or sets the border color of the Web control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BuiltInTheme | Gets or sets the value indicating whether to use one of the built in themes or not.
Public Property | ClientDataBound | Gets or sets the client data bound event.
Public Property | ClientError | Gets or sets the client error event.
Public Property | ClientID | Gets the control ID for HTML markup that is generated by ASP.NET. (Inherited from System.Web.UI.Control)
Public Property | ClientIDMode | Gets or sets the algorithm that is used to generate the value of the System.Web.UI.Control.ClientID property. (Inherited from System.Web.UI.Control)
Public Property | ClientRender | Gets or sets the client render event.
Public Property | ClientRenderComplete | Gets or sets the client render complete event.
Public Property | CompleteTemplate | Gets or sets the complete template.
Public Property | Controls | Gets a System.Web.UI.ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | Gets a value indicating whether a System.Web.UI.WebControls.Style object has been created for the System.Web.UI.WebControls.WebControl.ControlStyle property. This property is primarily used by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | DateTimeFormat | Gets or sets the format string to apply to the date time values within the control.
Public Property | DDRRenderExtensions | Gets or sets the collection of rendering extensions for DDR reports.
Public Property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from System.Web.UI.Control)
Public Property | ErrorTemplate | Gets or sets the error template.
Public Property | Filter | Gets or sets the filter to use to retrieve the list of reports from the service.
Public Property | FirstItemTemplate | Gets or sets the first item template.
Public Property | Font | Gets the font properties associated with the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | FooterTemplate | Gets or sets the template for report list footer.
Public Property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HeaderTemplate | Gets or sets the template for report list header.
Public Property | Height | Overridden. Gets or sets the height of the Web server control.
Public Property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from System.Web.UI.Control)
Public Property | ItemTemplate | Gets or sets the item template.
Public Property | LastItemTemplate | Gets or sets the last item template.
Public Property | ListTemplate | Gets or sets the template defining layout for this report list.
Public Property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same System.Web.UI.Control.ID property value. (Inherited from System.Web.UI.Control)
Public Property | NoReportsTemplate | Gets or sets the template that will be shown in case there are no reports.
Public Property | Page | Gets a reference to the System.Web.UI.Page instance that contains the server control. (Inherited from System.Web.UI.Control)
Public Property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from System.Web.UI.Control)
Public Property | ProgressTemplate | Gets or sets the progress template.
Public Property | RenderingCompatibility | Gets a value that specifies the ASP.NET version that rendered HTML will be compatible with. (Inherited from System.Web.UI.Control)
Public Property | ReportServicePath | Gets or sets the report service path.
Public Property | ResourceHandler | Gets or sets the resource handler url.
Public Property | SeparatorTemplate | Gets or sets the item separator template.
Public Property | ServerEndpointRootPath | Gets or sets the server endpoint root path.
Public Property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from System.Web.UI.Control)
Public Property | SkinID | Gets or sets the skin to apply to the control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Sorting | Gets or sets the sorting to use to retrieve the list of reports from the service.
Public Property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SupportsDisabledAttribute | Gets a value that indicates whether the control should set the disabled attribute of the rendered HTML element to "disabled" when the control's System.Web.UI.WebControls.WebControl.IsEnabled property is false. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | Gets the virtual directory of the System.Web.UI.Page or System.Web.UI.UserControl that contains the current server control. (Inherited from System.Web.UI.Control)
Public Property | Timeout | Gets or sets the timeout in milliseconds for the associated report service.
Public Property | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from System.Web.UI.Control)
Public Property | ValidateRequestMode | Gets or sets a value that indicates whether the control checks client input from the browser for potentially dangerous values. (Inherited from System.Web.UI.Control)
Public Property | ViewStateMode | Gets or sets the view-state mode of this control. (Inherited from System.Web.UI.Control)
Public Property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from System.Web.UI.Control)
Public Property | Width | Overridden. Gets or sets the width of the Web server control.
Top
Protected Properties
 | Name | Description
Protected Property | Adapter | Gets the browser-specific adapter for the control. (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | Gets a character value representing the separator character used in the System.Web.UI.Control.ClientID property. (Inherited from System.Web.UI.Control)
Protected Property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from System.Web.UI.Control)
Protected Property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from System.Web.UI.Control)
Protected Property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from System.Web.UI.Control)
Protected Property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by System.Web.UI.Control.ID instead of index. (Inherited from System.Web.UI.Control)
Protected Property | TagKey | Overridden. Gets the System.Web.UI.HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers.
Protected Property | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | Gets a value that indicates whether the System.Web.UI.StateBag object is case-insensitive. (Inherited from System.Web.UI.Control)
Top
See Also

Reference

ReportList Class
ActiveReports.Server.ReportControls Namespace


ActionTemplate Property

ActionTemplate Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : ActionTemplate Property
Gets or sets the layout template for report list item action.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property ActionTemplate As ITemplate
public virtual ITemplate ActionTemplate {get; set;}

Property Value

The layout template for report list item action.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members


AlternateItemTemplate Property

AlternateItemTemplate Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : AlternateItemTemplate Property
Gets or sets the item template.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property AlternateItemTemplate As ITemplate
public virtual ITemplate AlternateItemTemplate {get; set;}

Property Value

The alternate item template.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members


ARRenderExtensions Property

ARRenderExtensions Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : ARRenderExtensions Property
Gets or sets the collection of rendering extensions for AR reports.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ARRenderExtensions As String
public string ARRenderExtensions {get; set;}

Property Value

The collection of rendering extensions for AR reports.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members


BuiltInTheme Property

BuiltInTheme Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : BuiltInTheme Property
Gets or sets the value indicating whether to use one of the built in themes or not.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BuiltInTheme As ReportList.Theme
public ReportList.Theme BuiltInTheme {get; set;}

Property Value

The value indicating whether to use one of the built in themes or not.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members


ClientDataBound Property

ClientDataBound Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : ClientDataBound Property
Gets or sets the client data bound event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ClientDataBound As String
public string ClientDataBound {get; set;}

Property Value

The client data bound event.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members


ClientError Property

ClientError Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : ClientError Property
Gets or sets the client error event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ClientError As String
public string ClientError {get; set;}

Property Value

The client error event.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members


ClientRender Property

ClientRender Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : ClientRender Property
Gets or sets the client render event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ClientRender As String
public string ClientRender {get; set;}

Property Value

The client render event.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members


ClientRenderComplete Property

ClientRenderComplete Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : ClientRenderComplete Property
Gets or sets the client render complete event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ClientRenderComplete As String
public string ClientRenderComplete {get; set;}

Property Value

The client render complete event.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members


CompleteTemplate Property

CompleteTemplate Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : CompleteTemplate Property
Gets or sets the complete template.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property CompleteTemplate As ITemplate
public virtual ITemplate CompleteTemplate {get; set;}

Property Value

The complete template.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members


DateTimeFormat Property

DateTimeFormat Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : DateTimeFormat Property
Gets or sets the format string to apply to the date time values within the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DateTimeFormat As String
public string DateTimeFormat {get; set;}

Property Value

The format string to apply to the date time values within the control.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members


DDRRenderExtensions Property

DDRRenderExtensions Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : DDRRenderExtensions Property
Gets or sets the collection of rendering extensions for DDR reports.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DDRRenderExtensions As String
public string DDRRenderExtensions {get; set;}

Property Value

The collection of rendering extensions for DDR reports.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members


ErrorTemplate Property

ErrorTemplate Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : ErrorTemplate Property
Gets or sets the error template.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property ErrorTemplate As ITemplate
public virtual ITemplate ErrorTemplate {get; set;}

Property Value

The error template.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members


Filter Property

Filter Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : Filter Property
Gets or sets the filter to use to retrieve the list of reports from the service.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Filter As String
public string Filter {get; set;}

Property Value

The filter to use to retrieve the list of reports from the service.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members


FirstItemTemplate Property

FirstItemTemplate Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : FirstItemTemplate Property
Gets or sets the first item template.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property FirstItemTemplate As ITemplate
public virtual ITemplate FirstItemTemplate {get; set;}

Property Value

The first item template.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members


FooterTemplate Property

FooterTemplate Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : FooterTemplate Property
Gets or sets the template for report list footer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property FooterTemplate As ITemplate
public virtual ITemplate FooterTemplate {get; set;}

Property Value

The footer template.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members


HeaderTemplate Property

HeaderTemplate Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : HeaderTemplate Property
Gets or sets the template for report list header.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property HeaderTemplate As ITemplate
public virtual ITemplate HeaderTemplate {get; set;}

Property Value

The header template.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members


Height Property (ReportList)

Height Property (ReportList)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : Height Property
Gets or sets the height of the Web server control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Property Height As Unit
public override Unit Height {get; set;}

Property Value

A System.Web.UI.WebControls.Unit that represents the height of the control.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members
Base Implementation in Height


ItemTemplate Property

ItemTemplate Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : ItemTemplate Property
Gets or sets the item template.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property ItemTemplate As ITemplate
public virtual ITemplate ItemTemplate {get; set;}

Property Value

The item template.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members


LastItemTemplate Property

LastItemTemplate Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : LastItemTemplate Property
Gets or sets the last item template.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property LastItemTemplate As ITemplate
public virtual ITemplate LastItemTemplate {get; set;}

Property Value

The last item template.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members


ListTemplate Property

ListTemplate Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : ListTemplate Property
Gets or sets the template defining layout for this report list.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property ListTemplate As ITemplate
public virtual ITemplate ListTemplate {get; set;}

Property Value

The list template.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members


NoReportsTemplate Property

NoReportsTemplate Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : NoReportsTemplate Property
Gets or sets the template that will be shown in case there are no reports.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property NoReportsTemplate As ITemplate
public virtual ITemplate NoReportsTemplate {get; set;}

Property Value

The template.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members


ProgressTemplate Property

ProgressTemplate Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : ProgressTemplate Property
Gets or sets the progress template.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property ProgressTemplate As ITemplate
public virtual ITemplate ProgressTemplate {get; set;}

Property Value

The progress template.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members


ReportServicePath Property

ReportServicePath Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : ReportServicePath Property
Gets or sets the report service path.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReportServicePath As String
public string ReportServicePath {get; set;}

Property Value

The report service path.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members


ResourceHandler Property

ResourceHandler Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : ResourceHandler Property
Gets or sets the resource handler url.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ResourceHandler As String
public string ResourceHandler {get; set;}

Property Value

The resource handler url.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members


SeparatorTemplate Property

SeparatorTemplate Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : SeparatorTemplate Property
Gets or sets the item separator template.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property SeparatorTemplate As ITemplate
public virtual ITemplate SeparatorTemplate {get; set;}

Property Value

The item separator template.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members


ServerEndpointRootPath Property

ServerEndpointRootPath Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : ServerEndpointRootPath Property
Gets or sets the server endpoint root path.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ServerEndpointRootPath As String
public string ServerEndpointRootPath {get; set;}

Property Value

The server endpoint root path.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members


Sorting Property

Sorting Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : Sorting Property
Gets or sets the sorting to use to retrieve the list of reports from the service.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Sorting As String
public string Sorting {get; set;}

Property Value

The sorting to use to retrieve the list of reports from the service.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members


TagKey Property

TagKey Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : TagKey Property
Gets the System.Web.UI.HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers.
Syntax
  • Visual Basic
  • C#
'Declaration

Protected Overrides ReadOnly Property TagKey As HtmlTextWriterTag
protected override HtmlTextWriterTag TagKey {get;}

Property Value

One of the System.Web.UI.HtmlTextWriterTag enumeration values.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members
Base Implementation in TagKey


Timeout Property

Timeout Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : Timeout Property
Gets or sets the timeout in milliseconds for the associated report service.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Timeout As Integer
public int Timeout {get; set;}

Property Value

The timeout in milliseconds for the associated report service.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members


Width Property (ReportList)

Width Property (ReportList)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace > ReportList Class : Width Property
Gets or sets the width of the Web server control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Property Width As Unit
public override Unit Width {get; set;}

Property Value

A System.Web.UI.WebControls.Unit that represents the width of the control.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportList Class
ReportList Members
Base Implementation in Width


DesignerElements Enumeration

DesignerElements Enumeration

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace : DesignerElements Enumeration
Defines designer control elements.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum DesignerElements
   Inherits System.Enum
public enum DesignerElements : System.Enum
Members
Member | Description
FeedbackButton | Specifies tooltip feedback button.
HelpButton | Specifies tooltip help button.
None | Specifies empty value.
SaveButton | Specifies tooltip save button.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveReports.Server.ReportControls.DesignerElements

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReports.Server.ReportControls Namespace


ReportAction Enumeration

ReportAction Enumeration

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace : ReportAction Enumeration
Specifies the action designer should undertake on load.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ReportAction
   Inherits System.Enum
public enum ReportAction : System.Enum
Members
Member | Description
Create | Indicates create action.
Design | Indicates design action.
Preview | Indicates preview action.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveReports.Server.ReportControls.ReportAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReports.Server.ReportControls Namespace


ReportList.Theme Enumeration

ReportList.Theme Enumeration

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace : ReportList.Theme Enumeration
Specifies one of the built in report list themes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ReportList.Theme
   Inherits System.Enum
public enum ReportList.Theme : System.Enum
Members
Member | Description
Blue | Indicates that blue built in theme should be used.
Green | Indicates that green built in theme should be used.
None | Indicates that no built in theme should be used.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveReports.Server.ReportControls.ReportList.Theme

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReports.Server.ReportControls Namespace


WindowMode Enumeration

WindowMode Enumeration

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace : WindowMode Enumeration
Possible values of WindowMode property of the SWF file for transparency, layering, positioning, and rendering in the browser. The default value is "window".
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum WindowMode
   Inherits System.Enum
public enum WindowMode : System.Enum
Members
Member | Description
Opaque | The SWF content is layered together with other HTML elements on the page. The SWF file is opaque and hides everything layered behind it on the page. This option reduces playback performance compared to "Window" option.
Transparent | The SWF content is layered together with other HTML elements on the page. The SWF file background color (Stage color) is transparent. HTML elements beneath the SWF file are visible through any transparent areas of the SWF, with alpha blending. This option reduces playback performance compared to "Window" option.
Window | The SWF content plays in its own rectangle ("window") on a web page. The browser determines how the SWF content is layered against other HTML elements. With this value, you cannot explicitly specify if SWF content appears above or below other HTML elements on the page.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveReports.Server.ReportControls.WindowMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReports.Server.ReportControls Namespace


ActiveReports.Server.ReportControls.Servicing Namespace

ActiveReports.Server.ReportControls.Servicing Namespace
Inheritance Hierarchy
ActiveReports.Server.ReportControls Assembly : ActiveReports.Server.ReportControls.Servicing Namespace
Classes
 | Class | Description
Class | RemoteEndpoint | Represents a remote endpoint event arguments.
Class | ServiceChannelFactory<TServiceChannel> | Represents the factory to create an instance of the specified service channel.
Class | ServiceProxyBase | Represents the proxy base stuff.
See Also

Reference

ActiveReports.Server.ReportControls Assembly


RemoteEndpoint Class

RemoteEndpoint Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls.Servicing Namespace : RemoteEndpoint Class
Represents a remote endpoint event arguments.
Object Model
RemoteEndpoint Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class RemoteEndpoint
public class RemoteEndpoint
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportControls.Servicing.RemoteEndpoint

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RemoteEndpoint Members
ActiveReports.Server.ReportControls.Servicing Namespace


RemoteEndpoint Class Members

RemoteEndpoint Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls.Servicing Namespace : RemoteEndpoint Class

The following tables list the members exposed by RemoteEndpoint.

Public Constructors
 | Name | Description
Public Constructor | RemoteEndpoint Constructor | Creates new remote endpoint event arguments.
Top
Public Properties
 | Name | Description
Public Property | Address | Gets or sets the address of the remote endpoint.
Public Property | SecurityToken | Gets or sets the security token to communicate with the remote service.
Top
See Also

Reference

RemoteEndpoint Class
ActiveReports.Server.ReportControls.Servicing Namespace


RemoteEndpoint Constructor

RemoteEndpoint Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls.Servicing Namespace > RemoteEndpoint Class : RemoteEndpoint Constructor
Creates new remote endpoint event arguments.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public RemoteEndpoint()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RemoteEndpoint Class
RemoteEndpoint Members


RemoteEndpoint Class Properties

RemoteEndpoint Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls.Servicing Namespace : RemoteEndpoint Class

For a list of all members of this type, see RemoteEndpoint members.

Public Properties
 | Name | Description
Public Property | Address | Gets or sets the address of the remote endpoint.
Public Property | SecurityToken | Gets or sets the security token to communicate with the remote service.
Top
See Also

Reference

RemoteEndpoint Class
ActiveReports.Server.ReportControls.Servicing Namespace


Address Property

Address Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls.Servicing Namespace > RemoteEndpoint Class : Address Property
Gets or sets the address of the remote endpoint.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Address As String
public string Address {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RemoteEndpoint Class
RemoteEndpoint Members


SecurityToken Property (RemoteEndpoint)

SecurityToken Property (RemoteEndpoint)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls.Servicing Namespace > RemoteEndpoint Class : SecurityToken Property
Gets or sets the security token to communicate with the remote service.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SecurityToken As String
public string SecurityToken {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RemoteEndpoint Class
RemoteEndpoint Members


ServiceChannelFactory<TServiceChannel> Class

ServiceChannelFactory<TServiceChannel> Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls.Servicing Namespace : ServiceChannelFactory<TServiceChannel> Class
The type of the service channel.
Represents the factory to create an instance of the specified service channel.
Object Model
ServiceChannelFactory<TServiceChannel> Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit NotInheritable Class ServiceChannelFactory(Of TServiceChannel As IClientChannel)
public static class ServiceChannelFactory<TServiceChannel>
where TServiceChannel: IClientChannel
Type Parameters
TServiceChannel
The type of the service channel.
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportControls.Servicing.ServiceChannelFactory<TServiceChannel>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ServiceChannelFactory<TServiceChannel> Members
ActiveReports.Server.ReportControls.Servicing Namespace


ServiceChannelFactory<TServiceChannel> Class Members

ServiceChannelFactory<TServiceChannel> Class Members
Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls.Servicing Namespace : ServiceChannelFactory<TServiceChannel> Class

The following tables list the members exposed by ServiceChannelFactory<TServiceChannel>.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Create | Overloaded. Creates a service channel for default client configuration.
Top
See Also

Reference

ServiceChannelFactory<TServiceChannel> Class
ActiveReports.Server.ReportControls.Servicing Namespace


ServiceChannelFactory<TServiceChannel> Class Methods

ServiceChannelFactory<TServiceChannel> Class Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls.Servicing Namespace : ServiceChannelFactory<TServiceChannel> Class

For a list of all members of this type, see ServiceChannelFactory<TServiceChannel> members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Create | Overloaded. Creates a service channel for default client configuration.
Top
See Also

Reference

ServiceChannelFactory<TServiceChannel> Class
ActiveReports.Server.ReportControls.Servicing Namespace


Create Method (ServiceChannelFactory<TServiceChannel>)

Create Method (ServiceChannelFactory<TServiceChannel>)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls.Servicing Namespace > ServiceChannelFactory<TServiceChannel> Class : Create Method
Creates a service channel for default client configuration.
Overload List
Overload | Description
Create() | Creates a service channel for default client configuration.
Create(String) | Creates a service channel for the specified configuration name.
Create(Binding,EndpointAddress) | Creates a service channel for the specified binding and endpoint.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ServiceChannelFactory<TServiceChannel> Class
ServiceChannelFactory<TServiceChannel> Members


Create() Method

Create() Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls.Servicing Namespace > ServiceChannelFactory<TServiceChannel> Class > Create Method : Create() Method
Creates a service channel for default client configuration.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Create() As TServiceChannel
public static TServiceChannel Create()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ServiceChannelFactory<TServiceChannel> Class
ServiceChannelFactory<TServiceChannel> Members
Overload List


Create(String) Method

Create(String) Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls.Servicing Namespace > ServiceChannelFactory<TServiceChannel> Class > Create Method : Create(String) Method
The configuration name used for the endpoint.
Creates a service channel for the specified configuration name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Create( _
   ByVal endpointConfigurationName As String _
) As TServiceChannel
public static TServiceChannel Create(
   string endpointConfigurationName
)

Parameters

endpointConfigurationName
The configuration name used for the endpoint.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ServiceChannelFactory<TServiceChannel> Class
ServiceChannelFactory<TServiceChannel> Members
Overload List


Create(Binding,EndpointAddress) Method

Create(Binding,EndpointAddress) Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls.Servicing Namespace > ServiceChannelFactory<TServiceChannel> Class > Create Method : Create(Binding,EndpointAddress) Method
The System.ServiceModel.Channels.Binding used to configure the endpoint.
The System.ServiceModel.EndpointAddress that provides the location of the service.
Creates a service channel for the specified binding and endpoint.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Create( _
   ByVal binding As Binding, _
   ByVal remoteAddress As EndpointAddress _
) As TServiceChannel
public static TServiceChannel Create(
   Binding binding,
   EndpointAddress remoteAddress
)

Parameters

binding
The System.ServiceModel.Channels.Binding used to configure the endpoint.
remoteAddress
The System.ServiceModel.EndpointAddress that provides the location of the service.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ServiceChannelFactory<TServiceChannel> Class
ServiceChannelFactory<TServiceChannel> Members
Overload List


ServiceProxyBase Class

ServiceProxyBase Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls.Servicing Namespace : ServiceProxyBase Class
Represents the proxy base stuff.
Object Model
ServiceProxyBase Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class ServiceProxyBase
public abstract class ServiceProxyBase
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportControls.Servicing.ServiceProxyBase

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ServiceProxyBase Members
ActiveReports.Server.ReportControls.Servicing Namespace


ServiceProxyBase Class Members

ServiceProxyBase Class Members
Methods Events

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls.Servicing Namespace : ServiceProxyBase Class

The following tables list the members exposed by ServiceProxyBase.

Protected Methods
 | Name | Description
Protected Method | ResolveSecurityToken | Resolves the security token.
Protected Method | RetrieveRemoteEndpoint | Retrieves the remote endpoint configuration.
Top
Public Events
 | Name | Description
Public Event | ResolveRemoteEndpoint | Occurs when before delegating an operation to a remote server to resolve it's address and credentials to use.
Top
See Also

Reference

ServiceProxyBase Class
ActiveReports.Server.ReportControls.Servicing Namespace


ServiceProxyBase Class Methods

ServiceProxyBase Class Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls.Servicing Namespace : ServiceProxyBase Class

For a list of all members of this type, see ServiceProxyBase members.

Protected Methods
 | Name | Description
Protected Method | ResolveSecurityToken | Resolves the security token.
Protected Method | RetrieveRemoteEndpoint | Retrieves the remote endpoint configuration.
Top
See Also

Reference

ServiceProxyBase Class
ActiveReports.Server.ReportControls.Servicing Namespace


ResolveSecurityToken Method

ResolveSecurityToken Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls.Servicing Namespace > ServiceProxyBase Class : ResolveSecurityToken Method
The address.
The username.
The password.
Resolves the security token.
Syntax
  • Visual Basic
  • C#
'Declaration

Protected MustOverride Function ResolveSecurityToken( _
   ByVal address As String, _
   ByVal username As String, _
   ByVal password As String _
) As String
protected abstract string ResolveSecurityToken(
   string address,
   string username,
   string password
)

Parameters

address
The address.
username
The username.
password
The password.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ServiceProxyBase Class
ServiceProxyBase Members


RetrieveRemoteEndpoint Method

RetrieveRemoteEndpoint Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls.Servicing Namespace > ServiceProxyBase Class : RetrieveRemoteEndpoint Method
Retrieves the remote endpoint configuration.
Syntax
  • Visual Basic
  • C#
'Declaration

Protected Overridable Function RetrieveRemoteEndpoint() As RemoteEndpoint
protected virtual RemoteEndpoint RetrieveRemoteEndpoint()

Return Value

The remote endpoint.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ServiceProxyBase Class
ServiceProxyBase Members


ServiceProxyBase Class Events

ServiceProxyBase Class Events

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls.Servicing Namespace : ServiceProxyBase Class

For a list of all members of this type, see ServiceProxyBase members.

Public Events
 | Name | Description
Public Event | ResolveRemoteEndpoint | Occurs when before delegating an operation to a remote server to resolve it's address and credentials to use.
Top
See Also

Reference

ServiceProxyBase Class
ActiveReports.Server.ReportControls.Servicing Namespace


ResolveRemoteEndpoint Event

ResolveRemoteEndpoint Event

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls.Servicing Namespace > ServiceProxyBase Class : ResolveRemoteEndpoint Event
Occurs when before delegating an operation to a remote server to resolve it's address and credentials to use.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ResolveRemoteEndpoint As Action(Of RemoteEndpoint)
public event Action<RemoteEndpoint> ResolveRemoteEndpoint
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ServiceProxyBase Class
ServiceProxyBase Members


ActiveReports.Server.ReportServices.Contracts Namespace

ActiveReports.Server.ReportServices.Contracts Namespace
Inheritance Hierarchy
ActiveReports.Server.ReportControls Assembly : ActiveReports.Server.ReportServices.Contracts Namespace
Classes
 | Class | Description
Class | DataArrayResult | Represents an object that is returned as a result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation and contains base 64 encoded data.
Class | DataResult | Represents an object that is returned as a result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation and contains base 64 encoded data.
Class | DescriptionFilter | Represents a filter restricting the result of an operation.
Class | ExportOptions | Represents options for the export document operation.
Class | ItemDescriptionsResult | Represents an object that is returned as a result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation and contains an array of item descriptons.
Class | LookupData | Represents the result of lookup query.
Class | LookupField | Represents the field of lookup result.
Class | LookupFieldValues | Represents the field value collection of lookup result.
Class | LookupResult | Represents the result of lookup query.
Class | PermissionRecord | Represents information about report in the storage.
Class | Query | Represents a query defining the result of the select operation.
Class | RelayoutOptions | Represents options for the relayout document operation.
Class | RenderOptions | Represents options for rendering operation.
Class | ReportParameter | Represents a report parameter.
Class | ReportParametersResult | Represents an object that is returned as a result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService.GetParameterList operation and contains an array of report parameter descriptions.
Class | ReportVersionFilter | Represents a report version filter.
Class | RequestInfo | Defines status information on user's task request.
Class | RequestResult | Defines a result contract for a request operation.
Class | ResourcePermissionsResult | Represents an object that is returned as a result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation and contains an array of resource permissions.
Class | Result | Represents an object that is returned as a result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Class | StyleDescription | Represents information about style in the storage.
Class | ThemeDescription | Represents information about theme in the storage.
Class | UploadOptions | Represents a set of options for upload operation.
Class | UserCapabilities | Represents user capabilities.
Class | UserCapabilitiesResult | Represents the result containing user capabilities.
Enumerations
 | Enumeration | Description
Enumeration | DescriptionType | Represents a description types.
Enumeration | OverwriteBehavior | Defines the behavior for resource overwriting.
Enumeration | ReportParameterDomain | Represents supported report parameter domains.
Enumeration | RequestState | Specifies the state of a user request.
Enumeration | StorageType | Represents supported storage types.
See Also

Reference

ActiveReports.Server.ReportControls Assembly


DataArrayResult Class

DataArrayResult Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : DataArrayResult Class
Represents an object that is returned as a result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation and contains base 64 encoded data.
Object Model
DataArrayResult ClassError Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class DataArrayResult
   Inherits Result
public class DataArrayResult : Result
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Result
ActiveReports.Server.ReportServices.Contracts.DataArrayResult

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataArrayResult Members
ActiveReports.Server.ReportServices.Contracts Namespace


DataArrayResult Class Members

DataArrayResult Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : DataArrayResult Class

The following tables list the members exposed by DataArrayResult.

Public Constructors
 | Name | Description
Public Constructor | DataArrayResult Constructor | Creates new data array result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Top
Public Properties
 | Name | Description
Public Property | Data | Gets or sets the base 64 encoded data.
Public Property | Error | An error occurred during operation execution that should be returned to client. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Public Property | IsAuthenticated | Gets a value that indicates whether the user has been authenticated. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Top
See Also

Reference

DataArrayResult Class
ActiveReports.Server.ReportServices.Contracts Namespace


DataArrayResult Constructor

DataArrayResult Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > DataArrayResult Class : DataArrayResult Constructor
Creates new data array result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public DataArrayResult()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataArrayResult Class
DataArrayResult Members


DataArrayResult Class Properties

DataArrayResult Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : DataArrayResult Class

For a list of all members of this type, see DataArrayResult members.

Public Properties
 | Name | Description
Public Property | Data | Gets or sets the base 64 encoded data.
Public Property | Error | An error occurred during operation execution that should be returned to client. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Public Property | IsAuthenticated | Gets a value that indicates whether the user has been authenticated. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Top
See Also

Reference

DataArrayResult Class
ActiveReports.Server.ReportServices.Contracts Namespace


Data Property (DataArrayResult)

Data Property (DataArrayResult)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > DataArrayResult Class : Data Property
Gets or sets the base 64 encoded data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Data As String()
public string[] Data {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataArrayResult Class
DataArrayResult Members


DataResult Class

DataResult Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : DataResult Class
Represents an object that is returned as a result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation and contains base 64 encoded data.
Object Model
DataResult ClassError Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class DataResult
   Inherits Result
public class DataResult : Result
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Result
ActiveReports.Server.ReportServices.Contracts.DataResult

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataResult Members
ActiveReports.Server.ReportServices.Contracts Namespace


DataResult Class Members

DataResult Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : DataResult Class

The following tables list the members exposed by DataResult.

Public Constructors
 | Name | Description
Public Constructor | DataResult Constructor | Creates new data result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Top
Public Properties
 | Name | Description
Public Property | Data | Gets or sets the base 64 encoded data.
Public Property | Error | An error occurred during operation execution that should be returned to client. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Public Property | IsAuthenticated | Gets a value that indicates whether the user has been authenticated. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Top
See Also

Reference

DataResult Class
ActiveReports.Server.ReportServices.Contracts Namespace


DataResult Constructor

DataResult Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > DataResult Class : DataResult Constructor
Creates new data result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public DataResult()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataResult Class
DataResult Members


DataResult Class Properties

DataResult Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : DataResult Class

For a list of all members of this type, see DataResult members.

Public Properties
 | Name | Description
Public Property | Data | Gets or sets the base 64 encoded data.
Public Property | Error | An error occurred during operation execution that should be returned to client. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Public Property | IsAuthenticated | Gets a value that indicates whether the user has been authenticated. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Top
See Also

Reference

DataResult Class
ActiveReports.Server.ReportServices.Contracts Namespace


Data Property (DataResult)

Data Property (DataResult)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > DataResult Class : Data Property
Gets or sets the base 64 encoded data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Data As String
public string Data {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataResult Class
DataResult Members


DescriptionFilter Class

DescriptionFilter Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : DescriptionFilter Class
Represents a filter restricting the result of an operation.
Object Model
DescriptionFilter Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class DescriptionFilter
public class DescriptionFilter
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.DescriptionFilter
ActiveReports.Server.ReportServices.Contracts.ReportVersionFilter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DescriptionFilter Members
ActiveReports.Server.ReportServices.Contracts Namespace


DescriptionFilter Class Members

DescriptionFilter Class Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : DescriptionFilter Class

The following tables list the members exposed by DescriptionFilter.

Public Constructors
 | Name | Description
Public Constructor | DescriptionFilter Constructor | Initializes a new instance of the DescriptionFilter class.
Top
See Also

Reference

DescriptionFilter Class
ActiveReports.Server.ReportServices.Contracts Namespace


DescriptionFilter Constructor

DescriptionFilter Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > DescriptionFilter Class : DescriptionFilter Constructor
Initializes a new instance of the DescriptionFilter class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public DescriptionFilter()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DescriptionFilter Class
DescriptionFilter Members


ExportOptions Class

ExportOptions Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : ExportOptions Class
Represents options for the export document operation.
Object Model
ExportOptions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ExportOptions
public class ExportOptions
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.ExportOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportOptions Members
ActiveReports.Server.ReportServices.Contracts Namespace


ExportOptions Class Members

ExportOptions Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : ExportOptions Class

The following tables list the members exposed by ExportOptions.

Public Constructors
 | Name | Description
Public Constructor | ExportOptions Constructor | Creates new options for the export document of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Top
Public Properties
 | Name | Description
Public Property | DocumentId | Gets or sets the document id.
Public Property | Extension | Gets or sets the name for export extension to use.
Public Property | ExtensionSettings | Gets or sets the additional settings for rendering extension.
Public Property | InteractivityState | Gets or sets the interactivity actions history.
Top
See Also

Reference

ExportOptions Class
ActiveReports.Server.ReportServices.Contracts Namespace


ExportOptions Constructor

ExportOptions Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ExportOptions Class : ExportOptions Constructor
Creates new options for the export document of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ExportOptions()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportOptions Class
ExportOptions Members


ExportOptions Class Properties

ExportOptions Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : ExportOptions Class

For a list of all members of this type, see ExportOptions members.

Public Properties
 | Name | Description
Public Property | DocumentId | Gets or sets the document id.
Public Property | Extension | Gets or sets the name for export extension to use.
Public Property | ExtensionSettings | Gets or sets the additional settings for rendering extension.
Public Property | InteractivityState | Gets or sets the interactivity actions history.
Top
See Also

Reference

ExportOptions Class
ActiveReports.Server.ReportServices.Contracts Namespace


DocumentId Property (ExportOptions)

DocumentId Property (ExportOptions)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ExportOptions Class : DocumentId Property
Gets or sets the document id.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DocumentId As String
public string DocumentId {get; set;}

Property Value

The document id.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportOptions Class
ExportOptions Members


Extension Property (ExportOptions)

Extension Property (ExportOptions)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ExportOptions Class : Extension Property
Gets or sets the name for export extension to use.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Extension As String
public string Extension {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportOptions Class
ExportOptions Members


ExtensionSettings Property (ExportOptions)

ExtensionSettings Property (ExportOptions)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ExportOptions Class : ExtensionSettings Property
Gets or sets the additional settings for rendering extension.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ExtensionSettings As Dictionary(Of String,String)
public Dictionary<string,string> ExtensionSettings {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportOptions Class
ExportOptions Members


InteractivityState Property (ExportOptions)

InteractivityState Property (ExportOptions)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ExportOptions Class : InteractivityState Property
Gets or sets the interactivity actions history.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property InteractivityState As String()
public string[] InteractivityState {get; set;}

Property Value

The interactivity actions history values.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExportOptions Class
ExportOptions Members


ItemDescriptionsResult Class

ItemDescriptionsResult Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : ItemDescriptionsResult Class
Represents an object that is returned as a result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation and contains an array of item descriptons.
Object Model
ItemDescriptionsResult ClassError ClassItemDescription Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ItemDescriptionsResult
   Inherits Result
public sealed class ItemDescriptionsResult : Result
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Result
ActiveReports.Server.ReportServices.Contracts.ItemDescriptionsResult

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemDescriptionsResult Members
ActiveReports.Server.ReportServices.Contracts Namespace


ItemDescriptionsResult Class Members

ItemDescriptionsResult Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : ItemDescriptionsResult Class

The following tables list the members exposed by ItemDescriptionsResult.

Public Constructors
 | Name | Description
Public Constructor | ItemDescriptionsResult Constructor | Creates new item descriptions result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Top
Public Properties
 | Name | Description
Public Property | Error | An error occurred during operation execution that should be returned to client. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Public Property | IsAuthenticated | Gets a value that indicates whether the user has been authenticated. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Public Property | ItemDescriptions | Gets or sets an array of item descriptions.
Top
See Also

Reference

ItemDescriptionsResult Class
ActiveReports.Server.ReportServices.Contracts Namespace


ItemDescriptionsResult Constructor

ItemDescriptionsResult Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ItemDescriptionsResult Class : ItemDescriptionsResult Constructor
Creates new item descriptions result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ItemDescriptionsResult()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemDescriptionsResult Class
ItemDescriptionsResult Members


ItemDescriptionsResult Class Properties

ItemDescriptionsResult Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : ItemDescriptionsResult Class

For a list of all members of this type, see ItemDescriptionsResult members.

Public Properties
 | Name | Description
Public Property | Error | An error occurred during operation execution that should be returned to client. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Public Property | IsAuthenticated | Gets a value that indicates whether the user has been authenticated. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Public Property | ItemDescriptions | Gets or sets an array of item descriptions.
Top
See Also

Reference

ItemDescriptionsResult Class
ActiveReports.Server.ReportServices.Contracts Namespace


ItemDescriptions Property

ItemDescriptions Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ItemDescriptionsResult Class : ItemDescriptions Property
Gets or sets an array of item descriptions.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ItemDescriptions As ItemDescription()
public ItemDescription[] ItemDescriptions {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemDescriptionsResult Class
ItemDescriptionsResult Members


LookupData Class

LookupData Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : LookupData Class
Represents the result of lookup query.
Object Model
LookupData ClassLookupField Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class LookupData
public class LookupData
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.LookupData

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LookupData Members
ActiveReports.Server.ReportServices.Contracts Namespace


LookupData Class Members

LookupData Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : LookupData Class

The following tables list the members exposed by LookupData.

Public Constructors
 | Name | Description
Public Constructor | LookupData Constructor | Initializes a new instance of the LookupData class.
Top
Public Properties
 | Name | Description
Public Property | Fields | Gets or sets the fields.
Public Property | RecordCount | Gets or sets the record count in the result.
Top
See Also

Reference

LookupData Class
ActiveReports.Server.ReportServices.Contracts Namespace


LookupData Constructor

LookupData Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > LookupData Class : LookupData Constructor
Initializes a new instance of the LookupData class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public LookupData()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LookupData Class
LookupData Members


LookupData Class Properties

LookupData Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : LookupData Class

For a list of all members of this type, see LookupData members.

Public Properties
 | Name | Description
Public Property | Fields | Gets or sets the fields.
Public Property | RecordCount | Gets or sets the record count in the result.
Top
See Also

Reference

LookupData Class
ActiveReports.Server.ReportServices.Contracts Namespace


Fields Property

Fields Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > LookupData Class : Fields Property
Gets or sets the fields.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Fields As LookupField()
public LookupField[] Fields {get; set;}

Property Value

The fields.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LookupData Class
LookupData Members


RecordCount Property

RecordCount Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > LookupData Class : RecordCount Property
Gets or sets the record count in the result.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RecordCount As Integer
public int RecordCount {get; set;}

Property Value

The record count.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LookupData Class
LookupData Members


LookupField Class

LookupField Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : LookupField Class
Represents the field of lookup result.
Object Model
LookupField ClassLookupFieldValues Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class LookupField
public class LookupField
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.LookupField

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LookupField Members
ActiveReports.Server.ReportServices.Contracts Namespace


LookupField Class Members

LookupField Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : LookupField Class

The following tables list the members exposed by LookupField.

Public Constructors
 | Name | Description
Public Constructor | LookupField Constructor | Initializes a new instance of the LookupField class.
Top
Public Properties
 | Name | Description
Public Property | Name | Gets or sets the field name.
Public Property | Values | Gets or sets the field values.
Top
See Also

Reference

LookupField Class
ActiveReports.Server.ReportServices.Contracts Namespace


LookupField Constructor

LookupField Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > LookupField Class : LookupField Constructor
Initializes a new instance of the LookupField class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public LookupField()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LookupField Class
LookupField Members


LookupField Class Properties

LookupField Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : LookupField Class

For a list of all members of this type, see LookupField members.

Public Properties
 | Name | Description
Public Property | Name | Gets or sets the field name.
Public Property | Values | Gets or sets the field values.
Top
See Also

Reference

LookupField Class
ActiveReports.Server.ReportServices.Contracts Namespace


Name Property (LookupField)

Name Property (LookupField)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > LookupField Class : Name Property
Gets or sets the field name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As String
public string Name {get; set;}

Property Value

The field name.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LookupField Class
LookupField Members


Values Property (LookupField)

Values Property (LookupField)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > LookupField Class : Values Property
Gets or sets the field values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Values As LookupFieldValues
public LookupFieldValues Values {get; set;}

Property Value

The field values.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LookupField Class
LookupField Members


LookupFieldValues Class

LookupFieldValues Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : LookupFieldValues Class
Represents the field value collection of lookup result.
Object Model
LookupFieldValues Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class LookupFieldValues
   Inherits System.Collections.Generic.List(Of Object)
public class LookupFieldValues : System.Collections.Generic.List<object>
Inheritance Hierarchy

System.Object
System.Collections.Generic.List<T>
ActiveReports.Server.ReportServices.Contracts.LookupFieldValues

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LookupFieldValues Members
ActiveReports.Server.ReportServices.Contracts Namespace


LookupFieldValues Class Members

LookupFieldValues Class Members
Properties Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : LookupFieldValues Class

The following tables list the members exposed by LookupFieldValues.

Public Constructors
 | Name | Description
Public Constructor | LookupFieldValues Constructor | Initializes a new instance of the LookupFieldValues class.
Top
Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from System.Collections.Generic.List<object>)
Public Property | Count | Gets the number of elements contained in the List. (Inherited from System.Collections.Generic.List<object>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.Generic.List<object>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the List. (Inherited from System.Collections.Generic.List<object>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the List. (Inherited from System.Collections.Generic.List<object>)
Public Method | AsReadOnly | Returns a read-only ReadOnlyCollection wrapper for the current collection. (Inherited from System.Collections.Generic.List<object>)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<object>)
Public Method | Clear | Removes all elements from the List. (Inherited from System.Collections.Generic.List<object>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from System.Collections.Generic.List<object>)
Public Method | ConvertAll | Converts the elements in the current List to another type, and returns a list containing the converted elements. (Inherited from System.Collections.Generic.List<object>)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<object>)
Public Method | Exists | Determines whether the List contains elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<object>)
Public Method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List. (Inherited from System.Collections.Generic.List<object>)
Public Method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<object>)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<object>)
Public Method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List. (Inherited from System.Collections.Generic.List<object>)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<object>)
Public Method | ForEach | Performs the specified action on each element of the List. (Inherited from System.Collections.Generic.List<object>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from System.Collections.Generic.List<object>)
Public Method | GetRange | Creates a shallow copy of a range of elements in the source List. (Inherited from System.Collections.Generic.List<object>)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<object>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from System.Collections.Generic.List<object>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from System.Collections.Generic.List<object>)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<object>)
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from System.Collections.Generic.List<object>)
Public Method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<object>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from System.Collections.Generic.List<object>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from System.Collections.Generic.List<object>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from System.Collections.Generic.List<object>)
Public Method | Sort | Overloaded. Sorts the elements in the entire List using the default comparer. (Inherited from System.Collections.Generic.List<object>)
Public Method | ToArray | Copies the elements of the List to a new array. (Inherited from System.Collections.Generic.List<object>)
Public Method | TrimExcess | Sets the capacity to the actual number of elements in the List, if that number is less than a threshold value. (Inherited from System.Collections.Generic.List<object>)
Public Method | TrueForAll | Determines whether every element in the List matches the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<object>)
Top
See Also

Reference

LookupFieldValues Class
ActiveReports.Server.ReportServices.Contracts Namespace


LookupFieldValues Constructor

LookupFieldValues Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > LookupFieldValues Class : LookupFieldValues Constructor
Initializes a new instance of the LookupFieldValues class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public LookupFieldValues()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LookupFieldValues Class
LookupFieldValues Members


LookupResult Class

LookupResult Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : LookupResult Class
Represents the result of lookup query.
Object Model
LookupResult ClassLookupData ClassError Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class LookupResult
   Inherits Result
public sealed class LookupResult : Result
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Result
ActiveReports.Server.ReportServices.Contracts.LookupResult

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LookupResult Members
ActiveReports.Server.ReportServices.Contracts Namespace


LookupResult Class Members

LookupResult Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : LookupResult Class

The following tables list the members exposed by LookupResult.

Public Constructors
 | Name | Description
Public Constructor | LookupResult Constructor | Creates new lookup result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Top
Public Properties
 | Name | Description
Public Property | Data | Gets or sets the result data of lookup query.
Public Property | Error | An error occurred during operation execution that should be returned to client. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Public Property | IsAuthenticated | Gets a value that indicates whether the user has been authenticated. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Top
See Also

Reference

LookupResult Class
ActiveReports.Server.ReportServices.Contracts Namespace


LookupResult Constructor

LookupResult Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > LookupResult Class : LookupResult Constructor
Creates new lookup result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public LookupResult()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LookupResult Class
LookupResult Members


LookupResult Class Properties

LookupResult Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : LookupResult Class

For a list of all members of this type, see LookupResult members.

Public Properties
 | Name | Description
Public Property | Data | Gets or sets the result data of lookup query.
Public Property | Error | An error occurred during operation execution that should be returned to client. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Public Property | IsAuthenticated | Gets a value that indicates whether the user has been authenticated. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Top
See Also

Reference

LookupResult Class
ActiveReports.Server.ReportServices.Contracts Namespace


Data Property (LookupResult)

Data Property (LookupResult)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > LookupResult Class : Data Property
Gets or sets the result data of lookup query.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Data As LookupData
public LookupData Data {get; set;}

Property Value

The result data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LookupResult Class
LookupResult Members


PermissionRecord Class

PermissionRecord Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : PermissionRecord Class
Represents information about report in the storage.
Object Model
PermissionRecord Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class PermissionRecord
public class PermissionRecord
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.PermissionRecord

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PermissionRecord Members
ActiveReports.Server.ReportServices.Contracts Namespace


PermissionRecord Class Members

PermissionRecord Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : PermissionRecord Class

The following tables list the members exposed by PermissionRecord.

Public Constructors
 | Name | Description
Public Constructor | PermissionRecord Constructor | Initializes a new instance of the PermissionRecord class.
Top
Public Properties
 | Name | Description
Public Property | IsMember | Gets or sets a value indicating whether the user belongs to the role.
Public Property | IsReadOnly | Gets or sets a value indicating whether this instance is read only.
Public Property | Permission | Gets or sets the the permissions assigned to the role.
Public Property | Role | Gets or sets the role name bound to the permissions.
Top
See Also

Reference

PermissionRecord Class
ActiveReports.Server.ReportServices.Contracts Namespace


PermissionRecord Constructor

PermissionRecord Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > PermissionRecord Class : PermissionRecord Constructor
Initializes a new instance of the PermissionRecord class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public PermissionRecord()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PermissionRecord Class
PermissionRecord Members


PermissionRecord Class Properties

PermissionRecord Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : PermissionRecord Class

For a list of all members of this type, see PermissionRecord members.

Public Properties
 | Name | Description
Public Property | IsMember | Gets or sets a value indicating whether the user belongs to the role.
Public Property | IsReadOnly | Gets or sets a value indicating whether this instance is read only.
Public Property | Permission | Gets or sets the the permissions assigned to the role.
Public Property | Role | Gets or sets the role name bound to the permissions.
Top
See Also

Reference

PermissionRecord Class
ActiveReports.Server.ReportServices.Contracts Namespace


IsMember Property

IsMember Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > PermissionRecord Class : IsMember Property
Gets or sets a value indicating whether the user belongs to the role.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsMember As Boolean
public bool IsMember {get; set;}

Property Value

true if the user is member of the role; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PermissionRecord Class
PermissionRecord Members


IsReadOnly Property

IsReadOnly Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > PermissionRecord Class : IsReadOnly Property
Gets or sets a value indicating whether this instance is read only.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsReadOnly As Boolean
public bool IsReadOnly {get; set;}

Property Value

true if this instance is read only; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PermissionRecord Class
PermissionRecord Members


Permission Property

Permission Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > PermissionRecord Class : Permission Property
Gets or sets the the permissions assigned to the role.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Permission As Byte
public byte Permission {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PermissionRecord Class
PermissionRecord Members


Role Property

Role Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > PermissionRecord Class : Role Property
Gets or sets the role name bound to the permissions.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Role As String
public string Role {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PermissionRecord Class
PermissionRecord Members


Query Class

Query Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : Query Class
Represents a query defining the result of the select operation.
Object Model
Query Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Query
public class Query
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Query

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Query Members
ActiveReports.Server.ReportServices.Contracts Namespace


Query Class Members

Query Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : Query Class

The following tables list the members exposed by Query.

Public Constructors
 | Name | Description
Public Constructor | Query Constructor | Initializes a new instance of the Query class.
Top
Public Properties
 | Name | Description
Public Property | FilterBy | Gets or sets the filter roles.
Public Property | OrderBy | Gets or sets the property name to use to sort out the data.
Top
See Also

Reference

Query Class
ActiveReports.Server.ReportServices.Contracts Namespace


Query Constructor

Query Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > Query Class : Query Constructor
Initializes a new instance of the Query class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Query()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Query Class
Query Members


Query Class Properties

Query Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : Query Class

For a list of all members of this type, see Query members.

Public Properties
 | Name | Description
Public Property | FilterBy | Gets or sets the filter roles.
Public Property | OrderBy | Gets or sets the property name to use to sort out the data.
Top
See Also

Reference

Query Class
ActiveReports.Server.ReportServices.Contracts Namespace


FilterBy Property

FilterBy Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > Query Class : FilterBy Property
Gets or sets the filter roles.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FilterBy As String
public string FilterBy {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Query Class
Query Members


OrderBy Property

OrderBy Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > Query Class : OrderBy Property
Gets or sets the property name to use to sort out the data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OrderBy As String
public string OrderBy {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Query Class
Query Members


RelayoutOptions Class

RelayoutOptions Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : RelayoutOptions Class
Represents options for the relayout document operation.
Object Model
RelayoutOptions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class RelayoutOptions
public class RelayoutOptions
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.RelayoutOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RelayoutOptions Members
ActiveReports.Server.ReportServices.Contracts Namespace


RelayoutOptions Class Members

RelayoutOptions Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : RelayoutOptions Class

The following tables list the members exposed by RelayoutOptions.

Public Constructors
 | Name | Description
Public Constructor | RelayoutOptions Constructor | Initializes a new instance of the RelayoutOptions class.
Top
Public Properties
 | Name | Description
Public Property | DocumentId | Gets or sets the document id.
Public Property | InteractivityState | Gets or sets the interactivity actions history.
Top
See Also

Reference

RelayoutOptions Class
ActiveReports.Server.ReportServices.Contracts Namespace


RelayoutOptions Constructor

RelayoutOptions Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > RelayoutOptions Class : RelayoutOptions Constructor
Initializes a new instance of the RelayoutOptions class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public RelayoutOptions()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RelayoutOptions Class
RelayoutOptions Members


RelayoutOptions Class Properties

RelayoutOptions Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : RelayoutOptions Class

For a list of all members of this type, see RelayoutOptions members.

Public Properties
 | Name | Description
Public Property | DocumentId | Gets or sets the document id.
Public Property | InteractivityState | Gets or sets the interactivity actions history.
Top
See Also

Reference

RelayoutOptions Class
ActiveReports.Server.ReportServices.Contracts Namespace


DocumentId Property (RelayoutOptions)

DocumentId Property (RelayoutOptions)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > RelayoutOptions Class : DocumentId Property
Gets or sets the document id.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DocumentId As String
public string DocumentId {get; set;}

Property Value

The document id.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RelayoutOptions Class
RelayoutOptions Members


InteractivityState Property (RelayoutOptions)

InteractivityState Property (RelayoutOptions)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > RelayoutOptions Class : InteractivityState Property
Gets or sets the interactivity actions history.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property InteractivityState As String()
public string[] InteractivityState {get; set;}

Property Value

The interactivity actions history values.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RelayoutOptions Class
RelayoutOptions Members


RenderOptions Class

RenderOptions Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : RenderOptions Class
Represents options for rendering operation.
Object Model
RenderOptions ClassReportParameter Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class RenderOptions
public class RenderOptions
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.RenderOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderOptions Members
ActiveReports.Server.ReportServices.Contracts Namespace


RenderOptions Class Members

RenderOptions Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : RenderOptions Class

The following tables list the members exposed by RenderOptions.

Public Constructors
 | Name | Description
Public Constructor | RenderOptions Constructor | Initializes a new instance of the RenderOptions class.
Top
Public Properties
 | Name | Description
Public Property | Extension | Gets or sets the name for rendering extension to use.
Public Property | ExtensionSettings | Gets or sets the additional settings for rendering extension.
Public Property | Name | Gets or sets the name for output preview file.
Public Property | ReportId | Gets or sets the identifier of the report to render.
Public Property | ReportParameters | Gets or sets the report parameters.
Public Property | ReportType | Gets or sets the type of the report.
Top
See Also

Reference

RenderOptions Class
ActiveReports.Server.ReportServices.Contracts Namespace


RenderOptions Constructor

RenderOptions Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > RenderOptions Class : RenderOptions Constructor
Initializes a new instance of the RenderOptions class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public RenderOptions()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderOptions Class
RenderOptions Members


RenderOptions Class Properties

RenderOptions Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : RenderOptions Class

For a list of all members of this type, see RenderOptions members.

Public Properties
 | Name | Description
Public Property | Extension | Gets or sets the name for rendering extension to use.
Public Property | ExtensionSettings | Gets or sets the additional settings for rendering extension.
Public Property | Name | Gets or sets the name for output preview file.
Public Property | ReportId | Gets or sets the identifier of the report to render.
Public Property | ReportParameters | Gets or sets the report parameters.
Public Property | ReportType | Gets or sets the type of the report.
Top
See Also

Reference

RenderOptions Class
ActiveReports.Server.ReportServices.Contracts Namespace


Extension Property (RenderOptions)

Extension Property (RenderOptions)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > RenderOptions Class : Extension Property
Gets or sets the name for rendering extension to use.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Extension As String
public string Extension {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderOptions Class
RenderOptions Members


ExtensionSettings Property (RenderOptions)

ExtensionSettings Property (RenderOptions)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > RenderOptions Class : ExtensionSettings Property
Gets or sets the additional settings for rendering extension.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ExtensionSettings As Dictionary(Of String,String)
public Dictionary<string,string> ExtensionSettings {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderOptions Class
RenderOptions Members


Name Property (RenderOptions)

Name Property (RenderOptions)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > RenderOptions Class : Name Property
Gets or sets the name for output preview file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As String
public string Name {get; set;}

Property Value

The name.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderOptions Class
RenderOptions Members


ReportId Property (RenderOptions)

ReportId Property (RenderOptions)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > RenderOptions Class : ReportId Property
Gets or sets the identifier of the report to render.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReportId As String
public string ReportId {get; set;}

Property Value

The report id.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderOptions Class
RenderOptions Members


ReportParameters Property (RenderOptions)

ReportParameters Property (RenderOptions)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > RenderOptions Class : ReportParameters Property
Gets or sets the report parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReportParameters As ReportParameter()
public ReportParameter[] ReportParameters {get; set;}

Property Value

The report parameters.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderOptions Class
RenderOptions Members


ReportType Property (RenderOptions)

ReportType Property (RenderOptions)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > RenderOptions Class : ReportType Property
Gets or sets the type of the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReportType As ReportType
public ReportType ReportType {get; set;}

Property Value

The type of the report.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RenderOptions Class
RenderOptions Members


ReportParameter Class

ReportParameter Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : ReportParameter Class
Represents a report parameter.
Object Model
ReportParameter Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ReportParameter
public class ReportParameter
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.ReportParameter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameter Members
ActiveReports.Server.ReportServices.Contracts Namespace


ReportParameter Class Members

ReportParameter Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : ReportParameter Class

The following tables list the members exposed by ReportParameter.

Public Constructors
 | Name | Description
Public Constructor | ReportParameter Constructor | Initializes a new instance of the ReportParameter class.
Top
Public Properties
 | Name | Description
Public Property | Domain | Gets or sets the parameter domain.
Public Property | Name | Gets or sets the report parameter name.
Public Property | Values | Gets or sets the report parameter values.
Top
See Also

Reference

ReportParameter Class
ActiveReports.Server.ReportServices.Contracts Namespace


ReportParameter Constructor

ReportParameter Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ReportParameter Class : ReportParameter Constructor
Initializes a new instance of the ReportParameter class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ReportParameter()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameter Class
ReportParameter Members


ReportParameter Class Properties

ReportParameter Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : ReportParameter Class

For a list of all members of this type, see ReportParameter members.

Public Properties
 | Name | Description
Public Property | Domain | Gets or sets the parameter domain.
Public Property | Name | Gets or sets the report parameter name.
Public Property | Values | Gets or sets the report parameter values.
Top
See Also

Reference

ReportParameter Class
ActiveReports.Server.ReportServices.Contracts Namespace


Domain Property

Domain Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ReportParameter Class : Domain Property
Gets or sets the parameter domain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Domain As ReportParameterDomain
public ReportParameterDomain Domain {get; set;}

Property Value

The parameter domain.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameter Class
ReportParameter Members


Name Property (ReportParameter)

Name Property (ReportParameter)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ReportParameter Class : Name Property
Gets or sets the report parameter name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As String
public string Name {get; set;}

Property Value

The report parameter name.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameter Class
ReportParameter Members


Values Property (ReportParameter)

Values Property (ReportParameter)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ReportParameter Class : Values Property
Gets or sets the report parameter values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Values As String()
public string[] Values {get; set;}

Property Value

The report parameter values.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameter Class
ReportParameter Members


ReportParametersResult Class

ReportParametersResult Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : ReportParametersResult Class
Represents an object that is returned as a result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService.GetParameterList operation and contains an array of report parameter descriptions.
Object Model
ReportParametersResult ClassError ClassReportParameterDescription Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ReportParametersResult
   Inherits Result
public class ReportParametersResult : Result
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Result
ActiveReports.Server.ReportServices.Contracts.ReportParametersResult

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParametersResult Members
ActiveReports.Server.ReportServices.Contracts Namespace


ReportParametersResult Class Members

ReportParametersResult Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : ReportParametersResult Class

The following tables list the members exposed by ReportParametersResult.

Public Constructors
 | Name | Description
Public Constructor | ReportParametersResult Constructor | Creates new report parameters result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Top
Public Properties
 | Name | Description
Public Property | Error | An error occurred during operation execution that should be returned to client. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Public Property | IsAuthenticated | Gets a value that indicates whether the user has been authenticated. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Public Property | Parameters | Gets or sets an array of report parameter descriptions.
Top
See Also

Reference

ReportParametersResult Class
ActiveReports.Server.ReportServices.Contracts Namespace


ReportParametersResult Constructor

ReportParametersResult Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ReportParametersResult Class : ReportParametersResult Constructor
Creates new report parameters result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ReportParametersResult()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParametersResult Class
ReportParametersResult Members


ReportParametersResult Class Properties

ReportParametersResult Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : ReportParametersResult Class

For a list of all members of this type, see ReportParametersResult members.

Public Properties
 | Name | Description
Public Property | Error | An error occurred during operation execution that should be returned to client. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Public Property | IsAuthenticated | Gets a value that indicates whether the user has been authenticated. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Public Property | Parameters | Gets or sets an array of report parameter descriptions.
Top
See Also

Reference

ReportParametersResult Class
ActiveReports.Server.ReportServices.Contracts Namespace


Parameters Property (ReportParametersResult)

Parameters Property (ReportParametersResult)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ReportParametersResult Class : Parameters Property
Gets or sets an array of report parameter descriptions.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Parameters As ReportParameterDescription()
public ReportParameterDescription[] Parameters {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParametersResult Class
ReportParametersResult Members


ReportVersionFilter Class

ReportVersionFilter Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : ReportVersionFilter Class
Represents a report version filter.
Object Model
ReportVersionFilter Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ReportVersionFilter
   Inherits DescriptionFilter
public sealed class ReportVersionFilter : DescriptionFilter
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.DescriptionFilter
ActiveReports.Server.ReportServices.Contracts.ReportVersionFilter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportVersionFilter Members
ActiveReports.Server.ReportServices.Contracts Namespace


ReportVersionFilter Class Members

ReportVersionFilter Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : ReportVersionFilter Class

The following tables list the members exposed by ReportVersionFilter.

Public Constructors
 | Name | Description
Public Constructor | ReportVersionFilter Constructor | Initializes a new instance of the ReportVersionFilter class.
Top
Public Properties
 | Name | Description
Public Property | ReportId | Gets or sets the report ID to get the version for.
Top
See Also

Reference

ReportVersionFilter Class
ActiveReports.Server.ReportServices.Contracts Namespace


ReportVersionFilter Constructor

ReportVersionFilter Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ReportVersionFilter Class : ReportVersionFilter Constructor
Initializes a new instance of the ReportVersionFilter class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ReportVersionFilter()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportVersionFilter Class
ReportVersionFilter Members


ReportVersionFilter Class Properties

ReportVersionFilter Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : ReportVersionFilter Class

For a list of all members of this type, see ReportVersionFilter members.

Public Properties
 | Name | Description
Public Property | ReportId | Gets or sets the report ID to get the version for.
Top
See Also

Reference

ReportVersionFilter Class
ActiveReports.Server.ReportServices.Contracts Namespace


ReportId Property (ReportVersionFilter)

ReportId Property (ReportVersionFilter)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ReportVersionFilter Class : ReportId Property
Gets or sets the report ID to get the version for.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReportId As String
public string ReportId {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportVersionFilter Class
ReportVersionFilter Members


RequestInfo Class

RequestInfo Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : RequestInfo Class
Defines status information on user's task request.
Object Model
RequestInfo ClassExceptionDetail Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class RequestInfo
public sealed class RequestInfo
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.RequestInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RequestInfo Members
ActiveReports.Server.ReportServices.Contracts Namespace


RequestInfo Class Members

RequestInfo Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : RequestInfo Class

The following tables list the members exposed by RequestInfo.

Public Constructors
 | Name | Description
Public Constructor | RequestInfo Constructor | Initializes a new instance of the RequestInfo class.
Top
Public Properties
 | Name | Description
Public Property | ErrorCode | Gets or sets the error code.
Public Property | ErrorData | Gets or sets the error data.
Public Property | Exception | Gets or sets the error occured during execution.
Public Property | PrimaryUrl | Gets or sets the URL of a primary resource where to get result of it's execution.
Public Property | RequestId | Gets or sets the request id.
Public Property | State | Gets or sets the current request state.
Top
See Also

Reference

RequestInfo Class
ActiveReports.Server.ReportServices.Contracts Namespace


RequestInfo Constructor

RequestInfo Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > RequestInfo Class : RequestInfo Constructor
Initializes a new instance of the RequestInfo class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public RequestInfo()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RequestInfo Class
RequestInfo Members


RequestInfo Class Properties

RequestInfo Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : RequestInfo Class

For a list of all members of this type, see RequestInfo members.

Public Properties
 | Name | Description
Public Property | ErrorCode | Gets or sets the error code.
Public Property | ErrorData | Gets or sets the error data.
Public Property | Exception | Gets or sets the error occured during execution.
Public Property | PrimaryUrl | Gets or sets the URL of a primary resource where to get result of it's execution.
Public Property | RequestId | Gets or sets the request id.
Public Property | State | Gets or sets the current request state.
Top
See Also

Reference

RequestInfo Class
ActiveReports.Server.ReportServices.Contracts Namespace


ErrorCode Property (RequestInfo)

ErrorCode Property (RequestInfo)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > RequestInfo Class : ErrorCode Property
Gets or sets the error code.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ErrorCode As String
public string ErrorCode {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RequestInfo Class
RequestInfo Members


ErrorData Property

ErrorData Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > RequestInfo Class : ErrorData Property
Gets or sets the error data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ErrorData As String()
public string[] ErrorData {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RequestInfo Class
RequestInfo Members


Exception Property (RequestInfo)

Exception Property (RequestInfo)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > RequestInfo Class : Exception Property
Gets or sets the error occured during execution.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Exception As ExceptionDetail
public ExceptionDetail Exception {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RequestInfo Class
RequestInfo Members


PrimaryUrl Property (RequestInfo)

PrimaryUrl Property (RequestInfo)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > RequestInfo Class : PrimaryUrl Property
Gets or sets the URL of a primary resource where to get result of it's execution.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PrimaryUrl As String
public string PrimaryUrl {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RequestInfo Class
RequestInfo Members


RequestId Property

RequestId Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > RequestInfo Class : RequestId Property
Gets or sets the request id.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RequestId As String
public string RequestId {get; set;}

Property Value

The request id.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RequestInfo Class
RequestInfo Members


State Property

State Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > RequestInfo Class : State Property
Gets or sets the current request state.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property State As RequestState
public RequestState State {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RequestInfo Class
RequestInfo Members


RequestResult Class

RequestResult Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : RequestResult Class
Defines a result contract for a request operation.
Object Model
RequestResult ClassError ClassRequestInfo Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class RequestResult
   Inherits Result
public class RequestResult : Result
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Result
ActiveReports.Server.ReportServices.Contracts.RequestResult

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RequestResult Members
ActiveReports.Server.ReportServices.Contracts Namespace


RequestResult Class Members

RequestResult Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : RequestResult Class

The following tables list the members exposed by RequestResult.

Public Constructors
 | Name | Description
Public Constructor | RequestResult Constructor | Creates new request result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Top
Public Properties
 | Name | Description
Public Property | Error | An error occurred during operation execution that should be returned to client. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Public Property | Info | Gets or sets the status information for a request.
Public Property | IsAuthenticated | Gets a value that indicates whether the user has been authenticated. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Top
See Also

Reference

RequestResult Class
ActiveReports.Server.ReportServices.Contracts Namespace


RequestResult Constructor

RequestResult Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > RequestResult Class : RequestResult Constructor
Creates new request result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public RequestResult()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RequestResult Class
RequestResult Members


RequestResult Class Properties

RequestResult Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : RequestResult Class

For a list of all members of this type, see RequestResult members.

Public Properties
 | Name | Description
Public Property | Error | An error occurred during operation execution that should be returned to client. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Public Property | Info | Gets or sets the status information for a request.
Public Property | IsAuthenticated | Gets a value that indicates whether the user has been authenticated. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Top
See Also

Reference

RequestResult Class
ActiveReports.Server.ReportServices.Contracts Namespace


Info Property

Info Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > RequestResult Class : Info Property
Gets or sets the status information for a request.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Info As RequestInfo
public RequestInfo Info {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RequestResult Class
RequestResult Members


ResourcePermissionsResult Class

ResourcePermissionsResult Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : ResourcePermissionsResult Class
Represents an object that is returned as a result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation and contains an array of resource permissions.
Object Model
ResourcePermissionsResult ClassError ClassPermissionRecord Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ResourcePermissionsResult
   Inherits Result
public class ResourcePermissionsResult : Result
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Result
ActiveReports.Server.ReportServices.Contracts.ResourcePermissionsResult

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourcePermissionsResult Members
ActiveReports.Server.ReportServices.Contracts Namespace


ResourcePermissionsResult Class Members

ResourcePermissionsResult Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : ResourcePermissionsResult Class

The following tables list the members exposed by ResourcePermissionsResult.

Public Constructors
 | Name | Description
Public Constructor | ResourcePermissionsResult Constructor | Creates new resource permissions result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Top
Public Properties
 | Name | Description
Public Property | Error | An error occurred during operation execution that should be returned to client. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Public Property | IsAuthenticated | Gets a value that indicates whether the user has been authenticated. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Public Property | IsOwner | Indicates whether current user is owner of report.
Public Property | Permissions | Gets or sets the permissions array.
Top
See Also

Reference

ResourcePermissionsResult Class
ActiveReports.Server.ReportServices.Contracts Namespace


ResourcePermissionsResult Constructor

ResourcePermissionsResult Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ResourcePermissionsResult Class : ResourcePermissionsResult Constructor
Creates new resource permissions result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ResourcePermissionsResult()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourcePermissionsResult Class
ResourcePermissionsResult Members


ResourcePermissionsResult Class Properties

ResourcePermissionsResult Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : ResourcePermissionsResult Class

For a list of all members of this type, see ResourcePermissionsResult members.

Public Properties
 | Name | Description
Public Property | Error | An error occurred during operation execution that should be returned to client. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Public Property | IsAuthenticated | Gets a value that indicates whether the user has been authenticated. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Public Property | IsOwner | Indicates whether current user is owner of report.
Public Property | Permissions | Gets or sets the permissions array.
Top
See Also

Reference

ResourcePermissionsResult Class
ActiveReports.Server.ReportServices.Contracts Namespace


IsOwner Property

IsOwner Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ResourcePermissionsResult Class : IsOwner Property
Indicates whether current user is owner of report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsOwner As Boolean
public bool IsOwner {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourcePermissionsResult Class
ResourcePermissionsResult Members


Permissions Property (ResourcePermissionsResult)

Permissions Property (ResourcePermissionsResult)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ResourcePermissionsResult Class : Permissions Property
Gets or sets the permissions array.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Permissions As PermissionRecord()
public PermissionRecord[] Permissions {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourcePermissionsResult Class
ResourcePermissionsResult Members


Result Class

Result Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : Result Class
Represents an object that is returned as a result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Object Model
Result ClassError Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Result
public class Result
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Result
ActiveReports.Server.ReportServices.Contracts.DataArrayResult
ActiveReports.Server.ReportServices.Contracts.DataResult
ActiveReports.Server.ReportServices.Contracts.ItemDescriptionsResult
ActiveReports.Server.ReportServices.Contracts.LookupResult
ActiveReports.Server.ReportServices.Contracts.Policy.PolicyHistoryResult
ActiveReports.Server.ReportServices.Contracts.Policy.PolicyResult
ActiveReports.Server.ReportServices.Contracts.ReportParametersResult
ActiveReports.Server.ReportServices.Contracts.RequestResult
ActiveReports.Server.ReportServices.Contracts.ResourcePermissionsResult
ActiveReports.Server.ReportServices.Contracts.UserCapabilitiesResult

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Result Members
ActiveReports.Server.ReportServices.Contracts Namespace


Result Class Members

Result Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : Result Class

The following tables list the members exposed by Result.

Public Constructors
 | Name | Description
Public Constructor | Result Constructor | Creates new result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Top
Public Properties
 | Name | Description
Public Property | Error | An error occurred during operation execution that should be returned to client.
Public Property | IsAuthenticated | Gets a value that indicates whether the user has been authenticated.
Top
See Also

Reference

Result Class
ActiveReports.Server.ReportServices.Contracts Namespace


Result Constructor

Result Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > Result Class : Result Constructor
Creates new result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Result()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Result Class
Result Members


Result Class Properties

Result Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : Result Class

For a list of all members of this type, see Result members.

Public Properties
 | Name | Description
Public Property | Error | An error occurred during operation execution that should be returned to client.
Public Property | IsAuthenticated | Gets a value that indicates whether the user has been authenticated.
Top
See Also

Reference

Result Class
ActiveReports.Server.ReportServices.Contracts Namespace


Error Property

Error Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > Result Class : Error Property
An error occurred during operation execution that should be returned to client.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Error As Error
public Error Error {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Result Class
Result Members


IsAuthenticated Property

IsAuthenticated Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > Result Class : IsAuthenticated Property
Gets a value that indicates whether the user has been authenticated.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsAuthenticated As Boolean
public bool IsAuthenticated {get; set;}

Property Value

true if the user was authenticated; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Result Class
Result Members


StyleDescription Class

StyleDescription Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : StyleDescription Class
Represents information about style in the storage.
Object Model
StyleDescription Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class StyleDescription
   Inherits ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription
public class StyleDescription : ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription
ActiveReports.Server.ReportServices.Contracts.StyleDescription

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleDescription Members
ActiveReports.Server.ReportServices.Contracts Namespace


StyleDescription Class Members

StyleDescription Class Members
Properties Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : StyleDescription Class

The following tables list the members exposed by StyleDescription.

Public Constructors
 | Name | Description
Public Constructor | StyleDescription Constructor | Initializes a new instance of the StyleDescription class.
Top
Public Properties
 | Name | Description
Public Property | CreatedBy | Gets the user name created the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | CreationDate | Gets or sets the item creation date. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Id | Gets or sets the identifier for the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedBy | Gets the user name who made the last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedDate | Gets or sets the date of last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Name | Gets or sets the name of the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Permissions | Gets or sets the item permissions. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Top
Public Methods
 | Name | Description
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Top
See Also

Reference

StyleDescription Class
ActiveReports.Server.ReportServices.Contracts Namespace


StyleDescription Constructor

StyleDescription Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > StyleDescription Class : StyleDescription Constructor
Initializes a new instance of the StyleDescription class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public StyleDescription()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StyleDescription Class
StyleDescription Members


ThemeDescription Class

ThemeDescription Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : ThemeDescription Class
Represents information about theme in the storage.
Object Model
ThemeDescription Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ThemeDescription
   Inherits ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription
public class ThemeDescription : ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription
ActiveReports.Server.ReportServices.Contracts.ThemeDescription

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeDescription Members
ActiveReports.Server.ReportServices.Contracts Namespace


ThemeDescription Class Members

ThemeDescription Class Members
Properties Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : ThemeDescription Class

The following tables list the members exposed by ThemeDescription.

Public Constructors
 | Name | Description
Public Constructor | ThemeDescription Constructor | Initializes a new instance of the ThemeDescription class.
Top
Public Properties
 | Name | Description
Public Property | Accent1 | Gets or sets the accent 1 color of the theme.
Public Property | Accent2 | Gets or sets the accent 2 color of the theme.
Public Property | Accent3 | Gets or sets the accent 3 color of the theme.
Public Property | Accent4 | Gets or sets the accent 4 color of the theme.
Public Property | Accent5 | Gets or sets the accent 5 color of the theme.
Public Property | Accent6 | Gets or sets the accent 6 color of the theme.
Public Property | CreatedBy | Gets the user name created the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | CreationDate | Gets or sets the item creation date. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Dark1 | Gets or sets the dark 1 color of the theme.
Public Property | Dark2 | Gets or sets the dark 2 color of the theme.
Public Property | Id | Gets or sets the identifier for the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | IsDefault | Gets or sets a value indicating whether this theme is default.
Public Property | Light1 | Gets or sets the light 1 color of the theme.
Public Property | Light2 | Gets or sets the light 2 color of the theme.
Public Property | MajorFontFamily | Gets or sets the major font family of the theme.
Public Property | MajorFontSize | Gets or sets the major font size of the theme.
Public Property | MajorFontStyle | Gets or sets the major font style of the theme.
Public Property | MajorFontWeight | Gets or sets the major font weight of the theme.
Public Property | MinorFontFamily | Gets or sets the minor font family of the theme.
Public Property | MinorFontSize | Gets or sets the minor font size of the theme.
Public Property | MinorFontStyle | Gets or sets the minor font style of the theme.
Public Property | MinorFontWeight | Gets or sets the minor font weight of the theme.
Public Property | ModifiedBy | Gets the user name who made the last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedDate | Gets or sets the date of last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Name | Gets or sets the name of the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Permissions | Gets or sets the item permissions. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ThemeUri | Gets or sets the URL of the theme.
Top
Public Methods
 | Name | Description
Public Method | ToString | Returns a System.String that represents the current System.Object.
Top
See Also

Reference

ThemeDescription Class
ActiveReports.Server.ReportServices.Contracts Namespace


ThemeDescription Constructor

ThemeDescription Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ThemeDescription Class : ThemeDescription Constructor
Initializes a new instance of the ThemeDescription class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ThemeDescription()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeDescription Class
ThemeDescription Members


ThemeDescription Class Methods

ThemeDescription Class Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : ThemeDescription Class

For a list of all members of this type, see ThemeDescription members.

Public Methods
 | Name | Description
Public Method | ToString | Returns a System.String that represents the current System.Object.
Top
See Also

Reference

ThemeDescription Class
ActiveReports.Server.ReportServices.Contracts Namespace


ToString Method (ThemeDescription)

ToString Method (ThemeDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ThemeDescription Class : ToString Method
Returns a System.String that represents the current System.Object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As String
public override string ToString()

Return Value

A System.String that represents the current System.Object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeDescription Class
ThemeDescription Members
Base Implementation in ToString


ThemeDescription Class Properties

ThemeDescription Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : ThemeDescription Class

For a list of all members of this type, see ThemeDescription members.

Public Properties
 | Name | Description
Public Property | Accent1 | Gets or sets the accent 1 color of the theme.
Public Property | Accent2 | Gets or sets the accent 2 color of the theme.
Public Property | Accent3 | Gets or sets the accent 3 color of the theme.
Public Property | Accent4 | Gets or sets the accent 4 color of the theme.
Public Property | Accent5 | Gets or sets the accent 5 color of the theme.
Public Property | Accent6 | Gets or sets the accent 6 color of the theme.
Public Property | CreatedBy | Gets the user name created the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | CreationDate | Gets or sets the item creation date. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Dark1 | Gets or sets the dark 1 color of the theme.
Public Property | Dark2 | Gets or sets the dark 2 color of the theme.
Public Property | Id | Gets or sets the identifier for the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | IsDefault | Gets or sets a value indicating whether this theme is default.
Public Property | Light1 | Gets or sets the light 1 color of the theme.
Public Property | Light2 | Gets or sets the light 2 color of the theme.
Public Property | MajorFontFamily | Gets or sets the major font family of the theme.
Public Property | MajorFontSize | Gets or sets the major font size of the theme.
Public Property | MajorFontStyle | Gets or sets the major font style of the theme.
Public Property | MajorFontWeight | Gets or sets the major font weight of the theme.
Public Property | MinorFontFamily | Gets or sets the minor font family of the theme.
Public Property | MinorFontSize | Gets or sets the minor font size of the theme.
Public Property | MinorFontStyle | Gets or sets the minor font style of the theme.
Public Property | MinorFontWeight | Gets or sets the minor font weight of the theme.
Public Property | ModifiedBy | Gets the user name who made the last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedDate | Gets or sets the date of last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Name | Gets or sets the name of the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Permissions | Gets or sets the item permissions. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ThemeUri | Gets or sets the URL of the theme.
Top
See Also

Reference

ThemeDescription Class
ActiveReports.Server.ReportServices.Contracts Namespace


Accent1 Property

Accent1 Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ThemeDescription Class : Accent1 Property
Gets or sets the accent 1 color of the theme.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Accent1 As String
public string Accent1 {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeDescription Class
ThemeDescription Members


Accent2 Property

Accent2 Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ThemeDescription Class : Accent2 Property
Gets or sets the accent 2 color of the theme.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Accent2 As String
public string Accent2 {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeDescription Class
ThemeDescription Members


Accent3 Property

Accent3 Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ThemeDescription Class : Accent3 Property
Gets or sets the accent 3 color of the theme.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Accent3 As String
public string Accent3 {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeDescription Class
ThemeDescription Members


Accent4 Property

Accent4 Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ThemeDescription Class : Accent4 Property
Gets or sets the accent 4 color of the theme.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Accent4 As String
public string Accent4 {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeDescription Class
ThemeDescription Members


Accent5 Property

Accent5 Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ThemeDescription Class : Accent5 Property
Gets or sets the accent 5 color of the theme.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Accent5 As String
public string Accent5 {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeDescription Class
ThemeDescription Members


Accent6 Property

Accent6 Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ThemeDescription Class : Accent6 Property
Gets or sets the accent 6 color of the theme.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Accent6 As String
public string Accent6 {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeDescription Class
ThemeDescription Members


Dark1 Property

Dark1 Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ThemeDescription Class : Dark1 Property
Gets or sets the dark 1 color of the theme.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Dark1 As String
public string Dark1 {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeDescription Class
ThemeDescription Members


Dark2 Property

Dark2 Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ThemeDescription Class : Dark2 Property
Gets or sets the dark 2 color of the theme.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Dark2 As String
public string Dark2 {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeDescription Class
ThemeDescription Members


IsDefault Property

IsDefault Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ThemeDescription Class : IsDefault Property
Gets or sets a value indicating whether this theme is default.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsDefault As Boolean
public bool IsDefault {get; set;}

Property Value

true if this theme is default; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeDescription Class
ThemeDescription Members


Light1 Property

Light1 Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ThemeDescription Class : Light1 Property
Gets or sets the light 1 color of the theme.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Light1 As String
public string Light1 {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeDescription Class
ThemeDescription Members


Light2 Property

Light2 Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ThemeDescription Class : Light2 Property
Gets or sets the light 2 color of the theme.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Light2 As String
public string Light2 {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeDescription Class
ThemeDescription Members


MajorFontFamily Property

MajorFontFamily Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ThemeDescription Class : MajorFontFamily Property
Gets or sets the major font family of the theme.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MajorFontFamily As String
public string MajorFontFamily {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeDescription Class
ThemeDescription Members


MajorFontSize Property

MajorFontSize Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ThemeDescription Class : MajorFontSize Property
Gets or sets the major font size of the theme.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MajorFontSize As String
public string MajorFontSize {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeDescription Class
ThemeDescription Members


MajorFontStyle Property

MajorFontStyle Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ThemeDescription Class : MajorFontStyle Property
Gets or sets the major font style of the theme.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MajorFontStyle As String
public string MajorFontStyle {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeDescription Class
ThemeDescription Members


MajorFontWeight Property

MajorFontWeight Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ThemeDescription Class : MajorFontWeight Property
Gets or sets the major font weight of the theme.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MajorFontWeight As String
public string MajorFontWeight {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeDescription Class
ThemeDescription Members


MinorFontFamily Property

MinorFontFamily Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ThemeDescription Class : MinorFontFamily Property
Gets or sets the minor font family of the theme.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MinorFontFamily As String
public string MinorFontFamily {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeDescription Class
ThemeDescription Members


MinorFontSize Property

MinorFontSize Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ThemeDescription Class : MinorFontSize Property
Gets or sets the minor font size of the theme.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MinorFontSize As String
public string MinorFontSize {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeDescription Class
ThemeDescription Members


MinorFontStyle Property

MinorFontStyle Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ThemeDescription Class : MinorFontStyle Property
Gets or sets the minor font style of the theme.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MinorFontStyle As String
public string MinorFontStyle {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeDescription Class
ThemeDescription Members


MinorFontWeight Property

MinorFontWeight Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ThemeDescription Class : MinorFontWeight Property
Gets or sets the minor font weight of the theme.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MinorFontWeight As String
public string MinorFontWeight {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeDescription Class
ThemeDescription Members


ThemeUri Property

ThemeUri Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > ThemeDescription Class : ThemeUri Property
Gets or sets the URL of the theme.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ThemeUri As String
public string ThemeUri {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ThemeDescription Class
ThemeDescription Members


UploadOptions Class

UploadOptions Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : UploadOptions Class
Represents a set of options for upload operation.
Object Model
UploadOptions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class UploadOptions
public class UploadOptions
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.UploadOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UploadOptions Members
ActiveReports.Server.ReportServices.Contracts Namespace


UploadOptions Class Members

UploadOptions Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : UploadOptions Class

The following tables list the members exposed by UploadOptions.

Public Constructors
 | Name | Description
Public Constructor | UploadOptions Constructor | Initializes a new instance of the UploadOptions class.
Top
Public Properties
 | Name | Description
Public Property | ConnectionString | Defines new connection string to use with uploading model.
Public Property | Overwrite | Defines whether resource should be overwritten (if exists).
Public Property | OverwriteBehavior | Defines behavior which should be used for overwriting existing resources.
Public Property | SkipResourceValidation | Defines whether resource validation should be skipped or not.
Top
See Also

Reference

UploadOptions Class
ActiveReports.Server.ReportServices.Contracts Namespace


UploadOptions Constructor

UploadOptions Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > UploadOptions Class : UploadOptions Constructor
Initializes a new instance of the UploadOptions class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public UploadOptions()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UploadOptions Class
UploadOptions Members


UploadOptions Class Properties

UploadOptions Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : UploadOptions Class

For a list of all members of this type, see UploadOptions members.

Public Properties
 | Name | Description
Public Property | ConnectionString | Defines new connection string to use with uploading model.
Public Property | Overwrite | Defines whether resource should be overwritten (if exists).
Public Property | OverwriteBehavior | Defines behavior which should be used for overwriting existing resources.
Public Property | SkipResourceValidation | Defines whether resource validation should be skipped or not.
Top
See Also

Reference

UploadOptions Class
ActiveReports.Server.ReportServices.Contracts Namespace


ConnectionString Property

ConnectionString Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > UploadOptions Class : ConnectionString Property
Defines new connection string to use with uploading model.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ConnectionString As String
public string ConnectionString {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UploadOptions Class
UploadOptions Members


Overwrite Property

Overwrite Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > UploadOptions Class : Overwrite Property
Defines whether resource should be overwritten (if exists).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Overwrite As Boolean
public bool Overwrite {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UploadOptions Class
UploadOptions Members


OverwriteBehavior Property

OverwriteBehavior Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > UploadOptions Class : OverwriteBehavior Property
Defines behavior which should be used for overwriting existing resources.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OverwriteBehavior As OverwriteBehavior
public OverwriteBehavior OverwriteBehavior {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UploadOptions Class
UploadOptions Members


SkipResourceValidation Property

SkipResourceValidation Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > UploadOptions Class : SkipResourceValidation Property
Defines whether resource validation should be skipped or not.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SkipResourceValidation As Boolean
public bool SkipResourceValidation {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UploadOptions Class
UploadOptions Members


UserCapabilities Class

UserCapabilities Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : UserCapabilities Class
Represents user capabilities.
Object Model
UserCapabilities Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class UserCapabilities
public class UserCapabilities
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.UserCapabilities

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserCapabilities Members
ActiveReports.Server.ReportServices.Contracts Namespace


UserCapabilities Class Members

UserCapabilities Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : UserCapabilities Class

The following tables list the members exposed by UserCapabilities.

Public Constructors
 | Name | Description
Public Constructor | UserCapabilities Constructor | Initializes a new instance of the UserCapabilities class.
Top
Public Properties
 | Name | Description
Public Property | Email | Gets or sets the user email.
Public Property | HasAdminPrivileges | Gets or sets a value indicating whether a user has the administrative privileges.
Public Property | IsDesignPermitted | Gets or sets a value indicating whether the report designer is accessible.
Public Property | IsEvaluationVersion | Gets or sets a value indicating whether this system is evaluating.
Public Property | IsSchedulePermitted | Gets or sets a value indicating whether a scheduling is permitted.
Top
See Also

Reference

UserCapabilities Class
ActiveReports.Server.ReportServices.Contracts Namespace


UserCapabilities Constructor

UserCapabilities Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > UserCapabilities Class : UserCapabilities Constructor
Initializes a new instance of the UserCapabilities class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public UserCapabilities()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserCapabilities Class
UserCapabilities Members


UserCapabilities Class Properties

UserCapabilities Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : UserCapabilities Class

For a list of all members of this type, see UserCapabilities members.

Public Properties
 | Name | Description
Public Property | Email | Gets or sets the user email.
Public Property | HasAdminPrivileges | Gets or sets a value indicating whether a user has the administrative privileges.
Public Property | IsDesignPermitted | Gets or sets a value indicating whether the report designer is accessible.
Public Property | IsEvaluationVersion | Gets or sets a value indicating whether this system is evaluating.
Public Property | IsSchedulePermitted | Gets or sets a value indicating whether a scheduling is permitted.
Top
See Also

Reference

UserCapabilities Class
ActiveReports.Server.ReportServices.Contracts Namespace


Email Property (UserCapabilities)

Email Property (UserCapabilities)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > UserCapabilities Class : Email Property
Gets or sets the user email.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Email As String
public string Email {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserCapabilities Class
UserCapabilities Members


HasAdminPrivileges Property

HasAdminPrivileges Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > UserCapabilities Class : HasAdminPrivileges Property
Gets or sets a value indicating whether a user has the administrative privileges.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HasAdminPrivileges As Boolean
public bool HasAdminPrivileges {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserCapabilities Class
UserCapabilities Members


IsDesignPermitted Property

IsDesignPermitted Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > UserCapabilities Class : IsDesignPermitted Property
Gets or sets a value indicating whether the report designer is accessible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsDesignPermitted As Boolean
public bool IsDesignPermitted {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserCapabilities Class
UserCapabilities Members


IsEvaluationVersion Property

IsEvaluationVersion Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > UserCapabilities Class : IsEvaluationVersion Property
Gets or sets a value indicating whether this system is evaluating.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsEvaluationVersion As Boolean
public bool IsEvaluationVersion {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserCapabilities Class
UserCapabilities Members


IsSchedulePermitted Property

IsSchedulePermitted Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > UserCapabilities Class : IsSchedulePermitted Property
Gets or sets a value indicating whether a scheduling is permitted.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsSchedulePermitted As Boolean
public bool IsSchedulePermitted {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserCapabilities Class
UserCapabilities Members


UserCapabilitiesResult Class

UserCapabilitiesResult Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : UserCapabilitiesResult Class
Represents the result containing user capabilities.
Object Model
UserCapabilitiesResult ClassUserCapabilities ClassError Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class UserCapabilitiesResult
   Inherits Result
public sealed class UserCapabilitiesResult : Result
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Result
ActiveReports.Server.ReportServices.Contracts.UserCapabilitiesResult

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserCapabilitiesResult Members
ActiveReports.Server.ReportServices.Contracts Namespace


UserCapabilitiesResult Class Members

UserCapabilitiesResult Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : UserCapabilitiesResult Class

The following tables list the members exposed by UserCapabilitiesResult.

Public Constructors
 | Name | Description
Public Constructor | UserCapabilitiesResult Constructor | Creates new user cababilities result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Top
Public Properties
 | Name | Description
Public Property | Capabilities | Gets or sets the user capabilities.
Public Property | Error | An error occurred during operation execution that should be returned to client. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Public Property | IsAuthenticated | Gets a value that indicates whether the user has been authenticated. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Top
See Also

Reference

UserCapabilitiesResult Class
ActiveReports.Server.ReportServices.Contracts Namespace


UserCapabilitiesResult Constructor

UserCapabilitiesResult Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > UserCapabilitiesResult Class : UserCapabilitiesResult Constructor
Creates new user cababilities result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public UserCapabilitiesResult()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserCapabilitiesResult Class
UserCapabilitiesResult Members


UserCapabilitiesResult Class Properties

UserCapabilitiesResult Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : UserCapabilitiesResult Class

For a list of all members of this type, see UserCapabilitiesResult members.

Public Properties
 | Name | Description
Public Property | Capabilities | Gets or sets the user capabilities.
Public Property | Error | An error occurred during operation execution that should be returned to client. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Public Property | IsAuthenticated | Gets a value that indicates whether the user has been authenticated. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Top
See Also

Reference

UserCapabilitiesResult Class
ActiveReports.Server.ReportServices.Contracts Namespace


Capabilities Property

Capabilities Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace > UserCapabilitiesResult Class : Capabilities Property
Gets or sets the user capabilities.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capabilities As UserCapabilities
public UserCapabilities Capabilities {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserCapabilitiesResult Class
UserCapabilitiesResult Members


DescriptionType Enumeration

DescriptionType Enumeration

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : DescriptionType Enumeration
Represents a description types.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum DescriptionType
   Inherits System.Enum
public enum DescriptionType : System.Enum
Members
Member | Description
Assembly | Represents an assembly
Model | Represents a semantic model
Report | Represents a report
Style | Represents a style
Theme | Represents a theme
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveReports.Server.ReportServices.Contracts.DescriptionType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReports.Server.ReportServices.Contracts Namespace


OverwriteBehavior Enumeration

OverwriteBehavior Enumeration

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : OverwriteBehavior Enumeration
Defines the behavior for resource overwriting.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum OverwriteBehavior
   Inherits System.Enum
public enum OverwriteBehavior : System.Enum
Members
Member | Description
CreateNew | Defines whether resource should be considered as new resource.
ReplaceExisting | Defines whether existing resource should be replaced.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveReports.Server.ReportServices.Contracts.OverwriteBehavior

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReports.Server.ReportServices.Contracts Namespace


ReportParameterDomain Enumeration

ReportParameterDomain Enumeration

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : ReportParameterDomain Enumeration
Represents supported report parameter domains.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ReportParameterDomain
   Inherits System.Enum
public enum ReportParameterDomain : System.Enum
Members
Member | Description
AcceptingDynamicValues | Specifies that the specified values contains values that will be dynamically evaluated at runtime.
SelectAll | Specifies that the all valid values are set.
SpecifiedValues | Specifies that the values will be specified in the value collection.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveReports.Server.ReportServices.Contracts.ReportParameterDomain

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReports.Server.ReportServices.Contracts Namespace


RequestState Enumeration

RequestState Enumeration

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : RequestState Enumeration
Specifies the state of a user request.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum RequestState
   Inherits System.Enum
public enum RequestState : System.Enum
Members
Member | Description
Accomplished | Indicates that request task was accomplished.
Cancelled | Indicates that request was cancelled.
Pending | Indicates that request is in a request queue.
Rejected | Indicates that request was rejected.
Running | Indicates that request execution was started.
Unavailable | Indicates that request status information is not available due to connection problems or another reason.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveReports.Server.ReportServices.Contracts.RequestState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReports.Server.ReportServices.Contracts Namespace


StorageType Enumeration

StorageType Enumeration

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : StorageType Enumeration
Represents supported storage types.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum StorageType
   Inherits System.Enum
public enum StorageType : System.Enum
Members
Member | Description
Assembly | Specifies type for assembly.
ModelDraft | Specifies type for semantic model draft in the storage. For internal use only.
ModelVersion | Specifies type for semantic model version.
Report | Specifies type for report storage.
ReportVersion | Specifies type for report version.
Resource | Specifies type for resources, e.g. images, fonts, etc...
SharedPolicyTemplate | Specifies type for shared policy templates.
Smdl | Specifies type for semantic model storage.
Style | Specifies type for style storage.
Theme | Specifies type for theme storage.
UploadedFile | Specifies type for temporary uploaded files.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveReports.Server.ReportServices.Contracts.StorageType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReports.Server.ReportServices.Contracts Namespace


ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace

ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace
Inheritance Hierarchy
ActiveReports.Server.ReportControls Assembly : ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace
Classes
 | Class | Description
Class | AssemblyDescription | Represents information about an assembly in storage.
Class | DescriptionExt | Extension methods for ItemDescription class.
Class | ItemDescription | Represents base information about storage item.
Class | ReportDescription | Represents information about report in the storage.
Class | ReportParameterDescription | Represents information about report parameter.
Class | ReportVersionDescription | Represents information about report in the storage.
Class | ResourceDescription | Represents information about a resource in storage.
Class | SemanticModelDescription | Represents information about semantic model in the storage.
Class | SemanticModelDraftDescription | Represents information about semantic model draft in the storage.
Class | SemanticModelVersionDescription | Represents information about semantic model in the storage.
Class | SharedPolicyTemplateDescription | Represents information about shared policy template resource in the storage.
Class | TemporaryItemDescription | Represents information about temporary resource in the storage.
See Also

Reference

ActiveReports.Server.ReportControls Assembly


AssemblyDescription Class

AssemblyDescription Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : AssemblyDescription Class
Represents information about an assembly in storage.
Object Model
AssemblyDescription Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class AssemblyDescription
   Inherits ItemDescription
public class AssemblyDescription : ItemDescription
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription
ActiveReports.Server.ReportServices.Contracts.Descriptions.AssemblyDescription

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AssemblyDescription Members
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


AssemblyDescription Class Members

AssemblyDescription Class Members
Properties Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : AssemblyDescription Class

The following tables list the members exposed by AssemblyDescription.

Public Constructors
 | Name | Description
Public Constructor | AssemblyDescription Constructor | Initializes a new instance of the AssemblyDescription class.
Top
Public Properties
 | Name | Description
Public Property | CreatedBy | Gets the user name created the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | CreationDate | Gets or sets the item creation date. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Id | Gets or sets the identifier for the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedBy | Gets the user name who made the last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedDate | Gets or sets the date of last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Name | Gets or sets the name of the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Permissions | Gets or sets the item permissions. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Top
Public Methods
 | Name | Description
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Top
See Also

Reference

AssemblyDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


AssemblyDescription Constructor

AssemblyDescription Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > AssemblyDescription Class : AssemblyDescription Constructor
Initializes a new instance of the AssemblyDescription class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public AssemblyDescription()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AssemblyDescription Class
AssemblyDescription Members


DescriptionExt Class

DescriptionExt Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : DescriptionExt Class
Extension methods for ItemDescription class.
Object Model
DescriptionExt Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit NotInheritable Class DescriptionExt
public static class DescriptionExt
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Descriptions.DescriptionExt

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DescriptionExt Members
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


DescriptionExt Class Members

DescriptionExt Class Members
Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : DescriptionExt Class

The following tables list the members exposed by DescriptionExt.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | GetStorageType | Calls ItemDescription.GetStorageType method.
Top
See Also

Reference

DescriptionExt Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


DescriptionExt Class Methods

DescriptionExt Class Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : DescriptionExt Class

For a list of all members of this type, see DescriptionExt members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | GetStorageType | Calls ItemDescription.GetStorageType method.
Top
See Also

Reference

DescriptionExt Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


GetStorageType Method (DescriptionExt)

GetStorageType Method (DescriptionExt)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > DescriptionExt Class : GetStorageType Method
Calls ItemDescription.GetStorageType method.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function GetStorageType( _
   ByVal d As ItemDescription _
) As StorageType
public static StorageType GetStorageType(
   ItemDescription d
)

Parameters

d
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DescriptionExt Class
DescriptionExt Members


ItemDescription Class

ItemDescription Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : ItemDescription Class
Represents base information about storage item.
Object Model
ItemDescription Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ItemDescription
public class ItemDescription
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription
ActiveReports.Server.ReportServices.Contracts.Descriptions.AssemblyDescription
ActiveReports.Server.ReportServices.Contracts.Descriptions.ReportDescription
ActiveReports.Server.ReportServices.Contracts.Descriptions.ReportVersionDescription
ActiveReports.Server.ReportServices.Contracts.Descriptions.ResourceDescription
ActiveReports.Server.ReportServices.Contracts.Descriptions.SemanticModelDescription
ActiveReports.Server.ReportServices.Contracts.Descriptions.SemanticModelDraftDescription
ActiveReports.Server.ReportServices.Contracts.Descriptions.SemanticModelVersionDescription
ActiveReports.Server.ReportServices.Contracts.Descriptions.SharedPolicyTemplateDescription
ActiveReports.Server.ReportServices.Contracts.Descriptions.TemporaryItemDescription
ActiveReports.Server.ReportServices.Contracts.StyleDescription
ActiveReports.Server.ReportServices.Contracts.ThemeDescription

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemDescription Members
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


ItemDescription Class Members

ItemDescription Class Members
Properties Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : ItemDescription Class

The following tables list the members exposed by ItemDescription.

Public Constructors
 | Name | Description
Public Constructor | ItemDescription Constructor | Initializes a new instance of the ItemDescription class.
Top
Public Properties
 | Name | Description
Public Property | CreatedBy | Gets the user name created the item.
Public Property | CreationDate | Gets or sets the item creation date.
Public Property | Id | Gets or sets the identifier for the item.
Public Property | ModifiedBy | Gets the user name who made the last item modification.
Public Property | ModifiedDate | Gets or sets the date of last item modification.
Public Property | Name | Gets or sets the name of the item.
Public Property | Permissions | Gets or sets the item permissions.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | GetStorageType | Gets a ActiveReports.Server.ReportServices.Contracts.StorageType for specified System.Type of inheritor of ItemDescription class.
Public Method | ToString | Returns a System.String that represents the current System.Object.
Top
See Also

Reference

ItemDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


ItemDescription Constructor

ItemDescription Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ItemDescription Class : ItemDescription Constructor
Initializes a new instance of the ItemDescription class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ItemDescription()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemDescription Class
ItemDescription Members


ItemDescription Class Methods

ItemDescription Class Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : ItemDescription Class

For a list of all members of this type, see ItemDescription members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | GetStorageType | Gets a ActiveReports.Server.ReportServices.Contracts.StorageType for specified System.Type of inheritor of ItemDescription class.
Public Method | ToString | Returns a System.String that represents the current System.Object.
Top
See Also

Reference

ItemDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


GetStorageType Method (ItemDescription)

GetStorageType Method (ItemDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ItemDescription Class : GetStorageType Method
Base type fo mapping.
Gets a ActiveReports.Server.ReportServices.Contracts.StorageType for specified System.Type of inheritor of ItemDescription class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function GetStorageType( _
   ByVal descriptionType As Type _
) As StorageType
public static StorageType GetStorageType(
   Type descriptionType
)

Parameters

descriptionType
Base type fo mapping.

Return Value

Mapped ActiveReports.Server.ReportServices.Contracts.StorageType.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemDescription Class
ItemDescription Members


ToString Method (ItemDescription)

ToString Method (ItemDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ItemDescription Class : ToString Method
Returns a System.String that represents the current System.Object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As String
public override string ToString()

Return Value

A System.String that represents the current System.Object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemDescription Class
ItemDescription Members
Base Implementation in ToString


ItemDescription Class Properties

ItemDescription Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : ItemDescription Class

For a list of all members of this type, see ItemDescription members.

Public Properties
 | Name | Description
Public Property | CreatedBy | Gets the user name created the item.
Public Property | CreationDate | Gets or sets the item creation date.
Public Property | Id | Gets or sets the identifier for the item.
Public Property | ModifiedBy | Gets the user name who made the last item modification.
Public Property | ModifiedDate | Gets or sets the date of last item modification.
Public Property | Name | Gets or sets the name of the item.
Public Property | Permissions | Gets or sets the item permissions.
Top
See Also

Reference

ItemDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


CreatedBy Property (ItemDescription)

CreatedBy Property (ItemDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ItemDescription Class : CreatedBy Property
Gets the user name created the item.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CreatedBy As String
public string CreatedBy {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemDescription Class
ItemDescription Members


CreationDate Property (ItemDescription)

CreationDate Property (ItemDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ItemDescription Class : CreationDate Property
Gets or sets the item creation date.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CreationDate As Date
public DateTime CreationDate {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemDescription Class
ItemDescription Members


Id Property (ItemDescription)

Id Property (ItemDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ItemDescription Class : Id Property
Gets or sets the identifier for the item.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Id As String
public string Id {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemDescription Class
ItemDescription Members


ModifiedBy Property (ItemDescription)

ModifiedBy Property (ItemDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ItemDescription Class : ModifiedBy Property
Gets the user name who made the last item modification.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ModifiedBy As String
public string ModifiedBy {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemDescription Class
ItemDescription Members


ModifiedDate Property (ItemDescription)

ModifiedDate Property (ItemDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ItemDescription Class : ModifiedDate Property
Gets or sets the date of last item modification.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ModifiedDate As Date
public DateTime ModifiedDate {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemDescription Class
ItemDescription Members


Name Property (ItemDescription)

Name Property (ItemDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ItemDescription Class : Name Property
Gets or sets the name of the item.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As String
public string Name {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemDescription Class
ItemDescription Members


Permissions Property (ItemDescription)

Permissions Property (ItemDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ItemDescription Class : Permissions Property
Gets or sets the item permissions.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Permissions As Byte
public byte Permissions {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ItemDescription Class
ItemDescription Members


ReportDescription Class

ReportDescription Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : ReportDescription Class
Represents information about report in the storage.
Object Model
ReportDescription Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ReportDescription
   Inherits ItemDescription
public class ReportDescription : ItemDescription
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription
ActiveReports.Server.ReportServices.Contracts.Descriptions.ReportDescription

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDescription Members
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


ReportDescription Class Members

ReportDescription Class Members
Properties Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : ReportDescription Class

The following tables list the members exposed by ReportDescription.

Public Constructors
 | Name | Description
Public Constructor | ReportDescription Constructor | Initializes a new instance of the ReportDescription class.
Top
Public Properties
 | Name | Description
Public Property | AssemblyResourceId | Gets or sets id of assembly resource required for code-based section reports.
Public Property | ClassName | Gets or sets code-based section report full class name.
Public Property | CreatedBy | Gets the user name created the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | CreationDate | Gets or sets the item creation date. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Description | Gets or sets a report description.
Public Property | Id | Gets or sets the identifier for the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | IsBroken | Gets or sets the value indicating whether the report is broken for a recent model version.
Public Property | IsParametrized | Gets or sets the value indicating whether the report contains parameters.
Public Property | LastChangeComment | Gets or sets a last change comment.
Public Property | MasterReportIds | Gets or sets the master report IDs.
Public Property | ModelId | Gets or sets a model ID.
Public Property | ModelName | Gets or sets the bound model name.
Public Property | ModelPermissions | Gets or sets the permissions of a model bound to the report.
Public Property | ModelVersion | Gets or sets a model ID.
Public Property | ModifiedBy | Gets the user name who made the last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedDate | Gets or sets the date of last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Name | Gets or sets the name of the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Permissions | Gets or sets the item permissions. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ReportType | Gets or sets a report type.
Public Property | SubreportIds | Gets or sets the subreport IDs.
Public Property | ThemeId | Gets or sets theme id that the report is referenced to.
Public Property | Version | Gets or sets a report version.
Top
Public Methods
 | Name | Description
Public Method | ToString | Returns a System.String that represents the current System.Object.
Top
See Also

Reference

ReportDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


ReportDescription Constructor

ReportDescription Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportDescription Class : ReportDescription Constructor
Initializes a new instance of the ReportDescription class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ReportDescription()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDescription Class
ReportDescription Members


ReportDescription Class Methods

ReportDescription Class Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : ReportDescription Class

For a list of all members of this type, see ReportDescription members.

Public Methods
 | Name | Description
Public Method | ToString | Returns a System.String that represents the current System.Object.
Top
See Also

Reference

ReportDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


ToString Method (ReportDescription)

ToString Method (ReportDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportDescription Class : ToString Method
Returns a System.String that represents the current System.Object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As String
public override string ToString()

Return Value

A System.String that represents the current System.Object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDescription Class
ReportDescription Members
Base Implementation in ToString


ReportDescription Class Properties

ReportDescription Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : ReportDescription Class

For a list of all members of this type, see ReportDescription members.

Public Properties
 | Name | Description
Public Property | AssemblyResourceId | Gets or sets id of assembly resource required for code-based section reports.
Public Property | ClassName | Gets or sets code-based section report full class name.
Public Property | CreatedBy | Gets the user name created the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | CreationDate | Gets or sets the item creation date. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Description | Gets or sets a report description.
Public Property | Id | Gets or sets the identifier for the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | IsBroken | Gets or sets the value indicating whether the report is broken for a recent model version.
Public Property | IsParametrized | Gets or sets the value indicating whether the report contains parameters.
Public Property | LastChangeComment | Gets or sets a last change comment.
Public Property | MasterReportIds | Gets or sets the master report IDs.
Public Property | ModelId | Gets or sets a model ID.
Public Property | ModelName | Gets or sets the bound model name.
Public Property | ModelPermissions | Gets or sets the permissions of a model bound to the report.
Public Property | ModelVersion | Gets or sets a model ID.
Public Property | ModifiedBy | Gets the user name who made the last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedDate | Gets or sets the date of last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Name | Gets or sets the name of the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Permissions | Gets or sets the item permissions. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ReportType | Gets or sets a report type.
Public Property | SubreportIds | Gets or sets the subreport IDs.
Public Property | ThemeId | Gets or sets theme id that the report is referenced to.
Public Property | Version | Gets or sets a report version.
Top
See Also

Reference

ReportDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


AssemblyResourceId Property (ReportDescription)

AssemblyResourceId Property (ReportDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportDescription Class : AssemblyResourceId Property
Gets or sets id of assembly resource required for code-based section reports.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AssemblyResourceId As String
public string AssemblyResourceId {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDescription Class
ReportDescription Members


ClassName Property

ClassName Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportDescription Class : ClassName Property
Gets or sets code-based section report full class name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ClassName As String
public string ClassName {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDescription Class
ReportDescription Members


Description Property (ReportDescription)

Description Property (ReportDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportDescription Class : Description Property
Gets or sets a report description.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Description As String
public string Description {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDescription Class
ReportDescription Members


IsBroken Property

IsBroken Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportDescription Class : IsBroken Property
Gets or sets the value indicating whether the report is broken for a recent model version.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsBroken As Boolean
public bool IsBroken {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDescription Class
ReportDescription Members


IsParametrized Property (ReportDescription)

IsParametrized Property (ReportDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportDescription Class : IsParametrized Property
Gets or sets the value indicating whether the report contains parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsParametrized As Boolean
public bool IsParametrized {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDescription Class
ReportDescription Members


LastChangeComment Property

LastChangeComment Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportDescription Class : LastChangeComment Property
Gets or sets a last change comment.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LastChangeComment As String
public string LastChangeComment {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDescription Class
ReportDescription Members


MasterReportIds Property (ReportDescription)

MasterReportIds Property (ReportDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportDescription Class : MasterReportIds Property
Gets or sets the master report IDs.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MasterReportIds As String()
public string[] MasterReportIds {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDescription Class
ReportDescription Members


ModelId Property (ReportDescription)

ModelId Property (ReportDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportDescription Class : ModelId Property
Gets or sets a model ID.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ModelId As String
public string ModelId {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDescription Class
ReportDescription Members


ModelName Property (ReportDescription)

ModelName Property (ReportDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportDescription Class : ModelName Property
Gets or sets the bound model name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ModelName As String
public string ModelName {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDescription Class
ReportDescription Members


ModelPermissions Property

ModelPermissions Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportDescription Class : ModelPermissions Property
Gets or sets the permissions of a model bound to the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ModelPermissions As Byte
public byte ModelPermissions {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDescription Class
ReportDescription Members


ModelVersion Property (ReportDescription)

ModelVersion Property (ReportDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportDescription Class : ModelVersion Property
Gets or sets a model ID.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ModelVersion As Integer
public int ModelVersion {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDescription Class
ReportDescription Members


ReportType Property (ReportDescription)

ReportType Property (ReportDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportDescription Class : ReportType Property
Gets or sets a report type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReportType As ReportType
public ReportType ReportType {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDescription Class
ReportDescription Members


SubreportIds Property (ReportDescription)

SubreportIds Property (ReportDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportDescription Class : SubreportIds Property
Gets or sets the subreport IDs.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SubreportIds As String()
public string[] SubreportIds {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDescription Class
ReportDescription Members


ThemeId Property (ReportDescription)

ThemeId Property (ReportDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportDescription Class : ThemeId Property
Gets or sets theme id that the report is referenced to.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ThemeId As String
public string ThemeId {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDescription Class
ReportDescription Members


Version Property (ReportDescription)

Version Property (ReportDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportDescription Class : Version Property
Gets or sets a report version.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Version As Integer
public int Version {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportDescription Class
ReportDescription Members


ReportParameterDescription Class

ReportParameterDescription Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : ReportParameterDescription Class
Represents information about report parameter.
Object Model
ReportParameterDescription Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ReportParameterDescription
public class ReportParameterDescription
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Descriptions.ReportParameterDescription

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameterDescription Members
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


ReportParameterDescription Class Members

ReportParameterDescription Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : ReportParameterDescription Class

The following tables list the members exposed by ReportParameterDescription.

Public Constructors
 | Name | Description
Public Constructor | ReportParameterDescription Constructor | Initializes a new instance of the ReportParameterDescription class.
Top
Public Properties
 | Name | Description
Public Property | AllowBlank | Gets or sets a value indicating whether the value for this parameter is allowed to be an empty string.
Public Property | DataType | Gets or sets the data type of the parameter.
Public Property | DefaultValues | Gets or sets a default values for this parameter.
Public Property | Hidden | Gets or sets a value indicating whether this parameter should be visible to the end user.
Public Property | MultiValue | Gets or sets a value indicating whether mutltiple values for this parameter are allowed.
Public Property | Name | Gets or sets parameter name.
Public Property | Nullable | Gets or sets a value indicating whether the value for this parameter is allowed to be null.
Public Property | Prompt | Gets or sets parameter prompt.
Top
See Also

Reference

ReportParameterDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


ReportParameterDescription Constructor

ReportParameterDescription Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportParameterDescription Class : ReportParameterDescription Constructor
Initializes a new instance of the ReportParameterDescription class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ReportParameterDescription()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameterDescription Class
ReportParameterDescription Members


ReportParameterDescription Class Properties

ReportParameterDescription Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : ReportParameterDescription Class

For a list of all members of this type, see ReportParameterDescription members.

Public Properties
 | Name | Description
Public Property | AllowBlank | Gets or sets a value indicating whether the value for this parameter is allowed to be an empty string.
Public Property | DataType | Gets or sets the data type of the parameter.
Public Property | DefaultValues | Gets or sets a default values for this parameter.
Public Property | Hidden | Gets or sets a value indicating whether this parameter should be visible to the end user.
Public Property | MultiValue | Gets or sets a value indicating whether mutltiple values for this parameter are allowed.
Public Property | Name | Gets or sets parameter name.
Public Property | Nullable | Gets or sets a value indicating whether the value for this parameter is allowed to be null.
Public Property | Prompt | Gets or sets parameter prompt.
Top
See Also

Reference

ReportParameterDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


AllowBlank Property

AllowBlank Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportParameterDescription Class : AllowBlank Property
Gets or sets a value indicating whether the value for this parameter is allowed to be an empty string.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AllowBlank As Boolean
public bool AllowBlank {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameterDescription Class
ReportParameterDescription Members


DataType Property

DataType Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportParameterDescription Class : DataType Property
Gets or sets the data type of the parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataType As String
public string DataType {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameterDescription Class
ReportParameterDescription Members


DefaultValues Property

DefaultValues Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportParameterDescription Class : DefaultValues Property
Gets or sets a default values for this parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DefaultValues As String()
public string[] DefaultValues {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameterDescription Class
ReportParameterDescription Members


Hidden Property

Hidden Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportParameterDescription Class : Hidden Property
Gets or sets a value indicating whether this parameter should be visible to the end user.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Hidden As Boolean
public bool Hidden {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameterDescription Class
ReportParameterDescription Members


MultiValue Property

MultiValue Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportParameterDescription Class : MultiValue Property
Gets or sets a value indicating whether mutltiple values for this parameter are allowed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MultiValue As Boolean
public bool MultiValue {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameterDescription Class
ReportParameterDescription Members


Name Property (ReportParameterDescription)

Name Property (ReportParameterDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportParameterDescription Class : Name Property
Gets or sets parameter name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As String
public string Name {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameterDescription Class
ReportParameterDescription Members


Nullable Property

Nullable Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportParameterDescription Class : Nullable Property
Gets or sets a value indicating whether the value for this parameter is allowed to be null.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Nullable As Boolean
public bool Nullable {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameterDescription Class
ReportParameterDescription Members


Prompt Property

Prompt Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportParameterDescription Class : Prompt Property
Gets or sets parameter prompt.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Prompt As String
public string Prompt {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportParameterDescription Class
ReportParameterDescription Members


ReportVersionDescription Class

ReportVersionDescription Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : ReportVersionDescription Class
Represents information about report in the storage.
Object Model
ReportVersionDescription Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ReportVersionDescription
   Inherits ItemDescription
public class ReportVersionDescription : ItemDescription
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription
ActiveReports.Server.ReportServices.Contracts.Descriptions.ReportVersionDescription

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportVersionDescription Members
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


ReportVersionDescription Class Members

ReportVersionDescription Class Members
Properties Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : ReportVersionDescription Class

The following tables list the members exposed by ReportVersionDescription.

Public Constructors
 | Name | Description
Public Constructor | ReportVersionDescription Constructor | Initializes a new instance of the ReportVersionDescription class.
Top
Public Properties
 | Name | Description
Public Property | AssemblyResourceId | Gets or sets id of assembly resource required for code-based section reports.
Public Property | Comment | Gets or sets a report version comment.
Public Property | CreatedBy | Gets the user name created the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | CreationDate | Gets or sets the item creation date. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Id | Gets or sets the identifier for the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | IsParametrized | Gets or sets the value indicating whether the report contains parameters.
Public Property | MasterReportIds | Gets or sets the master report IDs.
Public Property | ModelId | Gets or sets a model ID.
Public Property | ModelVersion | Gets or sets a model ID.
Public Property | ModifiedBy | Gets the user name who made the last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedDate | Gets or sets the date of last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Name | Gets or sets the name of the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Permissions | Gets or sets the item permissions. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ReportId | Gets or sets a report ID.
Public Property | ReportType | Gets or sets a report type.
Public Property | SubreportIds | Gets or sets the subreport IDs.
Public Property | ThemeId | Gets or sets theme id that the report is referenced to.
Public Property | Version | Gets or sets report version.
Top
Public Methods
 | Name | Description
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Top
See Also

Reference

ReportVersionDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


ReportVersionDescription Constructor

ReportVersionDescription Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportVersionDescription Class : ReportVersionDescription Constructor
Initializes a new instance of the ReportVersionDescription class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ReportVersionDescription()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportVersionDescription Class
ReportVersionDescription Members


ReportVersionDescription Class Properties

ReportVersionDescription Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : ReportVersionDescription Class

For a list of all members of this type, see ReportVersionDescription members.

Public Properties
 | Name | Description
Public Property | AssemblyResourceId | Gets or sets id of assembly resource required for code-based section reports.
Public Property | Comment | Gets or sets a report version comment.
Public Property | CreatedBy | Gets the user name created the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | CreationDate | Gets or sets the item creation date. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Id | Gets or sets the identifier for the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | IsParametrized | Gets or sets the value indicating whether the report contains parameters.
Public Property | MasterReportIds | Gets or sets the master report IDs.
Public Property | ModelId | Gets or sets a model ID.
Public Property | ModelVersion | Gets or sets a model ID.
Public Property | ModifiedBy | Gets the user name who made the last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedDate | Gets or sets the date of last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Name | Gets or sets the name of the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Permissions | Gets or sets the item permissions. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ReportId | Gets or sets a report ID.
Public Property | ReportType | Gets or sets a report type.
Public Property | SubreportIds | Gets or sets the subreport IDs.
Public Property | ThemeId | Gets or sets theme id that the report is referenced to.
Public Property | Version | Gets or sets report version.
Top
See Also

Reference

ReportVersionDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


AssemblyResourceId Property (ReportVersionDescription)

AssemblyResourceId Property (ReportVersionDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportVersionDescription Class : AssemblyResourceId Property
Gets or sets id of assembly resource required for code-based section reports.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AssemblyResourceId As String
public string AssemblyResourceId {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportVersionDescription Class
ReportVersionDescription Members


Comment Property (ReportVersionDescription)

Comment Property (ReportVersionDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportVersionDescription Class : Comment Property
Gets or sets a report version comment.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Comment As String
public string Comment {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportVersionDescription Class
ReportVersionDescription Members


IsParametrized Property (ReportVersionDescription)

IsParametrized Property (ReportVersionDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportVersionDescription Class : IsParametrized Property
Gets or sets the value indicating whether the report contains parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsParametrized As Boolean
public bool IsParametrized {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportVersionDescription Class
ReportVersionDescription Members


MasterReportIds Property (ReportVersionDescription)

MasterReportIds Property (ReportVersionDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportVersionDescription Class : MasterReportIds Property
Gets or sets the master report IDs.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MasterReportIds As String()
public string[] MasterReportIds {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportVersionDescription Class
ReportVersionDescription Members


ModelId Property (ReportVersionDescription)

ModelId Property (ReportVersionDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportVersionDescription Class : ModelId Property
Gets or sets a model ID.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ModelId As String
public string ModelId {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportVersionDescription Class
ReportVersionDescription Members


ModelVersion Property (ReportVersionDescription)

ModelVersion Property (ReportVersionDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportVersionDescription Class : ModelVersion Property
Gets or sets a model ID.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ModelVersion As Integer
public int ModelVersion {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportVersionDescription Class
ReportVersionDescription Members


ReportId Property (ReportVersionDescription)

ReportId Property (ReportVersionDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportVersionDescription Class : ReportId Property
Gets or sets a report ID.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReportId As String
public string ReportId {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportVersionDescription Class
ReportVersionDescription Members


ReportType Property (ReportVersionDescription)

ReportType Property (ReportVersionDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportVersionDescription Class : ReportType Property
Gets or sets a report type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReportType As ReportType
public ReportType ReportType {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportVersionDescription Class
ReportVersionDescription Members


SubreportIds Property (ReportVersionDescription)

SubreportIds Property (ReportVersionDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportVersionDescription Class : SubreportIds Property
Gets or sets the subreport IDs.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SubreportIds As String()
public string[] SubreportIds {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportVersionDescription Class
ReportVersionDescription Members


ThemeId Property (ReportVersionDescription)

ThemeId Property (ReportVersionDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportVersionDescription Class : ThemeId Property
Gets or sets theme id that the report is referenced to.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ThemeId As String
public string ThemeId {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportVersionDescription Class
ReportVersionDescription Members


Version Property (ReportVersionDescription)

Version Property (ReportVersionDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ReportVersionDescription Class : Version Property
Gets or sets report version.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Version As Integer
public int Version {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReportVersionDescription Class
ReportVersionDescription Members


ResourceDescription Class

ResourceDescription Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : ResourceDescription Class
Represents information about a resource in storage.
Object Model
ResourceDescription Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ResourceDescription
   Inherits ItemDescription
public class ResourceDescription : ItemDescription
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription
ActiveReports.Server.ReportServices.Contracts.Descriptions.ResourceDescription

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourceDescription Members
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


ResourceDescription Class Members

ResourceDescription Class Members
Properties Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : ResourceDescription Class

The following tables list the members exposed by ResourceDescription.

Public Constructors
 | Name | Description
Public Constructor | ResourceDescription Constructor | Initializes a new instance of the ResourceDescription class.
Top
Public Properties
 | Name | Description
Public Property | CreatedBy | Gets the user name created the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | CreationDate | Gets or sets the item creation date. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Id | Gets or sets the identifier for the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | MIMEType | Gets or sets the MIME type of the resource.
Public Property | ModifiedBy | Gets the user name who made the last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedDate | Gets or sets the date of last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Name | Gets or sets the name of the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Permissions | Gets or sets the item permissions. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Top
Public Methods
 | Name | Description
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Top
See Also

Reference

ResourceDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


ResourceDescription Constructor

ResourceDescription Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ResourceDescription Class : ResourceDescription Constructor
Initializes a new instance of the ResourceDescription class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ResourceDescription()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourceDescription Class
ResourceDescription Members


ResourceDescription Class Properties

ResourceDescription Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : ResourceDescription Class

For a list of all members of this type, see ResourceDescription members.

Public Properties
 | Name | Description
Public Property | CreatedBy | Gets the user name created the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | CreationDate | Gets or sets the item creation date. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Id | Gets or sets the identifier for the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | MIMEType | Gets or sets the MIME type of the resource.
Public Property | ModifiedBy | Gets the user name who made the last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedDate | Gets or sets the date of last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Name | Gets or sets the name of the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Permissions | Gets or sets the item permissions. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Top
See Also

Reference

ResourceDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


MIMEType Property (ResourceDescription)

MIMEType Property (ResourceDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > ResourceDescription Class : MIMEType Property
Gets or sets the MIME type of the resource.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MIMEType As String
public string MIMEType {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ResourceDescription Class
ResourceDescription Members


SemanticModelDescription Class

SemanticModelDescription Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : SemanticModelDescription Class
Represents information about semantic model in the storage.
Object Model
SemanticModelDescription Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class SemanticModelDescription
   Inherits ItemDescription
public class SemanticModelDescription : ItemDescription
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription
ActiveReports.Server.ReportServices.Contracts.Descriptions.SemanticModelDescription

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SemanticModelDescription Members
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


SemanticModelDescription Class Members

SemanticModelDescription Class Members
Properties Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : SemanticModelDescription Class

The following tables list the members exposed by SemanticModelDescription.

Public Constructors
 | Name | Description
Public Constructor | SemanticModelDescription Constructor | Initializes a new instance of the SemanticModelDescription class.
Top
Public Properties
 | Name | Description
Public Property | CreatedBy | Gets the user name created the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | CreationDate | Gets or sets the item creation date. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | CurrentComment | Gets or sets current comment associated with the model.
Public Property | Description | Gets or sets the model description.
Public Property | Id | Gets or sets the identifier for the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedBy | Gets the user name who made the last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedDate | Gets or sets the date of last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Name | Gets or sets the name of the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Permissions | Gets or sets the item permissions. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ReportCount | Gets or sets the count of bound reports.
Public Property | Version | Gets or sets the version of the model.
Top
Public Methods
 | Name | Description
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Top
See Also

Reference

SemanticModelDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


SemanticModelDescription Constructor

SemanticModelDescription Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > SemanticModelDescription Class : SemanticModelDescription Constructor
Initializes a new instance of the SemanticModelDescription class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public SemanticModelDescription()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SemanticModelDescription Class
SemanticModelDescription Members


SemanticModelDescription Class Properties

SemanticModelDescription Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : SemanticModelDescription Class

For a list of all members of this type, see SemanticModelDescription members.

Public Properties
 | Name | Description
Public Property | CreatedBy | Gets the user name created the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | CreationDate | Gets or sets the item creation date. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | CurrentComment | Gets or sets current comment associated with the model.
Public Property | Description | Gets or sets the model description.
Public Property | Id | Gets or sets the identifier for the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedBy | Gets the user name who made the last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedDate | Gets or sets the date of last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Name | Gets or sets the name of the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Permissions | Gets or sets the item permissions. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ReportCount | Gets or sets the count of bound reports.
Public Property | Version | Gets or sets the version of the model.
Top
See Also

Reference

SemanticModelDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


CurrentComment Property

CurrentComment Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > SemanticModelDescription Class : CurrentComment Property
Gets or sets current comment associated with the model.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CurrentComment As String
public string CurrentComment {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SemanticModelDescription Class
SemanticModelDescription Members


Description Property (SemanticModelDescription)

Description Property (SemanticModelDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > SemanticModelDescription Class : Description Property
Gets or sets the model description.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Description As String
public string Description {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SemanticModelDescription Class
SemanticModelDescription Members


ReportCount Property

ReportCount Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > SemanticModelDescription Class : ReportCount Property
Gets or sets the count of bound reports.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReportCount As Integer
public int ReportCount {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SemanticModelDescription Class
SemanticModelDescription Members


Version Property (SemanticModelDescription)

Version Property (SemanticModelDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > SemanticModelDescription Class : Version Property
Gets or sets the version of the model.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Version As Integer
public int Version {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SemanticModelDescription Class
SemanticModelDescription Members


SemanticModelDraftDescription Class

SemanticModelDraftDescription Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : SemanticModelDraftDescription Class
Represents information about semantic model draft in the storage.
Object Model
SemanticModelDraftDescription Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class SemanticModelDraftDescription
   Inherits ItemDescription
public class SemanticModelDraftDescription : ItemDescription
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription
ActiveReports.Server.ReportServices.Contracts.Descriptions.SemanticModelDraftDescription

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SemanticModelDraftDescription Members
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


SemanticModelDraftDescription Class Members

SemanticModelDraftDescription Class Members
Properties Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : SemanticModelDraftDescription Class

The following tables list the members exposed by SemanticModelDraftDescription.

Public Constructors
 | Name | Description
Public Constructor | SemanticModelDraftDescription Constructor | Initializes a new instance of the SemanticModelDraftDescription class.
Top
Public Properties
 | Name | Description
Public Property | CreatedBy | Gets the user name created the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | CreationDate | Gets or sets the item creation date. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Id | Gets or sets the identifier for the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedBy | Gets the user name who made the last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedDate | Gets or sets the date of last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Name | Gets or sets the name of the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Permissions | Gets or sets the item permissions. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | User | Gets or sets the name of the user this draft belongs to.
Top
Public Methods
 | Name | Description
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Top
See Also

Reference

SemanticModelDraftDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


SemanticModelDraftDescription Constructor

SemanticModelDraftDescription Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > SemanticModelDraftDescription Class : SemanticModelDraftDescription Constructor
Initializes a new instance of the SemanticModelDraftDescription class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public SemanticModelDraftDescription()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SemanticModelDraftDescription Class
SemanticModelDraftDescription Members


SemanticModelDraftDescription Class Properties

SemanticModelDraftDescription Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : SemanticModelDraftDescription Class

For a list of all members of this type, see SemanticModelDraftDescription members.

Public Properties
 | Name | Description
Public Property | CreatedBy | Gets the user name created the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | CreationDate | Gets or sets the item creation date. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Id | Gets or sets the identifier for the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedBy | Gets the user name who made the last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedDate | Gets or sets the date of last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Name | Gets or sets the name of the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Permissions | Gets or sets the item permissions. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | User | Gets or sets the name of the user this draft belongs to.
Top
See Also

Reference

SemanticModelDraftDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


User Property (SemanticModelDraftDescription)

User Property (SemanticModelDraftDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > SemanticModelDraftDescription Class : User Property
Gets or sets the name of the user this draft belongs to.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property User As String
public string User {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SemanticModelDraftDescription Class
SemanticModelDraftDescription Members


SemanticModelVersionDescription Class

SemanticModelVersionDescription Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : SemanticModelVersionDescription Class
Represents information about semantic model in the storage.
Object Model
SemanticModelVersionDescription Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class SemanticModelVersionDescription
   Inherits ItemDescription
public sealed class SemanticModelVersionDescription : ItemDescription
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription
ActiveReports.Server.ReportServices.Contracts.Descriptions.SemanticModelVersionDescription

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SemanticModelVersionDescription Members
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


SemanticModelVersionDescription Class Members

SemanticModelVersionDescription Class Members
Properties Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : SemanticModelVersionDescription Class

The following tables list the members exposed by SemanticModelVersionDescription.

Public Constructors
 | Name | Description
Public Constructor | SemanticModelVersionDescription Constructor | Initializes a new instance of the SemanticModelVersionDescription class.
Top
Public Properties
 | Name | Description
Public Property | Comment | Gets or sets current comment associated with this version.
Public Property | CreatedBy | Gets the user name created the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | CreationDate | Gets or sets the item creation date. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Id | Gets or sets the identifier for the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedBy | Gets the user name who made the last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedDate | Gets or sets the date of last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Name | Gets or sets the name of the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Permissions | Gets or sets the item permissions. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Version | Gets or sets the version number of this version.
Top
Public Methods
 | Name | Description
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Top
See Also

Reference

SemanticModelVersionDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


SemanticModelVersionDescription Constructor

SemanticModelVersionDescription Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > SemanticModelVersionDescription Class : SemanticModelVersionDescription Constructor
Initializes a new instance of the SemanticModelVersionDescription class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public SemanticModelVersionDescription()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SemanticModelVersionDescription Class
SemanticModelVersionDescription Members


SemanticModelVersionDescription Class Properties

SemanticModelVersionDescription Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : SemanticModelVersionDescription Class

For a list of all members of this type, see SemanticModelVersionDescription members.

Public Properties
 | Name | Description
Public Property | Comment | Gets or sets current comment associated with this version.
Public Property | CreatedBy | Gets the user name created the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | CreationDate | Gets or sets the item creation date. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Id | Gets or sets the identifier for the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedBy | Gets the user name who made the last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedDate | Gets or sets the date of last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Name | Gets or sets the name of the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Permissions | Gets or sets the item permissions. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Version | Gets or sets the version number of this version.
Top
See Also

Reference

SemanticModelVersionDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


Comment Property (SemanticModelVersionDescription)

Comment Property (SemanticModelVersionDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > SemanticModelVersionDescription Class : Comment Property
Gets or sets current comment associated with this version.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Comment As String
public string Comment {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SemanticModelVersionDescription Class
SemanticModelVersionDescription Members


Version Property (SemanticModelVersionDescription)

Version Property (SemanticModelVersionDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > SemanticModelVersionDescription Class : Version Property
Gets or sets the version number of this version.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Version As Integer
public int Version {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SemanticModelVersionDescription Class
SemanticModelVersionDescription Members


SharedPolicyTemplateDescription Class

SharedPolicyTemplateDescription Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : SharedPolicyTemplateDescription Class
Represents information about shared policy template resource in the storage.
Object Model
SharedPolicyTemplateDescription Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class SharedPolicyTemplateDescription
   Inherits ItemDescription
public class SharedPolicyTemplateDescription : ItemDescription
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription
ActiveReports.Server.ReportServices.Contracts.Descriptions.SharedPolicyTemplateDescription

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharedPolicyTemplateDescription Members
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


SharedPolicyTemplateDescription Class Members

SharedPolicyTemplateDescription Class Members
Properties Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : SharedPolicyTemplateDescription Class

The following tables list the members exposed by SharedPolicyTemplateDescription.

Public Constructors
 | Name | Description
Public Constructor | SharedPolicyTemplateDescription Constructor | Initializes a new instance of the SharedPolicyTemplateDescription class.
Top
Public Properties
 | Name | Description
Public Property | CreatedBy | Gets the user name created the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | CreationDate | Gets or sets the item creation date. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | DescriptionText | Gets or sets the shared policy template description.
Public Property | Id | Gets or sets the identifier for the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedBy | Gets the user name who made the last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedDate | Gets or sets the date of last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Name | Gets or sets the name of the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Permissions | Gets or sets the item permissions. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ScheduleCount | Gets or sets the count of bound schedules.
Top
Public Methods
 | Name | Description
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Top
See Also

Reference

SharedPolicyTemplateDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


SharedPolicyTemplateDescription Constructor

SharedPolicyTemplateDescription Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > SharedPolicyTemplateDescription Class : SharedPolicyTemplateDescription Constructor
Initializes a new instance of the SharedPolicyTemplateDescription class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public SharedPolicyTemplateDescription()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharedPolicyTemplateDescription Class
SharedPolicyTemplateDescription Members


SharedPolicyTemplateDescription Class Properties

SharedPolicyTemplateDescription Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : SharedPolicyTemplateDescription Class

For a list of all members of this type, see SharedPolicyTemplateDescription members.

Public Properties
 | Name | Description
Public Property | CreatedBy | Gets the user name created the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | CreationDate | Gets or sets the item creation date. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | DescriptionText | Gets or sets the shared policy template description.
Public Property | Id | Gets or sets the identifier for the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedBy | Gets the user name who made the last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedDate | Gets or sets the date of last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Name | Gets or sets the name of the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Permissions | Gets or sets the item permissions. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ScheduleCount | Gets or sets the count of bound schedules.
Top
See Also

Reference

SharedPolicyTemplateDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


DescriptionText Property

DescriptionText Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > SharedPolicyTemplateDescription Class : DescriptionText Property
Gets or sets the shared policy template description.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DescriptionText As String
public string DescriptionText {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharedPolicyTemplateDescription Class
SharedPolicyTemplateDescription Members


ScheduleCount Property

ScheduleCount Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > SharedPolicyTemplateDescription Class : ScheduleCount Property
Gets or sets the count of bound schedules.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ScheduleCount As Integer
public int ScheduleCount {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SharedPolicyTemplateDescription Class
SharedPolicyTemplateDescription Members


TemporaryItemDescription Class

TemporaryItemDescription Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : TemporaryItemDescription Class
Represents information about temporary resource in the storage.
Object Model
TemporaryItemDescription Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class TemporaryItemDescription
   Inherits ItemDescription
public class TemporaryItemDescription : ItemDescription
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription
ActiveReports.Server.ReportServices.Contracts.Descriptions.TemporaryItemDescription

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TemporaryItemDescription Members
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


TemporaryItemDescription Class Members

TemporaryItemDescription Class Members
Properties Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : TemporaryItemDescription Class

The following tables list the members exposed by TemporaryItemDescription.

Public Constructors
 | Name | Description
Public Constructor | TemporaryItemDescription Constructor | Initializes a new instance of the TemporaryItemDescription class.
Top
Public Properties
 | Name | Description
Public Property | CreatedBy | Gets the user name created the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | CreationDate | Gets or sets the item creation date. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ExpirationDate | Gets or sets the expiration date.
Public Property | Id | Gets or sets the identifier for the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | MIMEType | Gets or sets the MIME type of the resource.
Public Property | ModifiedBy | Gets the user name who made the last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedDate | Gets or sets the date of last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Name | Gets or sets the name of the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Permissions | Gets or sets the item permissions. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | PrimaryId | Gets or sets the primary identifier of resource defining a group of related resources.
Public Property | User | Gets or sets the name of the user in the context of which session the file was created.
Top
Public Methods
 | Name | Description
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Top
See Also

Reference

TemporaryItemDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


TemporaryItemDescription Constructor

TemporaryItemDescription Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > TemporaryItemDescription Class : TemporaryItemDescription Constructor
Initializes a new instance of the TemporaryItemDescription class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public TemporaryItemDescription()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TemporaryItemDescription Class
TemporaryItemDescription Members


TemporaryItemDescription Class Properties

TemporaryItemDescription Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : TemporaryItemDescription Class

For a list of all members of this type, see TemporaryItemDescription members.

Public Properties
 | Name | Description
Public Property | CreatedBy | Gets the user name created the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | CreationDate | Gets or sets the item creation date. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ExpirationDate | Gets or sets the expiration date.
Public Property | Id | Gets or sets the identifier for the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | MIMEType | Gets or sets the MIME type of the resource.
Public Property | ModifiedBy | Gets the user name who made the last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedDate | Gets or sets the date of last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Name | Gets or sets the name of the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Permissions | Gets or sets the item permissions. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | PrimaryId | Gets or sets the primary identifier of resource defining a group of related resources.
Public Property | User | Gets or sets the name of the user in the context of which session the file was created.
Top
See Also

Reference

TemporaryItemDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


ExpirationDate Property

ExpirationDate Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > TemporaryItemDescription Class : ExpirationDate Property
Gets or sets the expiration date.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ExpirationDate As Date
public DateTime ExpirationDate {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TemporaryItemDescription Class
TemporaryItemDescription Members


MIMEType Property (TemporaryItemDescription)

MIMEType Property (TemporaryItemDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > TemporaryItemDescription Class : MIMEType Property
Gets or sets the MIME type of the resource.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MIMEType As String
public string MIMEType {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TemporaryItemDescription Class
TemporaryItemDescription Members


PrimaryId Property

PrimaryId Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > TemporaryItemDescription Class : PrimaryId Property
Gets or sets the primary identifier of resource defining a group of related resources.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PrimaryId As String
public string PrimaryId {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TemporaryItemDescription Class
TemporaryItemDescription Members


User Property (TemporaryItemDescription)

User Property (TemporaryItemDescription)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace > TemporaryItemDescription Class : User Property
Gets or sets the name of the user in the context of which session the file was created.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property User As String
public string User {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TemporaryItemDescription Class
TemporaryItemDescription Members


ActiveReports.Server.ReportServices.Contracts.Errors Namespace

ActiveReports.Server.ReportServices.Contracts.Errors Namespace
Inheritance Hierarchy
ActiveReports.Server.ReportControls Assembly : ActiveReports.Server.ReportServices.Contracts.Errors Namespace
Classes
 | Class | Description
Class | Error | Represents an error that could be returned to client in ActiveReports.Server.ReportServices.Servicing.IDesignerService.
Class | ExceptionDetail | Represents fault detail information.
Class | ExceptionError | Represents an error occured as an exception.
Class | NoticeType | Represents the field value collection of lookup result.
Class | ValidationError | Represents a validation error.
See Also

Reference

ActiveReports.Server.ReportControls Assembly


Error Class

Error Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace : Error Class
Represents an error that could be returned to client in ActiveReports.Server.ReportServices.Servicing.IDesignerService.
Object Model
Error Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Error
public class Error
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Errors.Error
ActiveReports.Server.ReportServices.Contracts.Errors.ExceptionError
ActiveReports.Server.ReportServices.Contracts.Errors.ValidationError

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Error Members
ActiveReports.Server.ReportServices.Contracts.Errors Namespace


Error Class Members

Error Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace : Error Class

The following tables list the members exposed by Error.

Public Constructors
 | Name | Description
Public Constructor | Error Constructor | Creates new error of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Top
Public Properties
 | Name | Description
Public Property | Description | Gets or sets the description for the error.
Public Property | Name | Gets or sets the name of the error.
Public Property | NonCritical | Gets or sets a value indicating whether this error is not critical.
Top
See Also

Reference

Error Class
ActiveReports.Server.ReportServices.Contracts.Errors Namespace


Error Constructor

Error Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace > Error Class : Error Constructor
Creates new error of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Error()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Error Class
Error Members


Error Class Properties

Error Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace : Error Class

For a list of all members of this type, see Error members.

Public Properties
 | Name | Description
Public Property | Description | Gets or sets the description for the error.
Public Property | Name | Gets or sets the name of the error.
Public Property | NonCritical | Gets or sets a value indicating whether this error is not critical.
Top
See Also

Reference

Error Class
ActiveReports.Server.ReportServices.Contracts.Errors Namespace


Description Property (Error)

Description Property (Error)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace > Error Class : Description Property
Gets or sets the description for the error.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Description As String
public string Description {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Error Class
Error Members


Name Property (Error)

Name Property (Error)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace > Error Class : Name Property
Gets or sets the name of the error.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As String
public string Name {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Error Class
Error Members


NonCritical Property

NonCritical Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace > Error Class : NonCritical Property
Gets or sets a value indicating whether this error is not critical.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NonCritical As Boolean
public bool NonCritical {get; set;}

Property Value

true if this error is not critical; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Error Class
Error Members


ExceptionDetail Class

ExceptionDetail Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace : ExceptionDetail Class
Represents fault detail information.
Object Model
ExceptionDetail ClassExceptionDetail Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ExceptionDetail
public sealed class ExceptionDetail
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Errors.ExceptionDetail

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExceptionDetail Members
ActiveReports.Server.ReportServices.Contracts.Errors Namespace


ExceptionDetail Class Members

ExceptionDetail Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace : ExceptionDetail Class

The following tables list the members exposed by ExceptionDetail.

Public Constructors
 | Name | Description
Public Constructor | ExceptionDetail Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | HelpLink | Gets or sets the help link from the exception passed to the constructor.
Public Property | InnerException | Gets or sets the ExceptionDetail object that represents the inner exception.
Public Property | Message | Gets or sets the message from the exception passed to the constructor.
Public Property | StackTrace | Gets or sets the stack trace information from the exception passed to the constructor.
Public Property | Type | Gets or sets the type string for the exception passed to the constructor.
Top
See Also

Reference

ExceptionDetail Class
ActiveReports.Server.ReportServices.Contracts.Errors Namespace


ExceptionDetail Constructor

ExceptionDetail Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace > ExceptionDetail Class : ExceptionDetail Constructor
Overload List
Overload | Description
ExceptionDetail Constructor(ExceptionDetail) | Initializes a new instance of the ExceptionDetail class.
ExceptionDetail Constructor(Exception) | Initializes a new instance of the ExceptionDetail class.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExceptionDetail Class
ExceptionDetail Members


ExceptionDetail Constructor(ExceptionDetail)

ExceptionDetail Constructor(ExceptionDetail)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace > ExceptionDetail Class > ExceptionDetail Constructor : ExceptionDetail Constructor(ExceptionDetail)
Failt detail information.
Initializes a new instance of the ExceptionDetail class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal exceptionDetail As ExceptionDetail _
)
public ExceptionDetail(
   ExceptionDetail exceptionDetail
)

Parameters

exceptionDetail
Failt detail information.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExceptionDetail Class
ExceptionDetail Members
Overload List


ExceptionDetail Constructor(Exception)

ExceptionDetail Constructor(Exception)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace > ExceptionDetail Class > ExceptionDetail Constructor : ExceptionDetail Constructor(Exception)
Error that occurs during application execution.
Initializes a new instance of the ExceptionDetail class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal exception As Exception _
)
public ExceptionDetail(
   Exception exception
)

Parameters

exception
Error that occurs during application execution.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExceptionDetail Class
ExceptionDetail Members
Overload List


ExceptionDetail Class Properties

ExceptionDetail Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace : ExceptionDetail Class

For a list of all members of this type, see ExceptionDetail members.

Public Properties
 | Name | Description
Public Property | HelpLink | Gets or sets the help link from the exception passed to the constructor.
Public Property | InnerException | Gets or sets the ExceptionDetail object that represents the inner exception.
Public Property | Message | Gets or sets the message from the exception passed to the constructor.
Public Property | StackTrace | Gets or sets the stack trace information from the exception passed to the constructor.
Public Property | Type | Gets or sets the type string for the exception passed to the constructor.
Top
See Also

Reference

ExceptionDetail Class
ActiveReports.Server.ReportServices.Contracts.Errors Namespace


HelpLink Property

HelpLink Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace > ExceptionDetail Class : HelpLink Property
Gets or sets the help link from the exception passed to the constructor.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HelpLink As String
public string HelpLink {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExceptionDetail Class
ExceptionDetail Members


InnerException Property

InnerException Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace > ExceptionDetail Class : InnerException Property
Gets or sets the ExceptionDetail object that represents the inner exception.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property InnerException As ExceptionDetail
public ExceptionDetail InnerException {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExceptionDetail Class
ExceptionDetail Members


Message Property

Message Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace > ExceptionDetail Class : Message Property
Gets or sets the message from the exception passed to the constructor.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Message As String
public string Message {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExceptionDetail Class
ExceptionDetail Members


StackTrace Property (ExceptionDetail)

StackTrace Property (ExceptionDetail)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace > ExceptionDetail Class : StackTrace Property
Gets or sets the stack trace information from the exception passed to the constructor.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StackTrace As String
public string StackTrace {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExceptionDetail Class
ExceptionDetail Members


Type Property (ExceptionDetail)

Type Property (ExceptionDetail)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace > ExceptionDetail Class : Type Property
Gets or sets the type string for the exception passed to the constructor.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Type As String
public string Type {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExceptionDetail Class
ExceptionDetail Members


ExceptionError Class

ExceptionError Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace : ExceptionError Class
Represents an error occured as an exception.
Object Model
ExceptionError ClassExceptionDetail Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ExceptionError
   Inherits Error
public class ExceptionError : Error
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Errors.Error
ActiveReports.Server.ReportServices.Contracts.Errors.ExceptionError

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExceptionError Members
ActiveReports.Server.ReportServices.Contracts.Errors Namespace


ExceptionError Class Members

ExceptionError Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace : ExceptionError Class

The following tables list the members exposed by ExceptionError.

Public Constructors
 | Name | Description
Public Constructor | ExceptionError Constructor | Creates new application execution error of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Top
Public Properties
 | Name | Description
Public Property | Description | Gets or sets the description for the error. (Inherited from ActiveReports.Server.ReportServices.Contracts.Errors.Error)
Public Property | ErrorCode | Gets or sets the error code.
Public Property | Exception | Gets or sets the exception occured.
Public Property | Name | Gets or sets the name of the error. (Inherited from ActiveReports.Server.ReportServices.Contracts.Errors.Error)
Public Property | NonCritical | Gets or sets a value indicating whether this error is not critical. (Inherited from ActiveReports.Server.ReportServices.Contracts.Errors.Error)
Public Property | Parameters | Gets or sets the parameters array for the error.
Top
See Also

Reference

ExceptionError Class
ActiveReports.Server.ReportServices.Contracts.Errors Namespace


ExceptionError Constructor

ExceptionError Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace > ExceptionError Class : ExceptionError Constructor
Creates new application execution error of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ExceptionError()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExceptionError Class
ExceptionError Members


ExceptionError Class Properties

ExceptionError Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace : ExceptionError Class

For a list of all members of this type, see ExceptionError members.

Public Properties
 | Name | Description
Public Property | Description | Gets or sets the description for the error. (Inherited from ActiveReports.Server.ReportServices.Contracts.Errors.Error)
Public Property | ErrorCode | Gets or sets the error code.
Public Property | Exception | Gets or sets the exception occured.
Public Property | Name | Gets or sets the name of the error. (Inherited from ActiveReports.Server.ReportServices.Contracts.Errors.Error)
Public Property | NonCritical | Gets or sets a value indicating whether this error is not critical. (Inherited from ActiveReports.Server.ReportServices.Contracts.Errors.Error)
Public Property | Parameters | Gets or sets the parameters array for the error.
Top
See Also

Reference

ExceptionError Class
ActiveReports.Server.ReportServices.Contracts.Errors Namespace


ErrorCode Property (ExceptionError)

ErrorCode Property (ExceptionError)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace > ExceptionError Class : ErrorCode Property
Gets or sets the error code.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ErrorCode As String
public string ErrorCode {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExceptionError Class
ExceptionError Members


Exception Property (ExceptionError)

Exception Property (ExceptionError)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace > ExceptionError Class : Exception Property
Gets or sets the exception occured.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Exception As ExceptionDetail
public ExceptionDetail Exception {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExceptionError Class
ExceptionError Members


Parameters Property (ExceptionError)

Parameters Property (ExceptionError)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace > ExceptionError Class : Parameters Property
Gets or sets the parameters array for the error.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Parameters As Object()
public object[] Parameters {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExceptionError Class
ExceptionError Members


NoticeType Class

NoticeType Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace : NoticeType Class
Represents the field value collection of lookup result.
Object Model
NoticeType Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class NoticeType
   Inherits System.Collections.Generic.List(Of String)
public class NoticeType : System.Collections.Generic.List<string>
Inheritance Hierarchy

System.Object
System.Collections.Generic.List<T>
ActiveReports.Server.ReportServices.Contracts.Errors.NoticeType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NoticeType Members
ActiveReports.Server.ReportServices.Contracts.Errors Namespace


NoticeType Class Members

NoticeType Class Members
Properties Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace : NoticeType Class

The following tables list the members exposed by NoticeType.

Public Constructors
 | Name | Description
Public Constructor | NoticeType Constructor | Initializes a new instance of the NoticeType class.
Top
Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from System.Collections.Generic.List<string>)
Public Property | Count | Gets the number of elements contained in the List. (Inherited from System.Collections.Generic.List<string>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.Generic.List<string>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the List. (Inherited from System.Collections.Generic.List<string>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the List. (Inherited from System.Collections.Generic.List<string>)
Public Method | AsReadOnly | Returns a read-only ReadOnlyCollection wrapper for the current collection. (Inherited from System.Collections.Generic.List<string>)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<string>)
Public Method | Clear | Removes all elements from the List. (Inherited from System.Collections.Generic.List<string>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from System.Collections.Generic.List<string>)
Public Method | ConvertAll | Converts the elements in the current List to another type, and returns a list containing the converted elements. (Inherited from System.Collections.Generic.List<string>)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<string>)
Public Method | Exists | Determines whether the List contains elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<string>)
Public Method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List. (Inherited from System.Collections.Generic.List<string>)
Public Method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<string>)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<string>)
Public Method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List. (Inherited from System.Collections.Generic.List<string>)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<string>)
Public Method | ForEach | Performs the specified action on each element of the List. (Inherited from System.Collections.Generic.List<string>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from System.Collections.Generic.List<string>)
Public Method | GetRange | Creates a shallow copy of a range of elements in the source List. (Inherited from System.Collections.Generic.List<string>)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<string>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from System.Collections.Generic.List<string>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from System.Collections.Generic.List<string>)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<string>)
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from System.Collections.Generic.List<string>)
Public Method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<string>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from System.Collections.Generic.List<string>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from System.Collections.Generic.List<string>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from System.Collections.Generic.List<string>)
Public Method | Sort | Overloaded. Sorts the elements in the entire List using the default comparer. (Inherited from System.Collections.Generic.List<string>)
Public Method | ToArray | Copies the elements of the List to a new array. (Inherited from System.Collections.Generic.List<string>)
Public Method | TrimExcess | Sets the capacity to the actual number of elements in the List, if that number is less than a threshold value. (Inherited from System.Collections.Generic.List<string>)
Public Method | TrueForAll | Determines whether every element in the List matches the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<string>)
Top
See Also

Reference

NoticeType Class
ActiveReports.Server.ReportServices.Contracts.Errors Namespace


NoticeType Constructor

NoticeType Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace > NoticeType Class : NoticeType Constructor
Initializes a new instance of the NoticeType class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public NoticeType()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NoticeType Class
NoticeType Members


ValidationError Class

ValidationError Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace : ValidationError Class
Represents a validation error.
Object Model
ValidationError ClassNoticeType ClassNoticeType Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ValidationError
   Inherits Error
public class ValidationError : Error
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Errors.Error
ActiveReports.Server.ReportServices.Contracts.Errors.ValidationError

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationError Members
ActiveReports.Server.ReportServices.Contracts.Errors Namespace


ValidationError Class Members

ValidationError Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace : ValidationError Class

The following tables list the members exposed by ValidationError.

Public Constructors
 | Name | Description
Public Constructor | ValidationError Constructor | Creates new validaion error of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Top
Public Properties
 | Name | Description
Public Property | Description | Gets or sets the description for the error. (Inherited from ActiveReports.Server.ReportServices.Contracts.Errors.Error)
Public Property | Errors | Gets or sets the validation errors.
Public Property | Name | Gets or sets the name of the error. (Inherited from ActiveReports.Server.ReportServices.Contracts.Errors.Error)
Public Property | NonCritical | Gets or sets a value indicating whether this error is not critical. (Inherited from ActiveReports.Server.ReportServices.Contracts.Errors.Error)
Public Property | Warnings | Gets or sets the validation warnings.
Top
See Also

Reference

ValidationError Class
ActiveReports.Server.ReportServices.Contracts.Errors Namespace


ValidationError Constructor

ValidationError Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace > ValidationError Class : ValidationError Constructor
Creates new validaion error of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ValidationError()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationError Class
ValidationError Members


ValidationError Class Properties

ValidationError Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace : ValidationError Class

For a list of all members of this type, see ValidationError members.

Public Properties
 | Name | Description
Public Property | Description | Gets or sets the description for the error. (Inherited from ActiveReports.Server.ReportServices.Contracts.Errors.Error)
Public Property | Errors | Gets or sets the validation errors.
Public Property | Name | Gets or sets the name of the error. (Inherited from ActiveReports.Server.ReportServices.Contracts.Errors.Error)
Public Property | NonCritical | Gets or sets a value indicating whether this error is not critical. (Inherited from ActiveReports.Server.ReportServices.Contracts.Errors.Error)
Public Property | Warnings | Gets or sets the validation warnings.
Top
See Also

Reference

ValidationError Class
ActiveReports.Server.ReportServices.Contracts.Errors Namespace


Errors Property

Errors Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace > ValidationError Class : Errors Property
Gets or sets the validation errors.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Errors As NoticeType
public NoticeType Errors {get; set;}

Property Value

The errors.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationError Class
ValidationError Members


Warnings Property

Warnings Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace > ValidationError Class : Warnings Property
Gets or sets the validation warnings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Warnings As NoticeType
public NoticeType Warnings {get; set;}

Property Value

The warnings.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationError Class
ValidationError Members


ActiveReports.Server.ReportServices.Contracts.Feedback Namespace

ActiveReports.Server.ReportServices.Contracts.Feedback Namespace
Inheritance Hierarchy
ActiveReports.Server.ReportControls Assembly : ActiveReports.Server.ReportServices.Contracts.Feedback Namespace
Classes
 | Class | Description
Class | BugReport | Represents a contract to send an issue report from the report portal.
Class | FeedbackReport | Represents a contract to send an feedback report from the report portal.
See Also

Reference

ActiveReports.Server.ReportControls Assembly


BugReport Class

BugReport Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Feedback Namespace : BugReport Class
Represents a contract to send an issue report from the report portal.
Object Model
BugReport Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class BugReport
   Inherits FeedbackReport
public sealed class BugReport : FeedbackReport
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Feedback.FeedbackReport
ActiveReports.Server.ReportServices.Contracts.Feedback.BugReport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BugReport Members
ActiveReports.Server.ReportServices.Contracts.Feedback Namespace


BugReport Class Members

BugReport Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Feedback Namespace : BugReport Class

The following tables list the members exposed by BugReport.

Public Constructors
 | Name | Description
Public Constructor | BugReport Constructor | Initializes a new instance of the BugReport class.
Top
Public Properties
 | Name | Description
Public Property | Data | Gets or sets the report data.
Public Property | ErrorId | Gets or sets the ID of an occurred error.
Public Property | ModelState | Gets or sets the state of the bug model.
Public Property | StackTrace | Gets or sets the stack trace of an occurred error.
Public Property | Title | Gets or sets the report title. (Inherited from ActiveReports.Server.ReportServices.Contracts.Feedback.FeedbackReport)
Public Property | UserDescription | Gets or sets the user description of the issue/feedback. (Inherited from ActiveReports.Server.ReportServices.Contracts.Feedback.FeedbackReport)
Public Property | UserEmail | Gets or sets the email of user who reports the issue/feedback. (Inherited from ActiveReports.Server.ReportServices.Contracts.Feedback.FeedbackReport)
Top
See Also

Reference

BugReport Class
ActiveReports.Server.ReportServices.Contracts.Feedback Namespace


BugReport Constructor

BugReport Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Feedback Namespace > BugReport Class : BugReport Constructor
Initializes a new instance of the BugReport class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public BugReport()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BugReport Class
BugReport Members


BugReport Class Properties

BugReport Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Feedback Namespace : BugReport Class

For a list of all members of this type, see BugReport members.

Public Properties
 | Name | Description
Public Property | Data | Gets or sets the report data.
Public Property | ErrorId | Gets or sets the ID of an occurred error.
Public Property | ModelState | Gets or sets the state of the bug model.
Public Property | StackTrace | Gets or sets the stack trace of an occurred error.
Public Property | Title | Gets or sets the report title. (Inherited from ActiveReports.Server.ReportServices.Contracts.Feedback.FeedbackReport)
Public Property | UserDescription | Gets or sets the user description of the issue/feedback. (Inherited from ActiveReports.Server.ReportServices.Contracts.Feedback.FeedbackReport)
Public Property | UserEmail | Gets or sets the email of user who reports the issue/feedback. (Inherited from ActiveReports.Server.ReportServices.Contracts.Feedback.FeedbackReport)
Top
See Also

Reference

BugReport Class
ActiveReports.Server.ReportServices.Contracts.Feedback Namespace


Data Property (BugReport)

Data Property (BugReport)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Feedback Namespace > BugReport Class : Data Property
Gets or sets the report data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Data As String
public string Data {get; set;}

Property Value

The report data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BugReport Class
BugReport Members


ErrorId Property

ErrorId Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Feedback Namespace > BugReport Class : ErrorId Property
Gets or sets the ID of an occurred error.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ErrorId As String
public string ErrorId {get; set;}

Property Value

The error ID.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BugReport Class
BugReport Members


ModelState Property

ModelState Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Feedback Namespace > BugReport Class : ModelState Property
Gets or sets the state of the bug model.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ModelState As String
public string ModelState {get; set;}

Property Value

The state of the bug model.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BugReport Class
BugReport Members


StackTrace Property (BugReport)

StackTrace Property (BugReport)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Feedback Namespace > BugReport Class : StackTrace Property
Gets or sets the stack trace of an occurred error.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StackTrace As String
public string StackTrace {get; set;}

Property Value

The stack trace.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BugReport Class
BugReport Members


FeedbackReport Class

FeedbackReport Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Feedback Namespace : FeedbackReport Class
Represents a contract to send an feedback report from the report portal.
Object Model
FeedbackReport Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class FeedbackReport
public class FeedbackReport
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Feedback.FeedbackReport
ActiveReports.Server.ReportServices.Contracts.Feedback.BugReport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FeedbackReport Members
ActiveReports.Server.ReportServices.Contracts.Feedback Namespace


FeedbackReport Class Members

FeedbackReport Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Feedback Namespace : FeedbackReport Class

The following tables list the members exposed by FeedbackReport.

Public Constructors
 | Name | Description
Public Constructor | FeedbackReport Constructor | Initializes a new instance of the FeedbackReport class.
Top
Public Properties
 | Name | Description
Public Property | Title | Gets or sets the report title.
Public Property | UserDescription | Gets or sets the user description of the issue/feedback.
Public Property | UserEmail | Gets or sets the email of user who reports the issue/feedback.
Top
See Also

Reference

FeedbackReport Class
ActiveReports.Server.ReportServices.Contracts.Feedback Namespace


FeedbackReport Constructor

FeedbackReport Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Feedback Namespace > FeedbackReport Class : FeedbackReport Constructor
Initializes a new instance of the FeedbackReport class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public FeedbackReport()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FeedbackReport Class
FeedbackReport Members


FeedbackReport Class Properties

FeedbackReport Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Feedback Namespace : FeedbackReport Class

For a list of all members of this type, see FeedbackReport members.

Public Properties
 | Name | Description
Public Property | Title | Gets or sets the report title.
Public Property | UserDescription | Gets or sets the user description of the issue/feedback.
Public Property | UserEmail | Gets or sets the email of user who reports the issue/feedback.
Top
See Also

Reference

FeedbackReport Class
ActiveReports.Server.ReportServices.Contracts.Feedback Namespace


Title Property

Title Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Feedback Namespace > FeedbackReport Class : Title Property
Gets or sets the report title.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Title As String
public string Title {get; set;}

Property Value

The report title.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FeedbackReport Class
FeedbackReport Members


UserDescription Property

UserDescription Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Feedback Namespace > FeedbackReport Class : UserDescription Property
Gets or sets the user description of the issue/feedback.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UserDescription As String
public string UserDescription {get; set;}

Property Value

The user description.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FeedbackReport Class
FeedbackReport Members


UserEmail Property

UserEmail Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Feedback Namespace > FeedbackReport Class : UserEmail Property
Gets or sets the email of user who reports the issue/feedback.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UserEmail As String
public string UserEmail {get; set;}

Property Value

The user email.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FeedbackReport Class
FeedbackReport Members


ActiveReports.Server.ReportServices.Contracts.Policy Namespace

ActiveReports.Server.ReportServices.Contracts.Policy Namespace
Inheritance Hierarchy
ActiveReports.Server.ReportControls Assembly : ActiveReports.Server.ReportServices.Contracts.Policy Namespace
Classes
 | Class | Description
Class | JournalEntry | Represents a journal entry.
Class | JournalEntryDetails | Represents a journal entry details.
Class | JournalEntryTemplate | Represents a journal entry template definition.
Class | Policy | Represents an object that is returned as a result of a Policy operation and contains an array of item descriptons.
Class | PolicyHistoryEntry | Represents a single policy history entry.
Class | PolicyHistoryResult | Represents a policy history result.
Class | PolicyResult | Wrapper under CachePolicy
See Also

Reference

ActiveReports.Server.ReportControls Assembly


JournalEntry Class

JournalEntry Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace : JournalEntry Class
Represents a journal entry.
Object Model
JournalEntry ClassJournalEntryDetails ClassRenderOptions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class JournalEntry
public class JournalEntry
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Policy.JournalEntry

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JournalEntry Members
ActiveReports.Server.ReportServices.Contracts.Policy Namespace


JournalEntry Class Members

JournalEntry Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace : JournalEntry Class

The following tables list the members exposed by JournalEntry.

Public Constructors
 | Name | Description
Public Constructor | JournalEntry Constructor | Initializes a new instance of the JournalEntry class.
Top
Public Properties
 | Name | Description
Public Property | AccessionCode | Gets or sets the accession code for this journal entry.
Public Property | Details | Gets or sets the journal entry details.
Public Property | EntryPriority | Gets or sets the current priority of the scheduled user request represented by this journal entry.
Public Property | EntryStatus | Gets or sets the current status of the scheduled user request represented by this journal entry.
Public Property | Id | Gets or sets the identifier for this journal entry.
Public Property | Job | Gets or sets the job request defining the tasks that associated with this journal entry.
Public Property | ScheduledTime | Gets or sets the time when the execution of the associated request is sceduled.
Top
See Also

Reference

JournalEntry Class
ActiveReports.Server.ReportServices.Contracts.Policy Namespace


JournalEntry Constructor

JournalEntry Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > JournalEntry Class : JournalEntry Constructor
Initializes a new instance of the JournalEntry class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public JournalEntry()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JournalEntry Class
JournalEntry Members


JournalEntry Class Properties

JournalEntry Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace : JournalEntry Class

For a list of all members of this type, see JournalEntry members.

Public Properties
 | Name | Description
Public Property | AccessionCode | Gets or sets the accession code for this journal entry.
Public Property | Details | Gets or sets the journal entry details.
Public Property | EntryPriority | Gets or sets the current priority of the scheduled user request represented by this journal entry.
Public Property | EntryStatus | Gets or sets the current status of the scheduled user request represented by this journal entry.
Public Property | Id | Gets or sets the identifier for this journal entry.
Public Property | Job | Gets or sets the job request defining the tasks that associated with this journal entry.
Public Property | ScheduledTime | Gets or sets the time when the execution of the associated request is sceduled.
Top
See Also

Reference

JournalEntry Class
ActiveReports.Server.ReportServices.Contracts.Policy Namespace


AccessionCode Property (JournalEntry)

AccessionCode Property (JournalEntry)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > JournalEntry Class : AccessionCode Property
Gets or sets the accession code for this journal entry.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AccessionCode As String
public string AccessionCode {get; set;}

Property Value

The accession code for this journal entry.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JournalEntry Class
JournalEntry Members


Details Property

Details Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > JournalEntry Class : Details Property
Gets or sets the journal entry details.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Details As JournalEntryDetails
public JournalEntryDetails Details {get; set;}

Property Value

The journal entry details.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JournalEntry Class
JournalEntry Members


EntryPriority Property (JournalEntry)

EntryPriority Property (JournalEntry)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > JournalEntry Class : EntryPriority Property
Gets or sets the current priority of the scheduled user request represented by this journal entry.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EntryPriority As JournalEntryPriority
public JournalEntryPriority EntryPriority {get; set;}

Property Value

The current priority of the scheduled user request represented by this journal entry.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JournalEntry Class
JournalEntry Members


EntryStatus Property

EntryStatus Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > JournalEntry Class : EntryStatus Property
Gets or sets the current status of the scheduled user request represented by this journal entry.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EntryStatus As JournalEntryStatus
public JournalEntryStatus EntryStatus {get; set;}

Property Value

The current status of the scheduled user request represented by this journal entry.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JournalEntry Class
JournalEntry Members


Id Property (JournalEntry)

Id Property (JournalEntry)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > JournalEntry Class : Id Property
Gets or sets the identifier for this journal entry.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Id As String
public string Id {get; set;}

Property Value

The identifier for this journal entry.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JournalEntry Class
JournalEntry Members


Job Property (JournalEntry)

Job Property (JournalEntry)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > JournalEntry Class : Job Property
Gets or sets the job request defining the tasks that associated with this journal entry.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Job As RenderOptions
public RenderOptions Job {get; set;}

Property Value

The job request defining the tasks that associated with this journal entry.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JournalEntry Class
JournalEntry Members


ScheduledTime Property

ScheduledTime Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > JournalEntry Class : ScheduledTime Property
Gets or sets the time when the execution of the associated request is sceduled.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ScheduledTime As Date
public DateTime ScheduledTime {get; set;}

Property Value

The time when the execution of the associated request is sceduled.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JournalEntry Class
JournalEntry Members


JournalEntryDetails Class

JournalEntryDetails Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace : JournalEntryDetails Class
Represents a journal entry details.
Object Model
JournalEntryDetails ClassExceptionDetail ClassReportParameter Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class JournalEntryDetails
public class JournalEntryDetails
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Policy.JournalEntryDetails

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JournalEntryDetails Members
ActiveReports.Server.ReportServices.Contracts.Policy Namespace


JournalEntryDetails Class Members

JournalEntryDetails Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace : JournalEntryDetails Class

The following tables list the members exposed by JournalEntryDetails.

Public Constructors
 | Name | Description
Public Constructor | JournalEntryDetails Constructor | Initializes a new instance of the JournalEntryDetails class.
Top
Public Properties
 | Name | Description
Public Property | ExceptionDetails | Gets or sets the exception details if the job was failed.
Public Property | PrimaryUrl | Gets or sets the primary URL to get the result.
Public Property | ReportParameters | Gets or sets the report parameters.
Top
See Also

Reference

JournalEntryDetails Class
ActiveReports.Server.ReportServices.Contracts.Policy Namespace


JournalEntryDetails Constructor

JournalEntryDetails Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > JournalEntryDetails Class : JournalEntryDetails Constructor
Initializes a new instance of the JournalEntryDetails class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public JournalEntryDetails()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JournalEntryDetails Class
JournalEntryDetails Members


JournalEntryDetails Class Properties

JournalEntryDetails Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace : JournalEntryDetails Class

For a list of all members of this type, see JournalEntryDetails members.

Public Properties
 | Name | Description
Public Property | ExceptionDetails | Gets or sets the exception details if the job was failed.
Public Property | PrimaryUrl | Gets or sets the primary URL to get the result.
Public Property | ReportParameters | Gets or sets the report parameters.
Top
See Also

Reference

JournalEntryDetails Class
ActiveReports.Server.ReportServices.Contracts.Policy Namespace


ExceptionDetails Property

ExceptionDetails Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > JournalEntryDetails Class : ExceptionDetails Property
Gets or sets the exception details if the job was failed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ExceptionDetails As ExceptionDetail
public ExceptionDetail ExceptionDetails {get; set;}

Property Value

The exception details.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JournalEntryDetails Class
JournalEntryDetails Members


PrimaryUrl Property (JournalEntryDetails)

PrimaryUrl Property (JournalEntryDetails)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > JournalEntryDetails Class : PrimaryUrl Property
Gets or sets the primary URL to get the result.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PrimaryUrl As String
public string PrimaryUrl {get; set;}

Property Value

The primary URL.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JournalEntryDetails Class
JournalEntryDetails Members


ReportParameters Property (JournalEntryDetails)

ReportParameters Property (JournalEntryDetails)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > JournalEntryDetails Class : ReportParameters Property
Gets or sets the report parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReportParameters As ReportParameter()
public ReportParameter[] ReportParameters {get; set;}

Property Value

The report parameters.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JournalEntryDetails Class
JournalEntryDetails Members


JournalEntryTemplate Class

JournalEntryTemplate Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace : JournalEntryTemplate Class
Represents a journal entry template definition.
Object Model
JournalEntryTemplate ClassRenderOptions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class JournalEntryTemplate
public class JournalEntryTemplate
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Policy.JournalEntryTemplate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JournalEntryTemplate Members
ActiveReports.Server.ReportServices.Contracts.Policy Namespace


JournalEntryTemplate Class Members

JournalEntryTemplate Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace : JournalEntryTemplate Class

The following tables list the members exposed by JournalEntryTemplate.

Public Constructors
 | Name | Description
Public Constructor | JournalEntryTemplate Constructor | Initializes a new instance of the JournalEntryTemplate class.
Top
Public Properties
 | Name | Description
Public Property | EntryPriority | Gets or sets the priority for the scheduled item represented by this instance.
Public Property | Job | Gets or sets the job to be done.
Top
See Also

Reference

JournalEntryTemplate Class
ActiveReports.Server.ReportServices.Contracts.Policy Namespace


JournalEntryTemplate Constructor

JournalEntryTemplate Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > JournalEntryTemplate Class : JournalEntryTemplate Constructor
Initializes a new instance of the JournalEntryTemplate class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public JournalEntryTemplate()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JournalEntryTemplate Class
JournalEntryTemplate Members


JournalEntryTemplate Class Properties

JournalEntryTemplate Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace : JournalEntryTemplate Class

For a list of all members of this type, see JournalEntryTemplate members.

Public Properties
 | Name | Description
Public Property | EntryPriority | Gets or sets the priority for the scheduled item represented by this instance.
Public Property | Job | Gets or sets the job to be done.
Top
See Also

Reference

JournalEntryTemplate Class
ActiveReports.Server.ReportServices.Contracts.Policy Namespace


EntryPriority Property (JournalEntryTemplate)

EntryPriority Property (JournalEntryTemplate)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > JournalEntryTemplate Class : EntryPriority Property
Gets or sets the priority for the scheduled item represented by this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EntryPriority As JournalEntryPriority
public JournalEntryPriority EntryPriority {get; set;}

Property Value

The priority for the scheduled item represented by this instance.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JournalEntryTemplate Class
JournalEntryTemplate Members


Job Property (JournalEntryTemplate)

Job Property (JournalEntryTemplate)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > JournalEntryTemplate Class : Job Property
Gets or sets the job to be done.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Job As RenderOptions
public RenderOptions Job {get; set;}

Property Value

The job to be done.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JournalEntryTemplate Class
JournalEntryTemplate Members


Policy Class

Policy Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace : Policy Class
Represents an object that is returned as a result of a Policy operation and contains an array of item descriptons.
Object Model
Policy ClassDistributionMethod ClassJournalEntryTemplate ClassSchedule Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Policy
public class Policy
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Policy.Policy

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Policy Members
ActiveReports.Server.ReportServices.Contracts.Policy Namespace


Policy Class Members

Policy Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace : Policy Class

The following tables list the members exposed by Policy.

Public Constructors
 | Name | Description
Public Constructor | Policy Constructor | Initializes a new instance of the Policy class.
Top
Public Properties
 | Name | Description
Public Property | CachePolicy | Gets or sets the rule set defining how the results of each journal entry should be cached.
Public Property | CreatedBy | Gets the name of the user created this policy.
Public Property | CreationDate | Gets or sets the creation date of this policy.
Public Property | Distribution | Gets or sets the distribution defining the rules of delivery the execution results to a user.
Public Property | Id | Gets or sets the id.
Public Property | JournalEntry | Gets or sets the template providing a way to create a journal entry.
Public Property | ModifiedBy | Gets the name of the user made the last modification of this policy.
Public Property | ModifiedDate | Gets or sets the date of last modification of this policy.
Public Property | Name | Gets or sets the name of this policy.
Public Property | ParentId | Id of the Item to apply
Public Property | PolicyType | Gets or sets the type of the policy, which describe policy subclasses.
Public Property | Schedule | Gets or sets the schedule defining the rules to determine execution timeline.
Public Property | SharedPolicyTemplateId | Gets or sets the related shared policy template id.
Public Property | TargetId | Id of the Item to apply
Top
See Also

Reference

Policy Class
ActiveReports.Server.ReportServices.Contracts.Policy Namespace


Policy Constructor

Policy Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > Policy Class : Policy Constructor
Initializes a new instance of the Policy class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Policy()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Policy Class
Policy Members


Policy Class Properties

Policy Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace : Policy Class

For a list of all members of this type, see Policy members.

Public Properties
 | Name | Description
Public Property | CachePolicy | Gets or sets the rule set defining how the results of each journal entry should be cached.
Public Property | CreatedBy | Gets the name of the user created this policy.
Public Property | CreationDate | Gets or sets the creation date of this policy.
Public Property | Distribution | Gets or sets the distribution defining the rules of delivery the execution results to a user.
Public Property | Id | Gets or sets the id.
Public Property | JournalEntry | Gets or sets the template providing a way to create a journal entry.
Public Property | ModifiedBy | Gets the name of the user made the last modification of this policy.
Public Property | ModifiedDate | Gets or sets the date of last modification of this policy.
Public Property | Name | Gets or sets the name of this policy.
Public Property | ParentId | Id of the Item to apply
Public Property | PolicyType | Gets or sets the type of the policy, which describe policy subclasses.
Public Property | Schedule | Gets or sets the schedule defining the rules to determine execution timeline.
Public Property | SharedPolicyTemplateId | Gets or sets the related shared policy template id.
Public Property | TargetId | Id of the Item to apply
Top
See Also

Reference

Policy Class
ActiveReports.Server.ReportServices.Contracts.Policy Namespace


CachePolicy Property (Policy)

CachePolicy Property (Policy)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > Policy Class : CachePolicy Property
Gets or sets the rule set defining how the results of each journal entry should be cached.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CachePolicy As CachePolicy
public CachePolicy CachePolicy {get; set;}

Property Value

The rule set defining how the results of each journal entry should be cached.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Policy Class
Policy Members


CreatedBy Property (Policy)

CreatedBy Property (Policy)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > Policy Class : CreatedBy Property
Gets the name of the user created this policy.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CreatedBy As String
public string CreatedBy {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Policy Class
Policy Members


CreationDate Property (Policy)

CreationDate Property (Policy)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > Policy Class : CreationDate Property
Gets or sets the creation date of this policy.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CreationDate As Date
public DateTime CreationDate {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Policy Class
Policy Members


Distribution Property (Policy)

Distribution Property (Policy)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > Policy Class : Distribution Property
Gets or sets the distribution defining the rules of delivery the execution results to a user.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Distribution As DistributionMethod
public DistributionMethod Distribution {get; set;}

Property Value

The distribution defining the rules of delivery the execution results to a user.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Policy Class
Policy Members


Id Property (Policy)

Id Property (Policy)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > Policy Class : Id Property
Gets or sets the id.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Id As String
public string Id {get; set;}

Property Value

The id.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Policy Class
Policy Members


JournalEntry Property (Policy)

JournalEntry Property (Policy)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > Policy Class : JournalEntry Property
Gets or sets the template providing a way to create a journal entry.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property JournalEntry As JournalEntryTemplate
public JournalEntryTemplate JournalEntry {get; set;}

Property Value

The template providing a way to create a journal entry.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Policy Class
Policy Members


ModifiedBy Property (Policy)

ModifiedBy Property (Policy)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > Policy Class : ModifiedBy Property
Gets the name of the user made the last modification of this policy.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ModifiedBy As String
public string ModifiedBy {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Policy Class
Policy Members


ModifiedDate Property (Policy)

ModifiedDate Property (Policy)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > Policy Class : ModifiedDate Property
Gets or sets the date of last modification of this policy.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ModifiedDate As Date
public DateTime ModifiedDate {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Policy Class
Policy Members


Name Property (Policy)

Name Property (Policy)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > Policy Class : Name Property
Gets or sets the name of this policy.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As String
public string Name {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Policy Class
Policy Members


ParentId Property (Policy)

ParentId Property (Policy)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > Policy Class : ParentId Property
Id of the Item to apply
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ParentId As String
public string ParentId {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Policy Class
Policy Members


PolicyType Property (Policy)

PolicyType Property (Policy)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > Policy Class : PolicyType Property
Gets or sets the type of the policy, which describe policy subclasses.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PolicyType As PolicyType
public PolicyType PolicyType {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Policy Class
Policy Members


Schedule Property (Policy)

Schedule Property (Policy)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > Policy Class : Schedule Property
Gets or sets the schedule defining the rules to determine execution timeline.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Schedule As Schedule
public Schedule Schedule {get; set;}

Property Value

The schedule defining the rules to determine execution timeline.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Policy Class
Policy Members


SharedPolicyTemplateId Property (Policy)

SharedPolicyTemplateId Property (Policy)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > Policy Class : SharedPolicyTemplateId Property
Gets or sets the related shared policy template id.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SharedPolicyTemplateId As String
public string SharedPolicyTemplateId {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Policy Class
Policy Members


TargetId Property (Policy)

TargetId Property (Policy)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > Policy Class : TargetId Property
Id of the Item to apply
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TargetId As String
public string TargetId {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Policy Class
Policy Members


PolicyHistoryEntry Class

PolicyHistoryEntry Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace : PolicyHistoryEntry Class
Represents a single policy history entry.
Object Model
PolicyHistoryEntry ClassJournalEntry Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class PolicyHistoryEntry
public class PolicyHistoryEntry
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Policy.PolicyHistoryEntry

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PolicyHistoryEntry Members
ActiveReports.Server.ReportServices.Contracts.Policy Namespace


PolicyHistoryEntry Class Members

PolicyHistoryEntry Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace : PolicyHistoryEntry Class

The following tables list the members exposed by PolicyHistoryEntry.

Public Constructors
 | Name | Description
Public Constructor | PolicyHistoryEntry Constructor | Initializes a new instance of the PolicyHistoryEntry class.
Top
Public Properties
 | Name | Description
Public Property | IsExpired | Gets or sets a value indicating whether this instance is expired.
Public Property | JournalEntry | Gets the journal entry.
Public Property | PolicyId | Gets the identifier of the associated policy.
Public Property | PolicyName | Gets the name.
Public Property | TargetId | Gets the target id.
Top
See Also

Reference

PolicyHistoryEntry Class
ActiveReports.Server.ReportServices.Contracts.Policy Namespace


PolicyHistoryEntry Constructor

PolicyHistoryEntry Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > PolicyHistoryEntry Class : PolicyHistoryEntry Constructor
Initializes a new instance of the PolicyHistoryEntry class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public PolicyHistoryEntry()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PolicyHistoryEntry Class
PolicyHistoryEntry Members


PolicyHistoryEntry Class Properties

PolicyHistoryEntry Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace : PolicyHistoryEntry Class

For a list of all members of this type, see PolicyHistoryEntry members.

Public Properties
 | Name | Description
Public Property | IsExpired | Gets or sets a value indicating whether this instance is expired.
Public Property | JournalEntry | Gets the journal entry.
Public Property | PolicyId | Gets the identifier of the associated policy.
Public Property | PolicyName | Gets the name.
Public Property | TargetId | Gets the target id.
Top
See Also

Reference

PolicyHistoryEntry Class
ActiveReports.Server.ReportServices.Contracts.Policy Namespace


IsExpired Property (PolicyHistoryEntry)

IsExpired Property (PolicyHistoryEntry)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > PolicyHistoryEntry Class : IsExpired Property
Gets or sets a value indicating whether this instance is expired.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsExpired As Boolean
public bool IsExpired {get; set;}

Property Value

true if this instance is expired; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PolicyHistoryEntry Class
PolicyHistoryEntry Members


JournalEntry Property (PolicyHistoryEntry)

JournalEntry Property (PolicyHistoryEntry)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > PolicyHistoryEntry Class : JournalEntry Property
Gets the journal entry.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property JournalEntry As JournalEntry
public JournalEntry JournalEntry {get; set;}

Property Value

The journal entry.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PolicyHistoryEntry Class
PolicyHistoryEntry Members


PolicyId Property (PolicyHistoryEntry)

PolicyId Property (PolicyHistoryEntry)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > PolicyHistoryEntry Class : PolicyId Property
Gets the identifier of the associated policy.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PolicyId As String
public string PolicyId {get; set;}

Property Value

The identifier of the associated policy.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PolicyHistoryEntry Class
PolicyHistoryEntry Members


PolicyName Property (PolicyHistoryEntry)

PolicyName Property (PolicyHistoryEntry)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > PolicyHistoryEntry Class : PolicyName Property
Gets the name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PolicyName As String
public string PolicyName {get; set;}

Property Value

The name.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PolicyHistoryEntry Class
PolicyHistoryEntry Members


TargetId Property (PolicyHistoryEntry)

TargetId Property (PolicyHistoryEntry)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > PolicyHistoryEntry Class : TargetId Property
Gets the target id.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TargetId As String
public string TargetId {get; set;}

Property Value

The target id.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PolicyHistoryEntry Class
PolicyHistoryEntry Members


PolicyHistoryResult Class

PolicyHistoryResult Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace : PolicyHistoryResult Class
Represents a policy history result.
Object Model
PolicyHistoryResult ClassError ClassPolicyHistoryEntry Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class PolicyHistoryResult
   Inherits ActiveReports.Server.ReportServices.Contracts.Result
public class PolicyHistoryResult : ActiveReports.Server.ReportServices.Contracts.Result
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Result
ActiveReports.Server.ReportServices.Contracts.Policy.PolicyHistoryResult

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PolicyHistoryResult Members
ActiveReports.Server.ReportServices.Contracts.Policy Namespace


PolicyHistoryResult Class Members

PolicyHistoryResult Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace : PolicyHistoryResult Class

The following tables list the members exposed by PolicyHistoryResult.

Public Constructors
 | Name | Description
Public Constructor | PolicyHistoryResult Constructor | Creates new policy history result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Top
Public Properties
 | Name | Description
Public Property | Error | An error occurred during operation execution that should be returned to client. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Public Property | History | Gets or sets the history.
Public Property | IsAuthenticated | Gets a value that indicates whether the user has been authenticated. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Top
See Also

Reference

PolicyHistoryResult Class
ActiveReports.Server.ReportServices.Contracts.Policy Namespace


PolicyHistoryResult Constructor

PolicyHistoryResult Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > PolicyHistoryResult Class : PolicyHistoryResult Constructor
Creates new policy history result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public PolicyHistoryResult()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PolicyHistoryResult Class
PolicyHistoryResult Members


PolicyHistoryResult Class Properties

PolicyHistoryResult Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace : PolicyHistoryResult Class

For a list of all members of this type, see PolicyHistoryResult members.

Public Properties
 | Name | Description
Public Property | Error | An error occurred during operation execution that should be returned to client. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Public Property | History | Gets or sets the history.
Public Property | IsAuthenticated | Gets a value that indicates whether the user has been authenticated. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Top
See Also

Reference

PolicyHistoryResult Class
ActiveReports.Server.ReportServices.Contracts.Policy Namespace


History Property

History Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > PolicyHistoryResult Class : History Property
Gets or sets the history.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property History As PolicyHistoryEntry()
public PolicyHistoryEntry[] History {get; set;}

Property Value

The history.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PolicyHistoryResult Class
PolicyHistoryResult Members


PolicyResult Class

PolicyResult Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace : PolicyResult Class
Wrapper under CachePolicy
Object Model
PolicyResult ClassError ClassPolicy Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class PolicyResult
   Inherits ActiveReports.Server.ReportServices.Contracts.Result
public class PolicyResult : ActiveReports.Server.ReportServices.Contracts.Result
Inheritance Hierarchy

System.Object
ActiveReports.Server.ReportServices.Contracts.Result
ActiveReports.Server.ReportServices.Contracts.Policy.PolicyResult

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PolicyResult Members
ActiveReports.Server.ReportServices.Contracts.Policy Namespace


PolicyResult Class Members

PolicyResult Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace : PolicyResult Class

The following tables list the members exposed by PolicyResult.

Public Constructors
 | Name | Description
Public Constructor | PolicyResult Constructor | Creates new policy result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Top
Public Properties
 | Name | Description
Public Property | Error | An error occurred during operation execution that should be returned to client. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Public Property | IsAuthenticated | Gets a value that indicates whether the user has been authenticated. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Public Property | Policies | Gets or sets the policies.
Top
See Also

Reference

PolicyResult Class
ActiveReports.Server.ReportServices.Contracts.Policy Namespace


PolicyResult Constructor

PolicyResult Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > PolicyResult Class : PolicyResult Constructor
Creates new policy result of a ActiveReports.Server.ReportServices.Servicing.IDesignerService operation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public PolicyResult()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PolicyResult Class
PolicyResult Members


PolicyResult Class Properties

PolicyResult Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace : PolicyResult Class

For a list of all members of this type, see PolicyResult members.

Public Properties
 | Name | Description
Public Property | Error | An error occurred during operation execution that should be returned to client. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Public Property | IsAuthenticated | Gets a value that indicates whether the user has been authenticated. (Inherited from ActiveReports.Server.ReportServices.Contracts.Result)
Public Property | Policies | Gets or sets the policies.
Top
See Also

Reference

PolicyResult Class
ActiveReports.Server.ReportServices.Contracts.Policy Namespace


Policies Property

Policies Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Policy Namespace > PolicyResult Class : Policies Property
Gets or sets the policies.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Policies As Policy()
public Policy[] Policies {get; set;}

Property Value

The policies.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PolicyResult Class
PolicyResult Members


ActiveReports.Server.ReportServices.Servicing Namespace

ActiveReports.Server.ReportServices.Servicing Namespace
Inheritance Hierarchy
ActiveReports.Server.ReportControls Assembly : ActiveReports.Server.ReportServices.Servicing Namespace
Interfaces
 | Interface | Description
Interface | IDesignerService | Specifies the IDesignerService contract interface.
Interface | IReportService | Defines a report management service.
See Also

Reference

ActiveReports.Server.ReportControls Assembly


IDesignerService Interface

IDesignerService Interface
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace : IDesignerService Interface
Specifies the IDesignerService contract interface.
Object Model
IDesignerService Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDesignerService
public interface IDesignerService
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDesignerService Members
ActiveReports.Server.ReportServices.Servicing Namespace


IDesignerService Interface Members

IDesignerService Interface Members
Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace : IDesignerService Interface

The following tables list the members exposed by IDesignerService.

Public Methods
 | Name | Description
Method | CancelRequest | Cancels the currently running request.
Method | CreatePolicy | Creates a policy for the specified target.
Method | DeletePolicy | Deletes the specified policy.
Method | DeleteReport | Deletes the report specified by a id.
Method | DoLookup | Performs the lookup according to specified a model and a query.
Method | DownloadItem | Download a requested resource from the storage.
Method | ExportDocument | Exports the document specified by ID in relayout options to another format.
Method | GetList | Returns a list of descriptors for specified type.
Method | GetParameterList | Returns a list of report parameter descriptions for specified report.
Method | GetPolicies | Gets a policy collection for the specified target.
Method | GetResourcePermissions | Gets the permissions to the report.
Method | GetUserCapabilities | Returns a user capabilities.
Method | IsLoggedIn | Determines whether the security token is valid.
Method | Login | Checks user credentials and creates an security token if the credentials are valid.
Method | Logout | Recalls the security token.
Method | RelayoutDocument | Relayouts the document specified by ID in relayout options.
Method | RenderReport | Renders the report specified by a report description.
Method | ResolveParameters | Populates the report parameters.
Method | RetrieveHistory | Ritrieves the collection of policy history entries matching the specified target.
Method | SavePolicy | Saves the changes to the specified policy.
Method | SetDescription | Sets the item description.
Method | SetResourcePermissions | Sets the permissions to the report.
Method | SubmitReport | Submits the BugzScout report.
Method | UploadItem | Upload item to server.
Top
See Also

Reference

IDesignerService Interface
ActiveReports.Server.ReportServices.Servicing Namespace


IDesignerService Interface Methods

IDesignerService Interface Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace : IDesignerService Interface

For a list of all members of this type, see IDesignerService members.

Public Methods
 | Name | Description
Method | CancelRequest | Cancels the currently running request.
Method | CreatePolicy | Creates a policy for the specified target.
Method | DeletePolicy | Deletes the specified policy.
Method | DeleteReport | Deletes the report specified by a id.
Method | DoLookup | Performs the lookup according to specified a model and a query.
Method | DownloadItem | Download a requested resource from the storage.
Method | ExportDocument | Exports the document specified by ID in relayout options to another format.
Method | GetList | Returns a list of descriptors for specified type.
Method | GetParameterList | Returns a list of report parameter descriptions for specified report.
Method | GetPolicies | Gets a policy collection for the specified target.
Method | GetResourcePermissions | Gets the permissions to the report.
Method | GetUserCapabilities | Returns a user capabilities.
Method | IsLoggedIn | Determines whether the security token is valid.
Method | Login | Checks user credentials and creates an security token if the credentials are valid.
Method | Logout | Recalls the security token.
Method | RelayoutDocument | Relayouts the document specified by ID in relayout options.
Method | RenderReport | Renders the report specified by a report description.
Method | ResolveParameters | Populates the report parameters.
Method | RetrieveHistory | Ritrieves the collection of policy history entries matching the specified target.
Method | SavePolicy | Saves the changes to the specified policy.
Method | SetDescription | Sets the item description.
Method | SetResourcePermissions | Sets the permissions to the report.
Method | SubmitReport | Submits the BugzScout report.
Method | UploadItem | Upload item to server.
Top
See Also

Reference

IDesignerService Interface
ActiveReports.Server.ReportServices.Servicing Namespace


CancelRequest Method (IDesignerService)

CancelRequest Method (IDesignerService)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IDesignerService Interface : CancelRequest Method
The security token to use.
The identifier of the request to cancel.
Cancels the currently running request.
Syntax
  • Visual Basic
  • C#
'Declaration

Function CancelRequest( _
   ByVal token As String, _
   ByVal id As String _
) As Result
Result CancelRequest(
   string token,
   string id
)

Parameters

token
The security token to use.
id
The identifier of the request to cancel.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDesignerService Interface
IDesignerService Members


CreatePolicy Method

CreatePolicy Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IDesignerService Interface : CreatePolicy Method
The security token to use.
The target id.
Name of the policy.
Type of the policy: schedule, cache or so on.
Id of related shared policy template.
Creates a policy for the specified target.
Syntax
  • Visual Basic
  • C#
'Declaration

Function CreatePolicy( _
   ByVal token As String, _
   ByVal targetId As String, _
   ByVal policyName As String, _
   ByVal policyType As PolicyType, _
   ByVal sharedPolicyTemplateId As String _
) As PolicyResult
PolicyResult CreatePolicy(
   string token,
   string targetId,
   string policyName,
   PolicyType policyType,
   string sharedPolicyTemplateId
)

Parameters

token
The security token to use.
targetId
The target id.
policyName
Name of the policy.
policyType
Type of the policy: schedule, cache or so on.
sharedPolicyTemplateId
Id of related shared policy template.

Return Value

The policy.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDesignerService Interface
IDesignerService Members


DeletePolicy Method

DeletePolicy Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IDesignerService Interface : DeletePolicy Method
The security token to use.
The target id.
The policy id.
Deletes the specified policy.
Syntax
  • Visual Basic
  • C#
'Declaration

Function DeletePolicy( _
   ByVal token As String, _
   ByVal targetId As String, _
   ByVal policyId As Guid _
) As Result
Result DeletePolicy(
   string token,
   string targetId,
   Guid policyId
)

Parameters

token
The security token to use.
targetId
The target id.
policyId
The policy id.

Return Value

The result.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDesignerService Interface
IDesignerService Members


DeleteReport Method

DeleteReport Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IDesignerService Interface : DeleteReport Method
The security token to use.
The identifier of the report to delete.
Deletes the report specified by a id.
Syntax
  • Visual Basic
  • C#
'Declaration

Function DeleteReport( _
   ByVal token As String, _
   ByVal id As String _
) As DataResult
DataResult DeleteReport(
   string token,
   string id
)

Parameters

token
The security token to use.
id
The identifier of the report to delete.

Return Value

ActiveReports.Server.ReportServices.Contracts.ResultContains the status of operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDesignerService Interface
IDesignerService Members


DoLookup Method

DoLookup Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IDesignerService Interface : DoLookup Method
The security token to use.
The model id.
The semantic query.
Performs the lookup according to specified a model and a query.
Syntax
  • Visual Basic
  • C#
'Declaration

Function DoLookup( _
   ByVal token As String, _
   ByVal modelId As String, _
   ByVal query As String _
) As LookupResult
LookupResult DoLookup(
   string token,
   string modelId,
   string query
)

Parameters

token
The security token to use.
modelId
The model id.
query
The semantic query.

Return Value

ActiveReports.Server.ReportServices.Contracts.LookupResult containing the lookup result.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDesignerService Interface
IDesignerService Members


DownloadItem Method

DownloadItem Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IDesignerService Interface : DownloadItem Method
The security token to use.
Specifies the type of item to download.
The identifier of items to download.
Download a requested resource from the storage.
Syntax
  • Visual Basic
  • C#
'Declaration

Function DownloadItem( _
   ByVal token As String, _
   ByVal type As StorageType, _
   ByVal ids() As String _
) As DataArrayResult
DataArrayResult DownloadItem(
   string token,
   StorageType type,
   string[] ids
)

Parameters

token
The security token to use.
type
Specifies the type of item to download.
ids
The identifier of items to download.

Return Value

ActiveReports.Server.ReportServices.Contracts.ResultObject containing downloaded item content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDesignerService Interface
IDesignerService Members


ExportDocument Method (IDesignerService)

ExportDocument Method (IDesignerService)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IDesignerService Interface : ExportDocument Method
The security token to use.
The report description.
The options for export.
Exports the document specified by ID in relayout options to another format.
Syntax
  • Visual Basic
  • C#
'Declaration

Function ExportDocument( _
   ByVal token As String, _
   ByVal description As ReportDescription, _
   ByVal options As ExportOptions _
) As RequestResult
RequestResult ExportDocument(
   string token,
   ReportDescription description,
   ExportOptions options
)

Parameters

token
The security token to use.
description
The report description.
options
The options for export.

Return Value

ActiveReports.Server.ReportServices.Contracts.RequestResult object containing the request id and resolved uri.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDesignerService Interface
IDesignerService Members


GetList Method

GetList Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IDesignerService Interface : GetList Method
The security token to use.
Specifies the type of resources to get list of.
Specifies the filter to process the result by.
Returns a list of descriptors for specified type.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetList( _
   ByVal token As String, _
   ByVal type As StorageType, _
   ByVal filter As DescriptionFilter _
) As ItemDescriptionsResult
ItemDescriptionsResult GetList(
   string token,
   StorageType type,
   DescriptionFilter filter
)

Parameters

token
The security token to use.
type
Specifies the type of resources to get list of.
filter
Specifies the filter to process the result by.

Return Value

ActiveReports.Server.ReportServices.Contracts.Result object containing a list of corresponding descriptions.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDesignerService Interface
IDesignerService Members


GetParameterList Method

GetParameterList Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IDesignerService Interface : GetParameterList Method
The security token to use.
Specifies the report id to resolve parameters for.
Returns a list of report parameter descriptions for specified report.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetParameterList( _
   ByVal token As String, _
   ByVal reportId As String _
) As ReportParametersResult
ReportParametersResult GetParameterList(
   string token,
   string reportId
)

Parameters

token
The security token to use.
reportId
Specifies the report id to resolve parameters for.

Return Value

ActiveReports.Server.ReportServices.Contracts.ReportParametersResult object containing a list of ActiveReports.Server.ReportServices.Contracts.Descriptions.ReportParameterDescriptions.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDesignerService Interface
IDesignerService Members


GetPolicies Method

GetPolicies Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IDesignerService Interface : GetPolicies Method
The security token to use.
The target id.
Gets a policy collection for the specified target.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetPolicies( _
   ByVal token As String, _
   ByVal targetId As String _
) As PolicyResult
PolicyResult GetPolicies(
   string token,
   string targetId
)

Parameters

token
The security token to use.
targetId
The target id.

Return Value

The collection of policies.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDesignerService Interface
IDesignerService Members


GetResourcePermissions Method (IDesignerService)

GetResourcePermissions Method (IDesignerService)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IDesignerService Interface : GetResourcePermissions Method
The security token to use.
Specifies the type of item.
The identifier of the report to request permissions.
Gets the permissions to the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetResourcePermissions( _
   ByVal token As String, _
   ByVal type As StorageType, _
   ByVal id As String _
) As ResourcePermissionsResult
ResourcePermissionsResult GetResourcePermissions(
   string token,
   StorageType type,
   string id
)

Parameters

token
The security token to use.
type
Specifies the type of item.
id
The identifier of the report to request permissions.

Return Value

ActiveReports.Server.ReportServices.Contracts.ResultObject containing permissions.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDesignerService Interface
IDesignerService Members


GetUserCapabilities Method (IDesignerService)

GetUserCapabilities Method (IDesignerService)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IDesignerService Interface : GetUserCapabilities Method
The security token to use.
Returns a user capabilities.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetUserCapabilities( _
   ByVal token As String _
) As UserCapabilitiesResult
UserCapabilitiesResult GetUserCapabilities(
   string token
)

Parameters

token
The security token to use.

Return Value

ActiveReports.Server.ReportServices.Contracts.UserCapabilitiesResult object containing user capabilities.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDesignerService Interface
IDesignerService Members


IsLoggedIn Method (IDesignerService)

IsLoggedIn Method (IDesignerService)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IDesignerService Interface : IsLoggedIn Method
The security token to validate.
Determines whether the security token is valid.
Syntax
  • Visual Basic
  • C#
'Declaration

Function IsLoggedIn( _
   ByVal token As String _
) As Boolean
bool IsLoggedIn(
   string token
)

Parameters

token
The security token to validate.

Return Value

true if the security token is valid; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDesignerService Interface
IDesignerService Members


Login Method (IDesignerService)

Login Method (IDesignerService)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IDesignerService Interface : Login Method
The user name to be validated.
The password for the specified user.
The value or values to validate in addition to user name and password, if any
A value that indicates whether the authentication ticket remains valid across sessions.
Checks user credentials and creates an security token if the credentials are valid.
Syntax
  • Visual Basic
  • C#
'Declaration

Function Login( _
   ByVal username As String, _
   ByVal password As String, _
   ByVal custom As String, _
   ByVal isPersistent As Boolean _
) As String
string Login(
   string username,
   string password,
   string custom,
   bool isPersistent
)

Parameters

username
The user name to be validated.
password
The password for the specified user.
custom
The value or values to validate in addition to user name and password, if any
isPersistent
A value that indicates whether the authentication ticket remains valid across sessions.

Return Value

A security token if user credentials are valid; otherwise, null
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDesignerService Interface
IDesignerService Members


Logout Method (IDesignerService)

Logout Method (IDesignerService)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IDesignerService Interface : Logout Method
The security token to recall.
Recalls the security token.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Logout( _
   ByVal token As String _
)
void Logout(
   string token
)

Parameters

token
The security token to recall.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDesignerService Interface
IDesignerService Members


RelayoutDocument Method

RelayoutDocument Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IDesignerService Interface : RelayoutDocument Method
The security token to use.
The report description.
The options for relayout.
Relayouts the document specified by ID in relayout options.
Syntax
  • Visual Basic
  • C#
'Declaration

Function RelayoutDocument( _
   ByVal token As String, _
   ByVal description As ReportDescription, _
   ByVal options As RelayoutOptions _
) As RequestResult
RequestResult RelayoutDocument(
   string token,
   ReportDescription description,
   RelayoutOptions options
)

Parameters

token
The security token to use.
description
The report description.
options
The options for relayout.

Return Value

ActiveReports.Server.ReportServices.Contracts.RequestResult object containing the request id and resolved uri.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDesignerService Interface
IDesignerService Members


RenderReport Method (IDesignerService)

RenderReport Method (IDesignerService)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IDesignerService Interface : RenderReport Method
The security token to use.
The report description.
The options for rendering.
Renders the report specified by a report description.
Syntax
  • Visual Basic
  • C#
'Declaration

Function RenderReport( _
   ByVal token As String, _
   ByVal description As ReportDescription, _
   ByVal options As RenderOptions _
) As RequestResult
RequestResult RenderReport(
   string token,
   ReportDescription description,
   RenderOptions options
)

Parameters

token
The security token to use.
description
The report description.
options
The options for rendering.

Return Value

ActiveReports.Server.ReportServices.Contracts.RequestResult object containing the request id and resolved uri.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDesignerService Interface
IDesignerService Members


ResolveParameters Method (IDesignerService)

ResolveParameters Method (IDesignerService)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IDesignerService Interface : ResolveParameters Method
The security token to use.
The report description.
The options for rendering.
Populates the report parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Function ResolveParameters( _
   ByVal token As String, _
   ByVal description As ReportDescription, _
   ByVal options As RenderOptions _
) As RequestResult
RequestResult ResolveParameters(
   string token,
   ReportDescription description,
   RenderOptions options
)

Parameters

token
The security token to use.
description
The report description.
options
The options for rendering.

Return Value

ActiveReports.Server.ReportServices.Contracts.RequestResult object containing the request id and resolved uri.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDesignerService Interface
IDesignerService Members


RetrieveHistory Method

RetrieveHistory Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IDesignerService Interface : RetrieveHistory Method
The security token to use.
The target id.
Ritrieves the collection of policy history entries matching the specified target.
Syntax
  • Visual Basic
  • C#
'Declaration

Function RetrieveHistory( _
   ByVal token As String, _
   ByVal targetId As String _
) As PolicyHistoryResult
PolicyHistoryResult RetrieveHistory(
   string token,
   string targetId
)

Parameters

token
The security token to use.
targetId
The target id.

Return Value

The collection of policy history entries matching the specified target.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDesignerService Interface
IDesignerService Members


SavePolicy Method

SavePolicy Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IDesignerService Interface : SavePolicy Method
The security token to use.
The policy.
Saves the changes to the specified policy.
Syntax
  • Visual Basic
  • C#
'Declaration

Function SavePolicy( _
   ByVal token As String, _
   ByVal policy As Policy _
) As Result
Result SavePolicy(
   string token,
   Policy policy
)

Parameters

token
The security token to use.
policy
The policy.

Return Value

The result.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDesignerService Interface
IDesignerService Members


SetDescription Method

SetDescription Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IDesignerService Interface : SetDescription Method
The security token to use.
The item description.
Sets the item description.
Syntax
  • Visual Basic
  • C#
'Declaration

Function SetDescription( _
   ByVal token As String, _
   ByVal itemDescription As ItemDescription _
) As Result
Result SetDescription(
   string token,
   ItemDescription itemDescription
)

Parameters

token
The security token to use.
itemDescription
The item description.

Return Value

ActiveReports.Server.ReportServices.Contracts.ResultContains the status of operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDesignerService Interface
IDesignerService Members


SetResourcePermissions Method (IDesignerService)

SetResourcePermissions Method (IDesignerService)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IDesignerService Interface : SetResourcePermissions Method
The security token to use.
Specifies the type of item.
The identifier of the report to set.
The permissions to set.
Sets the permissions to the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Function SetResourcePermissions( _
   ByVal token As String, _
   ByVal type As StorageType, _
   ByVal id As String, _
   ByVal permissions() As PermissionRecord _
) As ResourcePermissionsResult
ResourcePermissionsResult SetResourcePermissions(
   string token,
   StorageType type,
   string id,
   PermissionRecord[] permissions
)

Parameters

token
The security token to use.
type
Specifies the type of item.
id
The identifier of the report to set.
permissions
The permissions to set.

Return Value

ActiveReports.Server.ReportServices.Contracts.ResultObject containing new permissions.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDesignerService Interface
IDesignerService Members


SubmitReport Method

SubmitReport Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IDesignerService Interface : SubmitReport Method
The security token to use.
The BugzScout report details.
Submits the BugzScout report.
Syntax
  • Visual Basic
  • C#
'Declaration

Function SubmitReport( _
   ByVal token As String, _
   ByVal report As FeedbackReport _
) As DataResult
DataResult SubmitReport(
   string token,
   FeedbackReport report
)

Parameters

token
The security token to use.
report
The BugzScout report details.

Return Value

ActiveReports.Server.ReportServices.Contracts.ResultObject containing status information.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDesignerService Interface
IDesignerService Members


UploadItem Method

UploadItem Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IDesignerService Interface : UploadItem Method
The security token to use.
Specifies the type of item to upload.
Specifies the description of the item to upload.
Serialized data to upload.
Upload item to server.
Syntax
  • Visual Basic
  • C#
'Declaration

Function UploadItem( _
   ByVal token As String, _
   ByVal type As StorageType, _
   ByVal itemDescription As ItemDescription, _
   ByVal data As String _
) As ItemDescriptionsResult
ItemDescriptionsResult UploadItem(
   string token,
   StorageType type,
   ItemDescription itemDescription,
   string data
)

Parameters

token
The security token to use.
type
Specifies the type of item to upload.
itemDescription
Specifies the description of the item to upload.
data
Serialized data to upload.

Return Value

ActiveReports.Server.ReportServices.Contracts.ResultObject containing status information.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDesignerService Interface
IDesignerService Members


IReportService Interface

IReportService Interface
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace : IReportService Interface
Defines a report management service.
Object Model
IReportService Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IReportService
public interface IReportService
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportService Members
ActiveReports.Server.ReportServices.Servicing Namespace


IReportService Interface Members

IReportService Interface Members
Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace : IReportService Interface

The following tables list the members exposed by IReportService.

Public Methods
 | Name | Description
Method | CancelRequest | Cancels the currently running request.
Method | Delete | Deletes the report specified by a id.
Method | DeleteResource | Deletes the resource specified by a id or name.
Method | Download | Download a requested report from the storage.
Method | DownloadResource | Downloads a requested resource from the storage.
Method | ExportDocument | Exports the document specified by ID in relayout options to another format.
Method | GetRequestStatus | Retrieves the request status by the specified identifer.
Method | GetResourcePermissions | Gets the permissions to the resource.
Method | GetUserCapabilities | Returns a user capabilities.
Method | IsLoggedIn | Determines whether the security token is valid.
Method | Login | Checks user credentials and creates an security token if the credentials are valid.
Method | Logout | Recalls the security token.
Method | RenderReport | Renders the report specified by a report description according to the specified options.
Method | ResolveParameters | Populates the report parameters.
Method | Select | Retrieves an array of report descriptions matching the criterion defined by the specified query.
Method | SelectDescriptions | Retrieves an array of resource descriptions matching the criterion defined by the specified query.
Method | SelectModels | Retrieves an array of model descriptions matching the criterion defined by the specified query.
Method | SelectReports | Retrieves an array of report descriptions matching the criterion defined by the specified query.
Method | SendReportEmail | Renders and send via email the report specified by a report description according to the specified options.
Method | SetDefaultTheme | Sets theme identified by provided id as default theme.
Method | SetReportDescription | Updates a report description.
Method | SetResourcePermissions | Sets the permissions to the resource.
Method | Upload | Uploads a report to the storage.
Method | UploadResource | Uploads a resource to the storage.
Top
See Also

Reference

IReportService Interface
ActiveReports.Server.ReportServices.Servicing Namespace


IReportService Interface Methods

IReportService Interface Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace : IReportService Interface

For a list of all members of this type, see IReportService members.

Public Methods
 | Name | Description
Method | CancelRequest | Cancels the currently running request.
Method | Delete | Deletes the report specified by a id.
Method | DeleteResource | Deletes the resource specified by a id or name.
Method | Download | Download a requested report from the storage.
Method | DownloadResource | Downloads a requested resource from the storage.
Method | ExportDocument | Exports the document specified by ID in relayout options to another format.
Method | GetRequestStatus | Retrieves the request status by the specified identifer.
Method | GetResourcePermissions | Gets the permissions to the resource.
Method | GetUserCapabilities | Returns a user capabilities.
Method | IsLoggedIn | Determines whether the security token is valid.
Method | Login | Checks user credentials and creates an security token if the credentials are valid.
Method | Logout | Recalls the security token.
Method | RenderReport | Renders the report specified by a report description according to the specified options.
Method | ResolveParameters | Populates the report parameters.
Method | Select | Retrieves an array of report descriptions matching the criterion defined by the specified query.
Method | SelectDescriptions | Retrieves an array of resource descriptions matching the criterion defined by the specified query.
Method | SelectModels | Retrieves an array of model descriptions matching the criterion defined by the specified query.
Method | SelectReports | Retrieves an array of report descriptions matching the criterion defined by the specified query.
Method | SendReportEmail | Renders and send via email the report specified by a report description according to the specified options.
Method | SetDefaultTheme | Sets theme identified by provided id as default theme.
Method | SetReportDescription | Updates a report description.
Method | SetResourcePermissions | Sets the permissions to the resource.
Method | Upload | Uploads a report to the storage.
Method | UploadResource | Uploads a resource to the storage.
Top
See Also

Reference

IReportService Interface
ActiveReports.Server.ReportServices.Servicing Namespace


CancelRequest Method (IReportService)

CancelRequest Method (IReportService)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IReportService Interface : CancelRequest Method
The security token to use.
The identifier of the request to cancel.
Cancels the currently running request.
Syntax
  • Visual Basic
  • C#
'Declaration

Function CancelRequest( _
   ByVal token As String, _
   ByVal id As String _
) As Result
Result CancelRequest(
   string token,
   string id
)

Parameters

token
The security token to use.
id
The identifier of the request to cancel.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportService Interface
IReportService Members


Delete Method

Delete Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IReportService Interface : Delete Method
The security token to use.
The identifier of the report to delete.
Deletes the report specified by a id.
Syntax
  • Visual Basic
  • C#
'Declaration

Function Delete( _
   ByVal token As String, _
   ByVal id As String _
) As DataResult
DataResult Delete(
   string token,
   string id
)

Parameters

token
The security token to use.
id
The identifier of the report to delete.

Return Value

ActiveReports.Server.ReportServices.Contracts.ResultContains the status of operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportService Interface
IReportService Members


DeleteResource Method

DeleteResource Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IReportService Interface : DeleteResource Method
The security token to use.
The type of resource to delete.
The id or the name of the resource to delete.
Deletes the resource specified by a id or name.
Syntax
  • Visual Basic
  • C#
'Declaration

Function DeleteResource( _
   ByVal token As String, _
   ByVal descriptionType As DescriptionType, _
   ByVal resourceIdOrName As String _
) As DataResult
DataResult DeleteResource(
   string token,
   DescriptionType descriptionType,
   string resourceIdOrName
)

Parameters

token
The security token to use.
descriptionType
The type of resource to delete.
resourceIdOrName
The id or the name of the resource to delete.

Return Value

ActiveReports.Server.ReportServices.Contracts.ResultContains the status of operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportService Interface
IReportService Members


Download Method

Download Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IReportService Interface : Download Method
The security token to use.
The report identifier to download.
Download a requested report from the storage.
Syntax
  • Visual Basic
  • C#
'Declaration

Function Download( _
   ByVal token As String, _
   ByVal id As String _
) As DataResult
DataResult Download(
   string token,
   string id
)

Parameters

token
The security token to use.
id
The report identifier to download.

Return Value

ActiveReports.Server.ReportServices.Contracts.ResultObject containing downloaded item content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportService Interface
IReportService Members


DownloadResource Method

DownloadResource Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IReportService Interface : DownloadResource Method
The security token to use.
The type of requested resource.
The resource identifier to download.
Downloads a requested resource from the storage.
Syntax
  • Visual Basic
  • C#
'Declaration

Function DownloadResource( _
   ByVal token As String, _
   ByVal descriptionType As DescriptionType, _
   ByVal id As String _
) As DataResult
DataResult DownloadResource(
   string token,
   DescriptionType descriptionType,
   string id
)

Parameters

token
The security token to use.
descriptionType
The type of requested resource.
id
The resource identifier to download.

Return Value

ActiveReports.Server.ReportServices.Contracts.ResultObject containing downloaded item content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportService Interface
IReportService Members


ExportDocument Method (IReportService)

ExportDocument Method (IReportService)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IReportService Interface : ExportDocument Method
The security token to use.
The report description.
The options for export.
Exports the document specified by ID in relayout options to another format.
Syntax
  • Visual Basic
  • C#
'Declaration

Function ExportDocument( _
   ByVal token As String, _
   ByVal description As ReportDescription, _
   ByVal options As ExportOptions _
) As RequestResult
RequestResult ExportDocument(
   string token,
   ReportDescription description,
   ExportOptions options
)

Parameters

token
The security token to use.
description
The report description.
options
The options for export.

Return Value

ActiveReports.Server.ReportServices.Contracts.RequestResult object containing the request id and resolved uri.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportService Interface
IReportService Members


GetRequestStatus Method

GetRequestStatus Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IReportService Interface : GetRequestStatus Method
The security token to use.
The identifier of the request to get status of.
Retrieves the request status by the specified identifer.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetRequestStatus( _
   ByVal token As String, _
   ByVal requestId As String _
) As RequestResult
RequestResult GetRequestStatus(
   string token,
   string requestId
)

Parameters

token
The security token to use.
requestId
The identifier of the request to get status of.

Return Value

The status request.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportService Interface
IReportService Members


GetResourcePermissions Method (IReportService)

GetResourcePermissions Method (IReportService)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IReportService Interface : GetResourcePermissions Method
The security token to use.
Specifies the type of item.
The identifier of the resource to request permissions.
Gets the permissions to the resource.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetResourcePermissions( _
   ByVal token As String, _
   ByVal type As DescriptionType, _
   ByVal id As String _
) As ResourcePermissionsResult
ResourcePermissionsResult GetResourcePermissions(
   string token,
   DescriptionType type,
   string id
)

Parameters

token
The security token to use.
type
Specifies the type of item.
id
The identifier of the resource to request permissions.

Return Value

ActiveReports.Server.ReportServices.Contracts.ResultObject containing permissions.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportService Interface
IReportService Members


GetUserCapabilities Method (IReportService)

GetUserCapabilities Method (IReportService)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IReportService Interface : GetUserCapabilities Method
The security token to use.
Returns a user capabilities.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetUserCapabilities( _
   ByVal token As String _
) As UserCapabilitiesResult
UserCapabilitiesResult GetUserCapabilities(
   string token
)

Parameters

token
The security token to use.

Return Value

ActiveReports.Server.ReportServices.Contracts.UserCapabilitiesResult object containing user capabilities.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportService Interface
IReportService Members


IsLoggedIn Method (IReportService)

IsLoggedIn Method (IReportService)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IReportService Interface : IsLoggedIn Method
The security token to validate.
Determines whether the security token is valid.
Syntax
  • Visual Basic
  • C#
'Declaration

Function IsLoggedIn( _
   ByVal token As String _
) As Boolean
bool IsLoggedIn(
   string token
)

Parameters

token
The security token to validate.

Return Value

true if the security token is valid; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportService Interface
IReportService Members


Login Method (IReportService)

Login Method (IReportService)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IReportService Interface : Login Method
The user name to be validated.
The password for the specified user.
The value or values to validate in addition to user name and password, if any
A value that indicates whether the authentication ticket remains valid across sessions.
Checks user credentials and creates an security token if the credentials are valid.
Syntax
  • Visual Basic
  • C#
'Declaration

Function Login( _
   ByVal username As String, _
   ByVal password As String, _
   ByVal custom As String, _
   ByVal isPersistent As Boolean _
) As String
string Login(
   string username,
   string password,
   string custom,
   bool isPersistent
)

Parameters

username
The user name to be validated.
password
The password for the specified user.
custom
The value or values to validate in addition to user name and password, if any
isPersistent
A value that indicates whether the authentication ticket remains valid across sessions.

Return Value

A security token if user credentials are valid; otherwise, null
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportService Interface
IReportService Members


Logout Method (IReportService)

Logout Method (IReportService)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IReportService Interface : Logout Method
The security token to recall.
Recalls the security token.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Logout( _
   ByVal token As String _
)
void Logout(
   string token
)

Parameters

token
The security token to recall.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportService Interface
IReportService Members


RenderReport Method (IReportService)

RenderReport Method (IReportService)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IReportService Interface : RenderReport Method
The security token to use.
The report description.
The options for rendering.
Renders the report specified by a report description according to the specified options.
Syntax
  • Visual Basic
  • C#
'Declaration

Function RenderReport( _
   ByVal token As String, _
   ByVal description As ReportDescription, _
   ByVal options As RenderOptions _
) As RequestResult
RequestResult RenderReport(
   string token,
   ReportDescription description,
   RenderOptions options
)

Parameters

token
The security token to use.
description
The report description.
options
The options for rendering.

Return Value

Object containing a request information.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportService Interface
IReportService Members


ResolveParameters Method (IReportService)

ResolveParameters Method (IReportService)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IReportService Interface : ResolveParameters Method
The security token to use.
The report description.
The options for rendering.
Populates the report parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Function ResolveParameters( _
   ByVal token As String, _
   ByVal description As ReportDescription, _
   ByVal options As RenderOptions _
) As RequestResult
RequestResult ResolveParameters(
   string token,
   ReportDescription description,
   RenderOptions options
)

Parameters

token
The security token to use.
description
The report description.
options
The options for rendering.

Return Value

ActiveReports.Server.ReportServices.Contracts.RequestResult object containing the request id and resolved uri.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportService Interface
IReportService Members


Select Method (IReportService)

Select Method (IReportService)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IReportService Interface : Select Method
The security token to use.
The query.
Retrieves an array of report descriptions matching the criterion defined by the specified query.
Syntax
  • Visual Basic
  • C#
'Declaration

Function Select( _
   ByVal token As String, _
   ByVal query As Query _
) As ReportDescription()
ReportDescription[] Select(
   string token,
   Query query
)

Parameters

token
The security token to use.
query
The query.

Return Value

The array of report descriptions matching the criterion defined by the specified query.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportService Interface
IReportService Members


SelectDescriptions Method

SelectDescriptions Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IReportService Interface : SelectDescriptions Method
The security token to use.
The type of descriptions to select.
The query.
Retrieves an array of resource descriptions matching the criterion defined by the specified query.
Syntax
  • Visual Basic
  • C#
'Declaration

Function SelectDescriptions( _
   ByVal token As String, _
   ByVal descriptionType As DescriptionType, _
   ByVal query As Query _
) As ItemDescription()
ItemDescription[] SelectDescriptions(
   string token,
   DescriptionType descriptionType,
   Query query
)

Parameters

token
The security token to use.
descriptionType
The type of descriptions to select.
query
The query.

Return Value

The array of model descriptions matching the criterion defined by the specified query.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportService Interface
IReportService Members


SelectModels Method

SelectModels Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IReportService Interface : SelectModels Method
The security token to use.
The query.
Retrieves an array of model descriptions matching the criterion defined by the specified query.
Syntax
  • Visual Basic
  • C#
'Declaration

Function SelectModels( _
   ByVal token As String, _
   ByVal query As Query _
) As SemanticModelDescription()
SemanticModelDescription[] SelectModels(
   string token,
   Query query
)

Parameters

token
The security token to use.
query
The query.

Return Value

The array of model descriptions matching the criterion defined by the specified query.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportService Interface
IReportService Members


SelectReports Method

SelectReports Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IReportService Interface : SelectReports Method
The security token to use.
The query.
Retrieves an array of report descriptions matching the criterion defined by the specified query.
Syntax
  • Visual Basic
  • C#
'Declaration

Function SelectReports( _
   ByVal token As String, _
   ByVal query As Query _
) As ReportDescription()
ReportDescription[] SelectReports(
   string token,
   Query query
)

Parameters

token
The security token to use.
query
The query.

Return Value

The array of report descriptions matching the criterion defined by the specified query.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportService Interface
IReportService Members


SendReportEmail Method

SendReportEmail Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IReportService Interface : SendReportEmail Method
The security token to use.
The report description.
The options for rendering.
The options to use in creating the email to send the report. You can choose whether to send the report as an attachment or a link, create a template for the attachment or a base URI for the link, add text for the email content and subject line, and set the recipients for the email. See EMailDistribution for details.
Renders and send via email the report specified by a report description according to the specified options.
Syntax
  • Visual Basic
  • C#
'Declaration

Function SendReportEmail( _
   ByVal token As String, _
   ByVal description As ReportDescription, _
   ByVal options As RenderOptions, _
   ByVal distribution As EMailDistribution _
) As Result
Result SendReportEmail(
   string token,
   ReportDescription description,
   RenderOptions options,
   EMailDistribution distribution
)

Parameters

token
The security token to use.
description
The report description.
options
The options for rendering.
distribution
The options to use in creating the email to send the report. You can choose whether to send the report as an attachment or a link, create a template for the attachment or a base URI for the link, add text for the email content and subject line, and set the recipients for the email. See EMailDistribution for details.

Return Value

Object containing errors.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportService Interface
IReportService Members


SetDefaultTheme Method

SetDefaultTheme Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IReportService Interface : SetDefaultTheme Method
The security token to use.
The identifier of the theme.
Sets theme identified by provided id as default theme.
Syntax
  • Visual Basic
  • C#
'Declaration

Function SetDefaultTheme( _
   ByVal token As String, _
   ByVal id As String _
) As Result
Result SetDefaultTheme(
   string token,
   string id
)

Parameters

token
The security token to use.
id
The identifier of the theme.

Return Value

Object containing information about errors.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportService Interface
IReportService Members


SetReportDescription Method

SetReportDescription Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IReportService Interface : SetReportDescription Method
The security token to use.
Specifies the description of the report to update.
Updates a report description.
Syntax
  • Visual Basic
  • C#
'Declaration

Function SetReportDescription( _
   ByVal token As String, _
   ByVal description As ReportDescription _
) As ItemDescriptionsResult
ItemDescriptionsResult SetReportDescription(
   string token,
   ReportDescription description
)

Parameters

token
The security token to use.
description
Specifies the description of the report to update.

Return Value

ActiveReports.Server.ReportServices.Contracts.ResultObject containing status information.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportService Interface
IReportService Members


SetResourcePermissions Method (IReportService)

SetResourcePermissions Method (IReportService)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IReportService Interface : SetResourcePermissions Method
The security token to use.
Specifies the type of item.
The identifier of the resource to set.
The permissions to set.
Sets the permissions to the resource.
Syntax
  • Visual Basic
  • C#
'Declaration

Function SetResourcePermissions( _
   ByVal token As String, _
   ByVal type As DescriptionType, _
   ByVal id As String, _
   ByVal permissions() As PermissionRecord _
) As ResourcePermissionsResult
ResourcePermissionsResult SetResourcePermissions(
   string token,
   DescriptionType type,
   string id,
   PermissionRecord[] permissions
)

Parameters

token
The security token to use.
type
Specifies the type of item.
id
The identifier of the resource to set.
permissions
The permissions to set.

Return Value

ActiveReports.Server.ReportServices.Contracts.ResultObject containing new permissions.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportService Interface
IReportService Members


Upload Method

Upload Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IReportService Interface : Upload Method
The security token to use.
Specifies the description of the report to upload.
Represents the report data encoded in base 64 digits to upload.
Uploads a report to the storage.
Syntax
  • Visual Basic
  • C#
'Declaration

Function Upload( _
   ByVal token As String, _
   ByVal description As ReportDescription, _
   ByVal data As String _
) As ItemDescriptionsResult
ItemDescriptionsResult Upload(
   string token,
   ReportDescription description,
   string data
)

Parameters

token
The security token to use.
description
Specifies the description of the report to upload.
data
Represents the report data encoded in base 64 digits to upload.

Return Value

ActiveReports.Server.ReportServices.Contracts.ResultObject containing status information.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportService Interface
IReportService Members


UploadResource Method

UploadResource Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Servicing Namespace > IReportService Interface : UploadResource Method
The security token to use.
Specifies the description of the resource to upload.
Represents the resource data encoded in base 64 digits to upload.
Object containing various options which affects upload operation.
Uploads a resource to the storage.
Syntax
  • Visual Basic
  • C#
'Declaration

Function UploadResource( _
   ByVal token As String, _
   ByVal description As ItemDescription, _
   ByVal data As String, _
   ByVal options As UploadOptions _
) As ItemDescriptionsResult
ItemDescriptionsResult UploadResource(
   string token,
   ItemDescription description,
   string data,
   UploadOptions options
)

Parameters

token
The security token to use.
description
Specifies the description of the resource to upload.
data
Represents the resource data encoded in base 64 digits to upload.
options
Object containing various options which affects upload operation.

Return Value

ActiveReports.Server.ReportServices.Contracts.ResultObject containing status information.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReportService Interface
IReportService Members


ActiveReports.Server.Scheduling Namespace

ActiveReports.Server.Scheduling Namespace
Inheritance Hierarchy
ActiveReports.Server.ReportControls Assembly : ActiveReports.Server.Scheduling Namespace
Classes
 | Class | Description
Class | DistributionChain | Defines rules to deliver the results to a user.
Class | DistributionMethod | Defines a method of distributing of job resources.
Class | EMailDistribution | Defines a distribution via e-mail.
Class | FileShareDistribution | Defines a distribution via windows file shares.
Class | PolicyHistoryEntry | Represents a single history entry for a policy.
Class | PrintingOptions | Represents options of printer of report print task.
Class | RecurrenceRule | Defines a single recurrence rule.
Class | RecurrenceSet | Defines a recurence set for a schedule.
Class | Schedule | Defines rules to determine at which time point to execute an associated request.
Class | TerminationByCount | Defines the termination of recurrence rule event count.
Interfaces
 | Interface | Description
Interface | ICachePolicy | Defines when the output of the jobs created from the associated policy will expire.
Interface | IDistribution | Defines delivery methods for the jobs created from the associated policy.
Interface | IExpirationRule | Defines the rule providing an expiration for a given moment.
Interface | IJobEntryTemplate | Defines a template to build a job entry from.
Interface | IPolicy | Defines association between scheduling, distribution, caching rukes and the rules to create a user job.
Interface | ISchedule | Defines when to create the jobs from the associated policy.
Interface | IScheduler | Provides access to scheduling, distribution and caching configuration.
Structures
 | Structure | Description
Structure | Day | Defines a day for the by day list of recurrence rule.
Enumerations
 | Enumeration | Description
Enumeration | ExistingFileBehavior | Defines a behavior which should be applied in situation when file exists.
Enumeration | FileExtensionBehavior | Defines a behavior which determines should file extension be added to a file.
Enumeration | Frequency | Specifies the frequency for the associated recurrence rule.
Enumeration | PolicyType | Represents type of the policy.
Enumeration | ScheduleType | Represents type of the schedule.
Enumeration | TwoSidedPrinting | Specifies whether and how to print the report on both sides of the paper.
See Also

Reference

ActiveReports.Server.ReportControls Assembly


DistributionChain Class

DistributionChain Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : DistributionChain Class
Defines rules to deliver the results to a user.
Object Model
DistributionChain ClassDistributionMethod Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class DistributionChain
   Inherits DistributionMethod
public class DistributionChain : DistributionMethod
Inheritance Hierarchy

System.Object
ActiveReports.Server.Scheduling.DistributionMethod
ActiveReports.Server.Scheduling.DistributionChain

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DistributionChain Members
ActiveReports.Server.Scheduling Namespace


DistributionChain Class Members

DistributionChain Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : DistributionChain Class

The following tables list the members exposed by DistributionChain.

Public Constructors
 | Name | Description
Public Constructor | DistributionChain Constructor | Initializes a new instance of the DistributionChain class.
Top
Public Properties
 | Name | Description
Public Property | Items | Gets or sets the child elements of the distribution chain.
Top
See Also

Reference

DistributionChain Class
ActiveReports.Server.Scheduling Namespace


DistributionChain Constructor

DistributionChain Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > DistributionChain Class : DistributionChain Constructor
Initializes a new instance of the DistributionChain class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public DistributionChain()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DistributionChain Class
DistributionChain Members


DistributionChain Class Properties

DistributionChain Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : DistributionChain Class

For a list of all members of this type, see DistributionChain members.

Public Properties
 | Name | Description
Public Property | Items | Gets or sets the child elements of the distribution chain.
Top
See Also

Reference

DistributionChain Class
ActiveReports.Server.Scheduling Namespace


Items Property

Items Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > DistributionChain Class : Items Property
Gets or sets the child elements of the distribution chain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Items As DistributionMethod()
public DistributionMethod[] Items {get; set;}

Property Value

The child elements of the distribution chain.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DistributionChain Class
DistributionChain Members


DistributionMethod Class

DistributionMethod Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : DistributionMethod Class
Defines a method of distributing of job resources.
Object Model
DistributionMethod Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class DistributionMethod
public class DistributionMethod
Inheritance Hierarchy

System.Object
ActiveReports.Server.Scheduling.DistributionMethod
ActiveReports.Server.Scheduling.DistributionChain
ActiveReports.Server.Scheduling.EMailDistribution
ActiveReports.Server.Scheduling.FileShareDistribution

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DistributionMethod Members
ActiveReports.Server.Scheduling Namespace


DistributionMethod Class Members

DistributionMethod Class Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : DistributionMethod Class

The following tables list the members exposed by DistributionMethod.

Public Constructors
 | Name | Description
Public Constructor | DistributionMethod Constructor | Initializes a new instance of the DistributionMethod class.
Top
See Also

Reference

DistributionMethod Class
ActiveReports.Server.Scheduling Namespace


DistributionMethod Constructor

DistributionMethod Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > DistributionMethod Class : DistributionMethod Constructor
Initializes a new instance of the DistributionMethod class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public DistributionMethod()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DistributionMethod Class
DistributionMethod Members


EMailDistribution Class

EMailDistribution Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : EMailDistribution Class
Defines a distribution via e-mail.
Object Model
EMailDistribution Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class EMailDistribution
   Inherits DistributionMethod
public class EMailDistribution : DistributionMethod
Inheritance Hierarchy

System.Object
ActiveReports.Server.Scheduling.DistributionMethod
ActiveReports.Server.Scheduling.EMailDistribution

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EMailDistribution Members
ActiveReports.Server.Scheduling Namespace


EMailDistribution Class Members

EMailDistribution Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : EMailDistribution Class

The following tables list the members exposed by EMailDistribution.

Public Constructors
 | Name | Description
Public Constructor | EMailDistribution Constructor | Initializes a new instance of the EMailDistribution class.
Top
Public Properties
 | Name | Description
Public Property | AsAttachment | Gets or sets a value indicating whether include resource to the mail as attachment.
Public Property | AsLink | Gets or sets a value indicating whether to include resource to the mail as link.
Public Property | AttachmentTemplate | Gets or sets the template to format the attachment name.
Public Property | BaseUri | Gets or sets the base URI to use for link attachments.
Public Property | MessageBody | Gets or sets the message body of e-mail.
Public Property | Subject | Gets or sets the subject of e-mail.
Public Property | To | Gets or sets the address collection that contains the recipients of e-mail.
Top
See Also

Reference

EMailDistribution Class
ActiveReports.Server.Scheduling Namespace


EMailDistribution Constructor

EMailDistribution Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > EMailDistribution Class : EMailDistribution Constructor
Initializes a new instance of the EMailDistribution class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public EMailDistribution()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EMailDistribution Class
EMailDistribution Members


EMailDistribution Class Properties

EMailDistribution Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : EMailDistribution Class

For a list of all members of this type, see EMailDistribution members.

Public Properties
 | Name | Description
Public Property | AsAttachment | Gets or sets a value indicating whether include resource to the mail as attachment.
Public Property | AsLink | Gets or sets a value indicating whether to include resource to the mail as link.
Public Property | AttachmentTemplate | Gets or sets the template to format the attachment name.
Public Property | BaseUri | Gets or sets the base URI to use for link attachments.
Public Property | MessageBody | Gets or sets the message body of e-mail.
Public Property | Subject | Gets or sets the subject of e-mail.
Public Property | To | Gets or sets the address collection that contains the recipients of e-mail.
Top
See Also

Reference

EMailDistribution Class
ActiveReports.Server.Scheduling Namespace


AsAttachment Property

AsAttachment Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > EMailDistribution Class : AsAttachment Property
Gets or sets a value indicating whether include resource to the mail as attachment.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AsAttachment As Boolean
public bool AsAttachment {get; set;}

Property Value

true if include resource to the mail as attachment; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EMailDistribution Class
EMailDistribution Members


AsLink Property

AsLink Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > EMailDistribution Class : AsLink Property
Gets or sets a value indicating whether to include resource to the mail as link.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AsLink As Boolean
public bool AsLink {get; set;}

Property Value

true if include resource to the mail as link; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EMailDistribution Class
EMailDistribution Members


AttachmentTemplate Property

AttachmentTemplate Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > EMailDistribution Class : AttachmentTemplate Property
Gets or sets the template to format the attachment name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AttachmentTemplate As String
public string AttachmentTemplate {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EMailDistribution Class
EMailDistribution Members


BaseUri Property

BaseUri Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > EMailDistribution Class : BaseUri Property
Gets or sets the base URI to use for link attachments.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BaseUri As String
public string BaseUri {get; set;}

Property Value

The base URI to use for link attachments.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EMailDistribution Class
EMailDistribution Members


MessageBody Property

MessageBody Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > EMailDistribution Class : MessageBody Property
Gets or sets the message body of e-mail.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MessageBody As String
public string MessageBody {get; set;}

Property Value

The message body of e-mail.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EMailDistribution Class
EMailDistribution Members


Subject Property

Subject Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > EMailDistribution Class : Subject Property
Gets or sets the subject of e-mail.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Subject As String
public string Subject {get; set;}

Property Value

The subject of e-mail.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EMailDistribution Class
EMailDistribution Members


To Property

To Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > EMailDistribution Class : To Property
Gets or sets the address collection that contains the recipients of e-mail.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property To As String()
public string[] To {get; set;}

Property Value

The address collection that contains the recipients of e-mail.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EMailDistribution Class
EMailDistribution Members


FileShareDistribution Class

FileShareDistribution Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : FileShareDistribution Class
Defines a distribution via windows file shares.
Object Model
FileShareDistribution Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class FileShareDistribution
   Inherits DistributionMethod
public class FileShareDistribution : DistributionMethod
Inheritance Hierarchy

System.Object
ActiveReports.Server.Scheduling.DistributionMethod
ActiveReports.Server.Scheduling.FileShareDistribution

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileShareDistribution Members
ActiveReports.Server.Scheduling Namespace


FileShareDistribution Class Members

FileShareDistribution Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : FileShareDistribution Class

The following tables list the members exposed by FileShareDistribution.

Public Constructors
 | Name | Description
Public Constructor | FileShareDistribution Constructor | Initializes a new instance of the FileShareDistribution class.
Top
Public Properties
 | Name | Description
Public Property | ExistingBehavior | The behavior to use in situation when file with such name already exists.
Public Property | ExtensionBehavior | Determines whether to add format extension to the file name or not.
Public Property | FileName | The name of the resulting file.
Public Property | Password | The password of the user to use for distribution.
Public Property | Path | The path where to distribute to.
Public Property | User | The name of the user to use for distribution.
Top
See Also

Reference

FileShareDistribution Class
ActiveReports.Server.Scheduling Namespace


FileShareDistribution Constructor

FileShareDistribution Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > FileShareDistribution Class : FileShareDistribution Constructor
Initializes a new instance of the FileShareDistribution class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public FileShareDistribution()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileShareDistribution Class
FileShareDistribution Members


FileShareDistribution Class Properties

FileShareDistribution Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : FileShareDistribution Class

For a list of all members of this type, see FileShareDistribution members.

Public Properties
 | Name | Description
Public Property | ExistingBehavior | The behavior to use in situation when file with such name already exists.
Public Property | ExtensionBehavior | Determines whether to add format extension to the file name or not.
Public Property | FileName | The name of the resulting file.
Public Property | Password | The password of the user to use for distribution.
Public Property | Path | The path where to distribute to.
Public Property | User | The name of the user to use for distribution.
Top
See Also

Reference

FileShareDistribution Class
ActiveReports.Server.Scheduling Namespace


ExistingBehavior Property

ExistingBehavior Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > FileShareDistribution Class : ExistingBehavior Property
The behavior to use in situation when file with such name already exists.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ExistingBehavior As ExistingFileBehavior
public ExistingFileBehavior ExistingBehavior {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileShareDistribution Class
FileShareDistribution Members


ExtensionBehavior Property

ExtensionBehavior Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > FileShareDistribution Class : ExtensionBehavior Property
Determines whether to add format extension to the file name or not.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ExtensionBehavior As FileExtensionBehavior
public FileExtensionBehavior ExtensionBehavior {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileShareDistribution Class
FileShareDistribution Members


FileName Property

FileName Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > FileShareDistribution Class : FileName Property
The name of the resulting file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FileName As String
public string FileName {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileShareDistribution Class
FileShareDistribution Members


Password Property

Password Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > FileShareDistribution Class : Password Property
The password of the user to use for distribution.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Password As String
public string Password {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileShareDistribution Class
FileShareDistribution Members


Path Property

Path Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > FileShareDistribution Class : Path Property
The path where to distribute to.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Path As String
public string Path {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileShareDistribution Class
FileShareDistribution Members


User Property (FileShareDistribution)

User Property (FileShareDistribution)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > FileShareDistribution Class : User Property
The name of the user to use for distribution.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property User As String
public string User {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileShareDistribution Class
FileShareDistribution Members


PolicyHistoryEntry Class

PolicyHistoryEntry Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : PolicyHistoryEntry Class
Represents a single history entry for a policy.
Object Model
PolicyHistoryEntry Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class PolicyHistoryEntry
public class PolicyHistoryEntry
Inheritance Hierarchy

System.Object
ActiveReports.Server.Scheduling.PolicyHistoryEntry

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PolicyHistoryEntry Members
ActiveReports.Server.Scheduling Namespace


PolicyHistoryEntry Class Members

PolicyHistoryEntry Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : PolicyHistoryEntry Class

The following tables list the members exposed by PolicyHistoryEntry.

Public Constructors
 | Name | Description
Public Constructor | PolicyHistoryEntry Constructor | Initializes a new instance of the PolicyHistoryEntry class.
Top
Public Properties
 | Name | Description
Public Property | IsExpired | Gets a value indicating whether this instance is expired.
Public Property | JournalEntry | Gets the journal entry.
Public Property | PolicyId | Gets the identifier of the associated policy.
Public Property | PolicyName | Gets the name.
Public Property | TargetId | Gets the target id.
Top
See Also

Reference

PolicyHistoryEntry Class
ActiveReports.Server.Scheduling Namespace


PolicyHistoryEntry Constructor

PolicyHistoryEntry Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > PolicyHistoryEntry Class : PolicyHistoryEntry Constructor
The policy id.
The name of the policy.
The target id.
if set to true [is expired].
The journal entry.
Initializes a new instance of the PolicyHistoryEntry class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal policyId As Guid, _
   ByVal policyName As String, _
   ByVal targetId As String, _
   ByVal isExpired As Boolean, _
   ByVal journalEntry As IJournalEntry _
)
public PolicyHistoryEntry(
   Guid policyId,
   string policyName,
   string targetId,
   bool isExpired,
   IJournalEntry journalEntry
)

Parameters

policyId
The policy id.
policyName
The name of the policy.
targetId
The target id.
isExpired
if set to true [is expired].
journalEntry
The journal entry.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PolicyHistoryEntry Class
PolicyHistoryEntry Members


PolicyHistoryEntry Class Properties

PolicyHistoryEntry Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : PolicyHistoryEntry Class

For a list of all members of this type, see PolicyHistoryEntry members.

Public Properties
 | Name | Description
Public Property | IsExpired | Gets a value indicating whether this instance is expired.
Public Property | JournalEntry | Gets the journal entry.
Public Property | PolicyId | Gets the identifier of the associated policy.
Public Property | PolicyName | Gets the name.
Public Property | TargetId | Gets the target id.
Top
See Also

Reference

PolicyHistoryEntry Class
ActiveReports.Server.Scheduling Namespace


IsExpired Property (PolicyHistoryEntry)

IsExpired Property (PolicyHistoryEntry)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > PolicyHistoryEntry Class : IsExpired Property
Gets a value indicating whether this instance is expired.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsExpired As Boolean
public bool IsExpired {get;}

Property Value

true if this instance is expired; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PolicyHistoryEntry Class
PolicyHistoryEntry Members


JournalEntry Property (PolicyHistoryEntry)

JournalEntry Property (PolicyHistoryEntry)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > PolicyHistoryEntry Class : JournalEntry Property
Gets the journal entry.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property JournalEntry As IJournalEntry
public IJournalEntry JournalEntry {get;}

Property Value

The journal entry.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PolicyHistoryEntry Class
PolicyHistoryEntry Members


PolicyId Property (PolicyHistoryEntry)

PolicyId Property (PolicyHistoryEntry)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > PolicyHistoryEntry Class : PolicyId Property
Gets the identifier of the associated policy.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PolicyId As Guid
public Guid PolicyId {get;}

Property Value

The identifier of the associated policy.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PolicyHistoryEntry Class
PolicyHistoryEntry Members


PolicyName Property (PolicyHistoryEntry)

PolicyName Property (PolicyHistoryEntry)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > PolicyHistoryEntry Class : PolicyName Property
Gets the name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PolicyName As String
public string PolicyName {get;}

Property Value

The name.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PolicyHistoryEntry Class
PolicyHistoryEntry Members


TargetId Property (PolicyHistoryEntry)

TargetId Property (PolicyHistoryEntry)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > PolicyHistoryEntry Class : TargetId Property
Gets the target id.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TargetId As String
public string TargetId {get;}

Property Value

The target id.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PolicyHistoryEntry Class
PolicyHistoryEntry Members


PrintingOptions Class

PrintingOptions Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : PrintingOptions Class
Represents options of printer of report print task.
Object Model
PrintingOptions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class PrintingOptions
public sealed class PrintingOptions
Inheritance Hierarchy

System.Object
ActiveReports.Server.Scheduling.PrintingOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintingOptions Members
ActiveReports.Server.Scheduling Namespace


PrintingOptions Class Members

PrintingOptions Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : PrintingOptions Class

The following tables list the members exposed by PrintingOptions.

Public Constructors
 | Name | Description
Public Constructor | PrintingOptions Constructor |
Top
Public Properties
 | Name | Description
Public Property | Color | Gets or sets a value indicating whether the page should be printed in color
Public Property | Copies | Gets or sets the number of copies of the report to print
Public Property | Landscape | Gets or sets a value indicating whether the page is printed in landscape or portrait orientation
Public Property | PaperName | Gets or sets the name of the type of paper
Public Property | PaperSourceName | Gets or sets the name of the paper source
Public Property | PrinterId | Gets or sets printer id
Public Property | TwoSided | Gets or sets the printer setting for double-sided printing
Top
See Also

Reference

PrintingOptions Class
ActiveReports.Server.Scheduling Namespace


PrintingOptions Constructor

PrintingOptions Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > PrintingOptions Class : PrintingOptions Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public PrintingOptions()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintingOptions Class
PrintingOptions Members


PrintingOptions Class Properties

PrintingOptions Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : PrintingOptions Class

For a list of all members of this type, see PrintingOptions members.

Public Properties
 | Name | Description
Public Property | Color | Gets or sets a value indicating whether the page should be printed in color
Public Property | Copies | Gets or sets the number of copies of the report to print
Public Property | Landscape | Gets or sets a value indicating whether the page is printed in landscape or portrait orientation
Public Property | PaperName | Gets or sets the name of the type of paper
Public Property | PaperSourceName | Gets or sets the name of the paper source
Public Property | PrinterId | Gets or sets printer id
Public Property | TwoSided | Gets or sets the printer setting for double-sided printing
Top
See Also

Reference

PrintingOptions Class
ActiveReports.Server.Scheduling Namespace


Color Property

Color Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > PrintingOptions Class : Color Property
Gets or sets a value indicating whether the page should be printed in color
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Color As Nullable(Of Boolean)
public Nullable<bool> Color {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintingOptions Class
PrintingOptions Members


Copies Property

Copies Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > PrintingOptions Class : Copies Property
Gets or sets the number of copies of the report to print
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Copies As Nullable(Of Short)
public Nullable<short> Copies {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintingOptions Class
PrintingOptions Members


Landscape Property

Landscape Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > PrintingOptions Class : Landscape Property
Gets or sets a value indicating whether the page is printed in landscape or portrait orientation
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Landscape As Nullable(Of Boolean)
public Nullable<bool> Landscape {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintingOptions Class
PrintingOptions Members


PaperName Property

PaperName Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > PrintingOptions Class : PaperName Property
Gets or sets the name of the type of paper
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PaperName As String
public string PaperName {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintingOptions Class
PrintingOptions Members


PaperSourceName Property

PaperSourceName Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > PrintingOptions Class : PaperSourceName Property
Gets or sets the name of the paper source
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PaperSourceName As String
public string PaperSourceName {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintingOptions Class
PrintingOptions Members


PrinterId Property

PrinterId Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > PrintingOptions Class : PrinterId Property
Gets or sets printer id
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PrinterId As String
public string PrinterId {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintingOptions Class
PrintingOptions Members


TwoSided Property

TwoSided Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > PrintingOptions Class : TwoSided Property
Gets or sets the printer setting for double-sided printing
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TwoSided As Nullable(Of TwoSidedPrinting)
public Nullable<TwoSidedPrinting> TwoSided {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PrintingOptions Class
PrintingOptions Members


RecurrenceRule Class

RecurrenceRule Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : RecurrenceRule Class
Defines a single recurrence rule.
Object Model
RecurrenceRule ClassDay Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class RecurrenceRule
public sealed class RecurrenceRule
Inheritance Hierarchy

System.Object
ActiveReports.Server.Scheduling.RecurrenceRule

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecurrenceRule Members
ActiveReports.Server.Scheduling Namespace


RecurrenceRule Class Members

RecurrenceRule Class Members
Properties Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : RecurrenceRule Class

The following tables list the members exposed by RecurrenceRule.

Public Constructors
 | Name | Description
Public Constructor | RecurrenceRule Constructor | Initializes a new instance of the RecurrenceRule class.
Top
Public Properties
 | Name | Description
Public Property | ByDayList | Gets or sets the by day list. Repeats are ignored.
Public Property | ByHourList | Gets or sets the by hour list. Repeats are ignored.
Public Property | ByMinuteList | Gets or sets the by minute list. Repeats are ignored.
Public Property | ByMonthDayList | Gets or sets the by month day list. Repeats are ignored.
Public Property | ByMonthList | Gets or sets the by month list. Repeats are ignored.
Public Property | ByOccurrenceList | Gets or sets the list of values which corresponds to the nth occurrence within the set of events specified by the rule. It MUST only be used in conjunction with another BYxxx rule part. Repeats are ignored.
Public Property | BySecondList | Gets or sets the by second list. Repeats are ignored.
Public Property | ByWeekList | Gets or sets the by year week list. Repeats are ignored.
Public Property | ByYearDayList | Gets or sets the by year day list. Repeats are ignored.
Public Property | Frequency | Gets or sets the frequency. Required.
Public Property | Interval | Gets or sets the interval defining how often the recurrence rule repeats. Default is 1.
Public Property | StartDayOfWeek | Gets or sets the start day of week. This is significant when a WEEKLY RRULE has an interval greater than 1, and a BYDAY rule part is specified. This is also significant when in a YEARLY RRULE when a BYWEEKNO rule part is specified. The default value is MO.
Public Property | Termination | Gets or sets the value indicating when this rule is terminated. If null the rule longs forever.
Top
Public Methods
 | Name | Description
Public Method | Equals | Overloaded. Indicates whether the current object is equal to another object of the same type.
Public Method | GetHashCode | Serves as a hash function for a particular type.
Top
Public Operators
public Operator Equality | Implements the operator ==.
public Operator Inequality | Implements the operator !=.
Top
See Also

Reference

RecurrenceRule Class
ActiveReports.Server.Scheduling Namespace


RecurrenceRule Constructor

RecurrenceRule Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > RecurrenceRule Class : RecurrenceRule Constructor
Initializes a new instance of the RecurrenceRule class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public RecurrenceRule()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecurrenceRule Class
RecurrenceRule Members


RecurrenceRule Class Methods

RecurrenceRule Class Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : RecurrenceRule Class

For a list of all members of this type, see RecurrenceRule members.

Public Methods
 | Name | Description
Public Method | Equals | Overloaded. Indicates whether the current object is equal to another object of the same type.
Public Method | GetHashCode | Serves as a hash function for a particular type.
Top
See Also

Reference

RecurrenceRule Class
ActiveReports.Server.Scheduling Namespace


Equals Method (RecurrenceRule)

Equals Method (RecurrenceRule)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > RecurrenceRule Class : Equals Method
Indicates whether the current object is equal to another object of the same type.
Overload List
Overload | Description
Equals(RecurrenceRule) | Indicates whether the current object is equal to another object of the same type.
Equals(Object) | Determines whether the specified System.Object is equal to the current System.Object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecurrenceRule Class
RecurrenceRule Members


Equals(RecurrenceRule) Method

Equals(RecurrenceRule) Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > RecurrenceRule Class > Equals Method : Equals(RecurrenceRule) Method
An object to compare with this object.
Indicates whether the current object is equal to another object of the same type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Equals( _
   ByVal other As RecurrenceRule _
) As Boolean
public bool Equals(
   RecurrenceRule other
)

Parameters

other
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecurrenceRule Class
RecurrenceRule Members
Overload List


Equals(Object) Method

Equals(Object) Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > RecurrenceRule Class > Equals Method : Equals(Object) Method
The System.Object to compare with the current System.Object.
Determines whether the specified System.Object is equal to the current System.Object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
public override bool Equals(
   object obj
)

Parameters

obj
The System.Object to compare with the current System.Object.

Return Value

true if the specified System.Object is equal to the current System.Object; otherwise, false.
Exceptions
Exception | Description
System.NullReferenceException | The obj parameter is null.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecurrenceRule Class
RecurrenceRule Members
Overload List
Base Implementation in Equals(Object)


GetHashCode Method (RecurrenceRule)

GetHashCode Method (RecurrenceRule)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > RecurrenceRule Class : GetHashCode Method
Serves as a hash function for a particular type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As Integer
public override int GetHashCode()

Return Value

A hash code for the current System.Object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecurrenceRule Class
RecurrenceRule Members
Base Implementation in GetHashCode


RecurrenceRule Class Properties

RecurrenceRule Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : RecurrenceRule Class

For a list of all members of this type, see RecurrenceRule members.

Public Properties
 | Name | Description
Public Property | ByDayList | Gets or sets the by day list. Repeats are ignored.
Public Property | ByHourList | Gets or sets the by hour list. Repeats are ignored.
Public Property | ByMinuteList | Gets or sets the by minute list. Repeats are ignored.
Public Property | ByMonthDayList | Gets or sets the by month day list. Repeats are ignored.
Public Property | ByMonthList | Gets or sets the by month list. Repeats are ignored.
Public Property | ByOccurrenceList | Gets or sets the list of values which corresponds to the nth occurrence within the set of events specified by the rule. It MUST only be used in conjunction with another BYxxx rule part. Repeats are ignored.
Public Property | BySecondList | Gets or sets the by second list. Repeats are ignored.
Public Property | ByWeekList | Gets or sets the by year week list. Repeats are ignored.
Public Property | ByYearDayList | Gets or sets the by year day list. Repeats are ignored.
Public Property | Frequency | Gets or sets the frequency. Required.
Public Property | Interval | Gets or sets the interval defining how often the recurrence rule repeats. Default is 1.
Public Property | StartDayOfWeek | Gets or sets the start day of week. This is significant when a WEEKLY RRULE has an interval greater than 1, and a BYDAY rule part is specified. This is also significant when in a YEARLY RRULE when a BYWEEKNO rule part is specified. The default value is MO.
Public Property | Termination | Gets or sets the value indicating when this rule is terminated. If null the rule longs forever.
Top
See Also

Reference

RecurrenceRule Class
ActiveReports.Server.Scheduling Namespace


ByDayList Property

ByDayList Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > RecurrenceRule Class : ByDayList Property
Gets or sets the by day list. Repeats are ignored.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ByDayList As Day()
public Day[] ByDayList {get; set;}

Property Value

The by day list.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecurrenceRule Class
RecurrenceRule Members


ByHourList Property

ByHourList Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > RecurrenceRule Class : ByHourList Property
Gets or sets the by hour list. Repeats are ignored.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ByHourList As Integer()
public int[] ByHourList {get; set;}

Property Value

The by hour list.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecurrenceRule Class
RecurrenceRule Members


ByMinuteList Property

ByMinuteList Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > RecurrenceRule Class : ByMinuteList Property
Gets or sets the by minute list. Repeats are ignored.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ByMinuteList As Integer()
public int[] ByMinuteList {get; set;}

Property Value

The by minute list.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecurrenceRule Class
RecurrenceRule Members


ByMonthDayList Property

ByMonthDayList Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > RecurrenceRule Class : ByMonthDayList Property
Gets or sets the by month day list. Repeats are ignored.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ByMonthDayList As Integer()
public int[] ByMonthDayList {get; set;}

Property Value

The by month day list.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecurrenceRule Class
RecurrenceRule Members


ByMonthList Property

ByMonthList Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > RecurrenceRule Class : ByMonthList Property
Gets or sets the by month list. Repeats are ignored.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ByMonthList As Integer()
public int[] ByMonthList {get; set;}

Property Value

The by month list.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecurrenceRule Class
RecurrenceRule Members


ByOccurrenceList Property

ByOccurrenceList Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > RecurrenceRule Class : ByOccurrenceList Property
Gets or sets the list of values which corresponds to the nth occurrence within the set of events specified by the rule. It MUST only be used in conjunction with another BYxxx rule part. Repeats are ignored.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ByOccurrenceList As Integer()
public int[] ByOccurrenceList {get; set;}

Property Value

The list of values which corresponds to the nth occurrence within the set of events specified by the rule.
Example
"The last work day of the month" could be represented as MONTHLY;BYDAY=MO,TU,WE,TH,FR;BYSETPOS=-1.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecurrenceRule Class
RecurrenceRule Members


BySecondList Property

BySecondList Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > RecurrenceRule Class : BySecondList Property
Gets or sets the by second list. Repeats are ignored.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BySecondList As Integer()
public int[] BySecondList {get; set;}

Property Value

The by second list.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecurrenceRule Class
RecurrenceRule Members


ByWeekList Property

ByWeekList Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > RecurrenceRule Class : ByWeekList Property
Gets or sets the by year week list. Repeats are ignored.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ByWeekList As Integer()
public int[] ByWeekList {get; set;}

Property Value

The by year week list.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecurrenceRule Class
RecurrenceRule Members


ByYearDayList Property

ByYearDayList Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > RecurrenceRule Class : ByYearDayList Property
Gets or sets the by year day list. Repeats are ignored.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ByYearDayList As Integer()
public int[] ByYearDayList {get; set;}

Property Value

The by year day list.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecurrenceRule Class
RecurrenceRule Members


Frequency Property

Frequency Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > RecurrenceRule Class : Frequency Property
Gets or sets the frequency. Required.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Frequency As Frequency
public Frequency Frequency {get; set;}

Property Value

The frequency.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecurrenceRule Class
RecurrenceRule Members


Interval Property

Interval Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > RecurrenceRule Class : Interval Property
Gets or sets the interval defining how often the recurrence rule repeats. Default is 1.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Interval As Integer
public int Interval {get; set;}

Property Value

The the interval defining how often the recurrence rule repeats.
Example
Value 2 for Frecuency.Secondly means each other second.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecurrenceRule Class
RecurrenceRule Members


StartDayOfWeek Property

StartDayOfWeek Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > RecurrenceRule Class : StartDayOfWeek Property
Gets or sets the start day of week. This is significant when a WEEKLY RRULE has an interval greater than 1, and a BYDAY rule part is specified. This is also significant when in a YEARLY RRULE when a BYWEEKNO rule part is specified. The default value is MO.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StartDayOfWeek As DayOfWeek
public DayOfWeek StartDayOfWeek {get; set;}

Property Value

The start day of week.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecurrenceRule Class
RecurrenceRule Members


Termination Property

Termination Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > RecurrenceRule Class : Termination Property
Gets or sets the value indicating when this rule is terminated. If null the rule longs forever.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Termination As Termination
public Termination Termination {get; set;}

Property Value

The the value indicating when this rule terminates.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecurrenceRule Class
RecurrenceRule Members


Equality Operator (RecurrenceRule)

Equality Operator (RecurrenceRule)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > RecurrenceRule Class : Equality Operator
The left.
The right.
Implements the operator ==.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator =( _
   ByVal left As RecurrenceRule, _
   ByVal right As RecurrenceRule _
) As Boolean
public bool operator ==(
   RecurrenceRule left,
   RecurrenceRule right
)

Parameters

left
The left.
right
The right.

Return Value

The result of the operator.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecurrenceRule Class
RecurrenceRule Members


Inequality Operator (RecurrenceRule)

Inequality Operator (RecurrenceRule)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > RecurrenceRule Class : Inequality Operator
The left.
The right.
Implements the operator !=.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator <>( _
   ByVal left As RecurrenceRule, _
   ByVal right As RecurrenceRule _
) As Boolean
public bool operator !=(
   RecurrenceRule left,
   RecurrenceRule right
)

Parameters

left
The left.
right
The right.

Return Value

The result of the operator.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecurrenceRule Class
RecurrenceRule Members


RecurrenceSet Class

RecurrenceSet Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : RecurrenceSet Class
Defines a recurence set for a schedule.
Object Model
RecurrenceSet ClassRecurrenceRule ClassRecurrenceRule Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class RecurrenceSet
public sealed class RecurrenceSet
Remarks
RFC: The recurrence set is the complete set of recurrence instances for a calendar component. The recurrence set is generated by considering the initial "DTSTART" property along with the "RRULE", "RDATE", "EXDATE" and "EXRULE" properties contained within the iCalendar object. The "DTSTART" defines the first instance in the recurrence set. Multiple instances of the "RRULE" and "EXRULE" properties can also be specified to define more sophisticated recurrence sets. The final recurrence set is generated by gathering all of the start date-times generated by any of the specified "RRULE" and "RDATE" properties, and excluding any start date and times which fall within the union of start date and times generated by any specified "EXRULE" and "EXDATE" properties. This implies that start date and times within exclusion related properties (i.e., "EXDATE" and "EXRULE") take precedence over those specified by inclusion properties (i.e., "RDATE" and "RRULE"). Where duplicate instances are generated by the "RRULE" and "RDATE" properties, only one recurrence is considered. Duplicate instances are ignored.
Inheritance Hierarchy

System.Object
ActiveReports.Server.Scheduling.RecurrenceSet

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecurrenceSet Members
ActiveReports.Server.Scheduling Namespace


RecurrenceSet Class Members

RecurrenceSet Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : RecurrenceSet Class

The following tables list the members exposed by RecurrenceSet.

Public Constructors
 | Name | Description
Public Constructor | RecurrenceSet Constructor | Initializes a new instance of the RecurrenceSet class.
Top
Public Properties
 | Name | Description
Public Property | ExceptionDates | Gets the exception dates.
Public Property | ExceptionRules | Gets the exception rules.
Public Property | RecurrenceDates | Gets the recurrence dates.
Public Property | RecurrenceRules | Gets the recurrence rules.
Public Property | StartDate | Gets or sets the start date of the schedule.
Top
See Also

Reference

RecurrenceSet Class
ActiveReports.Server.Scheduling Namespace


RecurrenceSet Constructor

RecurrenceSet Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > RecurrenceSet Class : RecurrenceSet Constructor
Initializes a new instance of the RecurrenceSet class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public RecurrenceSet()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecurrenceSet Class
RecurrenceSet Members


RecurrenceSet Class Properties

RecurrenceSet Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : RecurrenceSet Class

For a list of all members of this type, see RecurrenceSet members.

Public Properties
 | Name | Description
Public Property | ExceptionDates | Gets the exception dates.
Public Property | ExceptionRules | Gets the exception rules.
Public Property | RecurrenceDates | Gets the recurrence dates.
Public Property | RecurrenceRules | Gets the recurrence rules.
Public Property | StartDate | Gets or sets the start date of the schedule.
Top
See Also

Reference

RecurrenceSet Class
ActiveReports.Server.Scheduling Namespace


ExceptionDates Property

ExceptionDates Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > RecurrenceSet Class : ExceptionDates Property
Gets the exception dates.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ExceptionDates As Date()
public DateTime[] ExceptionDates {get; set;}

Property Value

The exception dates.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecurrenceSet Class
RecurrenceSet Members


ExceptionRules Property

ExceptionRules Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > RecurrenceSet Class : ExceptionRules Property
Gets the exception rules.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ExceptionRules As RecurrenceRule()
public RecurrenceRule[] ExceptionRules {get; set;}

Property Value

The exception rules.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecurrenceSet Class
RecurrenceSet Members


RecurrenceDates Property

RecurrenceDates Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > RecurrenceSet Class : RecurrenceDates Property
Gets the recurrence dates.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RecurrenceDates As Date()
public DateTime[] RecurrenceDates {get; set;}

Property Value

The recurrence dates.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecurrenceSet Class
RecurrenceSet Members


RecurrenceRules Property

RecurrenceRules Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > RecurrenceSet Class : RecurrenceRules Property
Gets the recurrence rules.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RecurrenceRules As RecurrenceRule()
public RecurrenceRule[] RecurrenceRules {get; set;}

Property Value

The recurrence rules.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecurrenceSet Class
RecurrenceSet Members


StartDate Property

StartDate Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > RecurrenceSet Class : StartDate Property
Gets or sets the start date of the schedule.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StartDate As Date
public DateTime StartDate {get; set;}

Property Value

The start date of the schedule.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RecurrenceSet Class
RecurrenceSet Members


Schedule Class

Schedule Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : Schedule Class
Defines rules to determine at which time point to execute an associated request.
Object Model
Schedule ClassRecurrenceSet Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Schedule
   Implements ISchedule
public class Schedule : ISchedule
Inheritance Hierarchy

System.Object
ActiveReports.Server.Scheduling.Schedule

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Schedule Members
ActiveReports.Server.Scheduling Namespace


Schedule Class Members

Schedule Class Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : Schedule Class

The following tables list the members exposed by Schedule.

Public Constructors
 | Name | Description
Public Constructor | Schedule Constructor | Initializes a new instance of the Schedule class.
Top
Public Properties
 | Name | Description
Public Property | Enabled | Gets or sets a value indicating whether this Schedule is enabled.
Public Property | RecurrenceSet | Gets or sets the recurrence set.
Top
See Also

Reference

Schedule Class
ActiveReports.Server.Scheduling Namespace


Schedule Constructor

Schedule Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > Schedule Class : Schedule Constructor
Initializes a new instance of the Schedule class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Schedule()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Schedule Class
Schedule Members


Schedule Class Properties

Schedule Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : Schedule Class

For a list of all members of this type, see Schedule members.

Public Properties
 | Name | Description
Public Property | Enabled | Gets or sets a value indicating whether this Schedule is enabled.
Public Property | RecurrenceSet | Gets or sets the recurrence set.
Top
See Also

Reference

Schedule Class
ActiveReports.Server.Scheduling Namespace


Enabled Property (Schedule)

Enabled Property (Schedule)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > Schedule Class : Enabled Property
Gets or sets a value indicating whether this Schedule is enabled.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Enabled As Boolean
public bool Enabled {get; set;}

Property Value

true if enabled; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Schedule Class
Schedule Members


RecurrenceSet Property (Schedule)

RecurrenceSet Property (Schedule)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > Schedule Class : RecurrenceSet Property
Gets or sets the recurrence set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RecurrenceSet As RecurrenceSet
public RecurrenceSet RecurrenceSet {get; set;}

Property Value

The recurrence set.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Schedule Class
Schedule Members


TerminationByCount Class

TerminationByCount Class
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : TerminationByCount Class
Defines the termination of recurrence rule event count.
Object Model
TerminationByCount Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class TerminationByCount
   Inherits Termination
public sealed class TerminationByCount : Termination
Inheritance Hierarchy

System.Object
ActiveReports.Server.Scheduling.TerminationByCount

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TerminationByCount Members
ActiveReports.Server.Scheduling Namespace


TerminationByCount Class Members

TerminationByCount Class Members
Properties Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : TerminationByCount Class

The following tables list the members exposed by TerminationByCount.

Public Constructors
 | Name | Description
Public Constructor | TerminationByCount Constructor | Initializes a new instance of the TerminationByCount class.
Top
Public Properties
 | Name | Description
Public Property | Value | Gets or sets the value.
Top
Public Methods
 | Name | Description
Public Method | Equals | Overloaded. Indicates whether the current object is equal to another object of the same type.
Public Method | GetHashCode | Serves as a hash function for a particular type.
Top
Public Operators
public Operator Equality | Implements the operator ==.
public Operator Inequality | Implements the operator !=.
Top
See Also

Reference

TerminationByCount Class
ActiveReports.Server.Scheduling Namespace


TerminationByCount Constructor

TerminationByCount Constructor

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > TerminationByCount Class : TerminationByCount Constructor
Initializes a new instance of the TerminationByCount class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public TerminationByCount()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TerminationByCount Class
TerminationByCount Members


TerminationByCount Class Methods

TerminationByCount Class Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : TerminationByCount Class

For a list of all members of this type, see TerminationByCount members.

Public Methods
 | Name | Description
Public Method | Equals | Overloaded. Indicates whether the current object is equal to another object of the same type.
Public Method | GetHashCode | Serves as a hash function for a particular type.
Top
See Also

Reference

TerminationByCount Class
ActiveReports.Server.Scheduling Namespace


Equals Method (TerminationByCount)

Equals Method (TerminationByCount)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > TerminationByCount Class : Equals Method
Indicates whether the current object is equal to another object of the same type.
Overload List
Overload | Description
Equals(TerminationByCount) | Indicates whether the current object is equal to another object of the same type.
Equals(Object) | Determines whether the specified System.Object is equal to the current System.Object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TerminationByCount Class
TerminationByCount Members


Equals(TerminationByCount) Method

Equals(TerminationByCount) Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > TerminationByCount Class > Equals Method : Equals(TerminationByCount) Method
An object to compare with this object.
Indicates whether the current object is equal to another object of the same type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Equals( _
   ByVal other As TerminationByCount _
) As Boolean
public bool Equals(
   TerminationByCount other
)

Parameters

other
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TerminationByCount Class
TerminationByCount Members
Overload List


Equals(Object) Method

Equals(Object) Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > TerminationByCount Class > Equals Method : Equals(Object) Method
The System.Object to compare with the current System.Object.
Determines whether the specified System.Object is equal to the current System.Object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
public override bool Equals(
   object obj
)

Parameters

obj
The System.Object to compare with the current System.Object.

Return Value

true if the specified System.Object is equal to the current System.Object; otherwise, false.
Exceptions
Exception | Description
System.NullReferenceException | The obj parameter is null.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TerminationByCount Class
TerminationByCount Members
Overload List
Base Implementation in Equals(Object)


GetHashCode Method (TerminationByCount)

GetHashCode Method (TerminationByCount)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > TerminationByCount Class : GetHashCode Method
Serves as a hash function for a particular type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As Integer
public override int GetHashCode()

Return Value

A hash code for the current System.Object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TerminationByCount Class
TerminationByCount Members
Base Implementation in GetHashCode


TerminationByCount Class Properties

TerminationByCount Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : TerminationByCount Class

For a list of all members of this type, see TerminationByCount members.

Public Properties
 | Name | Description
Public Property | Value | Gets or sets the value.
Top
See Also

Reference

TerminationByCount Class
ActiveReports.Server.Scheduling Namespace


Value Property (TerminationByCount)

Value Property (TerminationByCount)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > TerminationByCount Class : Value Property
Gets or sets the value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Value As Integer
public int Value {get; set;}

Property Value

The value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TerminationByCount Class
TerminationByCount Members


Equality Operator (TerminationByCount)

Equality Operator (TerminationByCount)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > TerminationByCount Class : Equality Operator
The left.
The right.
Implements the operator ==.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator =( _
   ByVal left As TerminationByCount, _
   ByVal right As TerminationByCount _
) As Boolean
public bool operator ==(
   TerminationByCount left,
   TerminationByCount right
)

Parameters

left
The left.
right
The right.

Return Value

The result of the operator.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TerminationByCount Class
TerminationByCount Members


Inequality Operator (TerminationByCount)

Inequality Operator (TerminationByCount)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > TerminationByCount Class : Inequality Operator
The left.
The right.
Implements the operator !=.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator <>( _
   ByVal left As TerminationByCount, _
   ByVal right As TerminationByCount _
) As Boolean
public bool operator !=(
   TerminationByCount left,
   TerminationByCount right
)

Parameters

left
The left.
right
The right.

Return Value

The result of the operator.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TerminationByCount Class
TerminationByCount Members


ExistingFileBehavior Enumeration

ExistingFileBehavior Enumeration

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : ExistingFileBehavior Enumeration
Defines a behavior which should be applied in situation when file exists.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ExistingFileBehavior
   Inherits System.Enum
public enum ExistingFileBehavior : System.Enum
Members
Member | Description
Increment | Defines that file should be saved with incremented name.
NotSpecified | Action is not specified.
Overwrite | Defines that file should be overwritten.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveReports.Server.Scheduling.ExistingFileBehavior

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReports.Server.Scheduling Namespace


FileExtensionBehavior Enumeration

FileExtensionBehavior Enumeration

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : FileExtensionBehavior Enumeration
Defines a behavior which determines should file extension be added to a file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum FileExtensionBehavior
   Inherits System.Enum
public enum FileExtensionBehavior : System.Enum
Members
Member | Description
Add | Defines that file extension should be added to file name.
DontAdd | Defines that file extension should not be added to file name.
NotSpecified | Action is not specified.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveReports.Server.Scheduling.FileExtensionBehavior

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReports.Server.Scheduling Namespace


Frequency Enumeration

Frequency Enumeration

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : Frequency Enumeration
Specifies the frequency for the associated recurrence rule.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Frequency
   Inherits System.Enum
public enum Frequency : System.Enum
Members
Member | Description
Daily | Indicates that events occur daily.
Hourly | Indicates that events occur hourly.
Minutely | Indicates that events occur minutely.
Monthly | Indicates that events occur monthly.
Secondly | Indicates that events occur secondly.
Weekly | Indicates that events occur weekly.
Yearly | Indicates that events occur yearly.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveReports.Server.Scheduling.Frequency

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReports.Server.Scheduling Namespace


PolicyType Enumeration

PolicyType Enumeration

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : PolicyType Enumeration
Represents type of the policy.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum PolicyType
   Inherits System.Enum
public enum PolicyType : System.Enum
Members
Member | Description
CachePolicy | This type of policies is created using Designer UI and describe cache processing rules.
HiddenScheduledPolicy | This type of policies which can not be showed in UI but can show the history.
ScheduledPolicy | This type of policies is created using Designer UI and mean to be used as scheduled actions.
SendEmailPolicy | This type of policies which can not be showed in UI.
SystemScheduledPolicy | This type of policies is created using UI indirectly and mean not be showed in UI and modified only by admin.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveReports.Server.Scheduling.PolicyType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReports.Server.Scheduling Namespace


ScheduleType Enumeration

ScheduleType Enumeration

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : ScheduleType Enumeration
Represents type of the schedule.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ScheduleType
   Inherits System.Enum
public enum ScheduleType : System.Enum
Members
Member | Description
Printing | Schedule of printing of the report
Rendering | Schedule of rendering of the report
Unselected | Unselected type of schedule
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveReports.Server.Scheduling.ScheduleType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReports.Server.Scheduling Namespace


TwoSidedPrinting Enumeration

TwoSidedPrinting Enumeration

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : TwoSidedPrinting Enumeration
Specifies whether and how to print the report on both sides of the paper.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum TwoSidedPrinting
   Inherits System.Enum
public enum TwoSidedPrinting : System.Enum
Members
Member | Description
LongEdge | Prints the pages on the front and back of the paper so that they are bound along the long edge of the paper, like a book. When you turn the page from right to left, the back of the page is oriented the same as the front.
OneSided | Prints the pages on only one side of the paper.
ShortEdge | Prints the pages on the front and back of the paper so that they are bound along the short edge of the paper, like a top-bound notepad. When you flip the page up from the bottom, the back of the page is oriented so that you can read it in that position.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveReports.Server.Scheduling.TwoSidedPrinting

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReports.Server.Scheduling Namespace


Day Structure

Day Structure
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : Day Structure
Defines a day for the by day list of recurrence rule.
Object Model
Day Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure Day
   Inherits System.ValueType
public struct Day : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
ActiveReports.Server.Scheduling.Day

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Day Members
ActiveReports.Server.Scheduling Namespace


Day Structure Members

Day Structure Members
Fields Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : Day Structure

The following tables list the members exposed by Day.

Public Fields
 | Name | Description
Public Field | DayOfWeek | The day of week.
Public Field | Ordinal | If present indicates the nth occurrence of the specific day within the MONTHLY or YEARLY RRULE.
Top
Public Methods
 | Name | Description
Public Method | Equals | Overloaded. Indicates whether the current object is equal to another object of the same type.
Public Method | GetHashCode | Returns the hash code for this instance.
Top
Public Operators
public Operator Equality | Implements the operator ==.
public Operator Inequality | Implements the operator !=.
Top
See Also

Reference

Day Structure
ActiveReports.Server.Scheduling Namespace


Day Structure Methods

Day Structure Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : Day Structure

For a list of all members of this type, see Day members.

Public Methods
 | Name | Description
Public Method | Equals | Overloaded. Indicates whether the current object is equal to another object of the same type.
Public Method | GetHashCode | Returns the hash code for this instance.
Top
See Also

Reference

Day Structure
ActiveReports.Server.Scheduling Namespace


Equals Method (Day)

Equals Method (Day)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > Day Structure : Equals Method
Indicates whether the current object is equal to another object of the same type.
Overload List
Overload | Description
Equals(Day) | Indicates whether the current object is equal to another object of the same type.
Equals(Object) | Indicates whether this instance and a specified object are equal.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Day Structure
Day Members


Equals(Day) Method

Equals(Day) Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > Day Structure > Equals Method : Equals(Day) Method
An object to compare with this object.
Indicates whether the current object is equal to another object of the same type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Equals( _
   ByVal other As Day _
) As Boolean
public bool Equals(
   Day other
)

Parameters

other
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Day Structure
Day Members
Overload List


Equals(Object) Method

Equals(Object) Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > Day Structure > Equals Method : Equals(Object) Method
Another object to compare to.
Indicates whether this instance and a specified object are equal.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
public override bool Equals(
   object obj
)

Parameters

obj
Another object to compare to.

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Day Structure
Day Members
Overload List
Base Implementation in Equals(Object)


GetHashCode Method (Day)

GetHashCode Method (Day)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > Day Structure : GetHashCode Method
Returns the hash code for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As Integer
public override int GetHashCode()

Return Value

A 32-bit signed integer that is the hash code for this instance.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Day Structure
Day Members
Base Implementation in GetHashCode


Day Structure Fields

Day Structure Fields

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : Day Structure

For a list of all members of this type, see Day members.

Public Fields
 | Name | Description
Public Field | DayOfWeek | The day of week.
Public Field | Ordinal | If present indicates the nth occurrence of the specific day within the MONTHLY or YEARLY RRULE.
Top
See Also

Reference

Day Structure
ActiveReports.Server.Scheduling Namespace


DayOfWeek Field

DayOfWeek Field

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > Day Structure : DayOfWeek Field
The day of week.
Syntax
  • Visual Basic
  • C#
'Declaration

Public DayOfWeek As DayOfWeek
public DayOfWeek DayOfWeek
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Day Structure
Day Members


Ordinal Field

Ordinal Field

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > Day Structure : Ordinal Field
If present indicates the nth occurrence of the specific day within the MONTHLY or YEARLY RRULE.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Ordinal As Nullable(Of Integer)
public Nullable<int> Ordinal
Example
Within a MONTHLY rule, +1MO (or simply 1MO) represents the first Monday within the month, whereas -1MO represents the last Monday of the month. If an integer modifier is not present, it means all days of this type within the specified frequency.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Day Structure
Day Members


Equality Operator (Day)

Equality Operator (Day)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > Day Structure : Equality Operator
The left.
The right.
Implements the operator ==.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator =( _
   ByVal left As Day, _
   ByVal right As Day _
) As Boolean
public bool operator ==(
   Day left,
   Day right
)

Parameters

left
The left.
right
The right.

Return Value

The result of the operator.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Day Structure
Day Members


Inequality Operator (Day)

Inequality Operator (Day)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > Day Structure : Inequality Operator
The left.
The right.
Implements the operator !=.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator <>( _
   ByVal left As Day, _
   ByVal right As Day _
) As Boolean
public bool operator !=(
   Day left,
   Day right
)

Parameters

left
The left.
right
The right.

Return Value

The result of the operator.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Day Structure
Day Members


ICachePolicy Interface

ICachePolicy Interface
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : ICachePolicy Interface
Defines when the output of the jobs created from the associated policy will expire.
Object Model
ICachePolicy InterfaceIExpirationRule Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ICachePolicy
public interface ICachePolicy
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICachePolicy Members
ActiveReports.Server.Scheduling Namespace


ICachePolicy Interface Members

ICachePolicy Interface Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : ICachePolicy Interface

The following tables list the members exposed by ICachePolicy.

Public Properties
 | Name | Description
Property | Expiration | Gets or sets the expiration rule.
Property | Priority | Gets or sets the cache item priority.
Top
See Also

Reference

ICachePolicy Interface
ActiveReports.Server.Scheduling Namespace


ICachePolicy Interface Properties

ICachePolicy Interface Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : ICachePolicy Interface

For a list of all members of this type, see ICachePolicy members.

Public Properties
 | Name | Description
Property | Expiration | Gets or sets the expiration rule.
Property | Priority | Gets or sets the cache item priority.
Top
See Also

Reference

ICachePolicy Interface
ActiveReports.Server.Scheduling Namespace


Expiration Property

Expiration Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > ICachePolicy Interface : Expiration Property
Gets or sets the expiration rule.
Syntax
  • Visual Basic
  • C#
'Declaration

Property Expiration As IExpirationRule
IExpirationRule Expiration {get; set;}

Property Value

The expiration rule.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICachePolicy Interface
ICachePolicy Members


Priority Property (ICachePolicy)

Priority Property (ICachePolicy)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > ICachePolicy Interface : Priority Property
Gets or sets the cache item priority.
Syntax
  • Visual Basic
  • C#
'Declaration

Property Priority As CacheItemPriority
CacheItemPriority Priority {get; set;}

Property Value

The cache item priority.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICachePolicy Interface
ICachePolicy Members


IDistribution Interface

IDistribution Interface
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : IDistribution Interface
Defines delivery methods for the jobs created from the associated policy.
Object Model
IDistribution InterfaceDistributionMethod Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDistribution
public interface IDistribution
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDistribution Members
ActiveReports.Server.Scheduling Namespace


IDistribution Interface Members

IDistribution Interface Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : IDistribution Interface

The following tables list the members exposed by IDistribution.

Public Properties
 | Name | Description
Property | Methods | Gets or sets the distribution methods.
Top
See Also

Reference

IDistribution Interface
ActiveReports.Server.Scheduling Namespace


IDistribution Interface Properties

IDistribution Interface Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : IDistribution Interface

For a list of all members of this type, see IDistribution members.

Public Properties
 | Name | Description
Property | Methods | Gets or sets the distribution methods.
Top
See Also

Reference

IDistribution Interface
ActiveReports.Server.Scheduling Namespace


Methods Property

Methods Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > IDistribution Interface : Methods Property
Gets or sets the distribution methods.
Syntax
  • Visual Basic
  • C#
'Declaration

Property Methods As DistributionMethod()
DistributionMethod[] Methods {get; set;}

Property Value

The distribution methods.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IDistribution Interface
IDistribution Members


IExpirationRule Interface

IExpirationRule Interface
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : IExpirationRule Interface
Defines the rule providing an expiration for a given moment.
Object Model
IExpirationRule Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IExpirationRule
public interface IExpirationRule
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExpirationRule Members
ActiveReports.Server.Scheduling Namespace


IExpirationRule Interface Members

IExpirationRule Interface Members
Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : IExpirationRule Interface

The following tables list the members exposed by IExpirationRule.

Public Methods
 | Name | Description
Method | CreateExpiration | Creates the expiration for the specified moment.
Top
See Also

Reference

IExpirationRule Interface
ActiveReports.Server.Scheduling Namespace


IExpirationRule Interface Methods

IExpirationRule Interface Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : IExpirationRule Interface

For a list of all members of this type, see IExpirationRule members.

Public Methods
 | Name | Description
Method | CreateExpiration | Creates the expiration for the specified moment.
Top
See Also

Reference

IExpirationRule Interface
ActiveReports.Server.Scheduling Namespace


CreateExpiration Method

CreateExpiration Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > IExpirationRule Interface : CreateExpiration Method
The time of origin for the expiration.
Creates the expiration for the specified moment.
Syntax
  • Visual Basic
  • C#
'Declaration

Function CreateExpiration( _
   ByVal origin As Date _
) As IExpiration
IExpiration CreateExpiration(
   DateTime origin
)

Parameters

origin
The time of origin for the expiration.

Return Value

The expiration.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IExpirationRule Interface
IExpirationRule Members


IJobEntryTemplate Interface

IJobEntryTemplate Interface
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : IJobEntryTemplate Interface
Defines a template to build a job entry from.
Object Model
IJobEntryTemplate Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IJobEntryTemplate
public interface IJobEntryTemplate
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IJobEntryTemplate Members
ActiveReports.Server.Scheduling Namespace


IJobEntryTemplate Interface Members

IJobEntryTemplate Interface Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : IJobEntryTemplate Interface

The following tables list the members exposed by IJobEntryTemplate.

Public Properties
 | Name | Description
Property | AccessionCode | Gets or sets the accession code for the job entry to create.
Property | Job | Gets or sets the job to be done.
Property | Priority | Gets or sets the priority for the scheduled item represented by this instance.
Property | Version | Gets or sets the template version.
Top
See Also

Reference

IJobEntryTemplate Interface
ActiveReports.Server.Scheduling Namespace


IJobEntryTemplate Interface Properties

IJobEntryTemplate Interface Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : IJobEntryTemplate Interface

For a list of all members of this type, see IJobEntryTemplate members.

Public Properties
 | Name | Description
Property | AccessionCode | Gets or sets the accession code for the job entry to create.
Property | Job | Gets or sets the job to be done.
Property | Priority | Gets or sets the priority for the scheduled item represented by this instance.
Property | Version | Gets or sets the template version.
Top
See Also

Reference

IJobEntryTemplate Interface
ActiveReports.Server.Scheduling Namespace


AccessionCode Property (IJobEntryTemplate)

AccessionCode Property (IJobEntryTemplate)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > IJobEntryTemplate Interface : AccessionCode Property
Gets or sets the accession code for the job entry to create.
Syntax
  • Visual Basic
  • C#
'Declaration

Property AccessionCode As String
string AccessionCode {get; set;}

Property Value

The accession code for the job entry to create.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IJobEntryTemplate Interface
IJobEntryTemplate Members


Job Property (IJobEntryTemplate)

Job Property (IJobEntryTemplate)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > IJobEntryTemplate Interface : Job Property
Gets or sets the job to be done.
Syntax
  • Visual Basic
  • C#
'Declaration

Property Job As IJob
IJob Job {get; set;}

Property Value

The job to be done.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IJobEntryTemplate Interface
IJobEntryTemplate Members


Priority Property (IJobEntryTemplate)

Priority Property (IJobEntryTemplate)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > IJobEntryTemplate Interface : Priority Property
Gets or sets the priority for the scheduled item represented by this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Property Priority As JobEntryPriority
JobEntryPriority Priority {get; set;}

Property Value

The priority for the scheduled item represented by this instance.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IJobEntryTemplate Interface
IJobEntryTemplate Members


Version Property (IJobEntryTemplate)

Version Property (IJobEntryTemplate)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > IJobEntryTemplate Interface : Version Property
Gets or sets the template version.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Version As Integer
int Version {get;}

Property Value

The template version.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IJobEntryTemplate Interface
IJobEntryTemplate Members


IPolicy Interface

IPolicy Interface
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : IPolicy Interface
Defines association between scheduling, distribution, caching rukes and the rules to create a user job.
Object Model
IPolicy InterfaceICachePolicy InterfaceIDistribution InterfaceIJobEntryTemplate InterfaceISchedule Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IPolicy
public interface IPolicy
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPolicy Members
ActiveReports.Server.Scheduling Namespace


IPolicy Interface Members

IPolicy Interface Members
Properties Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : IPolicy Interface

The following tables list the members exposed by IPolicy.

Public Properties
 | Name | Description
Property | CachePolicy | Gets or sets the rule set defining how the results of each journal entry should be cached.
Property | CreatedBy | Gets the name of the user created this policy.
Property | CreationDate | Gets or sets the creation date of this policy.
Property | Distribution | Gets or sets the distribution defining the rules of delivery the execution results to a user.
Property | Id | Gets the identifier for this journal entry.
Property | JobEntry | Gets or sets the template providing a way to create a job entry.
Property | ModifiedBy | Gets the name of the user made the last modification of this policy.
Property | ModifiedDate | Gets or sets the date of last modification of this policy.
Property | Name | Gets or sets the name of this policy.
Property | ParentId | Gets the identifier for the parent of this policy applies to.
Property | PolicyType | Gets or sets the type of policy.
Property | Schedule | Gets or sets the schedule defining the rules to determine execution timeline.
Property | SharedPolicyTemplateId | Gets or sets the related shared policy template id.
Property | TargetId | Gets the identifier for the target this policy applies to.
Top
Public Methods
 | Name | Description
Method | Save | Saves the policy modifications.
Top
See Also

Reference

IPolicy Interface
ActiveReports.Server.Scheduling Namespace


IPolicy Interface Methods

IPolicy Interface Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : IPolicy Interface

For a list of all members of this type, see IPolicy members.

Public Methods
 | Name | Description
Method | Save | Saves the policy modifications.
Top
See Also

Reference

IPolicy Interface
ActiveReports.Server.Scheduling Namespace


Save Method

Save Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > IPolicy Interface : Save Method
Saves the policy modifications.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Save()
void Save()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPolicy Interface
IPolicy Members


IPolicy Interface Properties

IPolicy Interface Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : IPolicy Interface

For a list of all members of this type, see IPolicy members.

Public Properties
 | Name | Description
Property | CachePolicy | Gets or sets the rule set defining how the results of each journal entry should be cached.
Property | CreatedBy | Gets the name of the user created this policy.
Property | CreationDate | Gets or sets the creation date of this policy.
Property | Distribution | Gets or sets the distribution defining the rules of delivery the execution results to a user.
Property | Id | Gets the identifier for this journal entry.
Property | JobEntry | Gets or sets the template providing a way to create a job entry.
Property | ModifiedBy | Gets the name of the user made the last modification of this policy.
Property | ModifiedDate | Gets or sets the date of last modification of this policy.
Property | Name | Gets or sets the name of this policy.
Property | ParentId | Gets the identifier for the parent of this policy applies to.
Property | PolicyType | Gets or sets the type of policy.
Property | Schedule | Gets or sets the schedule defining the rules to determine execution timeline.
Property | SharedPolicyTemplateId | Gets or sets the related shared policy template id.
Property | TargetId | Gets the identifier for the target this policy applies to.
Top
See Also

Reference

IPolicy Interface
ActiveReports.Server.Scheduling Namespace


CachePolicy Property (IPolicy)

CachePolicy Property (IPolicy)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > IPolicy Interface : CachePolicy Property
Gets or sets the rule set defining how the results of each journal entry should be cached.
Syntax
  • Visual Basic
  • C#
'Declaration

Property CachePolicy As ICachePolicy
ICachePolicy CachePolicy {get; set;}

Property Value

The rule set defining how the results of each journal entry should be cached.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPolicy Interface
IPolicy Members


CreatedBy Property (IPolicy)

CreatedBy Property (IPolicy)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > IPolicy Interface : CreatedBy Property
Gets the name of the user created this policy.
Syntax
  • Visual Basic
  • C#
'Declaration

Property CreatedBy As String
string CreatedBy {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPolicy Interface
IPolicy Members


CreationDate Property (IPolicy)

CreationDate Property (IPolicy)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > IPolicy Interface : CreationDate Property
Gets or sets the creation date of this policy.
Syntax
  • Visual Basic
  • C#
'Declaration

Property CreationDate As Date
DateTime CreationDate {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPolicy Interface
IPolicy Members


Distribution Property (IPolicy)

Distribution Property (IPolicy)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > IPolicy Interface : Distribution Property
Gets or sets the distribution defining the rules of delivery the execution results to a user.
Syntax
  • Visual Basic
  • C#
'Declaration

Property Distribution As IDistribution
IDistribution Distribution {get; set;}

Property Value

The distribution defining the rules of delivery the execution results to a user.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPolicy Interface
IPolicy Members


Id Property (IPolicy)

Id Property (IPolicy)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > IPolicy Interface : Id Property
Gets the identifier for this journal entry.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Id As Guid
Guid Id {get;}

Property Value

The identifier for this journal entry.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPolicy Interface
IPolicy Members


JobEntry Property

JobEntry Property

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > IPolicy Interface : JobEntry Property
Gets or sets the template providing a way to create a job entry.
Syntax
  • Visual Basic
  • C#
'Declaration

Property JobEntry As IJobEntryTemplate
IJobEntryTemplate JobEntry {get; set;}

Property Value

The template providing a way to create a job entry.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPolicy Interface
IPolicy Members


ModifiedBy Property (IPolicy)

ModifiedBy Property (IPolicy)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > IPolicy Interface : ModifiedBy Property
Gets the name of the user made the last modification of this policy.
Syntax
  • Visual Basic
  • C#
'Declaration

Property ModifiedBy As String
string ModifiedBy {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPolicy Interface
IPolicy Members


ModifiedDate Property (IPolicy)

ModifiedDate Property (IPolicy)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > IPolicy Interface : ModifiedDate Property
Gets or sets the date of last modification of this policy.
Syntax
  • Visual Basic
  • C#
'Declaration

Property ModifiedDate As Date
DateTime ModifiedDate {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPolicy Interface
IPolicy Members


Name Property (IPolicy)

Name Property (IPolicy)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > IPolicy Interface : Name Property
Gets or sets the name of this policy.
Syntax
  • Visual Basic
  • C#
'Declaration

Property Name As String
string Name {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPolicy Interface
IPolicy Members


ParentId Property (IPolicy)

ParentId Property (IPolicy)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > IPolicy Interface : ParentId Property
Gets the identifier for the parent of this policy applies to.
Syntax
  • Visual Basic
  • C#
'Declaration

Property ParentId As String
string ParentId {get; set;}

Property Value

The identifier for the parent of this policy applies to.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPolicy Interface
IPolicy Members


PolicyType Property (IPolicy)

PolicyType Property (IPolicy)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > IPolicy Interface : PolicyType Property
Gets or sets the type of policy.
Syntax
  • Visual Basic
  • C#
'Declaration

Property PolicyType As PolicyType
PolicyType PolicyType {get; set;}

Property Value

The type of policy.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPolicy Interface
IPolicy Members


Schedule Property (IPolicy)

Schedule Property (IPolicy)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > IPolicy Interface : Schedule Property
Gets or sets the schedule defining the rules to determine execution timeline.
Syntax
  • Visual Basic
  • C#
'Declaration

Property Schedule As ISchedule
ISchedule Schedule {get; set;}

Property Value

The schedule defining the rules to determine execution timeline.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPolicy Interface
IPolicy Members


SharedPolicyTemplateId Property (IPolicy)

SharedPolicyTemplateId Property (IPolicy)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > IPolicy Interface : SharedPolicyTemplateId Property
Gets or sets the related shared policy template id.
Syntax
  • Visual Basic
  • C#
'Declaration

Property SharedPolicyTemplateId As String
string SharedPolicyTemplateId {get; set;}

Property Value

Related shared policy template id.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPolicy Interface
IPolicy Members


TargetId Property (IPolicy)

TargetId Property (IPolicy)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > IPolicy Interface : TargetId Property
Gets the identifier for the target this policy applies to.
Syntax
  • Visual Basic
  • C#
'Declaration

Property TargetId As String
string TargetId {get; set;}

Property Value

The identifier for the target this policy applies to.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IPolicy Interface
IPolicy Members


ISchedule Interface

ISchedule Interface
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : ISchedule Interface
Defines when to create the jobs from the associated policy.
Object Model
ISchedule InterfaceRecurrenceSet Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ISchedule
public interface ISchedule
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISchedule Members
ActiveReports.Server.Scheduling Namespace


ISchedule Interface Members

ISchedule Interface Members
Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : ISchedule Interface

The following tables list the members exposed by ISchedule.

Public Properties
 | Name | Description
Property | Enabled | Gets or sets a value indicating whether this ISchedule is enabled.
Property | RecurrenceSet | Gets or sets the recurrence set.
Top
See Also

Reference

ISchedule Interface
ActiveReports.Server.Scheduling Namespace


ISchedule Interface Properties

ISchedule Interface Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : ISchedule Interface

For a list of all members of this type, see ISchedule members.

Public Properties
 | Name | Description
Property | Enabled | Gets or sets a value indicating whether this ISchedule is enabled.
Property | RecurrenceSet | Gets or sets the recurrence set.
Top
See Also

Reference

ISchedule Interface
ActiveReports.Server.Scheduling Namespace


Enabled Property (ISchedule)

Enabled Property (ISchedule)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > ISchedule Interface : Enabled Property
Gets or sets a value indicating whether this ISchedule is enabled.
Syntax
  • Visual Basic
  • C#
'Declaration

Property Enabled As Boolean
bool Enabled {get; set;}

Property Value

true if enabled; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISchedule Interface
ISchedule Members


RecurrenceSet Property (ISchedule)

RecurrenceSet Property (ISchedule)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > ISchedule Interface : RecurrenceSet Property
Gets or sets the recurrence set.
Syntax
  • Visual Basic
  • C#
'Declaration

Property RecurrenceSet As RecurrenceSet
RecurrenceSet RecurrenceSet {get; set;}

Property Value

The recurrence set.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISchedule Interface
ISchedule Members


IScheduler Interface

IScheduler Interface
Members

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : IScheduler Interface
Provides access to scheduling, distribution and caching configuration.
Object Model
IScheduler Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IScheduler
public interface IScheduler
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IScheduler Members
ActiveReports.Server.Scheduling Namespace


IScheduler Interface Members

IScheduler Interface Members
Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : IScheduler Interface

The following tables list the members exposed by IScheduler.

Public Methods
 | Name | Description
Method | Create | Creates a new policy in the scheduler.
Method | Destroy | Performs the tasks associated with removing the specified policy from the scheduler.
Method | Select<TResult> | Ritrieves the collection of policies matching the specified query.
Top
See Also

Reference

IScheduler Interface
ActiveReports.Server.Scheduling Namespace


IScheduler Interface Methods

IScheduler Interface Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace : IScheduler Interface

For a list of all members of this type, see IScheduler members.

Public Methods
 | Name | Description
Method | Create | Creates a new policy in the scheduler.
Method | Destroy | Performs the tasks associated with removing the specified policy from the scheduler.
Method | Select<TResult> | Ritrieves the collection of policies matching the specified query.
Top
See Also

Reference

IScheduler Interface
ActiveReports.Server.Scheduling Namespace


Create Method (IScheduler)

Create Method (IScheduler)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > IScheduler Interface : Create Method
Creates a new policy in the scheduler.
Syntax
  • Visual Basic
  • C#
'Declaration

Function Create() As IPolicy
IPolicy Create()

Return Value

The new policy.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IScheduler Interface
IScheduler Members


Destroy Method

Destroy Method

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > IScheduler Interface : Destroy Method
The policy to destroy.
Performs the tasks associated with removing the specified policy from the scheduler.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Destroy( _
   ByVal policy As IPolicy _
)
void Destroy(
   IPolicy policy
)

Parameters

policy
The policy to destroy.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IScheduler Interface
IScheduler Members


Select<TResult> Method (IScheduler)

Select<TResult> Method (IScheduler)

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.Scheduling Namespace > IScheduler Interface : Select<TResult> Method
The type of the result.
The query to select policies.
Ritrieves the collection of policies matching the specified query.
Syntax
  • Visual Basic
  • C#
'Declaration

Function Select(Of TResult)( _
   ByVal query As IQuery(Of IPolicy,TResult) _
) As TResult
TResult Select<TResult>(
   IQuery<IPolicy,TResult> query
)

Parameters

query
The query to select policies.

Type Parameters

TResult
The type of the result.

Return Value

The collection of policies matching the specified query.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IScheduler Interface
IScheduler Members


ActiveReports.Server.Security Namespace

ActiveReports.Server.Security Namespace
Inheritance Hierarchy
ActiveReports.Server.Extensibility Assembly : ActiveReports.Server.Security Namespace
Classes
 | Class | Description
Class | PermissionsEnumExtensions | Extension methods for TeslaDb.Common.Operations and Permissions enums.
Class | Setting | Represents single settings property.
Class | UserContext | Represents the user context for provider speicific data.
Interfaces
 | Interface | Description
Interface | IRole | Specifies the role in the role-based security system.
Interface | ISecurityProvider | Specifies the contract for a custom security provider.
Interface | ISecurityProviderFactory | Specifies the security provider factory.
Interface | ISecurityProvidersRegistry | Defines interface to security providers registry responsible for configuring and instantiating security providers.
Structures
 | Structure | Description
Structure | UserDescription | Represents user description.
Enumerations
 | Enumeration | Description
Enumeration | Permissions | Represents permission types.
See Also

Reference

ActiveReports.Server.Extensibility Assembly


PermissionsEnumExtensions Class

PermissionsEnumExtensions Class
Members

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace : PermissionsEnumExtensions Class
Extension methods for TeslaDb.Common.Operations and Permissions enums.
Object Model
PermissionsEnumExtensions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit NotInheritable Class PermissionsEnumExtensions
public static class PermissionsEnumExtensions
Inheritance Hierarchy

System.Object
ActiveReports.Server.Security.PermissionsEnumExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PermissionsEnumExtensions Members
ActiveReports.Server.Security Namespace


PermissionsEnumExtensions Class Members

PermissionsEnumExtensions Class Members
Methods

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace : PermissionsEnumExtensions Class

The following tables list the members exposed by PermissionsEnumExtensions.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | ToOperations | Converts to TeslaDb.Common.Operations enum.
static (Shared in Visual Basic) | ToPermissions | Converts to Permissions enum.
Top
See Also

Reference

PermissionsEnumExtensions Class
ActiveReports.Server.Security Namespace


PermissionsEnumExtensions Class Methods

PermissionsEnumExtensions Class Methods

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace : PermissionsEnumExtensions Class

For a list of all members of this type, see PermissionsEnumExtensions members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | ToOperations | Converts to TeslaDb.Common.Operations enum.
static (Shared in Visual Basic) | ToPermissions | Converts to Permissions enum.
Top
See Also

Reference

PermissionsEnumExtensions Class
ActiveReports.Server.Security Namespace


ToOperations Method

ToOperations Method

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > PermissionsEnumExtensions Class : ToOperations Method
Permission to convert.
Converts to TeslaDb.Common.Operations enum.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function ToOperations( _
   ByVal perm As Permissions _
) As TeslaDb.Common.Operations
public static TeslaDb.Common.Operations ToOperations(
   Permissions perm
)

Parameters

perm
Permission to convert.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PermissionsEnumExtensions Class
PermissionsEnumExtensions Members


ToPermissions Method

ToPermissions Method

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > PermissionsEnumExtensions Class : ToPermissions Method
Operations to convert.
Converts to Permissions enum.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function ToPermissions( _
   ByVal ops As TeslaDb.Common.Operations _
) As Permissions
public static Permissions ToPermissions(
   TeslaDb.Common.Operations ops
)

Parameters

ops
Operations to convert.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PermissionsEnumExtensions Class
PermissionsEnumExtensions Members


Setting Class

Setting Class
Members

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace : Setting Class
Represents single settings property.
Object Model
Setting Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Setting
public sealed class Setting
Inheritance Hierarchy

System.Object
ActiveReports.Server.Security.Setting

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Setting Members
ActiveReports.Server.Security Namespace


Setting Class Members

Setting Class Members
Properties

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace : Setting Class

The following tables list the members exposed by Setting.

Public Constructors
 | Name | Description
Public Constructor | Setting Constructor | Initializes a new instance of the Setting class.
Top
Public Properties
 | Name | Description
Public Property | Description | Gets setting description.
Public Property | DisplayName | Gets setting display name.
Public Property | IsPassword | Gets a value indicating if the setting should be shown as password text.
Public Property | Name | Gets setting name.
Public Property | Type | Gets setting type.
Public Property | Value | Gets setting value.
Top
See Also

Reference

Setting Class
ActiveReports.Server.Security Namespace


Setting Constructor

Setting Constructor

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > Setting Class : Setting Constructor
The setting name.
The setting value.
The setting display name.
The setting description.
True if setting represents a password.
The type of the setting.
Initializes a new instance of the Setting class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As String, _
   ByVal value As String, _
   ByVal displayName As String, _
   ByVal description As String, _
   ByVal isPassword As Boolean, _
   ByVal type As Type _
)
public Setting(
   string name,
   string value,
   string displayName,
   string description,
   bool isPassword,
   Type type
)

Parameters

name
The setting name.
value
The setting value.
displayName
The setting display name.
description
The setting description.
isPassword
True if setting represents a password.
type
The type of the setting.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Setting Class
Setting Members


Setting Class Properties

Setting Class Properties

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace : Setting Class

For a list of all members of this type, see Setting members.

Public Properties
 | Name | Description
Public Property | Description | Gets setting description.
Public Property | DisplayName | Gets setting display name.
Public Property | IsPassword | Gets a value indicating if the setting should be shown as password text.
Public Property | Name | Gets setting name.
Public Property | Type | Gets setting type.
Public Property | Value | Gets setting value.
Top
See Also

Reference

Setting Class
ActiveReports.Server.Security Namespace


Description Property (Setting)

Description Property (Setting)

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > Setting Class : Description Property
Gets setting description.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Description As String
public string Description {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Setting Class
Setting Members


DisplayName Property

DisplayName Property

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > Setting Class : DisplayName Property
Gets setting display name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DisplayName As String
public string DisplayName {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Setting Class
Setting Members


IsPassword Property

IsPassword Property

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > Setting Class : IsPassword Property
Gets a value indicating if the setting should be shown as password text.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsPassword As Boolean
public bool IsPassword {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Setting Class
Setting Members


Name Property (Setting)

Name Property (Setting)

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > Setting Class : Name Property
Gets setting name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Name As String
public string Name {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Setting Class
Setting Members


Type Property (Setting)

Type Property (Setting)

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > Setting Class : Type Property
Gets setting type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Type As Type
public Type Type {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Setting Class
Setting Members


Value Property (Setting)

Value Property (Setting)

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > Setting Class : Value Property
Gets setting value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Value As String
public string Value {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Setting Class
Setting Members


UserContext Class

UserContext Class
Members

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace : UserContext Class
Represents the user context for provider speicific data.
Object Model
UserContext Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class UserContext
public abstract class UserContext
Inheritance Hierarchy

System.Object
ActiveReports.Server.Security.UserContext

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserContext Members
ActiveReports.Server.Security Namespace


UserContext Class Members

UserContext Class Members
Properties Methods

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace : UserContext Class

The following tables list the members exposed by UserContext.

Public Properties
 | Name | Description
Public Property | Item | Gets the value from the user context for the specified key.
Public Property | Keys | Gets available keys in the user context.
Top
Public Methods
 | Name | Description
Public Method | GetValue | Gets the value from the user context for the specified key.
Public Method | GetValues | Gets the values from the user context for the specified key.
Top
See Also

Reference

UserContext Class
ActiveReports.Server.Security Namespace


UserContext Class Methods

UserContext Class Methods

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace : UserContext Class

For a list of all members of this type, see UserContext members.

Public Methods
 | Name | Description
Public Method | GetValue | Gets the value from the user context for the specified key.
Public Method | GetValues | Gets the values from the user context for the specified key.
Top
See Also

Reference

UserContext Class
ActiveReports.Server.Security Namespace


GetValue Method

GetValue Method

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > UserContext Class : GetValue Method
The key to get a value for.
Gets the value from the user context for the specified key.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Function GetValue( _
   ByVal key As String _
) As String
public abstract string GetValue(
   string key
)

Parameters

key
The key to get a value for.

Return Value

The value from the user context.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserContext Class
UserContext Members


GetValues Method

GetValues Method

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > UserContext Class : GetValues Method
The key to get values for.
Gets the values from the user context for the specified key.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Function GetValues( _
   ByVal key As String _
) As String()
public abstract string[] GetValues(
   string key
)

Parameters

key
The key to get values for.

Return Value

The values from the user context.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserContext Class
UserContext Members


UserContext Class Properties

UserContext Class Properties

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace : UserContext Class

For a list of all members of this type, see UserContext members.

Public Properties
 | Name | Description
Public Property | Item | Gets the value from the user context for the specified key.
Public Property | Keys | Gets available keys in the user context.
Top
See Also

Reference

UserContext Class
ActiveReports.Server.Security Namespace


Item Property

Item Property

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > UserContext Class : Item Property
Gets the value from the user context for the specified key.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Default Property Item( _
   ByVal key As String _
) As String
public string this[
   string key
]; {get;}

Parameters

key
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserContext Class
UserContext Members


Keys Property

Keys Property

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > UserContext Class : Keys Property
Gets available keys in the user context.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride ReadOnly Property Keys As String()
public abstract string[] Keys {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserContext Class
UserContext Members


Permissions Enumeration

Permissions Enumeration

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace : Permissions Enumeration
Represents permission types.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Permissions
   Inherits System.Enum
public enum Permissions : System.Enum
Members
Member | Description
ChangePermission | ChangePermission operation is granted.
Full | All operations are granted.
Modify | Modify/Edit operation is granted.
None | No operation is granted, the same as there is no any corresponding record in the DB.
Read | Read operation is granted.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ActiveReports.Server.Security.Permissions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActiveReports.Server.Security Namespace


UserDescription Structure

UserDescription Structure
Members

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace : UserDescription Structure
Represents user description.
Object Model
UserDescription Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure UserDescription
   Inherits System.ValueType
public struct UserDescription : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
ActiveReports.Server.Security.UserDescription

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserDescription Members
ActiveReports.Server.Security Namespace


UserDescription Structure Members

UserDescription Structure Members
Properties

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace : UserDescription Structure

The following tables list the members exposed by UserDescription.

Public Properties
 | Name | Description
Public Property | Email | Gets or sets the user email.
Public Property | FriendlyUserName | Gets or sets user's friendly name.
Public Property | Key | Gets or sets user's unique key.
Top
See Also

Reference

UserDescription Structure
ActiveReports.Server.Security Namespace


UserDescription Structure Properties

UserDescription Structure Properties

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace : UserDescription Structure

For a list of all members of this type, see UserDescription members.

Public Properties
 | Name | Description
Public Property | Email | Gets or sets the user email.
Public Property | FriendlyUserName | Gets or sets user's friendly name.
Public Property | Key | Gets or sets user's unique key.
Top
See Also

Reference

UserDescription Structure
ActiveReports.Server.Security Namespace


Email Property (UserDescription)

Email Property (UserDescription)

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > UserDescription Structure : Email Property
Gets or sets the user email.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Email As String
public string Email {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserDescription Structure
UserDescription Members


FriendlyUserName Property

FriendlyUserName Property

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > UserDescription Structure : FriendlyUserName Property
Gets or sets user's friendly name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FriendlyUserName As String
public string FriendlyUserName {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserDescription Structure
UserDescription Members


Key Property

Key Property

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > UserDescription Structure : Key Property
Gets or sets user's unique key.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Key As String
public string Key {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UserDescription Structure
UserDescription Members


IRole Interface

IRole Interface
Members

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace : IRole Interface
Specifies the role in the role-based security system.
Object Model
IRole Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IRole
public interface IRole
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRole Members
ActiveReports.Server.Security Namespace


IRole Interface Members

IRole Interface Members
Properties

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace : IRole Interface

The following tables list the members exposed by IRole.

Public Properties
 | Name | Description
Property | Name | Gets the role name.
Top
See Also

Reference

IRole Interface
ActiveReports.Server.Security Namespace


IRole Interface Properties

IRole Interface Properties

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace : IRole Interface

For a list of all members of this type, see IRole members.

Public Properties
 | Name | Description
Property | Name | Gets the role name.
Top
See Also

Reference

IRole Interface
ActiveReports.Server.Security Namespace


Name Property (IRole)

Name Property (IRole)

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > IRole Interface : Name Property
Gets the role name.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Name As String
string Name {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IRole Interface
IRole Members


ISecurityProvider Interface

ISecurityProvider Interface
Members

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace : ISecurityProvider Interface
Specifies the contract for a custom security provider.
Object Model
ISecurityProvider Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ISecurityProvider
public interface ISecurityProvider
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISecurityProvider Members
ActiveReports.Server.Security Namespace


ISecurityProvider Interface Members

ISecurityProvider Interface Members
Methods

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace : ISecurityProvider Interface

The following tables list the members exposed by ISecurityProvider.

Public Methods
 | Name | Description
Method | CreateToken | Creates the security token.
Method | DisposeToken | Disposes the security token created with CreateToken.
Method | FilterRoles | Gets the roles for the specified identity.
Method | GetAdminContext | Gets the user context for the administrator.
Method | GetCacheKeySalt | Gets the additional hash to vary the cache key according to the multi-tenant context.
Method | GetUserContext | Gets the user context for the specified identity.
Method | GetUserContextKeys | Gets supported keys which may be used in user context.
Method | GetUserDescription | Gets user description for the specified identity.
Method | ValidateToken | Validates the security token.
Top
See Also

Reference

ISecurityProvider Interface
ActiveReports.Server.Security Namespace


ISecurityProvider Interface Methods

ISecurityProvider Interface Methods

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace : ISecurityProvider Interface

For a list of all members of this type, see ISecurityProvider members.

Public Methods
 | Name | Description
Method | CreateToken | Creates the security token.
Method | DisposeToken | Disposes the security token created with CreateToken.
Method | FilterRoles | Gets the roles for the specified identity.
Method | GetAdminContext | Gets the user context for the administrator.
Method | GetCacheKeySalt | Gets the additional hash to vary the cache key according to the multi-tenant context.
Method | GetUserContext | Gets the user context for the specified identity.
Method | GetUserContextKeys | Gets supported keys which may be used in user context.
Method | GetUserDescription | Gets user description for the specified identity.
Method | ValidateToken | Validates the security token.
Top
See Also

Reference

ISecurityProvider Interface
ActiveReports.Server.Security Namespace


CreateToken Method

CreateToken Method

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > ISecurityProvider Interface : CreateToken Method
The user name to create the token for.
The password to validate the user.
The custom credentials data to be used in the provider.
Creates the security token.
Syntax
  • Visual Basic
  • C#
'Declaration

Function CreateToken( _
   ByVal username As String, _
   ByVal password As String, _
   ByVal custom As String _
) As String
string CreateToken(
   string username,
   string password,
   string custom
)

Parameters

username
The user name to create the token for.
password
The password to validate the user.
custom
The custom credentials data to be used in the provider.

Return Value

The created token.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISecurityProvider Interface
ISecurityProvider Members


DisposeToken Method

DisposeToken Method

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > ISecurityProvider Interface : DisposeToken Method
The security token to dispose.
Disposes the security token created with CreateToken.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub DisposeToken( _
   ByVal token As String _
)
void DisposeToken(
   string token
)

Parameters

token
The security token to dispose.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISecurityProvider Interface
ISecurityProvider Members


FilterRoles Method

FilterRoles Method

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > ISecurityProvider Interface : FilterRoles Method
The security token to get the roles for.
The system roles to filter for the specified security token.
Gets the roles for the specified identity.
Syntax
  • Visual Basic
  • C#
'Declaration

Function FilterRoles( _
   ByVal token As String, _
   ByVal roles As IEnumerable(Of IRole) _
) As IEnumerable(Of IRole)
IEnumerable<IRole> FilterRoles(
   string token,
   IEnumerable<IRole> roles
)

Parameters

token
The security token to get the roles for.
roles
The system roles to filter for the specified security token.

Return Value

The role collection if the operation is permitted.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISecurityProvider Interface
ISecurityProvider Members


GetAdminContext Method

GetAdminContext Method

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > ISecurityProvider Interface : GetAdminContext Method
Gets the user context for the administrator.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetAdminContext() As UserContext
UserContext GetAdminContext()

Return Value

The user context for the administrator.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISecurityProvider Interface
ISecurityProvider Members


GetCacheKeySalt Method

GetCacheKeySalt Method

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > ISecurityProvider Interface : GetCacheKeySalt Method
The security token to get the hash for.
Gets the additional hash to vary the cache key according to the multi-tenant context.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetCacheKeySalt( _
   ByVal token As String _
) As String
string GetCacheKeySalt(
   string token
)

Parameters

token
The security token to get the hash for.

Return Value

The addtional hash to vary by.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISecurityProvider Interface
ISecurityProvider Members


GetUserContext Method

GetUserContext Method

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > ISecurityProvider Interface : GetUserContext Method
The security token to get the user context for.
Gets the user context for the specified identity.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetUserContext( _
   ByVal token As String _
) As UserContext
UserContext GetUserContext(
   string token
)

Parameters

token
The security token to get the user context for.

Return Value

The user context if the operation is permitted.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISecurityProvider Interface
ISecurityProvider Members


GetUserContextKeys Method

GetUserContextKeys Method

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > ISecurityProvider Interface : GetUserContextKeys Method
Gets supported keys which may be used in user context.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetUserContextKeys() As IEnumerable(Of String)
IEnumerable<string> GetUserContextKeys()

Return Value

The supported user context keys.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISecurityProvider Interface
ISecurityProvider Members


GetUserDescription Method

GetUserDescription Method

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > ISecurityProvider Interface : GetUserDescription Method
The security token to get user name for.
Gets user description for the specified identity.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetUserDescription( _
   ByVal token As String _
) As UserDescription
UserDescription GetUserDescription(
   string token
)

Parameters

token
The security token to get user name for.

Return Value

The user description.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISecurityProvider Interface
ISecurityProvider Members


ValidateToken Method

ValidateToken Method

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > ISecurityProvider Interface : ValidateToken Method
The security token to validate.
Validates the security token.
Syntax
  • Visual Basic
  • C#
'Declaration

Function ValidateToken( _
   ByVal token As String _
) As Boolean
bool ValidateToken(
   string token
)

Parameters

token
The security token to validate.

Return Value

Returns true if the token is valid; otherwise false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISecurityProvider Interface
ISecurityProvider Members


ISecurityProviderFactory Interface

ISecurityProviderFactory Interface
Members

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace : ISecurityProviderFactory Interface
Specifies the security provider factory.
Object Model
ISecurityProviderFactory Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ISecurityProviderFactory
public interface ISecurityProviderFactory
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISecurityProviderFactory Members
ActiveReports.Server.Security Namespace


ISecurityProviderFactory Interface Members

ISecurityProviderFactory Interface Members
Methods

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace : ISecurityProviderFactory Interface

The following tables list the members exposed by ISecurityProviderFactory.

Public Methods
 | Name | Description
Method | Create | Creates a security provider with the specified settings.
Method | GetSupportedSettings | Gets the supported settings.
Top
See Also

Reference

ISecurityProviderFactory Interface
ActiveReports.Server.Security Namespace


ISecurityProviderFactory Interface Methods

ISecurityProviderFactory Interface Methods

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace : ISecurityProviderFactory Interface

For a list of all members of this type, see ISecurityProviderFactory members.

Public Methods
 | Name | Description
Method | Create | Creates a security provider with the specified settings.
Method | GetSupportedSettings | Gets the supported settings.
Top
See Also

Reference

ISecurityProviderFactory Interface
ActiveReports.Server.Security Namespace


Create Method (ISecurityProviderFactory)

Create Method (ISecurityProviderFactory)

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > ISecurityProviderFactory Interface : Create Method
The settings to create the provider on.
Creates a security provider with the specified settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Function Create( _
   ByVal settings As IDictionary(Of String,String) _
) As ISecurityProvider
ISecurityProvider Create(
   IDictionary<string,string> settings
)

Parameters

settings
The settings to create the provider on.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISecurityProviderFactory Interface
ISecurityProviderFactory Members


GetSupportedSettings Method

GetSupportedSettings Method

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > ISecurityProviderFactory Interface : GetSupportedSettings Method
Gets the supported settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetSupportedSettings() As IEnumerable(Of String)
IEnumerable<string> GetSupportedSettings()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISecurityProviderFactory Interface
ISecurityProviderFactory Members


ISecurityProvidersRegistry Interface

ISecurityProvidersRegistry Interface
Members

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace : ISecurityProvidersRegistry Interface
Defines interface to security providers registry responsible for configuring and instantiating security providers.
Object Model
ISecurityProvidersRegistry Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ISecurityProvidersRegistry
public interface ISecurityProvidersRegistry
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISecurityProvidersRegistry Members
ActiveReports.Server.Security Namespace


ISecurityProvidersRegistry Interface Members

ISecurityProvidersRegistry Interface Members
Properties Methods

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace : ISecurityProvidersRegistry Interface

The following tables list the members exposed by ISecurityProvidersRegistry.

Public Properties
 | Name | Description
Property | CurrentProviderKey | Gets or sets the current provider.
Top
Public Methods
 | Name | Description
Method | CreateCustomProvider | Overloaded. Creates custom provider according to current configuration.
Method | CreateProvider | Creates provider according to current configuration.
Method | GetProviderList | Gets full provider list in form of Key+Value disctionary. Includes "builtin" provider.
Method | GetRegisteredProviderFactories | Reads the custom provider assemblies from file system.
Method | ReadSettings | Gets the settings for specific security provider.
Method | SaveSetting | Saves the single setting value for specific provider.
Top
See Also

Reference

ISecurityProvidersRegistry Interface
ActiveReports.Server.Security Namespace


ISecurityProvidersRegistry Interface Methods

ISecurityProvidersRegistry Interface Methods

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace : ISecurityProvidersRegistry Interface

For a list of all members of this type, see ISecurityProvidersRegistry members.

Public Methods
 | Name | Description
Method | CreateCustomProvider | Overloaded. Creates custom provider according to current configuration.
Method | CreateProvider | Creates provider according to current configuration.
Method | GetProviderList | Gets full provider list in form of Key+Value disctionary. Includes "builtin" provider.
Method | GetRegisteredProviderFactories | Reads the custom provider assemblies from file system.
Method | ReadSettings | Gets the settings for specific security provider.
Method | SaveSetting | Saves the single setting value for specific provider.
Top
See Also

Reference

ISecurityProvidersRegistry Interface
ActiveReports.Server.Security Namespace


CreateCustomProvider Method

CreateCustomProvider Method

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > ISecurityProvidersRegistry Interface : CreateCustomProvider Method
Creates custom provider according to current configuration.
Overload List
Overload | Description
CreateCustomProvider() | Creates custom provider according to current configuration.
CreateCustomProvider(String,IDictionary<String,String>) | Creates custom provider.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISecurityProvidersRegistry Interface
ISecurityProvidersRegistry Members


CreateCustomProvider() Method

CreateCustomProvider() Method

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > ISecurityProvidersRegistry Interface > CreateCustomProvider Method : CreateCustomProvider() Method
Creates custom provider according to current configuration.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function CreateCustomProvider() As ISecurityProvider
ISecurityProvider CreateCustomProvider()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISecurityProvidersRegistry Interface
ISecurityProvidersRegistry Members
Overload List


CreateCustomProvider(String,IDictionary<String,String>) Method

CreateCustomProvider(String,IDictionary<String,String>) Method

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > ISecurityProvidersRegistry Interface > CreateCustomProvider Method : CreateCustomProvider(String,IDictionary<String,String>) Method
Provider to create
Provider settings
Creates custom provider.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function CreateCustomProvider( _
   ByVal providerKey As String, _
   ByVal settings As IDictionary(Of String,String) _
) As ISecurityProvider
ISecurityProvider CreateCustomProvider(
   string providerKey,
   IDictionary<string,string> settings
)

Parameters

providerKey
Provider to create
settings
Provider settings
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISecurityProvidersRegistry Interface
ISecurityProvidersRegistry Members
Overload List


CreateProvider Method

CreateProvider Method

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > ISecurityProvidersRegistry Interface : CreateProvider Method
Creates provider according to current configuration.
Syntax
  • Visual Basic
  • C#
'Declaration

Function CreateProvider() As ISecurityProvider
ISecurityProvider CreateProvider()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISecurityProvidersRegistry Interface
ISecurityProvidersRegistry Members


GetProviderList Method

GetProviderList Method

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > ISecurityProvidersRegistry Interface : GetProviderList Method
Gets full provider list in form of Key+Value disctionary. Includes "builtin" provider.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetProviderList() As IEnumerable(Of KeyValuePair(Of String,String))
IEnumerable<KeyValuePair<string,string>> GetProviderList()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISecurityProvidersRegistry Interface
ISecurityProvidersRegistry Members


GetRegisteredProviderFactories Method

GetRegisteredProviderFactories Method

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > ISecurityProvidersRegistry Interface : GetRegisteredProviderFactories Method
Reads the custom provider assemblies from file system.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetRegisteredProviderFactories() As IEnumerable(Of Type)
IEnumerable<Type> GetRegisteredProviderFactories()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISecurityProvidersRegistry Interface
ISecurityProvidersRegistry Members


ReadSettings Method

ReadSettings Method

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > ISecurityProvidersRegistry Interface : ReadSettings Method
The provider key.
Gets the settings for specific security provider.
Syntax
  • Visual Basic
  • C#
'Declaration

Function ReadSettings( _
   ByVal providerKey As String _
) As IDictionary(Of String,Setting)
IDictionary<string,Setting> ReadSettings(
   string providerKey
)

Parameters

providerKey
The provider key.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISecurityProvidersRegistry Interface
ISecurityProvidersRegistry Members


SaveSetting Method

SaveSetting Method

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > ISecurityProvidersRegistry Interface : SaveSetting Method
Provider type.
Name of the setting.
The value.
Saves the single setting value for specific provider.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub SaveSetting( _
   ByVal providerKey As String, _
   ByVal settingName As String, _
   ByVal value As String _
)
void SaveSetting(
   string providerKey,
   string settingName,
   string value
)

Parameters

providerKey
Provider type.
settingName
Name of the setting.
value
The value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISecurityProvidersRegistry Interface
ISecurityProvidersRegistry Members


ISecurityProvidersRegistry Interface Properties

ISecurityProvidersRegistry Interface Properties

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace : ISecurityProvidersRegistry Interface

For a list of all members of this type, see ISecurityProvidersRegistry members.

Public Properties
 | Name | Description
Property | CurrentProviderKey | Gets or sets the current provider.
Top
See Also

Reference

ISecurityProvidersRegistry Interface
ActiveReports.Server.Security Namespace


CurrentProviderKey Property

CurrentProviderKey Property

ActiveReports.Server.Extensibility Assembly > ActiveReports.Server.Security Namespace > ISecurityProvidersRegistry Interface : CurrentProviderKey Property
Gets or sets the current provider.
Syntax
  • Visual Basic
  • C#
'Declaration

Property CurrentProviderKey As String
string CurrentProviderKey {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISecurityProvidersRegistry Interface
ISecurityProvidersRegistry Members


Web Service Library

Web Service Library
ActiveReports 12 Server User Guide > Web Service Library

The Web Service Library contains documentation and syntax for the ActiveReports Server ReportService.

Service

ReportService
Checks user credentials and creates a security token if the credentials are valid.

Objects

DataResult Object
Represents an object containing the status of an IReportService operation.
EMailDistribution Object
Defines e-mail options to use in distributing the report.
ExceptionDetail Object
Defines detailed exception information for an IReportService request operation error.
ItemDescription Object
Contains descriptive information about stored resources.
ItemDescriptionsResult Object
Represents an object that is returned as a result of an Upload operation and contains an array of item descriptons.
Query Object
Defines a query used to find reports in the Select operation.
RenderOptions Object
Defines options for how to render a report.
ReportDescription Object
Contains descriptive information about stored reports.
ReportParameter Object
Defines a parameter for the report.
RequestInfo Object
Defines status information for an IReportService request operation.
RequestResult Object
Represents an object containing the status, or result contract, of an IReportService request operation.
Result Object
Represents an object that is returned as a result of an IReportService operation.
UploadOptions Object
Defines options for how to upload a resource.
UserCapabilities Object
Represents a user capabilities object that is contained in a result from an IReportService get user capabilities operation.
UserCapabilitiesResult Object
Represents a user capabilities result object that is returned as a result of an IReportService get user capabilities operation.

Enumerations

ModelPermission Enumeration
Specifies the byte value of the enumerated level of permissions granted for the model associated with the report.
ReportParameterDomain Enumeration
Specifies the byte value of the enumerated report parameter domain.
ReportType Enumeration
Specifies the byte value of the enumerated report type for all supported reports.
RequestState Enumeration
Specifies the state of an IReportService request operation for a RequestInfo object.
See Also

Reference

Web Services


ReportService

ReportService
ActiveReports 12 Server User Guide > Web Service Library > ReportService

Checks user credentials and creates a security token if the credentials are valid.

Syntax

C#
Copy Code

public interface IReportService

Parameters

username
A string representing the user name to validate.

password
A string representing the password for the specified user.

custom
A string representing the value or values to validate in addition to user name and password, if any.

isPersistent
A Boolean value that indicates whether the security token remains valid across sessions.

Return Value

A security token if user credentials are valid; otherwise, null.

IReportService Methods

Name | Description
CancelRequest Method | Cancels the specified request.
Delete Method | Deletes the report specified in the ID parameter.
Download Method | Downloads the specified report from storage.
GetRequestStatus Method | Retrieves the status of the specified request.
GetUserCapabilities Method | Retrieves the capabilities of the user with the specified security token.
IsLoggedIn Method | Determines whether the security token is valid.
Login Method | Checks user credentials and creates a security token if the credentials are valid.
Logout Method | Recalls the security token.
RenderReport Method | Renders the report specified in the description using the specified options.
ResolveParameters Method | Populates the parameters for the specified report.
Select Method | Retrieves an array of report descriptions matching the criterion defined by the specified query.
SendReportEmail Method | Renders the specified report and sends it via email according to the specified options.
Upload Method | Uploads the specified report to storage.
UploadResource Method | Uploads the specified resource to storage.
See Also
Result Object


CancelRequest Method

CancelRequest Method
ActiveReports 12 Server User Guide > Web Service Library > ReportService > CancelRequest Method

Cancels the specified request.

Syntax

C#
Copy Code
Result CancelRequest(string token, string id);

Parameters

token
The security token to use.

id
The identifier of the request to cancel.

Return Value

A Result object.

See Also
GetRequestStatus Method


Delete Method

Delete Method
ActiveReports 12 Server User Guide > Web Service Library > ReportService > Delete Method

Deletes the report specified in the ID parameter.

Syntax

C#
Copy Code
DataResult Delete(string token, string id);

Parameters

token
The security token to use.

id
The identifier of the report to delete.

Return Value

A DataResult object containing the status of the delete operation.

See Also
DataResult Object


Download Method

Download Method
ActiveReports 12 Server User Guide > Web Service Library > ReportService > Download Method

Downloads the specified report from storage.

Syntax

C#
Copy Code
DataResult Download(string token, string id);

Parameters

token
The security token to use.

id
The identifier of the report to download.

Return Value

A DataResult object containing the report downloaded by the operation.

See Also
Upload Method


GetRequestStatus Method

GetRequestStatus Method
ActiveReports 12 Server User Guide > Web Service Library > ReportService > GetRequestStatus Method

Retrieves the status of the specified request.

Syntax

C#
Copy Code
RequestResult GetRequestStatus(string token, string requestId);

Parameters

token
The security token to use.

id
The identifier of the request for which to return a status.

Return Value

A Result object.

See Also
Result Object
CancelRequest Method


GetUserCapabilities Method

GetUserCapabilities Method
ActiveReports 12 Server User Guide > Web Service Library > ReportService > GetUserCapabilities Method

Retrieves the capabilities of the user with the specified security token.

Syntax

C#
Copy Code
UserCapabilitiesResult GetUserCapabilities(string token);

Parameters

token
The security token to use.

Return Value

A UserCapabilitiesResult Object.

See Also
UserCapabilitiesResult Object


IsLoggedIn Method

IsLoggedIn Method
ActiveReports 12 Server User Guide > Web Service Library > ReportService > IsLoggedIn Method

Determines whether the security token is valid.

Syntax

C#
Copy Code
bool IsLoggedIn(string token);

Parameters

token
The security token to use.

Return Value

A Boolean value indicating whether the security token is valid.

See Also
Login Method


Login Method

Login Method
ActiveReports 12 Server User Guide > Web Service Library > ReportService > Login Method

Checks user credentials and creates a security token if the credentials are valid.

Syntax

C#
Copy Code
string Login(string username, string password, string custom, bool isPersistent);

Parameters

username
A string value indicating the user name to validate.

password
A string value indicating the password for the specified user.

custom
Other string values to validate in addition to the user name and password, if any.

isPersistent
A Boolean value indicating whether the security token remains valid across sessions.

Return Value

A string value containing the security token if the user credentials are valid; otherwise, null.

See Also
IsLoggedIn Method
Logout Method


Logout Method

Logout Method
ActiveReports 12 Server User Guide > Web Service Library > ReportService > Logout Method

Recalls the security token.

Syntax

C#
Copy Code
void Logout(string token);

Parameters

token
The security token to recall.

See Also
Login Method
IsLoggedIn Method


RenderReport Method

RenderReport Method
ActiveReports 12 Server User Guide > Web Service Library > ReportService > RenderReport Method

Renders the report specified in the description using the specified options.

Syntax

C#
Copy Code
RequestResult RenderReport(string token, ReportDescription description, RenderOptions options);

Parameters

token
The security token to use.

description
The ReportDescription object containing information about the report.

options
The RenderOptions object containing information about how to render the report.

Return Value

A RequestResult object.

See Also
RequestResult Object
ReportDescription Object
RenderOptions Object


ResolveParameters Method

ResolveParameters Method
ActiveReports 12 Server User Guide > Web Service Library > ReportService > ResolveParameters Method

Populates the parameters for the specified report.

Syntax

C#
Copy Code
RequestResult ResolveParameters(string token, ReportDescription description, RenderOptions options);

Parameters

token
The security token to use.

description
The ReportDescription object containing information about the report.

options
The RenderOptions object containing information about how to render the report.

Return Value

A RequestResult Object.

See Also
ReportParameter Object
ReportDescription Object
RenderOptions Object
RequestResult Object


Select Method

Select Method
ActiveReports 12 Server User Guide > Web Service Library > ReportService > Select Method

Retrieves an array of report descriptions matching the criterion defined by the specified query.

Syntax

C#
Copy Code
ReportDescription[] Select(string token, Query query);

Parameters

token
The security token to use.

query
The Query object to use in finding reports to select.

Return Value

A array of ReportDescription objects.

See Also
Download Method
Query Object
ReportDescription Object


SendReportEmail Method

SendReportEmail Method
ActiveReports 12 Server User Guide > Web Service Library > ReportService > SendReportEmail Method

Renders the specified report and sends it via email according to the specified options.

Syntax

C#
Copy Code
Result SendReportEmail(string token, ReportDescription description, RenderOptions options, EMailDistribution distribution);

Parameters

token
The security token to use.

description
The ReportDescription object containing information about the report.

options
The RenderOptions object containing information about how to render the report.

distribution
The EMailDistribution object containing information about how to distribute the report.

Return Value

A Result object.

See Also
Result Object
EMailDistribution Object
ReportDescription Object
RenderOptions Object
ReportService


Upload Method

Upload Method
ActiveReports 12 Server User Guide > Web Service Library > ReportService > Upload Method

Uploads the specified report to storage.

Syntax

C#
Copy Code
ItemDescriptionsResult Upload(string token, ReportDescription description, string data);

Parameters

token
The security token to use.

description
The ReportDescription object containing information about the report to upload.

data
The string value representing the report data encoded in base 64 digits to upload.

Return Value

An ItemDescriptionsResult object.

See Also
Download Method
ReportDescription Object
ItemDescriptionsResult Object


UploadResource Method

UploadResource Method
ActiveReports 12 Server User Guide > Web Service Library > ReportService > UploadResource Method

Uploads the specified resource, a valid .NET assembly containing compiled ActiveReports, to storage.

Syntax

C#
Copy Code
ItemDescriptionsResult UploadResource(string token, ItemDescription description, string data, UploadOptions options);

Parameters

token
The security token to use.

description
The ItemDescription object containing information about the resource to upload.

data
The string value representing the resource data encoded in base 64 digits to upload.

options
The UploadOptions object containing optional settings such as Overwrite and SkipResourceValidation.

Return Value

An ItemDescriptionsResult object.

See Also
Upload Method
ItemDescription Object
UploadOptions Object
ItemDescriptionsResult Object


DataResult Object

DataResult Object
ActiveReports 12 Server User Guide > Web Service Library > DataResult Object

Represents an object containing the data returned by an IReportService operation.

Object Properties

Name | Description
Data Property | Gets the base 64 encoded data returned by the operation.
See Also
Delete Method
Download Method


EMailDistribution Object

EMailDistribution Object
ActiveReports 12 Server User Guide > Web Service Library > EMailDistribution Object

Defines e-mail options to use in distributing the report.

Object Properties

Name | Description
To Property | Gets or sets the string containing the address collection that contains the e-mail recipients.
Subject Property | Gets or sets the string containing the subject for the e-mail.
MessageBody Property | Gets or sets the string containing the message body of the e-mail.
AsLink Property | Gets or sets a Boolean value indicating whether to add a link to the report within the e-mail.
AsAttachment Property | Gets or sets a Boolean value indicating whether to attach the report to the e-mail.
BaseUri Property | Gets or sets the base URI to use for the report link in the e-mail.
See Also
SendReportEmail Method


ExceptionDetail Object

ExceptionDetail Object
ActiveReports 12 Server User Guide > Web Service Library > ExceptionDetail Object

Defines detailed exception information for an IReportService request operation error.

Object Properties

Name | Description
HelpLink Property | Gets the string for the help link from the exception.
InnerException Property | Gets the ExceptionDetail object that represents the inner exception.
Message Property | Gets the string message from the exception.
StackTrace Property | Gets the string stack trace information from the exception.
Type Property | Gets the string representing the type of the exception.
See Also
RequestInfo Object
GetRequestStatus Method


ItemDescription Object

ItemDescription Object
ActiveReports 12 Server User Guide > Web Service Library > ItemDescription Object

Contains descriptive information about uploaded resources.

Object Properties

Name | Description
CreatedBy Property | Gets the string containing the name of the user who uploaded the resource.
CreationDate Property | Gets the DateTime object containing the date on which the resource was uploaded.
Id Property | Gets the string containing the ID for the resource.
ModifiedBy Property | Gets the string containing the name of the user who last modified the resource.
ModifiedDate Property | Gets the DateTime object containing the date on which the resource was last modified.
Name Property | Gets the string value representing the name of the resource.
Permissions Property | Gets the byte value representing the permissions for the resource.
See Also
UploadResource Method
UploadOptions Object


ItemDescriptionsResult Object

ItemDescriptionsResult Object
ActiveReports 12 Server User Guide > Web Service Library > ItemDescriptionsResult Object

Represents an object that is returned as a result of an Upload operation and contains an array of item descriptons.

Object Properties

Name | Description
isAuthenticated Property | Gets the Boolean value indicating whether the user has been authenticated.
See Also
Upload Method
Result Object


Query Object

Query Object
ActiveReports 12 Server User Guide > Web Service Library > Query Object

Defines a query used to find reports in the Select operation.

Object Properties

Name | Description
FilterBy Property | Gets the string containing the comma-separated role values by which to filter reports.
OrderBy Property | Gets the string representing the property name to use in ordering the report descriptions returned by the Select operation.
See Also
ReportDescription Object
Select Method


RenderOptions Object

RenderOptions Object
ActiveReports 12 Server User Guide > Web Service Library > RenderOptions Object

Defines options for how to render a report.

Object Properties

Name | Description
Extension Property | Gets the string value representing the rendering extension to use.
ReportParameters Property | Gets any ReportParameter objects associated with the report.
ReportId Property | Gets the string containing the identity of the report to render.
Name Property | Gets the string containing the name of the preview file to render.
ReportType Property | Gets the enumerated ReportType value for the report to render.
See Also
RenderReport Method
ReportType Enumeration
ReportParameter Object


ReportDescription Object

ReportDescription Object
ActiveReports 12 Server User Guide > Web Service Library > ReportDescription Object

Contains descriptive information about stored reports.

Object Properties

Name | Description
CreatedBy Property | Gets the string containing the name of the user who created the report.
CreationDate Property | Gets the DateTime object containing the date on which the report was created.
Description Property | Gets the string containing a description of the report.
IsBroken Property | Gets the Boolean value indicating whether the report is broken by recent model version changes.
IsParametrized Property | Gets the Boolean value indicating whether the report contains parameters.
MasterReportIds Property | Gets the string value representing any master report used by the report. For internal use only.
ModelId Property | Gets the string containing the identity of the model associated with the report.
ModelName Property | Gets the string containing the name of the model associated with the report.
ModelPermissions Property | Gets the enumerated ModelPermission value for the model associated with the report
ModelVersion Property | Gets the int value for the history version of the model associated with the report.
ModifiedBy Property | Gets the string containing the name of the user who last modified the report.
ModifiedDate Property | Gets the DateTime object containing the date on which the report was last modified.
Name Property | Gets the string value representing the name of the report.
Permissions Property | Gets the byte value representing the permissions for the report.
Id Property | Gets the string value representing the ID of the report.
ReportType Property | Gets the enumerated ReportType value for the report.
SubReportIds Property | Gets the string value representing any subreport used by the report. For internal use only.
ThemeId Property | Gets the int value representing the theme used by the report.
See Also
RenderReport Method
ReportType Enumeration
ModelPermission Enumeration


ReportParameter Object

ReportParameter Object
ActiveReports 12 Server User Guide > Web Service Library > ReportParameter Object

Defines a parameter for the report.

Object Properties

Name | Description
Name Property | Gets the string containing the name of the report parameter.
Domain Property | Gets the enumerated ReportParameterDomain value for the report parameter.
Values Property | Gets the string representing values to supply for the report parameter.
See Also
RenderOptions Object
RenderReport Method
ReportParameterDomain Enumeration


RequestInfo Object

RequestInfo Object
ActiveReports 12 Server User Guide > Web Service Library > RequestInfo Object

Defines status information for an IReportService request operation.

Object Properties

Name | Description
Exception Property | Gets the ExceptionDetail object containing error information for the request.
PrimaryUrl Property | Gets the URL of a primary resource for execution results.
RequestId Property | Gets the string that identifies the request.
State Property | Gets the enumerated RequestState value signifying the current request state.
See Also
GetRequestStatus Method


RequestResult Object

RequestResult Object
ActiveReports 12 Server User Guide > Web Service Library > RequestResult Object

Represents an object containing the status, or result contract, of an IReportService request operation.

Object Properties

Name | Description
Info Property | Gets the RequestInfo object containing status information for a request.
See Also
GetRequestStatus Method


Result Object

Result Object
ActiveReports 12 Server User Guide > Web Service Library > Result Object

Represents an object that is returned as a result of an IReportService operation.

Object Properties

Name | Description
Error Property | An Error object that represents an error that occurs during operation execution.
IsAuthenticated Property | A Boolean value that indicates whether the request has been authenticated.
See Also
CancelRequest Method


UploadOptions Object

UploadOptions Object
ActiveReports 12 Server User Guide > Web Service Library > UploadOptions Object

Defines options for how to upload a resource.

Object Properties

Name | Description
ConnectionString Property | Gets the string value representing the connection string to use.
Overwrite Property | Gets the Boolean value indicating whether to overwrite existing resources.
SkipResourceValidation | Gets the Boolean value indicating whether to validate that all requirements are met for using the uploaded resource to serve compiled reports.
See Also
UploadResource Method
ItemDescription Object


UserCapabilities Object

UserCapabilities Object
ActiveReports 12 Server User Guide > Web Service Library > UserCapabilities Object

Represents a user capabilities object that is contained in a result from an IReportService get user capabilities operation.

Object Properties

Name | Description
Email Property | A string value that represents the e-mail address of the user.
IsAdministrator Property | A Boolean value indicating whether the user is the administrator.
IsEvaluationVersion Property | A Boolean value indicating whether the system is in evaluation mode.
IsSBEVersion Property | A Boolean value indicating whether the system is the small business edition.
IsSchedulePermitted Property | A Boolean value indicating whether the user has permission to scheduling.
IsUploadPermitted Property | A Boolean value indicating whether the user has permission to upload reports.
See Also
UserCapabilitiesResult Object
GetUserCapabilities Method
ReportService


UserCapabilitiesResult Object

UserCapabilitiesResult Object
ActiveReports 12 Server User Guide > Web Service Library > UserCapabilitiesResult Object

Represents a user capabilities result object that is returned as a result of an IReportService get user capabilities operation.

Object Properties

Name | Description
Capabilities Property | A UserCapabilities object that contains the capabilities for the user.
See Also
Result Object
GetUserCapabilities Method
UserCapabilities Object


ModelPermission Enumeration

ModelPermission Enumeration
ActiveReports 12 Server User Guide > Web Service Library > ModelPermission Enumeration

Specifies the byte value of the enumerated level of permissions granted for the model associated with the report.

Enumeration Members

Member | Description
None | The indicated security token has no permission to access the data model.
Read | The indicated security token has only read access to the data model.
CreateReport | The indicated security token has both read and reporting access to the data model.
See Also
ReportDescription Object


ReportParameterDomain Enumeration

ReportParameterDomain Enumeration
ActiveReports 12 Server User Guide > Web Service Library > ReportParameterDomain Enumeration

Specifies the byte value of the enumerated report parameter domain.

Enumeration Members

Member | Description
SpecifiedValues = 0 | Indicates that the parameter values are specified in the value collection.
SelectAll = 1 | Indicates that all valid values are set.
AcceptingDynamicValues = 2 | Indicates that the specified values include values to be evaluated dynamically at run time.
See Also
ReportParameter Object
RenderOptions Object
RenderReport Method


ReportType Enumeration

ReportType Enumeration
ActiveReports 12 Server User Guide > Web Service Library > ReportType Enumeration

Specifies the byte value of the enumerated report type for all supported reports.

Enumeration Members

Member | Description
Unknown = 0 | Indicates that the report type is unknown.
SW = 1 | Indicates a semantic report, created with ActiveReports Server.
AR = 2 | Indicates an ActiveReports developer report.
DDR = 3 | Indicates a Data Dynamics Reports developer report.
See Also
ReportDescription Object
RenderReport Method


RequestState Enumeration

RequestState Enumeration
ActiveReports 12 Server User Guide > Web Service Library > RequestState Enumeration

Specifies the state of an IReportService request operation for a RequestInfo object.

Enumeration Members

Member | Description
Accomplished | Indicates that the request operation completed successfully.
Cancelled | Indicates that the request operation was cancelled.
Pending | Indicates that the request operation is in a request queue.
Rejected | Indicates that the request operation was rejected.
Running | Indicates that the request operation execution has started, but has not yet completed.
Unavailable | Indicates that no request status information is available due to connection problems or other issues.
See Also
RequestInfo Object
GetRequestStatus Method


Section 508 Compliance

Section 508 Compliance
ActiveReports 12 Server User Guide > Section 508 Compliance
Show All
Hide All

Section 508 requires that when Federal agencies develop, procure, maintain, or use electronic and information technology, Federal employees with disabilities have access to and use of information and data that is comparable to the access and use by Federal employees without disabilities, unless an undue burden would be imposed on the agency. Section 508 also requires that individuals with disabilities seeking information or services from a Federal agency have access to and use of information and data that is comparable to that provided to the general public, unless an undue burden would be imposed on the agency.

Accessibility Summary:

All major features of ActiveReports software are accessible via keyboard navigation.

DISCLAIMER:

GRAPECITY MAKES NO WARRANTIES, EXPRESS OR IMPLIED, IN THIS DOCUMENT. The following information reflects the general accessibility features of GrapeCity software components as related to the Section 508 standards. If you find that the information is not accurate, or if you have specific accessibility needs that our products do not meet, please contact us and we will attempt to rectify the problem, although we cannot guarantee that we will be able to do so in every case.

ActiveReports Server Administrator and Designer controls

Section 1194.21 Software applications and operating systems

Criteria | Status | Remarks
(a) When software is designed to run on a system that has a keyboard, product functions shall be executable from a keyboard where the function itself or the result of performing a function can be discerned textually. | Supported with exceptions | ActiveReports Server partially supports navigation using the keyboard. However, a user cannot execute report functions by using only the keyboard on Administrator and Designer sites.
(b) Applications shall not disrupt or disable activated features of other products that are identified as accessibility features, where those features are developed and documented according to industry standards. Applications also shall not disrupt or disable activated features of any operating system that are identified as accessibility features where the application programming interface for those accessibility features has been documented by the manufacturer of the operating system and is available to the product developer. | Supported | The controls do not disrupt or disable industry standard accessibility features of other products.
(c) A well-defined on-screen indication of the current focus shall be provided that moves among interactive interface elements as the input focus changes. The focus shall be programmatically exposed so that Assistive Technology can track focus and focus changes. | Supported with exceptions | Some elements in the Report Designer, Viewer, Admin site, and Report Portal do not provide focus information to Assistive Technology.
(d) Sufficient information about a user interface element including the identity, operation and state of the element shall be available to Assistive Technology. When an image represents a program element, the information conveyed by the image must also be available in text. | Supported with exceptions | ActiveReports Server supports images for representing some user interface elements, and also provide a textual conveyance of the information.
(e) When bitmap images are used to identify controls, status indicators, or other programmatic elements, the meaning assigned to those images shall be consistent throughout an application's performance. | Supported | Any images used to identify a programmatic element have a consistent meaning throughout the controls.
(f) Textual information shall be provided through operating system functions for displaying text. The minimum information that shall be made available is text content, text input caret location, and text attributes. | Not Applicable | Operating system functions for displaying text are not supported in ActiveReports Server.
(g) Applications shall not override user selected contrast and color selections and other individual display attributes. | Supported with exceptions | ActiveReports Server does not override contrast and color in Internet Explorer 11 and Firefox. Google Chrome requires an extension to be installed.
(h) When animation is displayed, the information shall be displayable in at least one non-animated presentation mode at the option of the user. | Supported with exceptions | ActiveReports Server provides textual information for some animated elements.
(i) Color coding shall not be used as the only means of conveying information, indicating an action, prompting a response, or distinguishing a visual element. | Supported | ActiveReports Server does not have any feature or text that conveys any information or message using color coding.
(j) When a product permits a user to adjust color and contrast settings, a variety of color selections capable of producing a range of contrast levels shall be provided. | Supported | ActiveReports Server supports a wide variety of colors, range of contrast levels, themes and styles that can be applied to controls in a report.
(k) Software shall not use flashing or blinking text, objects, or other elements having a flash or blink frequency greater than 2 Hz and lower than 55 Hz. | Supported | The controls do not use flashing or blinking text or objects.
(l) When electronic forms are used, the form shall allow people using Assistive Technology to access the information, field elements, and functionality required for completion and submission of the form, including all directions and cues. | Supported | Any form-type dialogs or windows associated with the controls provide Assistive Technology with access to information on all directions, cues, field elements, and functionality required for completion.

Section 1194.22 Web-based Internet information and applications

Criteria | Status | Remarks
(a) A text equivalent for every non-text element shall be provided (e.g., via "alt", "longdesc", or in element content). | Supported with exceptions | Some of the non-text element has a text equivalent.
(b) Equivalent alternatives for any multimedia presentation shall be synchronized with the presentation. | Not Applicable | There is no multimedia presentation associated with the software.
(c) Web pages shall be designed so that all information conveyed with color is also available without color, for example from context or markup. | Supported | By default, no information is conveyed with color.
(d) Documents shall be organized so they are readable without requiring an associated style sheet. | Supported with exceptions | Some elements are not visible on the Admin site and the HTML5 Report Portal when styles are disabled.
(e) Redundant text links shall be provided for each active region of a server-side image map. | Not Applicable | There are no server-side image maps associated with the software.
(f) Client-side image maps shall be provided instead of server-side image maps except where the regions cannot be defined with an available geometric shape. | Not Applicable | There are no client-side image maps associated with the software.
(g) Row and column headers shall be identified for data tables. | Not Supported | By default, there are no data tables associated with the software.
(h) Markup shall be used to associate data cells and header cells for data tables that have two or more logical levels of row or column headers. | Not Supported | By default, there are no data tables associated with the software.
(i) Frames shall be titled with text that facilitates frame identification and navigation. | Not Applicable | By default, there are no frames associated with the software.
(j) Pages shall be designed to avoid causing the screen to flicker with a frequency greater than 2 Hz and lower than 55 Hz. | Supported | The software does not cause the screen to flicker outside the recommended range.
(k) A text-only page, with equivalent information or functionality, shall be provided to make a web site comply with the provisions of this part, when compliance cannot be accomplished in any other way. The content of the text-only page shall be updated whenever the primary page changes. | Not Applicable | Text-only page is not available in ActiveReports Web Viewer or Web controls.
(l) When pages utilize scripting languages to display content, or to create interface elements, the information provided by the script shall be identified with functional text that can be read by Assistive Technology. | Supported | The ActiveReports HTML5 Viewer control uses scripting that is supported by Assistive Technology.
(m) When a web page requires that an applet, plug-in or other application be present on the client system to interpret page content, the page must provide a link to a plug-in or applet that complies with §1194.21(a) through (l). | Supported | ActiveReports provides a link to install the Silverlight plug-in when an application using ActiveReports Silverlight viewer control is executed.
(n) When electronic forms are designed to be completed on-line, the form shall allow people using Assistive Technology to access the information, field elements, and functionality required for completion and submission of the form, including all directions and cues. | Supported with exceptions | The components used in ActiveReports have been configured for maximum compliance. However, some form controls do not support assistive technology.
(o) A method shall be provided that permits users to skip repetitive navigation links. | Not Applicable | By default, the software contains no repetitive navigation links.
(p) When a timed response is required, the user shall be alerted and given sufficient time to indicate more time is required. | Not Applicable | No timed responses are required with ActiveReports.

ActiveReports

Section 1194.31 Functional Performance Criteria

Criteria | Status | Remarks
(a) At least one mode of operation and information retrieval that does not require user vision shall be provided, or support for assistive technology used by people who are blind or visually impaired shall be provided. | Supported with exceptions | ActiveReports provide partial support to assistive technologies like screen readers.
(b) At least one mode of operation and information retrieval that does not require visual acuity greater than 20/70 shall be provided in audio and enlarged print output working together or independently, or support for assistive technology used by people who are visually impaired shall be provided. | Supported | ActiveReports does not require visual acuity greater than 20/70. Also, it is exposed to magnification tools like “Screen Magnifier” thus magnifying the screen for ease of use.
(c) At least one mode of operation and information retrieval that does not require user hearing shall be provided, or support for assistive technology used by people who are deaf or hard of hearing shall be provided. | Not Applicable | ActiveReports does not use any sound output and hearing is not necessary to use the product.
(d) Where audio information is important for the use of a product, at least one mode of operation and information retrieval shall be provided in an enhanced auditory fashion, or support for assistive hearing devices shall be provided. | Not Applicable | ActiveReports does not provide functionalities that require audio or video aids.
(e) At least one mode of operation and information retrieval that does not require user speech shall be provided, or support for assistive technology used by people with disabilities shall be provided. | Not Applicable | ActiveReports does not provide any functionality that use user speech.
(f) At least one mode of operation and information retrieval that does not require fine motor control or simultaneous actions and that is operable with limited reach and strength shall be provided. | Supported | ActiveReports does not provide any functionality that requires fine motor control or simultaneous action.

Documentation

Section 1194.41 Information, Documentation, and Support

Criteria | Status | Remarks
(a) Product support documentation provided to end-users shall be made available in alternate formats upon request, at no additional charge. | Supported | Documentation is available in four formats: HTML(Web), *.chm, *.PDF, and Help3(Visual Studio help content)
(b) End-users shall have access to a description of the accessibility and compatibility features of products in alternate formats or alternate methods upon request, at no additional charge. | Supported | ActiveReports provides information about accessibility and compatibility features in the documentation. Also, documentation is exposed to screen readers.
(c) Support services for products shall accommodate the communication needs of end-users with disabilities. | Supported | Support services such as telephone, email and forum support are provided to the customers.


Glossary

Glossary
A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

A

attribute tree
Displays the attributes that are associated with the entity selected under the entity tree. For example, the Customer entity has attributes like Address, Phone, Country, etc. If no entity is selected, the attribute tree is empty.

D

drill down
Allows users to expand collapsed table rows to reveal more data. See also drill through.

drill through
Allows users to click links to reports with more detailed data. Located in the Design tab toolbar, the Drilldown button is enabled when you select a table cell or chart data point. Specify parameters in the target report to supply relevant detail data.

R

report design surface
Visible on the Design tab and the Report tab, it is a visual page designer where you can drag and drop entities and attributes to create tables and charts and design your reports.

Report Info
An insert that you can add to a textbox to show page numbering, report name, or run time. Located in the Report tab toolbox, it is enabled when you click inside a textbox.

role root category
Role Root Category is a system category that is set as the top level category for a User Role. All the sub-categories under this level are available to the users in the user role. Role Root Category is a system category that is set as the top level category for a User Role. All the sub-categories under this level are available to the users in the user role.


ActiveReports.Server.Extensibility Assembly

ActiveReports.Server.Extensibility Assembly
Namespaces
Namespace | Description
ActiveReports.Server.Security |


ActiveReports.Server.Security Namespace Inheritance Hierarchy

ActiveReports.Server.Security Namespace Inheritance Hierarchy
ActiveReports.Server.Extensibility Assembly : ActiveReports.Server.Security Namespace
Inheritance Hierarchy
System.Object
ActiveReports.Server.Security.PermissionsEnumExtensions
ActiveReports.Server.Security.Setting
ActiveReports.Server.Security.UserContext
System.ValueType
ActiveReports.Server.Security.UserDescription
See Also

Reference

ActiveReports.Server.Extensibility Assembly


ActiveReports.Server.ReportControls Assembly

ActiveReports.Server.ReportControls Assembly
Namespaces
Namespace | Description
ActiveReports.Server.ReportControls |
ActiveReports.Server.ReportControls.Servicing |
ActiveReports.Server.ReportServices.Contracts |
ActiveReports.Server.ReportServices.Contracts.Descriptions |
ActiveReports.Server.ReportServices.Contracts.Errors |
ActiveReports.Server.ReportServices.Contracts.Feedback |
ActiveReports.Server.ReportServices.Contracts.Policy |
ActiveReports.Server.ReportServices.Servicing |
ActiveReports.Server.Scheduling |


Designer Class Events

Designer Class Events

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace : Designer Class

For a list of all members of this type, see Designer members.

Public Events
 | Name | Description
Public Event | DataBinding | Occurs when the server control binds to a data source. (Inherited from System.Web.UI.Control)
Public Event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from System.Web.UI.Control)
Public Event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from System.Web.UI.Control)
Public Event | Load | Occurs when the server control is loaded into the System.Web.UI.Page object. (Inherited from System.Web.UI.Control)
Public Event | PreRender | Occurs after the System.Web.UI.Control object is loaded but prior to rendering. (Inherited from System.Web.UI.Control)
Public Event | Unload | Occurs when the server control is unloaded from memory. (Inherited from System.Web.UI.Control)
Top
See Also

Reference

Designer Class
ActiveReports.Server.ReportControls Namespace


LocalizedDescriptionAttribute Class Methods

LocalizedDescriptionAttribute Class Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace : LocalizedDescriptionAttribute Class

For a list of all members of this type, see LocalizedDescriptionAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.ComponentModel.DescriptionAttribute)
Public Method | GetHashCode | (Inherited from System.ComponentModel.DescriptionAttribute)
Public Method | IsDefaultAttribute | (Inherited from System.ComponentModel.DescriptionAttribute)
Public Method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from System.Attribute)
Top
See Also

Reference

LocalizedDescriptionAttribute Class
ActiveReports.Server.ReportControls Namespace


LocalizedDescriptionAttribute Class Properties

LocalizedDescriptionAttribute Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace : LocalizedDescriptionAttribute Class

For a list of all members of this type, see LocalizedDescriptionAttribute members.

Public Properties
 | Name | Description
Public Property | Description | (Inherited from System.ComponentModel.DescriptionAttribute)
Public Property | TypeId | When implemented in a derived class, gets a unique identifier for this System.Attribute. (Inherited from System.Attribute)
Top
Protected Properties
 | Name | Description
Protected Property | DescriptionValue | (Inherited from System.ComponentModel.DescriptionAttribute)
Top
See Also

Reference

LocalizedDescriptionAttribute Class
ActiveReports.Server.ReportControls Namespace


ReportList Class Events

ReportList Class Events

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportControls Namespace : ReportList Class

For a list of all members of this type, see ReportList members.

Public Events
 | Name | Description
Public Event | DataBinding | Occurs when the server control binds to a data source. (Inherited from System.Web.UI.Control)
Public Event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from System.Web.UI.Control)
Public Event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from System.Web.UI.Control)
Public Event | Load | Occurs when the server control is loaded into the System.Web.UI.Page object. (Inherited from System.Web.UI.Control)
Public Event | PreRender | Occurs after the System.Web.UI.Control object is loaded but prior to rendering. (Inherited from System.Web.UI.Control)
Public Event | Unload | Occurs when the server control is unloaded from memory. (Inherited from System.Web.UI.Control)
Top
See Also

Reference

ReportList Class
ActiveReports.Server.ReportControls Namespace


ActiveReports.Server.ReportControls.Servicing Namespace Inheritance Hierarchy

ActiveReports.Server.ReportControls.Servicing Namespace Inheritance Hierarchy
ActiveReports.Server.ReportControls Assembly : ActiveReports.Server.ReportControls.Servicing Namespace
Inheritance Hierarchy
System.Object
ActiveReports.Server.ReportControls.Servicing.RemoteEndpoint
ActiveReports.Server.ReportControls.Servicing.ServiceChannelFactory<TServiceChannel>
ActiveReports.Server.ReportControls.Servicing.ServiceProxyBase
See Also

Reference

ActiveReports.Server.ReportControls Assembly


ActiveReports.Server.ReportControls Namespace Inheritance Hierarchy

ActiveReports.Server.ReportControls Namespace Inheritance Hierarchy
ActiveReports.Server.ReportControls Assembly : ActiveReports.Server.ReportControls Namespace
Inheritance Hierarchy
System.Object
System.Attribute
System.ComponentModel.DescriptionAttribute
ActiveReports.Server.ReportControls.LocalizedDescriptionAttribute
System.Web.UI.Control
ActiveReports.Server.ReportControls.Designer
System.Web.UI.WebControls.WebControl
System.Web.UI.ScriptControl
ActiveReports.Server.ReportControls.ReportList
See Also

Reference

ActiveReports.Server.ReportControls Assembly


AssemblyDescription Class Methods

AssemblyDescription Class Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : AssemblyDescription Class

For a list of all members of this type, see AssemblyDescription members.

Public Methods
 | Name | Description
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Top
See Also

Reference

AssemblyDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


AssemblyDescription Class Properties

AssemblyDescription Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : AssemblyDescription Class

For a list of all members of this type, see AssemblyDescription members.

Public Properties
 | Name | Description
Public Property | CreatedBy | Gets the user name created the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | CreationDate | Gets or sets the item creation date. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Id | Gets or sets the identifier for the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedBy | Gets the user name who made the last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedDate | Gets or sets the date of last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Name | Gets or sets the name of the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Permissions | Gets or sets the item permissions. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Top
See Also

Reference

AssemblyDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


ReportVersionDescription Class Methods

ReportVersionDescription Class Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : ReportVersionDescription Class

For a list of all members of this type, see ReportVersionDescription members.

Public Methods
 | Name | Description
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Top
See Also

Reference

ReportVersionDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


ResourceDescription Class Methods

ResourceDescription Class Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : ResourceDescription Class

For a list of all members of this type, see ResourceDescription members.

Public Methods
 | Name | Description
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Top
See Also

Reference

ResourceDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


SemanticModelDescription Class Methods

SemanticModelDescription Class Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : SemanticModelDescription Class

For a list of all members of this type, see SemanticModelDescription members.

Public Methods
 | Name | Description
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Top
See Also

Reference

SemanticModelDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


SemanticModelDraftDescription Class Methods

SemanticModelDraftDescription Class Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : SemanticModelDraftDescription Class

For a list of all members of this type, see SemanticModelDraftDescription members.

Public Methods
 | Name | Description
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Top
See Also

Reference

SemanticModelDraftDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


SemanticModelVersionDescription Class Methods

SemanticModelVersionDescription Class Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : SemanticModelVersionDescription Class

For a list of all members of this type, see SemanticModelVersionDescription members.

Public Methods
 | Name | Description
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Top
See Also

Reference

SemanticModelVersionDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


SharedPolicyTemplateDescription Class Methods

SharedPolicyTemplateDescription Class Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : SharedPolicyTemplateDescription Class

For a list of all members of this type, see SharedPolicyTemplateDescription members.

Public Methods
 | Name | Description
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Top
See Also

Reference

SharedPolicyTemplateDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


TemporaryItemDescription Class Methods

TemporaryItemDescription Class Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace : TemporaryItemDescription Class

For a list of all members of this type, see TemporaryItemDescription members.

Public Methods
 | Name | Description
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Top
See Also

Reference

TemporaryItemDescription Class
ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace


ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace Inheritance Hierarchy

ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace Inheritance Hierarchy
ActiveReports.Server.ReportControls Assembly : ActiveReports.Server.ReportServices.Contracts.Descriptions Namespace
Inheritance Hierarchy
System.Object
ActiveReports.Server.ReportServices.Contracts.Descriptions.DescriptionExt
ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription
ActiveReports.Server.ReportServices.Contracts.Descriptions.AssemblyDescription
ActiveReports.Server.ReportServices.Contracts.Descriptions.ReportDescription
ActiveReports.Server.ReportServices.Contracts.Descriptions.ReportVersionDescription
ActiveReports.Server.ReportServices.Contracts.Descriptions.ResourceDescription
ActiveReports.Server.ReportServices.Contracts.Descriptions.SemanticModelDescription
ActiveReports.Server.ReportServices.Contracts.Descriptions.SemanticModelDraftDescription
ActiveReports.Server.ReportServices.Contracts.Descriptions.SemanticModelVersionDescription
ActiveReports.Server.ReportServices.Contracts.Descriptions.SharedPolicyTemplateDescription
ActiveReports.Server.ReportServices.Contracts.Descriptions.TemporaryItemDescription
ActiveReports.Server.ReportServices.Contracts.StyleDescription
ActiveReports.Server.ReportServices.Contracts.ThemeDescription
ActiveReports.Server.ReportServices.Contracts.Descriptions.ReportParameterDescription
See Also

Reference

ActiveReports.Server.ReportControls Assembly


NoticeType Class Methods

NoticeType Class Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace : NoticeType Class

For a list of all members of this type, see NoticeType members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the List. (Inherited from System.Collections.Generic.List<string>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the List. (Inherited from System.Collections.Generic.List<string>)
Public Method | AsReadOnly | Returns a read-only ReadOnlyCollection wrapper for the current collection. (Inherited from System.Collections.Generic.List<string>)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<string>)
Public Method | Clear | Removes all elements from the List. (Inherited from System.Collections.Generic.List<string>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from System.Collections.Generic.List<string>)
Public Method | ConvertAll | Converts the elements in the current List to another type, and returns a list containing the converted elements. (Inherited from System.Collections.Generic.List<string>)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<string>)
Public Method | Exists | Determines whether the List contains elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<string>)
Public Method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List. (Inherited from System.Collections.Generic.List<string>)
Public Method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<string>)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<string>)
Public Method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List. (Inherited from System.Collections.Generic.List<string>)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<string>)
Public Method | ForEach | Performs the specified action on each element of the List. (Inherited from System.Collections.Generic.List<string>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from System.Collections.Generic.List<string>)
Public Method | GetRange | Creates a shallow copy of a range of elements in the source List. (Inherited from System.Collections.Generic.List<string>)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<string>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from System.Collections.Generic.List<string>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from System.Collections.Generic.List<string>)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<string>)
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from System.Collections.Generic.List<string>)
Public Method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<string>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from System.Collections.Generic.List<string>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from System.Collections.Generic.List<string>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from System.Collections.Generic.List<string>)
Public Method | Sort | Overloaded. Sorts the elements in the entire List using the default comparer. (Inherited from System.Collections.Generic.List<string>)
Public Method | ToArray | Copies the elements of the List to a new array. (Inherited from System.Collections.Generic.List<string>)
Public Method | TrimExcess | Sets the capacity to the actual number of elements in the List, if that number is less than a threshold value. (Inherited from System.Collections.Generic.List<string>)
Public Method | TrueForAll | Determines whether every element in the List matches the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<string>)
Top
See Also

Reference

NoticeType Class
ActiveReports.Server.ReportServices.Contracts.Errors Namespace


NoticeType Class Properties

NoticeType Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts.Errors Namespace : NoticeType Class

For a list of all members of this type, see NoticeType members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from System.Collections.Generic.List<string>)
Public Property | Count | Gets the number of elements contained in the List. (Inherited from System.Collections.Generic.List<string>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.Generic.List<string>)
Top
See Also

Reference

NoticeType Class
ActiveReports.Server.ReportServices.Contracts.Errors Namespace


ActiveReports.Server.ReportServices.Contracts.Errors Namespace Inheritance Hierarchy

ActiveReports.Server.ReportServices.Contracts.Errors Namespace Inheritance Hierarchy
ActiveReports.Server.ReportControls Assembly : ActiveReports.Server.ReportServices.Contracts.Errors Namespace
Inheritance Hierarchy
System.Object
ActiveReports.Server.ReportServices.Contracts.Errors.Error
ActiveReports.Server.ReportServices.Contracts.Errors.ExceptionError
ActiveReports.Server.ReportServices.Contracts.Errors.ValidationError
ActiveReports.Server.ReportServices.Contracts.Errors.ExceptionDetail
System.Collections.Generic.List<T>
ActiveReports.Server.ReportServices.Contracts.Errors.NoticeType
See Also

Reference

ActiveReports.Server.ReportControls Assembly


ActiveReports.Server.ReportServices.Contracts.Feedback Namespace Inheritance Hierarchy

ActiveReports.Server.ReportServices.Contracts.Feedback Namespace Inheritance Hierarchy
ActiveReports.Server.ReportControls Assembly : ActiveReports.Server.ReportServices.Contracts.Feedback Namespace
Inheritance Hierarchy
System.Object
ActiveReports.Server.ReportServices.Contracts.Feedback.FeedbackReport
ActiveReports.Server.ReportServices.Contracts.Feedback.BugReport
See Also

Reference

ActiveReports.Server.ReportControls Assembly


LookupFieldValues Class Methods

LookupFieldValues Class Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : LookupFieldValues Class

For a list of all members of this type, see LookupFieldValues members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the end of the List. (Inherited from System.Collections.Generic.List<object>)
Public Method | AddRange | Adds the elements of the specified collection to the end of the List. (Inherited from System.Collections.Generic.List<object>)
Public Method | AsReadOnly | Returns a read-only ReadOnlyCollection wrapper for the current collection. (Inherited from System.Collections.Generic.List<object>)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<object>)
Public Method | Clear | Removes all elements from the List. (Inherited from System.Collections.Generic.List<object>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from System.Collections.Generic.List<object>)
Public Method | ConvertAll | Converts the elements in the current List to another type, and returns a list containing the converted elements. (Inherited from System.Collections.Generic.List<object>)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<object>)
Public Method | Exists | Determines whether the List contains elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<object>)
Public Method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List. (Inherited from System.Collections.Generic.List<object>)
Public Method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<object>)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<object>)
Public Method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List. (Inherited from System.Collections.Generic.List<object>)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<object>)
Public Method | ForEach | Performs the specified action on each element of the List. (Inherited from System.Collections.Generic.List<object>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from System.Collections.Generic.List<object>)
Public Method | GetRange | Creates a shallow copy of a range of elements in the source List. (Inherited from System.Collections.Generic.List<object>)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<object>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from System.Collections.Generic.List<object>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from System.Collections.Generic.List<object>)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<object>)
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from System.Collections.Generic.List<object>)
Public Method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<object>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from System.Collections.Generic.List<object>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from System.Collections.Generic.List<object>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from System.Collections.Generic.List<object>)
Public Method | Sort | Overloaded. Sorts the elements in the entire List using the default comparer. (Inherited from System.Collections.Generic.List<object>)
Public Method | ToArray | Copies the elements of the List to a new array. (Inherited from System.Collections.Generic.List<object>)
Public Method | TrimExcess | Sets the capacity to the actual number of elements in the List, if that number is less than a threshold value. (Inherited from System.Collections.Generic.List<object>)
Public Method | TrueForAll | Determines whether every element in the List matches the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<object>)
Top
See Also

Reference

LookupFieldValues Class
ActiveReports.Server.ReportServices.Contracts Namespace


LookupFieldValues Class Properties

LookupFieldValues Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : LookupFieldValues Class

For a list of all members of this type, see LookupFieldValues members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from System.Collections.Generic.List<object>)
Public Property | Count | Gets the number of elements contained in the List. (Inherited from System.Collections.Generic.List<object>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.Generic.List<object>)
Top
See Also

Reference

LookupFieldValues Class
ActiveReports.Server.ReportServices.Contracts Namespace


ActiveReports.Server.ReportServices.Contracts.Policy Namespace Inheritance Hierarchy

ActiveReports.Server.ReportServices.Contracts.Policy Namespace Inheritance Hierarchy
ActiveReports.Server.ReportControls Assembly : ActiveReports.Server.ReportServices.Contracts.Policy Namespace
Inheritance Hierarchy
System.Object
ActiveReports.Server.ReportServices.Contracts.Policy.JournalEntry
ActiveReports.Server.ReportServices.Contracts.Policy.JournalEntryDetails
ActiveReports.Server.ReportServices.Contracts.Policy.JournalEntryTemplate
ActiveReports.Server.ReportServices.Contracts.Policy.Policy
ActiveReports.Server.ReportServices.Contracts.Policy.PolicyHistoryEntry
ActiveReports.Server.ReportServices.Contracts.Result
ActiveReports.Server.ReportServices.Contracts.Policy.PolicyHistoryResult
ActiveReports.Server.ReportServices.Contracts.Policy.PolicyResult
See Also

Reference

ActiveReports.Server.ReportControls Assembly


StyleDescription Class Methods

StyleDescription Class Methods

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : StyleDescription Class

For a list of all members of this type, see StyleDescription members.

Public Methods
 | Name | Description
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Top
See Also

Reference

StyleDescription Class
ActiveReports.Server.ReportServices.Contracts Namespace


StyleDescription Class Properties

StyleDescription Class Properties

ActiveReports.Server.ReportControls Assembly > ActiveReports.Server.ReportServices.Contracts Namespace : StyleDescription Class

For a list of all members of this type, see StyleDescription members.

Public Properties
 | Name | Description
Public Property | CreatedBy | Gets the user name created the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | CreationDate | Gets or sets the item creation date. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Id | Gets or sets the identifier for the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedBy | Gets the user name who made the last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | ModifiedDate | Gets or sets the date of last item modification. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Name | Gets or sets the name of the item. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Public Property | Permissions | Gets or sets the item permissions. (Inherited from ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription)
Top
See Also

Reference

StyleDescription Class
ActiveReports.Server.ReportServices.Contracts Namespace


ActiveReports.Server.ReportServices.Contracts Namespace Inheritance Hierarchy

ActiveReports.Server.ReportServices.Contracts Namespace Inheritance Hierarchy
ActiveReports.Server.ReportControls Assembly : ActiveReports.Server.ReportServices.Contracts Namespace
Inheritance Hierarchy
System.Object
ActiveReports.Server.ReportServices.Contracts.DescriptionFilter
ActiveReports.Server.ReportServices.Contracts.ReportVersionFilter
ActiveReports.Server.ReportServices.Contracts.Descriptions.ItemDescription
ActiveReports.Server.ReportServices.Contracts.StyleDescription
ActiveReports.Server.ReportServices.Contracts.ThemeDescription
ActiveReports.Server.ReportServices.Contracts.ExportOptions
ActiveReports.Server.ReportServices.Contracts.LookupData
ActiveReports.Server.ReportServices.Contracts.LookupField
ActiveReports.Server.ReportServices.Contracts.PermissionRecord
ActiveReports.Server.ReportServices.Contracts.Query
ActiveReports.Server.ReportServices.Contracts.RelayoutOptions
ActiveReports.Server.ReportServices.Contracts.RenderOptions
ActiveReports.Server.ReportServices.Contracts.ReportParameter
ActiveReports.Server.ReportServices.Contracts.RequestInfo
ActiveReports.Server.ReportServices.Contracts.Result
ActiveReports.Server.ReportServices.Contracts.DataArrayResult
ActiveReports.Server.ReportServices.Contracts.DataResult
ActiveReports.Server.ReportServices.Contracts.ItemDescriptionsResult
ActiveReports.Server.ReportServices.Contracts.LookupResult
ActiveReports.Server.ReportServices.Contracts.Policy.PolicyHistoryResult
ActiveReports.Server.ReportServices.Contracts.Policy.PolicyResult
ActiveReports.Server.ReportServices.Contracts.ReportParametersResult
ActiveReports.Server.ReportServices.Contracts.RequestResult
ActiveReports.Server.ReportServices.Contracts.ResourcePermissionsResult
ActiveReports.Server.ReportServices.Contracts.UserCapabilitiesResult
ActiveReports.Server.ReportServices.Contracts.UploadOptions
ActiveReports.Server.ReportServices.Contracts.UserCapabilities
System.Collections.Generic.List<T>
ActiveReports.Server.ReportServices.Contracts.LookupFieldValues
See Also

Reference

ActiveReports.Server.ReportControls Assembly


ActiveReports.Server.ReportServices.Servicing Namespace Inheritance Hierarchy

ActiveReports.Server.ReportServices.Servicing Namespace Inheritance Hierarchy
ActiveReports.Server.ReportControls Assembly : ActiveReports.Server.ReportServices.Servicing Namespace
Inheritance Hierarchy
System.Object
See Also

Reference

ActiveReports.Server.ReportControls Assembly


ActiveReports.Server.Scheduling Namespace Inheritance Hierarchy

ActiveReports.Server.Scheduling Namespace Inheritance Hierarchy
ActiveReports.Server.ReportControls Assembly : ActiveReports.Server.Scheduling Namespace
Inheritance Hierarchy
System.Object
ActiveReports.Server.Scheduling.DistributionMethod
ActiveReports.Server.Scheduling.DistributionChain
ActiveReports.Server.Scheduling.EMailDistribution
ActiveReports.Server.Scheduling.FileShareDistribution
ActiveReports.Server.Scheduling.PolicyHistoryEntry
ActiveReports.Server.Scheduling.PrintingOptions
ActiveReports.Server.Scheduling.RecurrenceRule
ActiveReports.Server.Scheduling.RecurrenceSet
ActiveReports.Server.Scheduling.Schedule
ActiveReports.Server.Scheduling.Termination
ActiveReports.Server.Scheduling.TerminationByCount
System.ValueType
ActiveReports.Server.Scheduling.Day
See Also

Reference

ActiveReports.Server.ReportControls Assembly


Templates

Templates

The new template feature has been introduced in the ActiveReports 12 Server Designer in order to allow users to create reports based on the existing templates that are uploaded by the administrator.

A user can create a report by clicking the Create Report button on the Report portal. Upon clicking, this button will navigate the user to the Active Reports Web Designer - a separate window where they are asked to select a report type and choose a template amongst a set of available templates. These tenmplates are displayed in the form of thumbnails along with their names and are described in the table shown below:

Template Name | Description
BlankReport_page.rdlx | This is a blank page report.
BlankReport_rdl.rdlx | This is a blank RDL report.
Invoice_page.rdlx | This is an invoice template.
Deliveryslip_page.rdlx | This is an invoice template. Change the background color of the detail lines with isolation.
Paymentslip_page.rdlx | This is a template of payment handling form. We output the convenience bar code used in the toll storage service.
Label_page.rdlx | This is a template of tack sticker used for addressing envelopes and tags.
SimpleChart_page.rdlx | This is a template of the sales trend table using a simple graph.
CompositeChart_page.rdlx | This is a template fo the sales transition table using a composite graph. Different graph types ae set for each series.
SalesSlip_page.rdlx | This is a template for sales slips. If the data doesn't fit on the first page, a different layout is output on the second page.
Paystub_page.rdlx | This is a template of salary details. Output round schedule schedule.
ReportOfExemptionForDependents_page.rdlx | This is a template of the dependence deduction declaration. Since you're using a layer, you can print only data when printing.
SalesSpecification_page.rdlx | This is a template of sales statement. Total is done by voucher, day, month.
Estimate_page.rdlx | This is a template of the estimate.
ChainStoreUniformSlip_page.rdlx | This is a template of chain store unified vouchers. Since you're using a later, you can print only data when printing.
ManufacturingInstruction_page.rdlx | This is a template of production instructions for manufacturing industry.
MatrixSample_RDL.rdlx | This is a template of the crosstabulation table. It is possible to drill down by clicking the [+] rank.
Salesdashboard_rdl.rdlx | This is a dashboard template. Visualize data using multiple graphs and tables.