ActiveReports 13
Deploy Windows Applications
ActiveReports 13 > ActiveReports User Guide > How To > Customize, Localize, and Deploy > Deploy Windows Applications

Before you begin

Before deploying a Windows application, there are a few settings that can be helpful.

It is also good to be sure that all of the references you need for your reports are included. Here is a table listing features and required DLLs.

Features and References

These assemblies are added automatically when you add controls to forms or report controls to code-based section reports, but Visual Studio does not do this with XML-based (RPX and RDLX) reports.

Feature Required Assembly
Export:
Excel, Html, Image/Tiff, Pdf, Word/Rtf, Text/Xml
GrapeCity.ActiveReports.Export.*.dll
(replace * with Excel, Html, Image, Pdf, Word, or Xml)
Viewer control (or printing without the Viewer control) GrapeCity.ActiveReports.Viewer.Win.dll
Designer, Toolbox, or ReportExplorer control GrapeCity.ActiveReports.Design.Win.dll

XCopy Deployment

  1. Open your project in Visual Studio, and set the Solution Configuration to Release.
  2. From the Build menu, select Build Solution.
  3. In Windows Explorer, navigate to the project's bin directory, and copy the files from the Release folder into a zip file.
  4. Distribute the zip file.

MSI Installer Deployment

To create an installer project

  1. Open an existing ActiveReports project or create a new one.
  2. From the Visual Studio Build menu, select Build YourActiveReportsProjectName to build your report project.
  3. From the File menu, select Add, then New Project to open the Add New Project dialog.
  4. In the Add New Project dialog under Project Types, expand the Other Project Types node and select Setup and Deployment.
  5. Under Visual Studio Installer, select Setup Project, rename the file and click OK. The ProductName that you enter determines the name that is displayed for the application in folder names and in the Programs and Features control panel item.
  6. In the File System editor that appears, under File System on Target Machine, select the Application Folder.
    Note: To show the File System editor at any time, drop down the View menu and select Editor, then File System.
  7. From the Visual Studio Action menu, select Add, then Project Output.
  8. In the Add Project Output Group dialog that appears, choose your ActiveReports project name from the drop-down list.
  9. In the list, select Primary Output and click OK. This adds all of the existing assembly dependencies to your project.
  10. If you want to add other ActiveReports DLLs to the installer (e.g. if you use OleObjects on reports, you need to include the Interop.dll or Interop64.dll for 64-bit machines), in the Solution Explorer, right-click the installer project name, select Add, then Assembly.
    Note: If you would rather use the ActiveReports .msm file, please contact our technical support team.
  11. In the Select Component dialog that appears, select any components that you want to add and click the OK button.
  12. From the Visual Studio Build menu, select Build YourInstallerProjectName to build your Installer project.

To deploy the installer application

  1. Select the Installer project in the Solution Explorer.
  2. From the Visual Studio Project menu, click Install.
  3. The Installer application runs and installs the project on your computer. The distributable exe and msi setup files appear in your installer project Debug folder.
See Also